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This document describes the process used to assemble a Right of Way Monumentation Sheet.  An 
InRoads XML report is used to display the required data from the geometry project.  This data is 
copied and pasted into the JPC#Monumentation.xls Excel file and then linked to the MicroStation 
JPC#ROWMonumentationSheet##.dgn file. 

Creating the InRoads XML File 
The data used to create the Right of Way Monumentation sheet is stored in an InRoads 
Geometry Project (*.alg).   Depending on the data required, one of two different reports 
are used to extract the data from the geometry project.  Both reports display Point 
Number, Northing, Easting, and Elevation.  If this is all the data that is required, a 
Geometry report is used.  If Station and Offset information is also required, then the 
Clearance report is used. 

Geometry Report 
Aside from having the data in the geometry project, there are no other prerequisites for 
creating a Geometry report. 

1. From the InRoads dialog box, select Tools > XML Reports.  The XML Reports 
dialog box is displayed. 
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2. Select the Geometry tab at the top of the XML Reports dialog box. 

3. In the COGO Points area, use the Include field to key in the desired COGO point 
numbers then Tab to accept the key in.  These can be specified as a range (XXX-
XXX), a list of individual points (XXX,XXX,XXX) or a combination of both (XXX-
XXX,XXX,XXX-XXX).  If the required point numbers are not known, all of the points 
can be listed by using the asterisk ( * ).  The asterisk can be used in conjunction with 
text to limit the list of points.  For example, keying in ‘10*’ would find all points 
whose first two digits were’1’ and ‘0’.  

4. Select the Save icon to compile the report.  This displays the Export dialog box. 
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5. In the Export dialog box’s File Name field, key in the desired file name. 

6. Select the Save icon to complete the report.    

 
This will dismiss the Export dialog box and display the Bentley InRoads Report 
Browser.  This will be discussed later in the workflow. 

 

Clearance Report 
This report is used to generate station and offset information.  In order to calculate this 
information, a horizontal alignment must be present.  

7. From the InRoads dialog box, select Tools > XML Reports as shown above.  Select 
the Clearance tab at the top of the dialog box. 

8. In the From area, select the Horizontal Alignment toggle. 
9. Use the drop-down to select the desired horizontal alignment.  This is the alignment 

from which the station and offset is measured. 
10. In the COGO Points area’s Include field, key in the desired COGO point numbers 

then Tab to accept the key in (see 3 above for key in options). 
11. Select the Save icon to compile the report.   
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12. This displays the Export dialog box.  In the File Name field, key in the desired file 

name. 

13. Select the Save icon to complete the report.    

 
This will dismiss the Export dialog box and display the Bentley InRoads Report 
Browser.   
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The Bentley InRoads Report Browser 

The Bentley InRoads Report Browser is a modified version of the Internet Explorer web 
browser used specifically for InRoads XML reports.  It is launched automatically when 
an XML report is saved.  It can also be launched by selecting Tools > View XML 
Reports from the InRoads dialog box.  The illustrations below will be using the List 
Coordinates report, however procedures are the same for the Clearance report. 

Selecting an XML Report Template 
Report templates are program files that format the raw data contained within the XML 
file.  When the Bentley InRoads Report Browser opens, it selects a default report 
template for the type of report that was created. 

14. CDOT’s custom report templates are stored in the CDOT  folder.  Data on the CDOT 
folder to display the templates.  Two custom templates are provided for creating 
Monumentation sheets; CDOT_Monumentation_ListCoordinates and 
CDOT_Monumentation_Clearance.  Data on desired the template name to activate 
that template.  

 

 
 
This updates the report layout automatically. 
 

 

Version 03.02 Page 5 of 16 Created May, 2007   



CDOT Monumentation Sheets.pdf 

 
Format Options 
The default precision is set for two decimal places.  If a different precision is required, it 
can be set using Format Options. 

 
15. From the Bentley InRoads Report Browser, select Tools > Format Options.  This 

displays the dialog box. 
16. Use the pull downs to set the desired precision on the desired fields.  For the reports 

discussed in this document, the following fields are used: Northing/Easting, 
Elevation, Linear (for offsets), and Station. 

 

 
 
Selecting a different precision will automatically update the column or columns that 
use that format option.  Select the Close icon to dismiss the dialog box when finished. 
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Copying The Report To The Monumentation Spreadsheet 

Now that the report has been generated and formatted as desired, it can be copied into the 
JPC#Monumentation.xls Excel file.  This file has separate sheets for different types of 
monuments.  These are; ROW Markers To Be Set, Control Points TO BE Set, ROW 
Markers To Be Reset, Permenent Easement Markers, Aliquot Corners, and Temporary 
Easement Points.  Because any number of these monument types may be stored in the 
geometry project, it may be necessary to copy different blocks of data from the report to 
paste into different sheets in the spreadsheet. 

17. Open the JPC#Monumentation.xls file with Excel then minimize it. 
18. Go back to the Bentley InRoads Report Browser and highlight the desired data in the 

report. 
19. Right Click on the highlighted data to display the menu.  Select Copy from that 

menu. 
 

 
20. Minimize the Bentley InRoads Report Browser and maximize the Excel session. 
21. Using the tabs at the bottom, select the sheet for the copied data. 
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22. Data in cell A3 of the selected sheet.  This is where the copied data will be pasted.  

Right click in the same cell and select Paste from the menu that displays. 
 

 
 
The illustration below shows the results of this operation. 
 

 
 
 
Because the example is a List Coordinates report, the Station and Offset columns are 
empty.  These two columns will be hidden in order to center the title over the data. 
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23. Select Tools > Protection > Unprotect Sheet.   This will allow changes to be made 
to the sheets format so that the unused columns can be hidden. 

 

 
 

24. Data and hold the mouse button on the ‘F’ column label and drag the cursor over the 
‘G’ column label.  Both columns highlight. 

25. Right Click on the highlighted columns (in the body of the table) and select Hide 
from the menu. 
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26. The Station and Offset columns vanish and the title is centered over the remaining 

columns.   
 

 
 
Before the sheet can be linked to the JPC#ROWMonumentationSheet##.dgn file, the 
gridlines need to be turned off.  If they are left on, they will appear in a print of the 
dgn file. 
 

27. Select Tools > Protection > Protect Sheet to maintain the new sheet formatting.  
This will display the Protect Sheet dialog box. 

28. Toggle on Protect worksheet and contents of locked cells, Select locked cells, and 
Select unlocked cells.  Select the OK icon to accept the changes and dismiss the 
dialog box. 
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29. Select Tools > Options from the Excel menu. 
 

 
 

30. From the Options dialog box, select the View tab. 
31. In the Windows Options area, toggle off Gridlines.  Select the OK icon to accept 

the changes and dismiss the dialog box. 
 

 
 
The left most column in the JPC#ROWMonumentationSheet##.dgn file can hold 50 
rows of data (not counting the two title rows).  Other columns can hold 41 rows of 
data.  If there are more rows of data than a column can hold, the sheet can be copied 
and the duplicate data deleted from the sheets. 
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32. To make a copy of a sheet, right click on the sheet tab (at the bottom of the window) 

and select MOVE or Copy from the menu. 
 

 
 

33. In the Move or Copy dialog box, toggle on Create a copy.  Select the OK icon to 
create the copy and dismiss the dialog box. 

 

 
 

34. The Copy is denoted with (2) appended to the sheet name.  The sheets can be 
renamed by right clicking on the tab and selecting Rename from the menu.  Key in 
the new name and press the enter key to accept the change. 

35. In the original sheet, delete all the data below row 52 for the long column 43 for the 
short columns (the long column can hold 50 rows of data and there are two rows of 
headings). 

36. In the copied sheet, delete the data from rows 3 through 52. 
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Linking the Spreadsheet to the MicroStation Sheet File 

Once the data has been copied to the spreadsheet and the sheets formatted, they can be 
linked to the MicroStation sheet border. 

37. Open the JPC#ROWMonumentationSheet##.dgn file with MicroStation then 
minimize it. 

38. In The Excel file, highlight the data to be linked.  Be sure to include only columns 
and rows with data (including the two title rows). 

39. From the Excel menu, select Edit > Copy (or right click in the highlighted area and 
select Copy from the menu). 

 

 
 

40. Maximize the MicroStation window.  From the menu select Edit > Paste Special. 
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41. The Paste Special dialog box is displayed.  Select Linked MicroSoft Office Excel 

Worksheet from the list and Data the Paste icon. 
 

 
 

42. In the Paste OLE tool settings box, set the Method to By Size.   
43. In the Scale field, key in 9. 
 

 
 
An outline of the linked file is attached to the cursor. 

44. Move the outline near the corner of the no-plot column markers and Data to place the 
file. 
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45. Zoom in around the corner of the no-plot column marker.  Select the Move command 

and Tentative to the corner of the linked file and accept.  Then Tentative to the 
corner of the column marker, Data to accept and move the linked file, then Reset to 
release the file. 

 

 
 
This will place the linked file in the correct location within the sheet border.  Repeat 
this process with the other sheets in the spreadsheet as needed.  It may be necessary 
to make copies of the JPC#ROWMonumentationSheet##.dgn file to hold all of the 
data. 
 
Below is an example of a finished sheet. 
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Linking a Spreadsheet with the Station and Offset Columns 
 
Because spreadsheets with the Station and Offset columns displayed are wider, only two 
sets of data can be displayed on a single sheet.  This will require some minor 
modification to the JPC#ROWMonumentationSheet##.dgn file.  The three column boxes 
inside the sheet border will be replaced by two, larger column markers. 
  
46. Delete the three column boxes from inside the sheet border. 
47. Select the Fit View icon to display the contents of the entire file.  The two larger 

column boxes will appear the left of the sheet border. 
48. Select the Element Selector tool and highlight both boxes. 

 
 

49. Select the Move icon and Data near one of the highlighted boxes. 

 
 

50. In the Key In dialog box, type “di=12,0” and press the Enter key.  This will move 
the column boxes into place.  Reset to exit the Move command then Data to 
unhighlight the boxes. 

 

 
 
Below is an example on the results of this procedure. 
 

 
 

51. Follow steps 37 through 45 above to link the spreadsheets to the sheet border file. 
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