CDOT Level Update for V03.02
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This document guides you through updating the MicroStation levels that were changed, deleted,
and renamed from the Configuration Releases prior to V03.02. All drawing files created under
the V03.01 and prior Configuration Releases will need to be updated to the current CDOT
standard levels. See CDOT Configuration Readme.pdf file located in the level library section.
Converting Levels in MicroStation

1. From the MicroStation Manager, open a drawing file.

2. Select File > Save As.

FZ C:\Projects\12345\Misc

File | Edt Element Setting:
[ New... Ctri+N

—Z Qpen... Ctrl+ 0
[ Close Ctri+w
= save Ctri+5
’% Save As... |
Compress 3

Save Settings  Ctrl+F

Reference

- Raster Manager
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B Import 3
. Export 3

3. Rename the current opened drawing file and select Options.

Save As

Directory

Directaries:
12345FlanProfile0Zaldgn | .AProjectsy 12345 YDesign’ Drawings’,
12345ApproximateQuantities##.dgn = = T,
12345Earthwork Quantities##.don e Frojects
12345GeneralMNote sSheatdl .dgn = 12345
12345GeneralMNote sSheatlZ dgn e Design
12345FlanProfiled#.dgn = Dravwing s
12345FlanProfile0l .dgn £ Cross_Sections
12345FlanProfile02.dgn £ Reference_Files
12345FlanProfile03.dgn £ Tabs

12345FlanProfile0d.dgn
12345 lanProfile0b.dgn

12345FlanProfiles.dgn =
1 »
Cancel
Select Format To Sawve: Drives:
MicroStation W8 DGN Files [“dgn] ¥ | Els =l

Version 03.02 Page 1 of 10 Created June, 2007



CDOT Level Update for V03.02.pdf

4. Inthe Save As V8 Options dialog box, select the Browse for CSV remapping file
icon. A standard CSV file is located in the configuration which is already set up to
remap all of the previous versions’ levels to the standard CDOT MicroStation V03.01
levels.

Save As V8 Options ‘

| References | Filter |

CSV File [ 'a

|Br0~.'u5e for CSV remapping file

sl§sl =k nljxk

OK Cancel |

5. If not already there, browse to C:\Program Files\Workspace-CDOT\Standards-
Global\MicroStation\Tables\Level_Translation. Select the file
V03.02_Level _Conversion.csv. Select OK.

Select Remapping CSV File

File Directory
Files: Directories:

[%03.02_Lewvel Conversion.cay . ATableshLevel Translation'

W03.02_Level_Conversion. cav I I = Ch
[~ Program Files
= workspace-CDOT
(7= Standards-Global
[ MicroStation
[=r Tables
= Level_Tramslation

Cancel
List Fileg of Type: Dirives:
Remapping Files [ cav] v| |§ C: ] m
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6. Inthe Save As V8 Options dialog box, check on the field for Apply Level

Mapping. Select OK.

F= Save As V8 Options

Remap | Rieferences | Filtell

r
-
-

CSY File [W0300_To_ %0301 csv

W i&pply Level Mapping

Qi

Cancel |

7. Select OK in the Save As dialog box. The CSV file will execute and the previous
levels will be converted to the updated levels in the V03.01 configuration release.

Save As

Directory

| 12345PlanProfiled2a]dgn

Directories:

LAProjectsy 1234584 Designt Drawings!,

12345Approximate Quantities##.dan
12345Eanhwork Cluantities##.dgn
12345GeneralNotesSheetll.dgn
12345GeneralNotesSheatl2.dgn
12345FlanProfile##.dan
12345PlanFrofile01.dgn
12345PlanFrofilel2.dgn
12345FlanFrofile03.dgn
12345PlanFrofileld.dgn
12345FlanFrofile05.dgn
12345PlanFrofile06.dgn

KN
Select Format To Sawe:
MicroStation W8 DIGN Files .dgn]

-

e

|

=y
= Projects
[ 12345a
{72 Design
= Drawings
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21 Reference_Files
£ Tabs

Drives:
El=

=

oK

Cancel
Options

Note: Once the new file is created, there will be two files with the same data. From
windows explorer delete the old file and rename the newly created file to the old
name. This will allow all reference file calls to be correct and will eliminate having

duplicate data
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Compressing the Model File

8. After the level updates have been made to the drawing files created in previous
versions, select File > Compress Design > Options.

-
=
Edt Element Settings Took U
3 New... Ctri+N
— @ Open... Ctr+0
4 Cose CtrisW
e save Ctri+S
Save As...
[ Compress »  Design
Save Settings Ctri+F Options
E Reference
: Raster Manager

9. Inthe Compress Design Options window, all options should be on except Delete
Text Elements Containing Only Spaces. Select the Compress icon, then select the

OKicon.
= Compress Options E] =

Select Action Aliag I
Delete Emphy Cell Headers EMPTY_CELL
Delete Erpty Text Element EMPTY TE=T
] Delete Text Elementz Containing Only Spaces  SPACE_TEXRT |
[w] Delete Unuzed Mamed Shared Cells SE_N.-’-‘-.HED
Delete Unuzed snonymous Shared Cells SC_AMOM
Delete Unuzed Line Styules LIMESTYLES
Delete Unuzed Dimenzion Shles DIMSTYLES
Delete Unuged Text Shles TEXTSTYLES
Delete Unuged Levels LEVELS
Delete Unugzed Mested Attachment Levels LEVELTAELES

Compress (H] % l Cancel Apply
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Converting Levels in MicroStation as a Batch Routine

1. From the MicroStation Manager, open a drawing file

2. Itis recommended that a new project folder is created for the translated data to insure
the original project data is not lost. Using the same JPC# number appended with a “—
(initials)”. Once the data is verified the original data can be backed up to disc and
delete. The “—(initials)” then can be dropped from the project folder. The example

used for this workflow will be 12345-NLJ.

3. Select Utilities > Batch Converter.

‘E'—-El C:\Projects\12345\Design\Drawings\12345PlanProfili

File Edit Element Settings Tools | Utilities Workspace  ind:

Ned & B “
Connect Web Browser
Il HTML Author. ..

Cell Selector

Image 3
Render 3
Augiliary Coordinates

Saved Yiews

T
; D. Marmed Groups
A O I Batch Converter. .. I

L3

1
Batch Process...
B A

. Standards Checker 4

4. Change the Default Destination to the temporary project folder.

=) [untitled] - Batch Convert

Eil=  Edit
= S &
Default Dutput Format |48 -

E)efault Destination | c:hprojectsh 12345

LConversion Tasks

# ¢ | Source To Destination

Browse for Destination H
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5. Browse to the temporary project folder and click OK.

F% Select Destination Directory

Directony:
|

o \projects’,

= o -
£ projects
q
£ 12345-HLJ |
2eUT_High-Flains
3 Batch Processes
£3 Bentley
1 BHI
£a ChoT —
23 Downloads
3 Johnsaons

23 Manuals L] r— ]
=l

Dirives:
=2C

Help

6. Select the Add Files or Directories to Convert icon.

?—j[untitled] - Batch Convert
File Edit
& W ok r

Default Dutp, Add Files or Directories to Convert

Diefault Destination | c:\projectsh12345-MLI QL g

Conversion Tazks

# ¢ | Source To Destination J
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7. Within the Add Files or Directories dialog box Files can be added individually and
added to the process or entire directories can be added. Toggle on Include
Subdirectories prior to adding folders to a convert process. Select the folder and
select Add. Select Done when you are finished adding files and/or folders.

E--f] Select Files and Directories to convert

Directories:

Files:
| chprojectsh,

= et
B e

1 12345

Tea40-NLS
£ 3601_High-Plains
3 Batch Frocesses
23 Bentley
1 BHI
£ cooT
3 Dowrloads
23 Johnzons
23 Manuals

Dirives:

Ligt Filez of Tvpe:

=

DGM Files [*.dan]
Selected Files
o hprojectsh] 23455

-]

=2

=]
IW Include Subdirectonies I

Cancel
Help
Add

Bemove

i

8. Select Edit > V8 Save Options...

F= [untitled] - Batch Convert [;__]
Eil= | Edit
_1[ Add Files... &
Add Ackive File
- rojectsy 1 2345-MLJY Q. g
DWia Cpen Oplions...
Corv Dy Save Options...
YE Save Dptions. .. To Dlegtination I
12 WZ Save Options, ., Wa c:hprojectsh12345-ML1Y
Log File Options. ..
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9. Inthe Save As V8 Options dialog box, select the Browse for CSV remapping file
icon. A standard CSV file is located in the configuration which is already set up to
remap all of the previous versions’ levels to the standard CDOT MicroStation V03.00
levels.

Save As V8 Options ‘

Re

I References | Filter |

CSV File [ )

|Br0~.v5e for CSV remapping fie

D

sl§sl] =k nljwk

OK I Cancel |

10. If not already there, browse to C:\Program Files\Workspace-CDOT\Standards-
Global\MicroStation\Tables\Level_Translation. Select the file
V0204 _To_V0300.csv. Select OK.

Select Remapping CSV File

File Directory
Files: Directories:
|V0302_LeveI_Update.csv JATahbleshLewel_Translation,
0302_Level_Update cev I = B
= Program Files
= Workspace-CDOT
[ Standards-Global
(= MicroStation
= Tables
= Level_Translation
(8]
Cancel
List Files of Type: Drives:
Femapping Files [*.csv] i | El= =l Help
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11. In the Save As V8 Options dialog box, check on the field for Apply Level

Mapping. Select OK.

Save As VB Opticns

Remap | References | Filter|

CEY File | WO30Z_Level_Update cav

I~ Apply Level Mapping |

) o o

Cancel

12. Select the Process Batch Convert Job icon when all files and directories have been

added to the convert process.

P [untitled] - Batch Convert

File  Edit
b “u [

- i

Default Dutput Format |V]Process Batch Convert Job
Default Destination | c:projectsi1 2345-NL1Y Q 4J

LConversion Tasks

# | Source To Destination I

2 cohprojectsh 123454, e chprojectsh]2345-MLJN

13. Select Convert.
E.'j- Files to Convert &
# /| Source Format | Destination To | Status Time
1 chprojects' 123454 . M1 23450 ndget odeli#. dan 8 C:AProjectsh12345-ML).. 51 2345Bridgetd odeldf. dgn Y8 Pending
2 chprojects\1234. 0123458 idgeProfileftit dgn W8 C:\Projectsh] 2345-M.. \12345BnidgeProfilefif.dgn . VB Pending
3 chprojects\ 12345, \12345PlanProfile01 . dan W8 C:\Projectsh12345-ML).. M 2345PlanProflel].dan - ¥EB  Pending
4 chprojectsh1234580..0 2345PlanS heettt. dgn W8 C:\Projectsh1 2345-MLIND . M 2345F anS heetftif.dgr WB  Pending
5 chprojectsh 1234, \12345PofileSheeti . dgn - W8 CAPiojectsh12345:N.. V1 2345FofileSheettf . dgn - Y8 Pending
B chprojectsh12.M23485 andardPlanList dgn W8 C:\Projectsh1 2345, 4123485 tandardPlanList.dgn . W8 Pending
T ochprojects\123454Desi. \12348TitleSheet dgn W8 C:\Projectsh1 2345-MLND e M2345TilleSheet dgn W8 Pending
8 chpro. AMES Standard Plans List Index.dgn W3 C:\Projec... \M&S Standard Plans List Index.dgn W8 Pending
9 chprojectsh12345% W 2348Designkdodeldi dor W8 C:\Projectsh12345-ML) . 4 23450 esigntdodel it dor W8 Pending
10 chprojectsh1234. \12345D esignProfilefH. dgn - V8 C:\Projectsh12345-M.. M\ 23450 esignProfilettf dan - Y8 Pending
11 cohprojectsh. \12348Interchangelapoutitf.dgn W8 C:AProjectsh] 23, \12348Interchangelapoutiit.dgn VB  Pending
12 chprojectsh12345. 412348Intersectionftl. dgn V8 C:\Projectsh12345-NL.. M 2348 ntersectiontttt.dgn  vB  Pending
13 chprojectsh12345..412345Phasingtodelit. dar V8 C:\Projectsh1 2345-ML.. M 2345Phasingtodelftit.dgr W8 Pending
14 chprojectsh123.412345L andscapetd odelfi.dg V8 C:\Projectsh12345-. M1 2345L andscapetodelft dor W8 Pending
15 coihproject.. 1234585 uctureQuanttiest. don - W8 C:A\Projectsh1.. 8123485 buctureQuantitiestif.don - V8  Pending
16 chprojectsh123.412345Hpdiaulicstodelft# dor V8 C:\Projectsh12345-. 41 2345Hudraulicshd odeldf. don Y8 Pending
17 chprojectsh1. M 2348HpdiavlicsProfleti# dgn W8 C:\Projectsh 1234\ 2348HpdraulicsProflef#t.dgn YB  Pending
18 chprojectsh12345y A1 2345R 00 M odeldt dgn W8 C:\Projectsh12345-ML) . M 2345R 0w Modelit dgn W8  Pending
19 chvprojectsh1 23823455 uveyMadeli dgn - VB C:\Projectsh12345- M\ 23485 uveyModelif dagn YB  Pending
20 cohprojec. V123455urveyTopofftScaleft.dgn W8 C:\Projectsh,. \123455urvepT opolfiScaletl.dgn VB Pending
21 chprojectsh12345\Traf. A1 2345Lighting#f#. dgn V8 C:\Projectsh12345-NLINT ra. . A1 2345Lighting###. dgn Y8 Pending
22 chprojectsh1 2345\ Traffi..\123455ignaltit.dgn V8 C:\Projectzh] 2345-MLINT raff... A1 23455 ignalitt.dgn VB  Pending
23 chprojectsh. N12345T rafficD esigntd odeldf. dan V8 C:\Projectsh123. V2345 T rafficD esigntodelft. dan Y8 Pending
24 cohprojectsh12345\Ut . N1Z2345U ity odelftit.dg V8 C:\Projectsh1 2345-MLINL M 23450y odelftit.dc WEB  Pending
I Carveert I Cancel
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14. Once Convert is selected the process will run and the status column will be updated
from Pending to Converted.

15. Once all the files have been updated select Done.

F= Files to Convert %
# | Souce Format | Destination To | Status Time 1
1 cihprojectsh] 23454 51 23458 ridgeM odel#H. dan V8 C:5Projectsh12345-NL). 4123458 dgetodelit. don ¥8  Convered 0.4
2 chprojects\1234. 4123458 ndgeProfilefl.don V8 C:\Projects\12345-M.. 4123458 ndgeFrofileftt.dogn V8 Converted 0.3
3 chprojects\12345. \12345PlanProfiled].dgn WE C:\Projectsh12345-MLJ.. A1 2345P anProfile0l.dgn - W8 Converted 0.4
4 chprojects\ 12345480 . A1 2345F anSheetd. don V8 C:\Projects412345-MLIMD. . 41 2345P anSheetB# dor VY8 Converted 0.4
5 chprojects\1234. 51 2345PofileSheetif dogn W8 C:\Projectsh12345-M.. \12348PofileSheetff.dan V8 Converted 0.4
B chprojects\12. M 23455 tandardPlanlist. dgn W8 C:\Projectsh 12346, 8123455 tandardPlanlist dgn. V8 Converted 0.5
7 chprojects\12345\Desi. N 2345TitleSheet. dgn W8 C:\Projectsh12345-MLID e, \12348TileShest. dgn V8 Converted 0.4
8 chpro. SMES Standard Plans List Index.dagn Wa C:\Projec.. \ME&S Standard Plans List Index.dan W8 Converted 0.4
9 chprojects\ 123454\ 23450 esignM odelfi# dgr VB C:\Projectsh12345-MLJ.. A1 23450 esignt odelfi#. dgr V8 Converted 0.2
10 ehvprojectsi1234. M 23450 esignProfilefift.dgn W8 C:\Projectsh12345-M.. 4123450 esignProfilet.dgn V8 Converted 0.4
11 chprojectst . M12345Interchangel apoutif don W8 C:\Projectsh123. A1 2348Interchangel ayoutiil dogn V8 Converted 0.3
12 chprojects\12345. 412348 ntersectionfft.dgn W8 C:\Projects412345-ML .41 2348 ntersectiondt.dgn V8 Converted 0.3
13 cohprojects\12345. \12345Phasingt odelii#. dar W8 C:\Projectsh12345-ML . A1 2345PhasingM odelfi#. dgr V8 Converted 0.2
14 cihprojectsh 123,01 2345 andscapetodelith. dg W8 C:\Projectsh12345- A1 2345L andzcapeM odelfft. dgr VB Converted 0.4
15 cihproject. N 23455 uctureQuantiiest#.don - W8 C:AProjectsh1.. A1 23455 uctureQuantiestif.don - W8 Converted 0.2
16 chprojectsh123. 0 2345HydrauliceModel#$ dar W8 C:\Projectsh12345- A1 2345HydravlicsModelit dan V8 Converted 0.4
17 chprojectsi1. A 234EHydradlicsPrafilefiit. dgn W8 C:\Projectsh1234. A1 2345HydraulicsProfilett . dgn - V8 Converted 0.3
18 coihprojects\12345% A 2345R0W Modelttl dgn W8 C:\Projectsh12345-MLJ.. 41 2345R 00 Modelitd.dgn V8 Converted 0.5
19 cihprojects\123. M 23455 urveyModelift. don W8 C:\Projectsh12345- A1 23455 urveyModelftdogn - V8 Converted 0.3
20 cihprojec. M12348SurveyTopoltScaletift.dgn W8 C:\Projectsh. .\ 1234585 uvey T opoliitScaleftf dgn VB Converted 0.4
21 cohprojects\1 23455 Traf.. 1 2345LightingH#.dgn W8 C:\Projectsh12345-MLITra. 4 12345Lighting# 4. dgn V8 Converted 0.3
22 cihprojects\ 12345\ Traffi. A\12345Signalft dan W8 C:\Projectsh12345-MLIAT raff 4\ 12345Signalitd dgn V8 Converted 0.4
23 cihprojectsh.. N12345TrafficDesigntodelf#. dgn W8 C:\Projects4123.. 12345 TrafficDesignModelt.dgn V8 Converted 0.4
24 coihvprojects\123454UE AT 2345 U Modelt s dg VB C:\Projectsh12345-MLJN. N 23450t I odel$H.dc VB Converted 0.3

16. Take time to verify your data. The translation will only build folders and copy the
translated data. You will need to copy all missing folders and data from you original
project to the translated project folder. When folders and data have been verified,
either delete or archive your original project folder and rename the translated project
folder by removing your initials. This step will ensure that all references will
display.
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