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Document Conventions 
There are several conventions that are used throughout this document to indicate 
actions to be taken or to highlight important information.  The conventions are as 
follows: 

 

Item     

View Perimeter a command name or a file that you are to select 

Meaning 

Tools > Options a command path that you are to select – usually from the 
pull-down menus 

Key in entering data with the keyboard 

Document name style used when referring to another document 

Note:  text information about a command or process that you should 
pay particular attention to 

Emphasis an important word or phrase 

1. Numbered Steps actions that you are to perform as part of the lab activities 

<D> or Data press the data button on the mouse 

<R> or Reset press the reset button on the mouse 

<T> or Tentative press the tentative button on the mouse 
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1. Getting Started 

Purpose of the class 
The purpose of this class is to teach users in the Traffic group the workflow used to 
produce their sheets using MicroStation. It is not intended to re-teach MicroStation 
concepts, but to reinforce the concepts learned in previous training through 
applying them to a Traffic job. 

Course Overview 
The class starts with a review of the workflow used by Traffic, then takes each of 
the primary categories in the workflow and expands on it with an individual lab 
activity. Finally, there is a recap project that takes the students through the whole 
process yet again, reinforcing the workflow. 

Throughout the course, the students will be using the CDOT Menu to complete 
their traffic exercises, and the CDOT Workflows and CADD Manual will be 
referenced to point the students where to look for more information. 

Prerequisites 
This course has been developed for students in the Traffic group that have already 
taken basic MicroStation training. It is not intended as an introductory MicroStation 
training class. 
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CDOT CADD Resources 
There are many resources available to assist you when working on your CDOT 
CADD project. These resources can be found on the CDOT CADD & Engineering 
Innovation Web site. 

CDOT CADD & Engineering Innovation Web Site 
The CDOT CADD & Engineering Innovation web page is available at: 

http://internal/cadd/  It can also be found on the internal CDOT website: 
Organizations > Project Development > CADD and Engineering Innovation. 

The website (presently only available to CDOT) provides CDOT users with up 
to date information, tools, and resources related to CADD and the Colorado 
Engineering Software Transition (CEST) project.  

This website is a valuable resource for CADD users and includes links to: 

CADD Library -- provides links to manuals, newsletters, standard details, Tips 
and Tricks etc. 

CADD Manual -- documents standardized procedures for the exchange of 
information. The Manual also addresses software issues, tools, techniques, 
standards and procedures, etc. which will aid the user in the efficient production 
of CDOT plan sets. 

CDOT Workflows -- step-by-step CDOT-specific procedures for certain tasks 
that you may encounter when working in MicroStation or InRoads on a CDOT 
project. 

Issues Logs -- to determine the status of submitted requests. 

Requests and Support -- provides CADD help solutions where you can submit 
questions or requests, obtain InRoads, InRoads Survey and MicroStation 
support, and link to IT Services for support. 

Training -- sign up for training classes or review online computer-based training 
(CBT) for MicroStation, InRoads and InRoads Survey. 

 

 

http://internal/cadd/�
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2. The CDOT Traffic Workflow 

Overall Workflow 
While there are certainly many variations, a simplified general workflow for Traffic 
using MicroStation is shown below. 
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Difference between model and sheet files 
To understand how CDOT uses MicroStation for design and drafting, you first 
need to understand the difference between Model files and Sheet files.  

Model files contain the design graphics. These are the working files for your 
design. Traffic will use at least one Model file, but can have multiple model files 
for different type of graphics. For example, you may have separate model files 
for signs, signals, lighting, etc. 

The traffic model files can reference other group’s models.  

 
 

 
  

Design Model Traffic Model Traffic Model 

Traffic Model with Design Model Referenced 
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Sheet files are the files that will be plotted for the creation of a plan set. Sheet 
files reference model file graphics. A reference is just a MicroStation file 
attached to your active file (the file you have opened). You can reference 
multiple model files to create a sheet file. For example, a Traffic sheet may 
reference the existing survey/topo model, the proposed roadway design model 
and the proposed bridge model to show all of the needed information on the 
sheet. Sheet files, typically, do not contain design graphics since they are 
referenced in from the model files. You can’t modify the model file reference 
graphics in a sheet file; they are there for information only. The sheet files, 
however, do contain the border and associated information (bar scale, north 
arrow, etc.) along with text and dimensions, which can be modified since these 
elements are placed directly in the sheet. 
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Project set-up  
The Project Manager is responsible for setting up a new project. To take full 
advantage of single source data, the project directory is created on either a network 
sever or on the PM’s personal computer. All users working on a project would then 
need to map the PM’s machine in order to access the project directory. 

The Create Project Directory Utility 
To create the project directory, the Project Manager runs the Create Project 
Directory utility. The utility is found on the Windows Start Menu (Start > All 
Programs > _CDOT_CADD_Information > Create Project Directory 
Structure). 

 

The PM enters the Job Project Code (JPC) and runs the utility. This creates the 
project directory and associated blank and auto-populated files, along with the 
Project Configuration File (PCF).  

The project can either reside on the Project Manager’s computer or on a network 
drive. If it’s on the PM’s machine, make sure this drive is shared to others 
working on the project. To create the project on a network drive, select the 
Browse button (…) next to Destination and then select Open. 

 
You can now set the path to any mapped network drive. 
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For more information search the CDOT CADD Manual for Project Creation 
Utility. 
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The PCF file 
The Project Configuration File, created by the utility, defines a specific directory 
that MicroStation defaults to when opening up a DGN file or referencing model 
files. PCF files are extremely useful when multiple users are accessing the same 
project directory across the network, or when DGN files are moved from one 
directory to another. 

Working in a server environment 
If multiple users are accessing the same project directory, the PCF file will need 
to be distributed to everyone on the team accessing the project directory. Each 
member of the team should have their own copy of the PCF file and it should be 
saved to the same location, C:\Program Files\Workspace-CDOT\Standards-
Local\Projects.  

When team members are sharing the project manager’s machine, the PCF file 
will need to be edited. See the Workflow CDOT PCF Management for more 
information. 
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The CDOT Project Directory Structure 
The Project Creation utility creates the project directory structure on the server or 
PM’s computer. All CDOT projects should follow this structure to ensure the 
accurate sharing of information between groups within the Department as well as 
outside consultants. The CDOT Project Directory’s top level designates the project 
code. Below this folder is a set of standardized sub-directories for each CDOT 
specialty group. Under each specialty group folder is a sub-directory structure 
unique to that specialty group. 

For more information about the CDOT project directory structure, search the CDOT 
CADD Manual for Project Directory Structure.  
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Training Project Directory 
For this training class, you will use a project directory structure with an example 
Job Project Code (JPC) of 12345 shown below. The Traffic_ITS sub-folder is 
shown expanded. 

 

Training files 
The training lab files for CDOT CADD courses can be accessed from the 
Windows Start Menu. Select Start > All Programs > 
_CDOT_CADD_Information > Training Files > Insert Training Files on my 
Computer. A link is also available on the Training page of the CDOT CADD 
web site.  

It is highly recommended that you that you install the training files and continue 
practicing with MicroStation by completing the lab exercises contained in this 
course guide, especially if you do not plan to start work on a MicroStation 
project soon. 
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CDOT file naming convention 
Model files and Sheet files need standard, informative, and unique names to 
allow easy identification of the specialty group responsible for the file and the 
type of information contained within the file. All CDOT CADD drawings 
created should follow this naming convention so the data can be easily identified 
and shared by all users.  

The CDOT file naming convention contains the Job Project Code (JPC), a short 
standardized file name, file counter, and file extension.  

 

An example of a MicroStation design file would look like the following. 

12345DesignModel01.dgn 

12345 indicating the CDOT Project Number, DesignModel indicates it is 
Roadway Design’s model file and 01 indicating it is the “First” design file in 
this series of design files. DGN is the default extension for MicroStation design 
files. 

Note

For more information about the CDOT naming conventions, search the CDOT 
CADD Manual for File Naming Convention. 

:  A fourth segment is used on Working Files. This segment should 
be the initials of the designer or engineer who is working on the 
file.  
Example: CU12345DesignModel01.dgn where CU, are the 
initials of the designer or engineer (in this example, CU stands 
for “CDOT User”).  
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Auto-populated files 
In addition to creating the project directory structure, the Project Creation Utility 
also creates several auto-populated drawing files that have the CDOT standard 
file names already assigned (the # symbol is used for the counter). When 
creating a new file, one option is to open the appropriated auto-populated file in 
MicroStation, select File > Save As and then rename the file. 

The diagrams below shows and example of auto-populated files automatically 
created for the Traffic group. 
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What files go where? 
As you’ve learned there are two main types of CADD files for a CDOT project: 
Model files, which contain graphics for referencing into sheets and Sheet 
files, which generally contain either references to model files or non-design 
related items such as general notes, special symbols, quantities, sheet borders, 
etc. 

Working Model files 
Working files (or sketch files) are model files containing graphical data created 
during the design workflow.  These files should be placed in the "Working" 
folder in each group’s sub-folder. The file name should include the designer's 
initials. These files are not to be considered final design files, and 
should not be referenced to sheet files or other reference model 
files. An example of a working file would be: 
//12345/Traffic_ITS/Working/CU12345TrafficModel01.dgn 

 

Reference Model files 
The most up-to-date model files which are available to other groups for 
referencing (files that only have the most current non-sketch or working 
information in them) should be placed in the group’s Drawings > 
Reference_Files folder. The designer’s or engineer’s initials should be removed 
after moving this file. 
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Sheet Files 
Sheet files are typically stored in a group’s Drawings folder as shown.  

 

Plot files 
When sheet files are plotted to PDF, the plot files are placed in the project’s 
Plot_Sets folder. Sub folders for AD, FIR, FOR and ROW are available. 
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For more information, search the CDOT CADD Manual for Group Sub-
Directory Structure. 

 

 

See also: 

 CDOT CADD Manual, File Naming Convention, File Types. 
 CDOT Directory Structure Workflow. 
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Lab 2 – CDOT Traffic Workflow 
 

Objectives 
After completing this exercise, you will learn: 

• What’s where and how references affect others working on the 
design. 

• How to modify pcf file to access a PM’s drive if necessary. 

• How to use the CADD Manual to see where files are located. 

• How to use predefined workflows for specific tasks. 

• How to use reference file and understand how you’re affected by 
the work of others and how your work affects others. 
 

Getting Started 
Initially, you will open and review some model files and sheet files for a 
project to familiarize yourself with folder structure, naming convention 
and the general reference flow of a traffic project.  

Later, you will be creating many of these or similar files as you work 
through examples, so we have suffixed each of these training files with 
55 so you won’t have naming conflicts later. 

To start MicroStation: 

1. Select Start >All Programs > MicroStation > MicroStation   

or  –  
 
Double-click on the MicroStation V8 icon located on your desktop or in 
the MicroStation product directory  
(usually C:\Program Files > Bentley > Program > MicroStation). 
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MicroStation will start and the MicroStation Manager dialog box will 
appear on your screen.  

 

The MicroStation Manager is your file management interface in MicroStation. It 
allows you to create, rename, delete and open files as well as set workspace 
parameters. The MicroStation workspace is made up of three components: Users, 
Project and Interface. Setting these components allow you to customize the 
MicroStation interface. 
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Opening your file 

 

1. In the lower portion on the dialog box, make certain the following are 
set:  

 User:   CDOT User 
 Project:  12345 
 Interface:  CDOT 

Note

2. Navigate to Traffic_ITS\Drawings\Reference_Files. 

: Setting the Project to 12345 automatically set the directory to 
C:\Projects\12345 

3. Choose 12345TrafficDesignModel55.dgn. 

4. Select OK. 
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The CDOT Menu 
1. From the MicroStation Main Toolbar, select the CDOT logo. 

 

2. The CDOT menu will open. 
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Review the CADD Website 
1. On the CDOT Menu, choose Help > CADD Manual 

 

2. Review CDOT CADD Manual – Project folder for Traffic ITS 

 -- File Naming convention 
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PCF Management 
Note

1. On the CDOT Menu, choose Help > Workflows. 

:  At times you will be asked to use project data that is not located 
on your machine. For example, it may be located on the project 
manager’s machine. If that occurs, use the workflow provided in 
the CDOT workflow CDOT PCF Management. It describes 
how to edit the .pcf file for your use. 

 
 

2. Review the CDOT PCF Management workflow. 
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3. Using Notepad, open the file 12345.pcf in the C:\Program 
Files\Workspace-CDOT\Standards-Local\Projects folder. 

 
Note

4. Exit Notepad without saving any changes. 

:  The MS_DEF variable is set to C:/Projects/12345/. If you are 
working in a project located on the Project Manager’s (or any 
other person’s) machine, copy this file from his or her machine 
into the same folder on your machine and edit the MS_DEF 
variable as shown in the workflow. Once the MS_DEF variable 
has been established, Reference file links should be okay. 
Initially they will show up red if the link cannot be established. 

Directory Structure 
Review directory structure in the CADD Manual to see where files are 
located for roadway design (designs and plan sets). Hint: Use the search 
option to search for directory structure. 

Note that the model files for Roadway Design are located in 
C:\Projects\12345\Design\Drawings\Reference_Files. Model files 
contain the graphics for the design and are referenced by other groups. 
Since everyone places their design graphics at the correct coordinates, 
they may be referenced so that each group can see the other’s work. 
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Review Roadway Design Model 
1. Choose File > Open. 

2. Open the file 12345DesignModel55.dgn located in the 
\Design\Drawings\Reference_Files folder. 

 

3. Choose OK. 

4. Choose File > Reference or choose the References icon on the 
MicroStation menu. 

 

5. Expand the Hierarchy to show all reference files and make certain you’re 
seeing any nested references. Hint: If Display is toggled off for the first 
reference, you won’t see the nested ones. 

Note:  Any reference file names that display in red indicate that the path 
to the reference has been lost and you are not seeing the 
reference file. If this happens, close the file and make certain the 
.pcf file was edited correctly. 
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Review Roadway Design Plan Sheet 
1. Choose File > Open. 

 

2. Open the file 12345PlanSheet55.dgn located in the Design\Drawings 
folder.  

3. Choose File > Reference or choose the References icon on the 
MicroStation menu if you closed it earlier. 

 

4. Expand the Hierarchy to show all reference files and make certain you’re 
seeing any nested references. 

Notice that for this example the Traffic models are not attached, however 
the Roadway Designer may want to utilize your traffic models for 
reference. 
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Review a Traffic Model 
1. Choose File > Open. 

 

2. Highlight the file 1234TrafficDesignModel55.dgn located in the 
Traffic_ITS\Drawings\Reference_Files folder. 

3. Choose File > Reference or choose the References icon on the 
MicroStation menu if you closed it earlier. 

 

4. Expand the Hierarchy to show all reference files and make certain you’re 
seeing any nested references. 

Notice that the Traffic Model references the Roadway Design Model as 
well as the Survey Model through nested references. 
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Review a Traffic Plan (Sheet File) 
1. Choose File > Open. 

 

2. Open 12345SigningPlan55.dgn in the \Traffic_ITS\Drawings folder.  

3. Choose File > Reference or choose the References icon on the 
MicroStation menu if you closed it earlier. 

 
4. Expand the Hierarchy to show all reference files and make certain you’re 

seeing any nested references. 

Notice that the Signing Plan references the Traffic Model, which in turn 
references the Roadway Design Model.  

5. In the hierarchy on the left, highlight 12345SigningPlan55.dgn. 

Note

6. On the right, highlight 12345TrafficDesignModel55.dgn. 

:  This is the Active file, or the file you have open. 
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7. At the bottom of the dialog (you may have to expand the box) toggle 
Live Nesting to Copy Attachment. 

 

Notice that the nested references are now shown as upper level 
attachments. This allows for easier manipulation of the references. 

8. On the right, highlight all the references. 
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9. At the bottom of the dialog, toggle off Display. 

10. Close the References dialog. 

11. Fit the View. 

Note

12. Open the References dialog. 

: The model files that are referenced contain the actual design 
graphics. When they are turned off, you can see that very little is 
actually contained in the sheet file. The sheet file consists mainly 
of the border and title information, and some annotation. This is 
typical of plan sheets, but there are a few types of sheets that will 
contain more graphics such as a detail sheet or a tab sheet. 

13. On the right, highlight all the files. 

14. At the bottom of the dialog, toggle on Display. 

15. On the right, highlight 12345SigningPlan55.dgn. 

16. Toggle Copy Attachments back to Live Nesting. 

17. Close the References dialog. 

Make changes to the Traffic model 
1. Choose File > Open. 

 

2. Open the file 12345TrafficDesignModel55.dgn in 
Traffic_ITS\Drawings\Reference_Files folder.  

3. Choose OK. 

4. Make the changes shown in the diagram below. 
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5. Choose File > Open. 

Move the 45 MPH sign as shown 
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6. Open the file 12345SigningPlan55.dgn in Traffic_ITS\Drawings folder. 

 

Note

7. Choose File > Exit to exit MicroStation. 

:  Your work in the traffic model carries through to the traffic plan 
sheets. Any other groups using these sheets or referencing your 
traffic model will see these changes as well. Again, since all 
groups are creating their plans at the true coordinates, each can 
reference the needed information and have it appear in the true 
location. 
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3. The CDOT Menu 
The customized CDOT menu provides access to tools and applications intended 
to provide the user a simple, efficient method to apply CDOT’s CADD 
standards to every project.  These menus direct MicroStation to place elements 
on discipline-defined levels for drawing consistency.  

Note

Opening the menu 

: Since the CDOT Menu automatically selects the correct level for 
element placement across disciplines, you should have the menu 
set to the xxxMulti-Discipline group from the Select Group 
Environment program. This is the default setting, so you won’t 
have to make any changes unless your machine has been 
previously set to the Bridge Group. 

After starting MicroStation, select the CDOT icon from MicroStation’s Main 
toolbar to open the CDOT Menu. You can hover over the icon to verify the 
CDOT configuration release. 

 

 

Note: You can also open the CDOT Menu from the Group Menus 
toolbar. Select Group Menus > CDOT Menu.  The CDOT 
Group Menus automatically opens when you start MicroStation. 
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There are two group options: Bridge (and CDOT Menus (for all 
other groups). 

 

Parts of the menu 
 

 

Drop-down menus 

Explorer 

Status Window 

Main Menu 
Help 

Filters 

Item 

Category 

Active angle and 
scale settings 
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Drop-down menus 
Use the drop-down menus to make the following selections: 

Group Display 

Toggle on your Group to display Explorer menu selections for placing graphics. 
Some groups, like Drafting and Traffic ITS have “children” options that can be 
expanded with the “+” symbol in the Explorer menu tree. Drafting is a generic 
group (i.e. it’s used by all groups) for placing general text, dimensions, borders, 
etc. There is an option on this menu to select/deselect all groups. 

 

Add On’s 

The Add On’s menu allows you to launch custom add-on programs like 
AutoTrack, SignCAD, Typical Section Program as wall as other MDL  and 
automation tools for working with graphics like the Breakline tool and the 
ModZ tool, covered later in this class. 

For more information on Add On’s, see the CDOT CADD Manual, Chapter 
Two – CDOT Workspace, section 2.5 Customized MicroStation Menu 
and follow the links Review Discipline Specific Group Menus – All about 
Add On’s pull-down. 
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Options 

This menu allows you to have the CDOT Menu appear on top of any Windows 
Application, or have it reside behind other programs. 

Help 

This pull-down provides convenient links to the CDOT CADD web site Home 
page, the CDOT CADD Manual, Support Requests and Workflows. 

Explorer 
The Explorer Window is used to navigate through the tree structure of group 
options. 

Status Window 
The Status Window is used to select either Existing or Proposed 
categories/items for a particular group. Category options changed based on the 
Exiting or Proposed status. 

Category 
Group categories for graphic placement. 

Item 
Items are the specific graphical elements that can be placed in the design file. 
When an item is selected, the CDOT Menu automatically selects the proper 
drawing tool and selects the appropriate level for placement (along with that 
level’s ByLevel symbology). 

Filters 
Filters are used to filter types of items. There are five filters: Lines, Text, Cells, 
Patterns and All. Selecting a filer shows you only those types of elements in the 
selection window. 

Main Menu Help 
Reserved for future workflow help. 

Settings 
Allows you to set the Active Angle and Active Scale before placing text, cell 
and pattern items. 
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Lab 3 – The CDOT Menu Overview 

Objectives 
After completing this lab, you will understand how to use the CDOT menu for 
automating CADD work completed by the Traffic group. 

Getting Started 
1. Start MicroStation 

2. On the MicroStation Manager, highlight the file 
12345TrafficDesignModel55.dgn in the 
Traffic_ITS\Drawings\Reference_Files folder. 

3. Choose OK. 

The CDOT Drafting Menu 
1. From the MicroStation Main Toolbar, select the CDOT logo. 

 
The CDOT menu opens the way it was the last time is was closed. 
Therefore it probably will not look exactly like this picture. 



 

Page 38  Traffic Workflow Using Microstation 

2. Choose the Group Display pull-down menu and note what options are 
currently on. 

 

3. Toggle off all options except Drafting. 

4. Choose the + next to Drafting to expand the Drafting group tree. 

5. Select Linework. 
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6. Choose the Place pull-down menu and note that you can place different 
types of MicroStation elements. 

 

7. Under Linework, notice you have three categories for choosing what you 
want to draw. 

8. Choose Line Weight. 

9. Select 0 and notice the Level listed in the Attributes toolbar. 

 

10. Select 5 and again notice the Level listed. 

 

Note

11. Select the Line Style category. 

:  Choosing one of the line weights automatically sets the level for 
placement. Since CDOT uses By Level symbology, setting the 
level in turn sets the other attributes like color, weight and line 
style. 
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12. Choose the Continuous item and notice the Level listed in the Attributes 
toolbar. 

 

13. Choose Short Dash and again notice the Level listed. 

 

Note

14. Choose Settings. 

:  By choosing one of the options on the Linework menu, you are 
simply selecting an active level. Because of this, you only 
choose one option at a time. For example, you cannot choose a 
weight of 5 and a Plot Color of Lime, as they are each 
representing a different level. The last one chosen is active. 

 

Notice that you can set the Active Scale and the Active Level from this 
box. 

15. Close the Settings box. 
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16. In the tree structure at left, choose Borders. 

 

Notice that you can Place different type borders as well as different 
sizes by selecting the appropriate options in the Border category. You 
can also choose if you want a Bar Scale and/or North Arrow and the 
type. And, finally, you can choose to place the Resident Engineer cell 
and which one to place. We will later use this utility to place a border 
when we are ready to create sheets. 

17. Review the Text and Miscellaneous options under Drafting in the CDOT 
Menu Explorer to see what is available. 

Note:  At this point, your goal is to become comfortable with the 
location of the different options on the menu. You will be using 
the menu throughout the course. 
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18. Back at the top of the Menu, choose Add On’s. 

 

Note: The Add On’s are additional utilities or programs that you may 
need to use. Some, such as Launch AutoTrack require that you 
have additional software loaded on your machine. If you try one 
that doesn’t work, but you feel you need access to that particular 
program, contact the CDOT Help Desk to request that the 
software be loaded on your machine. 
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The CDOT Traffic Menu 
1. On the CDOT Menu, choose Group Display and toggle on Traffic ITS. 

 

Notice the additional option in the tree structure. 

2. Expand the Traffic ITS option if it is not already expanded. 

3. Choose ITS. 

On the right side of the menu, you will see a Status window and ITS 
categories. 
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4. Choose the Conduit category. 

 

Notice the buttons above the listing (Filter options). These filter the 
category items based on the type of command you’re accessing. For 
example, if you are placing Conduit, it uses linework. If you choose 
another Filter, such as the Text, there are no options for placing conduit. 

5. Select the Show Text filter. 

 
Notice there are not any placement commands available, since no 
conduit options are for text. 

6. Select Show Lines filter. 
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7. Choose Conduit. 

 

Notice that choosing Conduit sets the Active Level and activates Place 
Smartline. 

8. Draw a line to see the ITS symbology. 

9. Review the level of the line. 

10. Undo to delete the line. 

11. Choose the Devices category, and then select the item Fibermarker 
Dome. 

 

This sets the Active Level, activates the Place cell command and makes 
the active cell FBMarker-Dome. 
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12. Choose the Fiber category, and then the VMS category to see what is 
available under those two options. 

13. In the Group Display tree structure at left, choose Signals and notice the 
various options available. 

 

14. In the Group Display tree structure at left, choose Signing. 

 

Notice there are more options here. You must first choose a Place option 
for Sign, Structure or Both. Then the Status, the type of Structure and 
finally the actual Sign. 
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15. Set the Place option to Sign & Structure. 

16. Set the Status to Proposed. 

17. Select the first Structures option. 

18. Choose one of the signs as shown below. 
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19. Choose Apply. 

Notice your prompts as you place the sign. 

 First, identify the location for the structure. 

Note

 Next, identify the location for the sign cell. 

: Anywhere in the file is okay, as you will delete the sign later. 

 Identify the location for the beginning of the curvestring or 
leader. 

 Continue identifying as many locations for the curvestring as 
you would like. 

 Reset when you’re done. 

 

1 

2 

3 

4 

5 
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20. Choose another sign. 

 

Notice the X’s in the menu. These are the variables in the sign that you 
can set before you place the sign. 

21. Right click on the name with the X’s and choose Edit. 
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22. Enter a value for the variable. 

 

Note

23. Now choose Apply and place the sign. 

:  Some signs have two lines of variables that can be edited. 

 

Notice that the variables are now entered rather than appearing as X’s. 
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24. You can right-click on and Reset the Sign when you’re done if desired. 

 

25. Place any other signs you would like to see how the command works. 

26. Delete all of the signs, structures and leaders you just placed. 

27. Review the Staff Traffic, Striping, and TCD options under the Traffic ITS 
group in the CDOT Menu Explorer and place any items in the file you 
would like. 

28. When you feel comfortable with how the menu operates, Delete all of 
the placed objects. 

29. Exit MicroStation. 
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4. Beginning the Design 

Review of workflow 
In this chapter, you will be looking at the portions of the workflow indicated below. 
The workflow is basically the same for the existing sign model and the proposed 
traffic model(s). First, a blank file is created or copied from the autopopulated files, 
and then the appropriate files are referenced.

 
Project  
Setup 

 
Copy .pcf  

and modify if 
necessary 

 
Create 

Existing 
Sign Model 

File 

 

Reference 
Existing 

Topo  
Models 

 
Create 

Existing Sign 
Graphics 

 
Create  

Traffic Model  
File(s) 

 
Reference 

Design  
Model 

Create 
Sign Striping 

Signal and 
Phasing 
Graphics 

 
Create  
Sheets 

 
 Plan 
 Tab 
 Notes 

 
 

Plot 
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Creating a new Traffic Model file 
When you’re ready to create a new model file to begin your work, you have two 
options: 

 Create the new file from an auto-populated file or 
 Create the new file from a seed file 

Creating a model file from an auto-populated file 
Auto-populated files are created by the Project Creation utility. The model files 
are created in \Traffic_ITS\Drawing\Reference_Files folder. You can rename 
these files and save them to the project’s \Traffic_ITS\Working folder to create 
your new model file. The standard practice is to prefix the working file with 
your initials, then when it’s ready to be referenced by other groups, move it to 
the Reference_Files folder and remove the initials. 

Creating Model files from seed files 
A seed file is a “starter” file.  It has all CDOT standard settings for each 
specialty group. Seed files are either 2D or 3D, so make sure you choose 3D 
when creating model files. 

See the CDOT CADD Manual, Chapter Five – Drafting Standards, 
section 5.2 – Seed files for more information. 
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Review of References 
A Reference is a file that is attached to your active file, so that you can see the 
file’s graphics.  Reference graphics are not actually in your active file, but serve as 
background data.  You cannot modify reference graphics from the active file.  You 
can, however, copy graphics from the reference model to the active model and then 
modify them, if desired.  Using references is a good way to copy a large number of 
graphics from model to model. 

The proper use of MicroStation References is critical to achieving two key 
components of the CDOT MicroStation workflow: 

 Maintaining a single source for project data. 
 Sharing graphical data between specialty groups. 

References allow multiple users to work on different parts of a project at the same 
time.  Multiple users can access the same reference from a central location (e.g. 
project directory on the PM’s computer). Specialty groups can interact throughout 
the design process by referencing other discipline-specific model files. The data 
exchange between disciplines is “real time” when using MicroStation References.  

References are useful in the plan set creation phase.  You can “build” the sheets by 
referencing in the individual model files. The Traffic Model file can reference other 
discipline’s model files, as needed. The Traffic Model file can then be referenced 
into a newly created sheet file. You can also reference in details and show these at a 
different scale on the same sheet. 

Attaching References 
To attach references, select References from the Primary toolbar. In the 
References dialog box, select Tools > Attach.  
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Different reference file attachment methods are available to help control 
reference manipulations and displays. These include: 

 No nesting 
 Live nesting 
 Copy attachments   

Nested References 
References can be attached nested — meaning you can attach a reference’s 
reference. 

 

The Nested Depth option determines how many reference levels deep you can 
attach.  In the example below, if the reference TrafficModel is attached to 
TrafficPlanSheet01 with No Nesting, only the Traffic Model graphics are 
attached. If the nested depth is set to 1, you would attach TrafficModel01 and 
DesignModel01. If the nested depth is set to 2, you would attach 
TrafficModel01, DesignModel01, Survey/Topo and UtilityModel01. 

TrafficPlanSheet01.dgn 
(Sheet File) 

TrafficModel01.dgn 

DesignModel01.dgn 

Survey/Topo.dgn UtilityModel01.dgn 

Model Files 

Nested depth =1 

Nested depth =2 
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The Live Nesting option allows you to dynamically update a reference’s sub-
references after the reference is attached.  You can change your Live Nested 
Depth and your references will automatically update without having to detach 
and reattach the reference. 

The CDOT recommended method is that if Nesting is used, it be limited to a 
Depth of 1. 

The Copy Attachment Option 
The Copy Attachment option allows you to dynamically make nested 
references upper-level references. This way, you can manipulate and control 
each reference display individually, if needed. You can switch between nested 
references and the copy attachment at any time. 

 

Working with Raster Attachments  
When you attach a reference, you have the option to Display Raster 
References. If the reference has a raster image attached (e.g. aerial photo), you 
can choose to attach the raster with the reference. You can toggle the raster 
reference on/off from the Reference dialog box. 

 

Reference Levels 
You can control each reference’s levels just like the master file levels. The Level 
Display box shows a list of all attached references to the Master file. Select the 
reference and then turn the reference level on/off. 
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Lab 4 – Beginning the Design 

Objectives 
After completing this lab, you will know: 

 How to create Traffic Model files. 
 How to access the appropriate Roadway model files to begin working on 

your design. 
 The difference between Nested References and the Copy Attachment 

option. 
 How to use Copy Attachment to manipulate references. 
 What goes into the Traffic Model files. 

Getting Started with the Existing Sign Model File 
1. Start MicroStation. 

 

2. In the MicroStation Manager, highlight the file 
12345TrafficDesignModel##.dgn in the 
Traffic_ITS\Drawings\Reference_Files folder. 

3. Choose OK. 

MicroStation starts in the empty file. 

4. Choose File > Save As. 



 

Page 60  Traffic Workflow Using Microstation 

5. Set the directory to Traffic_ITS\Working. 

 

6. Key in the file name CU12345ExistingSignModel01.dgn (CU=CDOT 
User). 

You now have the existing sign model file created. The file is placed in 
the Working folder. This folder is used while you are creating the 
graphics for the design, but have not finished them. Upon completion, 
the file is moved to the Reference_Files folder and the initials removed. 
Other groups should not reference files from the Working folder – only 
from Reference_Files. 

Next, you will attach files to reference while working on your design. 

Reference the Existing Topo 
1. Choose File > Reference. 
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2. Choose Tools > Attach. 

 

3. Ensure the Attachment Method is set to Coincident World. 

4. Highlight the file 12345SurveyTopo100Scale01.dgn in the 
ROW_Survey \Drawings\Reference_Files folder. 

5. Choose OK. 

6. Fit your View. 

7. Save Settings. 

Notice that you now have all of the existing topo information from 
survey referenced to your drawing so that you can complete the existing 
sign model. 



 

Page 62  Traffic Workflow Using Microstation 

Getting Started with the Proposed Traffic Model File 
1. Choose File > Open. 

 

2. Highlight the file 12345TrafficDesignModel##.dgn in the 
Traffic_ITS\Drawings\Reference_Files folder. 

3. Choose OK. 

MicroStation starts in the empty file. 

4. Choose File > Save As. 

 

5. Set the directory to C:\Projects\12345\Traffic_ITS\Working. 

6. Key in the file name CU12345TrafficDesignModel01.dgn (CU=CDOT 
User). 

You now have the Traffic model file created. You would normally prefix 
the file name with your initials, but for the class data, you will use CU.  
Next, you will attach files to reference while working on your design. 
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Reference the Design Model File 
1. Choose File > Reference. 

 

2. Choose Tools > Attach. 

 

3. Ensure the Attachment Method is set to Coincident World. 

4. Highlight 12345DesignModel55.dgn in the 
\Design\Drawings\Reference_Files folder. 

5. Choose OK. 

6. Fit your View. 
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7. In the References dialog, change the Nesting to Live Nesting with a 
level of 1. 

 

Note:  With Live Nesting, you get the references to your reference file, 
so you now have multiple files attached. 

 

8. Expand the hierarchy on the left to see the levels of references. 
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9. Highlight the Active file on the left, which will show the first level 
reference on the right. 

 

10. Highlight 12345DesignModel55.dgn on the right side of the dialog. 

11. Toggle off the Display. 

Note

12. With 12345DesignModel55.dgn highlighted on the right, toggle Live 
Nesting to Copy Attachments. 

:  The nested references are also toggled off. You cannot toggle off 
a primary (upper-level) reference without the nested references 
also being toggled off. 

 

Note

13. Highlight 123454DesignModel55.dgn and toggle off the Display. 

: You now have top level references instead of only one with 
another underneath.  

Notice that with the reference set to Copy Attachments, you can 
manipulate the nested attachments individually. 
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14. With 12345DesignModel55.dgn highlighted on the right, toggle Copy 
Attachments to Live Nesting. 

Notice that you go back to not being able manipulate the nested files 
individually if the Design Model is toggled off. 

Raster References 
Notice there are no raster files attached currently. If Design had the raster 
images referenced, you would be able to see them through the model 
reference as well, as long as Display Raster References was toggled on 
in the Attachment settings when the Design Model was attached. 

Since the rasters are not attached, but there are aerials that have already 
been registered by design, you will now attach them to your traffic file. 

For additional information, see the workflow CDOT Using 
Georeferenced Images in Raster Manager. 

Check your Preferences 

1. Choose Workspace > Preferences. 

2. Highlight Raster Manager on the left. 

3. Set the preferences as shown below. 

 

4. Be certain the WorldFile Default Unit is set to Survey Feet. 

5. Choose OK. 
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Attach the Raster Images 

6. Choose File > Raster Manager. 

 

7. Choose File > Attach. 

 

8. Set the directory to 
C:\Projects\12345\Design\Drawings\Reference_Files. 

9. Highlight 09a.tif and use the other settings shown. Be certain Place 
Interactively is off. 

10. Choose OK. 
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11. Fit your view and window in to see the image. 

 

12. Repeat the process to attach 10a.tif. 

13. Again, Fit your view and window in to see the images. 

 

Notice they are already in the proper location, since they have been 
registered by Design. If you need to attach raster files that are not 
registered, you should work with Design or work with CDOT support. 

You can turn off the rasters but leave them referenced by toggling off the 
views. You can also Detach the rasters which you will do here. 
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14. Select File > Detach All. 

 

15. Review the workflow Using Raster Images in Plan Production 
for information on adjusting raster images. 

16. Save Settings. 

17. Exit MicroStation. 

To summarize, you now have the Existing Sign Model file created, 
which references Existing Topo as an upper level attachment. Nested 
attachments include several other files from survey, which can be 
manipulated more easily by changing the Live Nesting setting to Copy 
Attachment. 

You also have the Traffic Model file created, which references the 
Design Model file as an upper level attachment. The first level of nested 
attachments includes the Topo file from survey. 
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5. Creating Design Models 

Review of the Traffic Workflow 
In the last chapter, you created the Traffic Model file and referenced the Design 
Model. In this chapter, you will create Traffic-related graphics in the model file. 
Again, this is the same workflow you would use if you were creating existing sign 
graphics, only you would use the existing sign model rather than the Traffic Model. 
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The Traffic Level Structure 
Thirteen Specialty Group Design File Level Libraries (DGNLIBs) are available for 
use within CDOT.  The levels libraries are attached to your MicroStation design file 
and provide the CDOT approved standard discipline levels you can use when 
placing graphics. You can not create, edit or delete levels within the CDOT 
Workspace – use must use the levels provided in the DGNLIBs. Likewise, you can 
not modify the level's symbology, thereby maintaining “ByLevel” status for 
standardization purposes. ByLevel symbology is used by default for all level 
libraries and is the required standard for plan set creation.  CDOT has adopted an 
“existing vs. proposed” leveling scheme, whereas with the use of pen tables, all 
existing design data will plot gray scale.  Level duplication across disciplines has 
been avoided wherever possible. 

Level libraries (DGNLIBs) are stored in the CDOT workspace (C:\Program Files 
\Workspace-CDOT\Standards-Global\MicroStation\DGNlib). 
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For more information about the CDOT level structure and a list of all discipline 
level libraries, search the CADD Manual for Level Libraries. You can link to 
Traffic to review your standard level structure. 
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Review of Traffic Filters 
Level filters are named groups of levels that can be turned on or off as a group 
(e.g. all traffic levels, all survey levels, all topo levels).  

CDOT filters 
Several pre-defined CDOT filters are available for your use.  These filters are 
obtained from the various discipline-specific CDOT level libraries attached to 
your file.  The filters have been defined based on logical groups of levels that 
you normally work with (e.g. Cross Section, Profiles, Surface for the Design 
group, Signals, Signing, Striping for the ROW group.)  

Setting filters 
Use Level Display to turn the filters on or off.  Set the Show option to Filters, 
and then select the filter from the list. This turns the entire group of levels 
on/off. 

  

Show option 
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When working with levels, it is often easier to work with just a subset to quickly 
find a level to set active or turn on/off. In this case, you can “filter down” your 
levels by setting the Show Option to Levels and then changing the List Filter 
option from (none) to the desired filter.  

   
 

 

 

Filters can also be set on the Attributes toolbar when setting the active level. 

    

  
 

As you can see, using filters can be a great way to sort through the levels to find the 
one(s) you want for turning the displays on and off. This is especially handy if you 
are using one traffic model file for signs, signals, and striping. You may also use 
them to find the levels to draw on, but the CDOT Menu takes care of most of that 
for you. 

List Filter set to none 
(All Levels) 

List Filter set to Traffic (A subset showing 
only traffic-related levels) 

List Filter 
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Placing graphics with the Traffic Menu 
The Traffic menu is used to place the majority of graphics when you are creating 
your models. The Drafting portion of the menu is used as well as the Traffic 
portion.  

It is often necessary to place graphics, such as signs at a particular station and offset 
from an alignment. This is accomplished by either using MicroStation or InRoads. 
The InRoads method is easier and should be used if you have InRoads and the 
geometry project containing the alignment available. 

Using Station and Offset from MicroStation 
The workflow for using Station and Offset to locate a point 

In a tangent section 
Make certain AccuDraw is on. 

Find the nearest tick mark on the alignment. 

Copy it parallel the distance required to the desired station. For example, if it is 
the 202+20 tick mark and you need to locate 202+22.14, copy it 2.14’. 

Select Extend Line and toggle on From End. 

Identify the newly copied tick line at the end closes the alignment. 

AccuDraw’s compass will lock onto the origin. 

Move your cursor so that the line is extending away from the alignment in the 
direction you want. 

Key in the distance for the entire offset. (Remember, with AccuDraw, you do 
not need to click in the field, just key in the value.) 

The end of this line is the location of the station and offset. 

After you have placed the data you need at the station and offset, you can delete 
the line or make sure it’s on the DRAFT_INFO_No-Plot level and you can leave it 
for future use. 

In a curve 
Copy the curve into your file if it is in a reference. 

Often, the alignment is a complex chain. If so, Drop the complex status after 
copying. 

Turn off the level of the alignment in the Reference. 

Shorten the curve so that it ends at the desired station.  

Hint: If you shorten to the nearest tick mark first, then you won’t have to use 
the PC or PT station to calculate the desired length. 

Optionally, you can use Point at Distance Along to place a point at the 
correct location from the PC, then Partial Delete the curve to that point. 

Select Place Line, then Perpendicular Snap Point. 

Snap to the curves new endpoint. 
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AccuDraw’s compass will lock onto the origin. 

Move your cursor so that the line is extending away from the alignment in the 
direction you want. 

Key in the distance for the entire offset. (Remember, with AccuDraw, you do 
not need to click in the field, just key in the value.) 

The end of this line is the location of the station and offset. 

After you have placed the data you need at the station and offset, you can delete 
the line or make sure it’s on the DRAFT_INFO_No-Plot level and you can leave it 
for future use. You should also delete the alignment data that was copied into 
the Active file. 

Using Station and Offset with InRoads 
If you have access to InRoads and the alignment in question, then an easier 
method of locating stations and offset is available. 

Proposed (Design) alignments are stored in an .alg file under 
JPC#\Design\InRoads. Existing alignments from Survey are found under 
JPC#\ROW_Survey\InRoads. 

When you load an .alg in InRoads, the first person to load the file will have 
Read/Write privileges to all alignments. The alignments should not be modified. 
If you need to load an alignment that’s currently in use, you can load the file and 
it will give you Read Only access. Should you need to create an alignment, you 
should do so in a traffic .alg which should be stored under 
C:\Projects\12345\Traffic_ITS\InRoads. 

Start InRoads 

Load the .alg file containing the alignment.  

Make the alignment active. 

Select the command you need to place the item at a particular station and offset. 
For example, Apply the Place Sign. 

Key in the station offset in the MicroStation key-in field in the following syntax: 
so=station,offset.  You can optionally key in 
so=station,offset,elevation,align_name, in which case the alignment does 
not have to be active. 

Dropping cells and editing 
If you need to edit a sign or other cell after it has been place, you can do so. Text 
edits can be performed without modifying the cell first, as can changing the width 
of the cell with the Stretch command. (As long as they were not placed with the 
Share option.) 

If one of the traffic cells needs to be edited each time it’s placed, you should submit 
a request to CADD Management to either make the change in the configuration or 
add a new sign. 
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Copying Signs 
If the sign you need to copy already exists in another file, you have a couple of 
options for copying the sign. 

References 
Open the file containing the sign. 

Window in to the sign. 

Create a Saved View of the sign. 

Open the file in which you want to place the sign. 

Reference the previous file using the Saved View of the sign. 

As you move your cursor around the file, notice the saved view ‘following’ it. 

Move to a clear area and accept the location with a <D>. 

Make a selection set from the sign as shown. 

Choose Copy and move the sign to the area where you want it in this file. 

Detach the reference file. 

You can now use the CDOT Menu to place the structure and leader for this 
sign. 

Copy and Paste 
Open the file containing the sign. 

Make a Selection Set of the sign. 

Tentative <T> (but don’t accept) the point by which you want to place the sign 
when it’s copied. 

Select Edit > Copy or <CTRL> C on your keyboard. 

Open the file you want to copy into. 

Set the Active Scale to 1 and the Active Angle as needed. 

Select Edit > Paste or <CTRL> V on your keyboard. 

The sign will follow your cursor by the insertion point you selected with the 
tentative. 
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Lab 5 Creating Design Models  

Objectives 
After completing this lab, you will: 

 Be familiar with the traffic levels available and where to go for a listing. 
 Be comfortable with the level structure. 
 Know how to use the Traffic menu for placing signals, striping and signs. 
 Know how to use precision input (including stations and offsets) to place 

graphics (such as signs). 
 Know how to load InRoads .alg files and use them to track alignments 

and to place signs at stations and offsets. 
 Know how to edit a sign. 
 Know how to copy and paste signs. 

Getting Started 
1. Start MicroStation. 

 

2. On the MicroStation Manager, highlight the file 
CU12345TrafficDesignModel01.dgn in the Traffic_ITS\Working folder. 

3. Choose OK. 

4. Start the CDOT Menu. 
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Review Traffic Model files 
1. On the CDOT Menu, choose Help > CADD Manual. 

2. Search on Project Directory Structure. In the Group Sub-
Directory Structure topic, select the link to Traffic ITS Project Folder.  
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Notice there are three standard Final Model Files found in the 
Reference_Files folder. You are working in the 
TrafficDesignModel01.dgn file, but since it is not finished, it is prefixed 
with your initials and located in the Working folder. When complete, you 
will move the file to the Reference_Files folder and rename it, removing 
your initials as previously discussed. Currently, you may separate the 
Striping, Signal and Sign graphics into different Model files, or you may 
keep them all in one. They are placed on different levels, so you can 
work with only the graphics you need at any given time. 

3. Close the CADD Manual. 

Review Traffic Levels 
1. Choose Settings > Level > Display or choose the Level Display icon 

from the Primary toolbar. 
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2. Click the List Filters icon on the dialog. 

 

3. Scroll down and choose the Traffic filter. 

 

Notice the levels that are available include Accident, Striping, Signals, 
etc. 
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4. Choose the Signals Filter. 

 

5. Notice the levels that are available include only Signal levels. 

6. Choose other Traffic filters to see what is available in them. 

7. Choose (none) under List Filters. 

 

As you can see, using filters is a great way to sort through the levels to 
find the one(s) you want for turning the displays on and off. This is 
especially handy if you are using one traffic model file for signs, signals, 
and striping. You may also use them to find the levels to draw on, but the 
CDOT Menu takes care of most of that for you. 
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Place Signal Graphics 
1. Window in to the area around the intersection as shown. 

 

Rotate the Plan View by 3 Points 
Rotate the MicroStation view so the main roadway is horizontal. 

1. Turn the Depth Lock on. 

2. Turn AccuSnap off. 

3. From the View Control toolbar, select Rotate View. 

4. In the Tool Settings box, set Method to 3 Points. 

5. <T> on the mainline alignment near the 223+00 tick mark as the first 
point (left of the intersection). 

Your cursor jumps to the closest keypoint 

6. <D> to accept the tentative. 

7. <T> on the mainline alignment near the 227+00 tick mark as the second 
point (right of the intersection). 

8. <D> to accept the tentative.  

This defines the view’s new X axis in the positive direction. 
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9. When prompted to Define Y direction, <D> anywhere above the 
mainline alignment to define the view’s new positive Y direction. 

 

The view is rotated so that the beginning of the alignment is horizontal. 

Place the signal graphics 
1. On the CDOT Menu Explorer, make certain Traffic ITS is toggled on 

under Group Display. 
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2. Select Traffic > Signals from the Explorer on the left. 

 

3. Choose Settings at the bottom of the menu and set the Scale to 40 and 
the Active Angle to 0 (you can make changes as needed to create the 
graphics). 

 

Note:  You can also use MicroStation’s Scale and Active Angle 
settings. 
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4. Create the signal graphics as shown below using MicroStation and the 
CDOT Menu options. 

Your goal is to learn to use the options on the menu, not to precisely 
replicate the drawing. Feel free to deviate and try options not shown on 
this drawing.  
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Place Striping Graphics 
You may choose to place signs, signals and striping in separate model 
files. Here, you’ll be placing all three in the same model. 

1. Turn off the Signal levels. 

 

Note:  Use the filter to easily find the signal levels in the Level Display 
dialog. 
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2. On the CDOT Menu, select Traffic > Striping. 

 

3. Choose Settings at the bottom of the menu and set the Scale to 1 and 
the Active Angle to 0 (you can change the angle as needed to create the 
graphics). 
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4. Create the striping graphics as shown below using the CDOT Menu 
options. 

Again, your goal is to learn to use the options on the menu, not to 
precisely replicate the drawing. Feel free to deviate and try options not 
shown on this drawing.  
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Place Sign Graphics 
1. Turn off the Striping levels. 

 

Note:  Use the filter to easily find the levels in the Level Display 
dialog. 

 

2. Review the CDOT Traffic Signing Menu workflow.  
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3. On the CDOT Menu, select Traffic > Signing. 

 

4. Choose Settings at the bottom of the menu and set the Scale to 100 and 
the Active Angle to 270. 
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5. Choose Sign & Structure in the Place category. 

6. Set the Status to Proposed. 

7. Choose the option shown under Structures. 

8. Choose the D Signs category and highlight the d9-4 item. 

9. Right-click on XXD9-4 and choose Edit. 

10. Change the XX to 24. 
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Locate the position of the sign using Station Offset with 
MicroStation 
You want to place the sign at station 223+68 and offset -28 feet. First, you will 
use MicroStation to locate the position of the structure. 

1. Toggle off Graphic Group Lock. 

2. Ensure AccuDraw is on. 

3. Window in near the 223+60 tick mark on the SH 86 alignment. You can 
turn off other levels as necessary, such as the secondary alignment’s 
stationing as shown here. 
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4. Use MicroStation Copy Parallel to copy the tick mark 8 feet to the 
right. 

 

5. Select Extend Line and toggle off Distance and on From End. 
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6. Identify the newly copied tick line at the end nearest the alignment, so 
the distance will be measured from there. 

 

Accudraw’s compass will locks onto the end of the line. 

7. Move your cursor so that the line is extending away from the alignment 
in the direction you want. 

8. Key in 28 for the distance. (Remember, with AccuDraw, you do not 
need to click in the field, just key in the value.) 

 

The end of this line is the location of the sign structure. 

9. <D> to accept the line. 
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10. On the CDOT Menu, choose Apply. 

11. Snap to the end of the line you just created to locate the structure. 

 

12. Follow the prompts to place the sign as shown. 

13. Delete the placement line. If you need the location later, you can always 
move the line to the DRAFT_INFO_No-Plot level and keep it for later use. 
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Locate the position of a sign using Station Offset with 
InRoads 

Next, you’ll place a sign by station and offset using InRoads. Window in 
to the area shown, where you’ll place a sign at station 227+00 and an 
offset of 20. 
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1. Start InRoads by choosing the InRoads icon on the Main Toolbar. 

 

2. On the InRoads menu, choose File > Open. 

 

3. Set the Files of Type to *.alg (Geometry Projects).  

Project Defaults in InRoads set the ‘look-in’ directory for .alg files.  

4. Highlight the 12345_Design.alg and choose Open. 

Note

5. Cancel the Open dialog. 

:  You now have the geometry loaded that contains the project 
alignment. This is the design alignment, which is located in the 
Design\InRoads folder. The existing alignment(s) are located in 
the ROW_Survey\InRoads folder. 
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6. On the InRoads menu, choose Geometry > Active Geometry. 

 

7. Set the Type to Horizontal Alignment. 

8. Highlight SH 86 and choose Apply. 

9. Close the Active Geometry dialog. 

10. In the Explorer portion of the InRoads menu, select the Geometry tab. 
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11. Right-click on the SH 86 alignment and choose Details. 

 

 

Notice that you currently have Read – Write privileges to the alignment. 
There is a lock file (.lck) that tracks who has the geometry project open. 
Since no one else had it open, you have full privileges to modify the file. 
Should someone else need to modify the alignment, you can change 
yourself to Read Only, giving them access to the alignment. Had the 
geometry project been opened by someone else, you would have Read 
Only access and could view / track / station, etc., but would not be able 
to modify the alignments. 
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12. On the CDOT Menu, choose the Regulatory category and the item r2-3. 

 

The sign name expands to show two lines. 

13. Right-click on the first row (XX) and choose Edit. 

14. Change the XX to 55. 

15. Right-click on the second row (XXR2-3(XX) and choose Edit. 

16. Change the second row to 36R2-3(55) 
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17. Also on the CDOT Menu, choose Settings and change the Angle to 90, 
then Apply and Close. 

 

18. Select Apply. 

19. In the MicroStation key-in field, enter SO=227+10,20 

Note:  This is the location for the structure. 

 

20. Place the sign graphics in a location similar to that shown in the picture. 

21. Place the leader similar to that shown. 

22. Reset <R> when done. 
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Editing a Sign after placement 
After placing the sign, you realize that the speed was incorrect and 
should have been 45. You could always delete the sign and place it 
again, but for experience, you will follow these steps to edit the sign. 

1. Choose Edit Text. 

 

2. Select the sign label and change the 55 to 45. 

3. Select the sign text and change the 55 to 45. 

 

Note:  This edit was just because of a typo when creating the sign, so 
there is no reason to save the change as another sign. However, 
signs that have been edited may by saved to a personal cell 
library if it’s something you need to keep. If the change is 
something that is used frequently or is used on multiple jobs, you 
should request that the sign be added to the CDOT Menu / Cell 
Library. 
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Place a sign from SignCAD 
1. Choose File > Open on the MicroStation menu. 

 

2. Open STNAME OVER-b.dgn from the Miscellaneous folder. 

 

3. Hover over the graphics and note that the sign is not on the proper level. 

4. Tentative <T> on the graphics and note that they are not at elevation 0. 

In the next series of steps, you will move the graphics to the proper level 
and elevation. 
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5. Using your Element Select tool, make a selection set of all the graphics. 

 

6. Choose Change Element Attributes. 

 

7. Set the Level to TRAF_SIGNING_Proposed. 

Hint: use your filter to make it easy to find the level. 

8. Set the other options as shown. 

9. <D> to accept the selection set and move the graphics to the appropriate 
level. 

10. Leave the sign graphics in a selection set for the next step. 
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11. From the CDOT Menu, choose Add On’s > ModZ Load. 

 

12. Set the Elevation to 0.0 

13. Choose Single. 

The Single option will work with a selection set, or if there is no 
selection set, you can choose the elements one at a time. 

14. Close ModZ. 

15. Fit your view and check the level and elevation of the graphics. 

Copying signs from other projects 
If there are signs that have been edited in other projects, you can Copy 
and Paste them into your file, or you can copy them by referencing them 
into your current file. Using this sign from SignCAD, you’ll use both 
methods to see the difference. 

1. Window in to the sign as shown if you have zoomed out. 

 

You will begin by making a Saved View that you can reference (and 
copy) into the other file. 
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2. Choose Utilities > Saved Views. 

 

3. Choose the Save View icon. 

 

4. Set the Save View dialog as shown. 

5. Choose OK. 

6. Choose File > Save Settings. 

You’ll be using the saved view a little later. First, while you’re in this 
file, you will Copy the sign graphics and then Paste them into your traffic 
model. 

7. If you have cleared the Selection Set, then make another one out of the 
graphics in your view. 
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8. <T> on the upper left corner of the sign, but don’t <D> 

 

9. Choose Edit > Copy or <CTRL> C to copy the selection set. 

10. Select File > Open. 

11. On the MicroStation Manager, highlight the file 
CU12345TrafficDesignModel01.dgn in the Traffic_ITS\Working folder. 

12. Choose OK. 
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13. Fit, then Window in similar to what’s shown here. 

 

14. Choose Edit > Paste. 

   

The sign will follow your cursor based on the Tentative point when you 
copied it. Notice the ability to change the Scale on the fly. 

15. <D> to place the sign. 

16. Choose Settings > View Attributes and toggle off Fill. 
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Next, you’ll use copy from a Reference to complete the same task 

17. Choose File > Reference. 

 

18. Choose Tools > Attach. 

 

19. Set the Attachment Method to Interactive. 

20. Browse to 12345\Miscellaneous and highlight the file  
STNAME OVER-b.dgn. 

21. Choose OK. 
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22. On the Attachment Settings box, choose the Saved View shown. 

 

23. Choose OK. 

 

As you move your cursor around the file, notice the saved view 
‘following’ it. 
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24. Move to a clear area and accept the location with a <D>. 

 

25. Make a selection set from the sign as shown. 
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26. Choose Copy, Snap to a point on the sign and move the sign to the area 
where you want it in this file as shown. 

 

27. <D> to accept the new location. 

28. Detach the reference file. 

 

29. Close the References dialog. 

30. You really don’t need this sign, so you can Delete both copies with 
MicroStation. 
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Complete the design 
1. Create additional sign graphics as shown below using the CDOT Menu 

options. 

Place as many different signs as you would like in the area. Again, the 
goal is not to reproduce what you see exactly, but to become familiar 
with the menu and how to use it to create graphics for your jobs. 

  

2. Exit MicroStation. 

Note:  Of course you are not able to complete a full design in the short 
time span of this training class, but at this point, you are 
assuming the design is complete and will move the Traffic 
Model to the correct location. 
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3. Using Explorer or My Computer, move the file 
C:\Projects\12345\Traffic_ITS\Working\ 
CU12345TrafficDesignModel01.dgn to the folder 
C:\Projects\12345\Traffic_ITS\Drawings\Reference_Files and 
rename it by taking the initials (CU) off the front of the file name. 

Note: If you prefer, you use a Save As in MicroStation to save the file to 
the Reference_Files folder and take the initials off. Then, you can delete 
the original file. 

The Reference_Files folder is for completed models that are available to 
be used as reference for creating sheets and for other disciplines. Files 
located in the working folder are not to be referenced to other models or 
sheets. See the workflow CDOT Directory Structure for additional 
information on what files are placed in specific folders. 
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6. Sheet Files 

Review of the Traffic Workflow 
In the last chapter, you created the Traffic Model graphics. In this chapter, you will 
create the Traffic-related sheets by referencing the model file(s).  
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Creating Traffic plan sheets from Design plan sheets 
Often, the sheets you need for traffic will have already been laid out by Design. In 
these cases, you can copy Design’s plan sheets and rename them. You can either 
update the border cell in each sheet with the traffic information, or create a border 
specifically for traffic and replace the border in each sheet. 

To have the traffic information appear on the sheets, there are a couple of options: 

1. Have the designer reference your traffic model to the design model. This is a 
very quick solution, as the traffic model will show up on the sheet and already 
be clipped just like the design model. They can turn off the display in their 
design model if they do not want the information showing there. 

2. Go into each sheet and reference the traffic model. In this case, you will take 
each of the sheets where you want traffic data and reference your traffic model, 
then clip it as necessary. 

See the workflow in the lab activity for additional details. 

Workflow for creating Traffic plan sheets from scratch 
If you need to create a traffic plan sheet that does not have a corresponding sheet 
from design, you can place your own plan limits cell in the traffic model file, then 
reference it into a sheet. This can be done for scales other than the default 100 scale. 

See the workflow in the lab activity for details. 

If the sheet you need is similar to a sheet created by Design, you can use the plan 
limits cell that design has already placed in the Design Model. 

Workflow for creating Tab sheets 
When the project directory structure is created, there are automatically some traffic 
tab sheets created, such as the TRAFSignsTab##.dgn file. These files are already set 
up with links to tab spreadsheets, but they link to the spreadsheets in the workspace 
rather than the project.  

Copy the …Tab##.dgn file in the Drawings folder to …Tab01.dgn, for example. 

Update the spreadsheet link to link to your project-specific spreadsheet. 

Update the border to your project-specific border. 

See the workflow in the lab activity for additional details. 
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Workflow for creating Detail sheets 
Details are created in model files and are not necessarily created in a particular 
coordinate range or at full-scale. When they are used to create the detail sheets, you 
can scale them as necessary to fit the situation. 

You can create multiple details in one model file, or if you prefer, you can create 
model file for each detail. The general workflow for creating detail sheets is: 

Create the details in a model file. 

Create a new sheet file. 

Attach the detail model as a reference and clip if necessary. 

Place and position the border cell. 

Scale the detail to fit the border. 

See the workflow in the lab activity for additional details. 

Workflow for creating Traffic Notes Sheets 
GeneralNotesSheet01.dgn and 02 are created in the …\Design\Drawings folder 
through the create project utility. These sheet files initially reference a generic notes 
file in the CDOT workspace. However, the sheet files should reference the project-
specific notes file, 12345GeneralNote.dgn located in the 
…\Design\Drawings\Reference Files folder.  

For Traffic, you will copy the …GeneralNote.dgn file and the 
…GeneralNotesSheet.dgn files to create Traffic files. Then, edit the notes file to 
be project-specific and also update the references in the sheet file to point to the 
project-specific notes.  

In the current configuration, there are no default notes files for Traffic. However, in 
future releases there will be, so this workflow will start with a …TrafficNote.dgn 
file rather than a general one in the future. Currently, the general workflow for 
creating a Traffic notes sheet is: 

Copy and Rename the GeneralNotesSheet01.dgn (and 02.dgn) file in the 
…\Design\Drawings folder to TrafficNotesSheet01.dgn (and 02.dgn) in the 
…\Traffic_ITS\Drawings folder. 

Copy and Rename the GeneralNote.dgn file in the 
…\Design\Drawings\Reference_Files folder to TrafficNote.dgn in the 
…\Traffic_ITS\Drawings\Reference_File folder. 

Update the TrafficNote.dgn file with the new traffic notes. This can be done by 
editing the text in the file, or by importing a new text file. 

Update the Reference link in the Sheet file(s) to reference the new TrafficNote.dgn. 

See the workflow in the lab activity for additional details. 
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More Information 
For more information on creating sheet files, see CDOT Workflows Sheet File 
Creation, Sheet File Creation Multiple Scales, Creating Multiple Plan 
Sheets, Note Sheets, and Title Vicinity Map. 

 

Search the CDOT CADD Manual, for Project Sheets. There are several useful 
links for sheet workflows. 

 



 Sheet Files 

 

Traffic Workflow Using Microstation  Page 121 



 

Page 122  Traffic Workflow Using Microstation 



 Sheet Files 

 

Traffic Workflow Using Microstation  Page 123 

Lab 6 -- Sheet Files 

Objectives 
After completing this lab, you will be able to: 

 Create sheets by copying Roadway sheets (preferred method). 
 Create different types of CDOT sheets from scratch.  

Workflow for creating Traffic Plans from Design Plans 

Copy and Rename the Design Plan(s) 
1. Using Explorer or My Computer, look in the folder 

C:\12345\Design\Drawings 

 

Notice that the sheet files are already created for the roadway plan and 
roadway plan/profile. To expedite the sheet creation process, you should 
start with a copy of the Design plans whenever possible. Here, you will 
copy Design Plans and also create plans from scratch to learn both 
processes.  

Note that the Sheet files created by traffic should be placed in the 
C:\Projects\12345\Design\ Drawings folder.  
They will reference files from the  
C:\Projects\12345\Design\ Drawings\Reference_Files folder as 
well as the Reference_File folders of other disciplines. 
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2. In Explorer or My Computer, copy the 
12345Plan10.dgn file from C:\Projects\12345\Design\Drawings to 
C:\Projects\12345\Traffic_ITS\Drawings. 

Note:  You can copy several or even all of the sheet files, depending 
upon where the traffic information is located. In this case, you’ll 
copy just one to see the process. 

 

3. In the file you copied, change names by changing Plan to 
SigningandStripingPlan. 

 

4. Start MicroStation. 

5. On the MicroStation Manager, highlight the file 
12345SigningandStripingPlan10.dgn in the 
Traffic ITS\ Drawings folder.  
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6. Choose OK. 

 

Notice all of the references are still attached. You did not copy the files 
with the original graphics in them, just the sheet files which contain the 
border and possibly some annotation. 

7. Window in on the title block. 

Notice that the title block is still filled in as if this were a plan sheet from 
Design. You could simply edit this border now since it a cell that resides 
in this file. However, if you have many borders to edit, you can create 
your own Traffic-specific border and replace the Design borders. Next, 
we’ll create a new border to reflect the Traffic information for just such a 
scenario. 
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Create a project specific border 
You can use the following method to create a project-specific border cell. This 
method uses a border file from Design that you’ll copy and edit. After it is 
edited, you will use it as a cell to replace the border in the copied plan sheets. 

Alternately, you can keep the Design borders and edit them individually. The 
method you choose should depend on the amount of edits you need to do to each 
and the number of sheets to edit.  

Note: If you need to create a border entirely from scratch, you can use the 
CDOT Menu 

Copy the border file from Design 
Since you will use this border for multiple sheets, create one project border to 
avoid editing multiple borders later. 

1. From MicroStation, select File > Open. 

2. Set the directory to Design\Drawings. 

3. Highlight 12345PlanBorder01.dgn. 

4. Select OK.  

5. Choose File > Save As. 

 

6. Change the name to 12345TrafficBorder01.dgn and save it in the folder 
\Traffic_ITS\Drawings. 

Edit the border text with project specific information 
1. Zoom in on the lower portion of the border as shown. 

2. Select the Edit Text command from the Text toolbar. 

3. Make any Traffic-specific edits you’d like. 

4. Fit the view. 
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Replace the Design border with the Traffic border 
1. Choose File > Open and highlight the file 

12345SigningandStripingPlan10.dgn in the 
C:\Projects\12345\Traffic ITS\Drawings folder. 

2. Choose OK. 

Notice the border is still the old Design cell. 

3. Select Elements > Cells, then File > Attach. 

 

4. From the \Traffic_ITS\Drawings folder, highlight the new border cell 
file 12345TrafficBorder01.cel. 

5. Choose OK. 

6. Close the Cell Library dialog. 

7. Choose Replace Cells command on the Cells toolbar. 
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8. Set the Method to Replace. 

 

9. Set the Mode to Single. 

10. Toggle on Use Active and Browse to the cell list using the magnifying 
glass icon. 

11. Find your new border in the list and highlight it, then choose 
Placement. 

12. Close the Cell Library dialog. 

13. Identify the border cell as the one to replace and then <D> to accept it. 

Notice the border is now the one you edited for traffic. You could now 
use the border to replace any plan border in files you have copied from 
design, or you can use it for any plans you create from scratch. 
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Reference the Traffic Model – Option 1 
The easiest way to have the traffic data show on each of the plans sheets is to 
reference it to the Design model, since it already shows in each sheet. This way, 
you do not have to attach it to every sheet and you do not have to concern yourself 
with putting together a new sheet or with clipping the other attached models when 
you reference them to a new set of sheets. However, since Traffic does not ‘own’ 
the design model, you would need to request that the Designer who does ‘own’ the 
model attach your file as reference. 
The following steps would be completed by the ‘owner’ of the design 
model, not

Reference the Traffic Model to the Design Model 

 by Traffic!  For illustrative purposes only, you will complete this 
portion in class. 

1. Choose File > Open. 

2. On the MicroStation Manager, highlight 12345DesignModel55.dgn in 
the Design\Drawings\Reference_Files folder.  

3. Choose OK. 

4. Choose File > Reference. 

 

5. Choose Tools > Attach. 
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6. Set the Attachment Method to Coincident World. 

7. In the folder  
Traffic ITS\Drawings\Reference_Files highlight 
12345TrafficModel01.dgn. 

8. Choose OK. 

9. In the References dialog, highlight the newly attached Traffic Model 
and turn off the Display. 

 

This way, the default for anyone looking at or referencing the design 
model will be for the traffic information to be turned off and therefore 
not show in their views. 

Again, these past few steps would not

After requesting the ‘owner’ of the Design Model make the previous changes, 
you will pick back up here. 

 be completed by Traffic! 
They are shown here for illustrative purposed only. 

10. Save Settings. 
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Open Sheet files and turn on Traffic levels 
1. Choose File > Open. 

2. On the MicroStation Manager, highlight the file 
12345SigningandStripingPlan10.dgn in the  
Traffic ITS\ Drawings folder. 

3. Choose OK. 

4. Choose File > Reference. 

 

5. Use the ‘+’ next to the current file to expand the Hierarchy and highlight 
the DesignModel55.dgn reference. 

 

6. Highlight the Traffic Model file on the right and turn on the Display. 
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7. Highlight the SurveyTopo file and turn off the Display. 

 

8. Choose Settings > Level > Display. 

9. Highlight the Traffic Model and toggle on the levels for the Signing and 
Striping plan and off any other levels, such as the Signals. 

Notice that the traffic model is now shown in the plan sheets as well as 
the other information referenced by Design. Using this method, you do 
not have to rotate the view or clip the reference – the traffic reference 
takes on the rotation and clipping of the Design model. 
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Re-visit the Design Model 
Before completing the next method, you will return the Design Model to its 
original state. 

1. Choose File > Open. 

2. On the MicroStation Manager, highlight 12345DesignModel55.dgn in 
the Design\Drawings\Reference_Files folder.  

3. Choose OK. 

4. Choose File > Reference. 

5. Highlight 12345TrafficModel01.dgn. 

 

6. Choose Tools > Detach. 

7. Choose OK. 

8. Fit your View. 

9. Save Settings. 

Now, you are ready to proceed with the second option which does not 
require Design to alter their reference attachments. 
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Reference the Traffic Model – Option 2 
In the next series of steps, you will again use a Design Plan sheet to create a Traffic 
sheet, but you will reference the traffic model to the already completed design plan. 
You’re using the same file as before, which was created by Design using Plan and 
Profile Generator. If it was a sheet created manually, there would be a Sheet Limits 
cell in the Model file that could be used for clipping. The manual method using the 
cell will be shown in the next activity. 

1. Choose File > Open. 

2. On the MicroStation Manager, highlight the file 
12345SigningandStripingPlan10.dgn in the  
Traffic ITS\ Drawings folder. 

3. Choose OK. 

4. Choose File > Reference. 

 

5. Choose Tools > Attach. 

6. Ensure the Attachment Method is Coincident World. 

7. Find the folder Traffic ITS\Drawings\Reference_Files and  
highlight 12345TrafficModel01.dgn. 

8. Choose OK. 
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9. Fit your View. 

Notice that the traffic model is referenced, but it is not clipped around the 
sheet. 

10. Window in as shown. 

 

11. On the Reference dialog, highlight the Traffic Model file and choose 
File > Clip Boundary. 

12. On the Tool Settings box, set the Method to Element. 
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13. <D> on the clip boundary as shown below. 

 

14. <D> again to Accept. 
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15. Choose Settings > Level > Display. 

16. Highlight the Traffic Model and toggle on the levels for the Signing and 
Striping plan and off any others that you don’t need. 

Now the Traffic Model is referenced and clipped. 
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Workflow for creating a 40-scale plan sheet 
The CDOT default scale for plan sheets is 100. However, there are times when you 
will need to create a sheet at a different scale, which is demonstrated in the 
following steps. In this case, you will create a single sheet at a scale of 40. 

Place the Plan Limits 
1. Choose File > Open. 

2. On the MicroStation Manager, highlight the file 
12345TrafficDesignModel01.dgn in the  
Traffic ITS\ Drawings\Reference_Files folder. 

3. Choose OK. 

4. Use Place Cell to place the Sheet_Design-Plan-Limits cell at 40 Scale 
as shown. 

 

 



 Sheet Files 

 

Traffic Workflow Using Microstation  Page 139 

Create the Sheet file 
1. From the MicroStation Manager, select File > New. 

2. Set the directory to Traffic_ITS\Drawings. 

3. In the Name field, key in a file name 12345PropSignalPlan01.dgn.  

4. In the New dialog box, select OK.  

5. The file you created will be highlighted. Select OK to open that file. 

Attach the Model file 
1. Select the Reference icon from the Primary Tools toolbar. 

 

2. In the References dialog box, select Tools > Attach, or choose the 
Attach Reference icon. 

 

3. Navigate to the Traffic_ITS\Drawings\Reference_Files folder and select 
the file 12345TrafficModel01.dgn. 

4. Verify the Attachment Method is set to Interactive. Select OK.   
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5. In the Reference Attachment Settings box: 

 

 Key in a logical name of Traffic and Proposed 
Intersection Signal Plan for a Description.   

 Verify that Orientation is set to Coincident-World and the 
Scale is set at 1:1  

 Set Nested Attachment to Live Nesting and set  
Depth to 1. 

6. Select OK. 

Note:  The Coincident-World option ensures that references are 
attached with their true coordinate information.  
A scale factor of 1:1 ensures that plan graphics are referenced in 
actual size. These two options allow plan sheet graphics to 
maintain their true model coordinates and size.  
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7. Turn on the Show Hierarchy and expand the hierarchy list. 

 

Notice that with nested references, the Design model reference is nested 
below the Traffic model file. 

Note

8. Select Tools > Attach and attach the 40 scale Topo/Survey reference 
with a No Nesting as shown. 

: While 1:100 scale survey information is most commonly used, 
others are normally provided from survey as well.   
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9. Turn on all levels in the Traffic file, to be certain your plan limits show 
up, and then turn off the Signing and Striping levels. 

 

10. Fit View so all graphics are displayed, then window in as shown. 

 

11. Save Settings (File > Save Settings). 
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Rotate the View  
Rotate the view so that the plan limit outline is horizontal in the view. 

1. Window around the intersection as shown. 

 

2. Turn on Depth lock. 

3. Turn off AccuSnap. 

4. Rotate the view by 3 points so the plan limit is horizontal. 
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Attach the Border Cell 
1. Select Cells from the Primary toolbar. 

2. In the Cell Library dialog box, select File > Attach and navigate to the 
C:\Projects\12345\Design\Drawings folder. 

 

3. Select the 12345TrafficPlanBorder.cel file. 

This is the project-specific border created earlier. 

4. Select OK to attach the cell library. 

 

The cell library only has one cell (model) – the 12345 Traffic Plan 
Border that you previously created. 

5. Select Placement to make the border the active placement cell. 

6. Close the Cell Library dialog box. 
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Place the border 
1. Select Place Active Cell from the Cells toolbar. 

 

2. In the Tool Settings box, set Active Angle to 0 and the Active Scale to 
40 for X, Y and Z. 

Note

3. Snap the cell to the corner of the plan limits cell. If necessary, you can 
use the Move command and move the border cell so that it is in the 
intersection is centered in the upper plan portion as shown. 

:  The Active Angle is view independent and not associated with 
view rotation. Therefore, the x-axis is always horizontal 
regardless of the view rotation.  You will not need to set this for 
correct placement of the North Arrow or other cells. 
 
The Active Scale scales the border up 40 times around the full-
sized graphics to match the plot scale. 
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Clip the Reference File 
1. Place a Fence using the Plan limit by snapping to the corners of the plan 

limits cell. 

2. Open References from the Primary toolbar. 

 

3. In the References dialog box, highlight the SurveyTopo and Traffic 
Model references. 

4. Select the Clip Reference icon. 

Note

5. In the Tool Settings box, verify Method is set to Fence. 

:  You can select more than one reference file at a time by holding 
the <Shift> or <Control> keys down while you are making your 
selection.  You can clip multiple drawings in one step when they 
are all selected.       

6. When prompted, Accept the fence to clip the reference.  
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7. In this case, you probably don’t need the SurveyTopo file displayed, so 
you can turn off the reference display if you’d like. 

8. Fit the MicroStation view and Save Settings after clipping the reference 
files.  

Place the bar scale and north arrow 
1. From the CDOT Menu Explorer, select Drafting > Borders. 

 Set Place to Design <None> 
 Set Bar Scale to Horizontal 
 Set North Arrow to Standard 
 Toggle off Place Resident Engineer 

2. Apply. 

3. When prompted to locate the Bar Scale, <D> inside the sheet border. 

4. When prompted to locate the North Arrow, <D> inside the sheet border 
in the upper-right area.  

Set the Text Scale Factor 
Set the text scale factor to match the border and plot scale factors. 

1. Select Models from the Primary toolbar. 

 

2. In the Models box, select Model Properties. 

 

Note the Annotation Scale is set to 1:100 – the CDOT default. 
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3. Change the Annotation Scale to 1:40. 

 

4. Select OK. 

5. Close the Models box. 

6. Fit the view. 

7. Save Settings. 

The Annotation Scale for the file now matches the border and plot 
scales. If you place text and/or dimensions in this file, they will be the 
correct size. 
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Workflow for creating a tab sheet 

Create the sheet file 
1. Choose File > Open. 

2. On the MicroStation Manager, highlight the file 
12345TRAFSignsTab##.dgn in the  
Traffic_ITS\Drawings\ folder.  

 

3. Choose OK. 

4. Choose File > Save As. 

 

5. Change the file name to 12345TRAFSignsTab01.dgn and choose OK. 

You have now copied the generic tab sheet to one for this project. There 
are still a couple of changes to make. First, you will update the border 
with the project information and then you will update the link to the 
spreadsheet. 
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Replace the Border 
1. Select Elements > Cells, the File > Attach. 

2. Highlight the new border cell file 12345TrafficPlanBorder.cel. 

3. Choose OK. 

4. Close the Cell Library dialog. 

5. Choose Replace Cells command on the Cells toolbar. 

6. Set the Method to Replace. 

7. Set the Mode to Single. 

8. Toggle on Use Active and Browse to the cell list using the magnifying 
glass icon. 

9. Find your new border in the list and highlight it, then choose 
Placement. 

10. Close the Cell Library dialog. 

11. Identify the border cell as the one to replace and then <D> to accept it. 

12. Use MicroStation Edit Text to change any text you’d like in the title 
block. 

13. Use Text in the Drafting category of the CDOT Menu to add any text to 
the title block. 

Update the Spreadsheet Link 
1. Fit the MicroStation view. 

2. Choose the Element Select tool and hover over the spreadsheet. 

 

Notice in the pop-up information that the link for the spreadsheet points 
to the CDOT Workspace. Next, you’ll change that link to the Project 
spreadsheet. 

Note:  If the pop-up information does not appear, make certain 
AccuSnap is on. 
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3. Click on the Spreadsheet, and then select Edit > Links. 

 

4. Select Change Source. 

 

5. Set the Look in folder to 
C:\Projects\12345\Traffic_ITS\Drawings\Tabs and highlight the 
Traffic-Tabs.xls file. 

6. Choose Open, and then Cancel the Links dialog. 

7. Hover over the spreadsheet again and check the link. 

 

8. Double-click on the spreadsheet and Excel will start. 

9. Make any changes desired to the spreadsheet. 

10. Exit Excel and notice the change has been made in the MicroStation file. 
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Workflow for creating a Detail Sheet 
Details for your job have already been drawn. You will next create a sheet by 
referencing those details. 

Create the sheet file 
1. From the MicroStation Manager, select File > New. 

2. Set the directory to Traffic_ITS\Drawings. 

3. In the Name field, key in a file name 12345TypDetCoordUnitPlan.dgn. 

 

4. In the New dialog box, select OK.  

5. The file you created will be highlighted. Select OK to open that file. 
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Attach the Model file 
1. Select the Reference icon from the Primary Tools toolbar. 

 

2. In the References dialog box, select Tools > Attach, or choose the 
Attach Reference icon. 

3. Navigate to the C:\Projects\12345\Traffic_ITS\Drawings 
\Reference_Files folder and select the file 12345TrafDetails01.dgn. 

4. Verify the Attachment Method is set to Interactive. Select OK.   

5. In the Reference Attachment Settings box: 

 

 Key in a logical name of Coord Unit and Coordination 
Unit Detail for a Description.   

 Verify that Orientation is set to Top and the  
Scale is set at 1:1.  

Since the details do not contain coordinate-based data, you do not have 
to reference them in Coincident World as you would a model file. 

 Set Nested Attachment to Live Nesting and set  
Depth to 1. 
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6. Select OK. 

7. <D> in the view to accept the attachment. 

Note

8. Fit View using the icon so all graphics are displayed.  

:   Details are often not drawn to scale as in this example. After 
placing the border, you will scale the detail to fit.  

9. Save Settings. 

Clip the Reference File 
1. Place a fence around the lower left detail. 

 

2. Open References from the Primary toolbar. 

3. In the References dialog box, highlight the reference. 

4. Select the Clip Reference icon. 

5. In the Tool Settings box, verify Method is set to Fence. 

6. Accept the Fence to clip.  
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7. Fit the MicroStation view, and then zoom out once and Save Settings.  

 

Attach the Border Cell 
1. Select Cells from the Primary toolbar. 

2. In the Cell Library dialog box, select File > Attach and navigate to the 
C:\Projects\Design\Drawings folder. 

3. Select the 12345TrafficPlanBorder.cel file. 

This is the project-specific border created earlier. 

4. Select OK to attach the cell library. 

The cell library only has one cell (model) – the 12345 Traffic Plan 
Border that you previously created. 

5. Select Placement to make the border the active placement cell. 

6. Close the Cell Library dialog box. 
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Place the border 
1. Select Place Active Cell from the Cells toolbar. 

2. In the Tool Settings box, set Active Angle to 0 and the Active Scale to 
100 for X, Y and Z. 

 

Note

3. Snap the border to the lower left corner of the box around the detail. 

:  The Active Angle is view independent and not associated with 
view rotation. Therefore, the x-axis is always horizontal 
regardless of the view rotation.  You will not need to set this for 
correct placement of the North Arrow or other cells. 
Use the Move command and move the border cell so that the 
lower left inside corner of the border is at the lower left corner of 
the box drawn around the detail. 
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4. Open a second view and set the two views up as shown, with the border 
in one and the detail in the other. 

 

Notice how much larger the detail is than the border. Next, you’ll scale 
the detail down to match the border. 
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5. Move the Border so the inside lower left corner is at the lower left corner 
of the box surrounding the detail. 

 

6. On the References dialog, choose Scale Reference. 

 

 

7. Set the Method to By Points. 
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8. Identify <D> the lower left corner of the box drawn around the detail. 

9. Identify <D> the lower right corner of the box drawn around the detail. 

This sets what you want to scale ‘from’. 

10. Identify <D> the lower right corner of the inside of the border. 

 

This sets what you want to scale ‘to’ and scales the reference to fit the 
border. This method should only be used when the reference is not to 
scale. 

11. Fit the view. 

12. Save Settings. 
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Workflow for creating a General Notes Sheet 
The 12345GeneralNotesSheet01.dgn and 02 have been created in the 
…\Design\Drawings folder through the create project utility. These sheet files 
currently reference a generic notes file in the CDOT workspace. However, the 
sheet files should reference the project-specific notes file, 
12345GeneralNote.dgn located in the …\Design\Drawings\Reference 
Files folder. You must edit the project notes file to be project-specific and also 
update the references in the sheet file to point to the project-specific notes.  

Note

Updating the General Notes Files 

: This process is the same for any specialty group. 

1. Open the file 12345GeneralNote.dgn from the 
Design\Drawings\Reference_Files folder. 

 

2. Select File > Save As 

3. Set the folder to \Traffic_ITS\Drawings\Reference_Files 

 

4. Enter the File Name 12345TrafficNote.dgn. 
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5. Select OK. 

This copies the General Notes Sheet and opens the new copy. 

Notice there are some generic notes in the file. Next, you’ll replace those 
with traffic-specific notes for this project. These are contained in a text 
file, which has already been created for you to save time. 

6. Delete the yellow text inside the boxes. 

7. Set the Level to Draft_Text-3. 

8. Choose File > Import > Text. 

 

9. Choose the file 12345TrafficNote.txt in the 
C:\Projects\12345\Traffic_ITS\Drawings\Reference_Files folder. 

10. Snap it to the upper left corner of the box, labeled Insertion Point. 

Updating Border Cell and Reference Files 
11. Open the file 12345GeneralNotesSheet01.dgn from the 

C:\Projects\12345\Design\Drawings folder. 

 
This file was automatically generated by the create project utility 
program. 
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12. Select File > Save As … 

 

13. Set the folder as shown and enter the File Name 
12345TrafficNotesSheet01.dgn. 

14. Select OK. 

This copies the General Notes Sheet and opens the new copy. 

Notice the border is still the generic Design cell. 

15. Replace the border file with your traffic one as you’ve learned. 

16. Select References from the Primary toolbar. 

 

The two generic notes files from the CDOT workspace are references. 
Update these references to point to the traffic project notes file. 

17. Double-click on the first reference to open the Attachment Settings 
dialog box. 

Note: You can also highlight the reference and select Settings > 
Attachment.  
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18. Select the Browse button next to the File Name. 

 

19. In the Reattach Reference dialog, set the directory to 
Traffic_ITS\Drawings\Reference_Files. 

20. Select the File 12345TrafficNote.dgn and then select OK. 

21. Select OK in the Attachment Settings box to reattach the reference from 
the new project location. 

22. Repeat the above steps for the second reference. 

Notice that the second reference is currently blank. 

Note

23. Save Settings (File > Save Settings). 

: There are two references for each sheet (for the left and right 
columns). You must reattach both by pointing to the same 
project notes file. 
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Editing the Notes 
1. Select File > Open and set the directory to 

Design\Drawings\Reference_Files. 

2. Select the file 12345TrafficNote.dgn and then select OK to open this 
file. 

The generic file GeneralNotesSheet01.dgn references the first two 
blocks (from the top down), so the file you just created 
TrafficNotesSheet01.dgn does also. GeneralNotesSheet02.dgn 
references the third and fourth block of text. 

3. From the Text toolbar, select the Edit Text command. 

4. <D> on the yellow notes text to select it for editing. 

Note

5. All of the general notes text is displayed in the Word Processor. Make 
the edits as shown: 
 
At the top of the file, add the following text: 

: This opens MicroStation’s Word Processor. This is one way to 
edit text. Other options for editing include the Dialog Box 
method and editing the TrafficNote.txt file and then importing 
again. See the CDOT Note Sheets workflow for additional 
information on these two methods. 

TRAFFIC GENERAL NOTES 

Add carriage returns on the lines where the text goes beyond the outline. 

6. When finished editing the text, <D> anywhere in the view to accept. 

7. Review the text to make sure the edits are correct. If not, edit the text 
again until you’re satisfied. 

8. Zoom in on the bottom of the second block of text. If the text falls on the 
block line, Edit the text and place carriage returns above the last 
paragraph of text to force it into the next block as shown. 

9. <D> anywhere in the view to accept the edits. 

10. Review the text to make sure the edits are correct. If not, edit the text 
again until you’re satisfied. 
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Review the changes in the sheet file 
1. Select File > Open and open the 12345TrafficNotesSheet01.dgn file 

from the Traffic_ITS\Drawings folder. 

2. Note that the edits you made in the project notes file are now updated in 
the sheet file. 

 

Note

 

: If you have two sheets of general notes (i.e. more than two 
blocks of notes from the project notes file), repeat the process 
using the 12345GeneralNotesSheet02.dgn file to create 
12345TrafficNotesSheet02.dgn. 
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7. Plotting Sheets 

Proper location for sheet files  
MicroStation (.dgn) Sheet files are located in the \Traffic_ITS\Drawings folder. 

Final sheet files that are plotted to .pdf are located in the \Plot_Sets folder in the 
appropriate subfolder. The available subfolders are: 

\AD  

\Revisions 

\FIR 

\FOR 

\ROWPR 
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Creating plot and/or pdf files of individual sheets or of 
multiple sheets at one time 

CDOT has established workflows for plotting to either 11” x 17” printers or 
plotting to Adobe Portable Document Files (PDFs). These workflows include 
MicroStation Printing for single sheets or Batch Printing for printing multiple 
sheets or PDF files. See the CDOT Workflows for more information. 
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Lab 7 Plotting Sheets 

Objectives 
After completion of this lab, you will: 

 Know where to go in the CADD Manual to find information on creating 
plot files. 

 Be able to create pdf files of individual sheets and know in which folder 
to place them. 

 Know how to create multiple sheets in one pdf using batch plotting. 

Getting Started 
Review the following workflows: 

  CDOT Shaded Color and Grayscale Printing 
  CDOT MicroStation Printing 
  CDOT Batch Printing 
  CDOT Directory Structure 

In reviewing the Directory Structure, notice that the C:\Projects\12345\Plot_Sets 
folder has subfolders under it that are for submittal sets of sheets. For our purposes, 
we will generate PDFs for sheets and place them in the upper level Plot_Sets folder. 

1. Start MicroStation. 

2. On the MicroStation Manager, navigate to \Traffic_ITS\Drawings and 
highlight the file 12345PropSignalPlan.dgn. 

3. Choose OK. 
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Print an individual sheet to PDF 
1. Follow the workflow CDOT MicroStation Printing to print a PDF file 

of the sheet, placing it in the C:\Projects\12345\Plot_Sets folder. 

2. Select Place Fence and set the Fence Type to Block 

3. Place the fence by Snapping to the outer corners of the yellow plot 
boundary.  The shape defining the outer edge of the border is called 
SHEET_Plot-Boundary.    

4. Choose File > Print, or click the printer icon on the Standard Tool Box.       

Note

5. Make sure Fence is selected under General Settings.  

:  If the print dialog box does not show up or is black when 
opened, close and reopen it.  This will fix the problem.  Also, it 
will speed the plot dialog if you toggle off the preview. 
Alternately, you can right-click as it updates when you have seen 
enough to know your plot is correct.   

The default Printer Driver is CDOT-DefaultPrinter.plt and the default 
Pen Table is CDOT-PenTable.tbl. To change the Printer Driver, select 
the magnifying glass located under Printer and Paper Size.  

6. Select the PDF driver CDOT-PDFdriver.plt. 

7. Leave the pen table set to the default. 

8. Full Sheet is selected on by default.  

Note

9. The X and Y values under Print Scale will update automatically based 
on the fence placed in MicroStation.      

: If the preview is not displaying correctly and you made changes 
to the paper size, you may need to toggle the Full Sheet option 
off and then back on again.  The print scale and size in the 
preview window will be adjusted, displaying the correct print 
layout. See previous note on speeding the plot dialog. 

Note

10. Once everything has been set, choose the Print icon. 

:  If the print size does not default to the correct size (11x17), then 
your fence is placed wrong.  Double check you are snapping to 
the outside corners of the plot boundary. Also, verify Full Sheet 
is checked on. 

11. Since you are plotting to a PDF file, you are prompted to key in a file 
name. Keep the name of the file, but an extension of .pdf (which is 
automatic). 

12. Set the folder for the file to 12345\Plot_Sets. 

13. Choose OK. 

Note:  This folder is only for completed plots. If the plot is not 
complete, you can send the pdf to the Working folder. 
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Print multiple sheets to one PDF 
Batch Printing is used to print multiple files at one time. While this workflow prints 
multiple sheets to one pdf, you can also print to multiple pdfs with Batch Print.  A 
.job file can be saved and called back for future printing.  It can also be used for 
plotting to PDF. 

1. Select File > Batch Print in MicroStation.   

 

Note

2. Choose Edit > Add Files and navigate to the 
C:\Projects\12345\Traffic_ITS\ Drawings\ folder. 

:  You can be in any MicroStation file when you run the Batch 
Print process. 

 

3. Select the sheets to add to the batch process.  

4. Choose Add.    

Note:  You can hold down the Ctrl or Shift key to select multiple files.  



 

Page 174  Traffic Workflow Using Microstation 

5. Choose Done.  

 

6. The batch process default specifications are: 

 Printer:  11x17 Printer 
 Print Area:  SHEET_Plot-Boundary 
 Layout:  Maximize (Do not change this setting) 
 Display:  As-Is Display 

7. Select Specifications > Manage to change the default specifications.    
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8. Under Types, select Printer  

 

 Select Properties and set the PDF Printer Properties as 
shown and select OK. Be sure to toggle ON Print Document 
Set to a single file. 

9. Under Types, select Print Area and then select Properties. 

 

Notes

10. Cancel the Properties box. 

: The printable area defaults to the outer boundary of the standard 
CDOT sheet border (the yellow shape on level SHEET_Plot-
Boundary). 
 
Both Master File and References are checked ON under 
Search Files.  If the level SHEET_Plot-Boundary is not found in 
the Master File as a cell, it will search for the level in the 
Reference files associated with the sheet file.   
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11. Under Types, select Display 

 Select As-Is Display 
 Select Properties 

Notes

12. Cancel out of the Properties box. 

: The As-Is Display Specification sets up the print properties for 
various elements. The As-Is setting reads MicroStation’s View 
Attributes setting for each design file. 
 
The Pen Table defaults to CDOT-PenTable.tbl, which is the 
table used for black-and-white printing. 

13. Close the Batch Print Specification Manager box by selecting the X in 
the upper-right corner. 

Your changes are shown in the main Batch Print dialog box. 

Save your Specifications to a Job file (*.job) 
1. Select File>Save As… 

2. Navigate to the project’s …Plot_Sets\FOR folder. 

3. In the Files field, key in 12345Traffic01 and select OK. 

The job file should be saved to the project in the appropriate folder under 
the Plot_Sets. The file is automatically assigned a .job extension. If you 
want to process this job again, select File > Open from the Batch Print 
dialog box and choose the 12345Traffic01.job file. 

Create the Batch Prints 
1. Select the Print icon to open the Print Batch dialog box. 

2. In the Print Batch dialog box: 

 Set Print Range to All to print all the files selected 

Note

3. Select OK to start the batch process. 

: The option Selection would print only the files that you 
highlight in the list. 

The process may take a few minutes to complete depending upon how 
many sheets are being plotted. If errors are encountered, open the error 
log batchplt.log in the C:\Program 
Files\Bentley\Program\MicroStation folder for more information. 
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Review the PDF file 
1. In Windows, open My Computer. 

2. Navigate to the C:\Projects\12345\Plot_Sets\FOR folder. 

The folder contains all of the PDF sheet files plus the 12345Traffic01.job 
file. 

3. Double-click on the PDF file to open. 

4. Close My Computer. 

 



 

Page 178  Traffic Workflow Using Microstation 

Print multiple sheets to different PDFs 
Next, you’ll use Batch Printing to print multiple files at one time to 
individual PDFs. 

Select Files to Batch Print 
1. Select Batch Print in MicroStation from the file pull down menu. 

Note

2. In the Batch Print dialog box, select Edit > Add Files. 

:  You can be in any MicroStation file when you run the Batch 
Print process. 

Note

3. Navigate to the C:\Projects\12345\Traffic_ITS\Drawings folder.  
Select the following files to add to the batch process (you can hold down 
the Ctrl or Shift key to select multiple files): 

:  Add Active File adds the design file that is open in 
MicroStation. 

 12345TrafficGeneralNotes01.dgn 
 12345TrafficPlan10.dgn 
 12345TypDetCoordUnitPlan.dgn 

4. Select Add. 

Note

5. When finished adding files, select Done. 

: If you want to add other sheets to the batch process, you can 
change folders, select the file(s) and select Add again. 
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Set Batch Process Specifications 
1. The batch process default specifications are: 

 Printer:  11x17 Printer 
 Print Area:  SHEET_Plot-Boundary 
 Layout:  Maximize 
 Display:  As-Is Display 

2. Select Specifications > Manage to change the default specifications.    

3. Under Types, select Printer  

 Select PDF Printer.   
 Select Properties and set the PDF Printer Properties as 

shown and select OK. Be sure to toggle off Print Document 
Set to a single file. 

Notes

4. Under Types, select Print Area and then select Properties. 

: If you choose to create multiple PDF files, the name of the dgn 
file will be used with a “-001” appended to it (e.g. 
12345PlanProfile01-001.pdf). 
 
To print the set to a single file, see the previous example or the 
workflow CDOT Batch Printing. 

Notes

5. Cancel the Properties box. 

: The printable area defaults to the outer boundary of the standard 
CDOT sheet border (the yellow shape on level SHEET_Plot-
Boundary). 
 
Both Master File and References are checked ON under 
Search Files.  If the level SHEET_Plot-Boundary is not found in 
the Master File as a cell, it will search for the level in the 
Reference files associated with the sheet file.   
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6. Under Types, select Display 

 Select As-Is Display 
 Select Properties 

Notes

7. Cancel out of the Properties box. 

: The As-Is Display Specification sets up the print properties for 
various elements. The As-Is setting reads MicroStation’s View 
Attributes setting for each design file. 
 
The Pen Table defaults to CDOT-PenTable.tbl, which is the 
table used for black-and-white printing. 

8. Close the Batch Print Specification Manager box by selecting the X in 
the upper-right corner. 

Your changes are shown in the main Batch Print dialog box. 

Save your Specifications to a Job file (*.job) 
1. Select File>Save As… 

2. Navigate to the project’s …Plot_Sets\FOR folder. 

3. In the Files field, key in 12345Traffic02 and select OK. 

The job file should be saved to the project in the appropriate folder under 
the Plot_Sets. The file is automatically assigned a .job extension. If you 
want to process this job again, select File > Open from the Batch Print 
dialog box and choose the 12345Traffic02.job file. 

Create the Batch Prints 
1. Select the Print icon to open the Print Batch dialog box. 

2. In the Print Batch dialog box: 

 Set Print Range to All to print all the files selected 

Note

3. Select OK to start the batch process. 

: The option Selection would print only the files that you 
highlight in the list. 

The process will take a few minutes to complete. If errors are 
encountered, open the error log batchplt.log in the C:\Program 
Files\Bentley\Program\MicroStation folder for more information. 



 Plotting Sheets 

 

Traffic Workflow Using Microstation  Page 181 

Review the PDF files 
1. In Windows, open My Computer. 

2. Navigate to the C:\Projects\12345\Plot_Sets\FOR folder. 

The folder contains all of the individual PDF sheet files plus the 
12345Traffic*.job files. 

3. Double-click on one of the PDF files to open. 

4. Review other PDF as desired. 

5. Close My Computer. 

6. Return to MicroStation and Exit. 
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8. Example Traffic Project 
 

 

Given:   Project 12345 from Roadway 

Required:  Signing Plan 

  Signing Plan Sheet 

  Signal Plan 

  40 Scale Signal Plan Sheet 

  Traffic Notes Sheet 

   

Using what you have learned, create the above using the project files you 
have used during class. You can re-install the class files and start over, or 
you can use different names for your files as you create them. Don’t limit 
yourself to just what’s listed. If you would like, create additional detail 
sheets or other types of sheets you might need. 
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