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Workflow MS 1 - Explaining File Types

This document describes the various file types used in plan production at CDOT. 

CADD Files

File 
Extention

Description

dgn MicroStation CADD file format. Files of this format are called Drawings or Design Files.

cel MicroStation Cell Library. A cell library contains small drawings tha ca be used over and 
over. The “Cell” is treated as a group so that it can be placed, moved, copied, manipulated, 
or deleted as one element.

dgnlib MicroStation Design Library. Design Libraries store standard settings for MicroStation. 
Items like Text Styles, Level Names and Symbology, Dimension Styles, and Line Styles. 
These files are stored within the workspace and should not be modified by the users.

pcf Project Configurtion File. This file is used by MicroStation to set the directory path to refer-
ence file locations for a specific project. The pcf file is used for projects stored locally, and 
is only accessed when MicroStation is launched from the Start Menu or desktop icon.

dwg/dxf AutoCAD CADD file format. This is similar to the dgn file. MicroStation can read dgn and 
dxf file formats, but they need to be converted to dgn format so that CDOT standards can be 
applied to them.

Image Files

File 
Extention

Description

jpg An image file format use for aerial photos that can be attached to plan sheets. It may come 
with a sister file. 

tif An image file format use for aerial photos that can be attached to plan sheets. It may come 
with a sister file.

tfw A sister file (or world file) is an ASCII text file that contains special formatted coordinate 
information about where the image is in relation to the surface of the earth.

tif GeoTiff files (also with a tif extension) but these do not have a sister file. They have the 
coordinate (and sometimes GeoCoordinate system) embedded within the file
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InRoads Files

File 
Extention

Description

dtm Digital Terrain Model, sometimes called a surface file. This file contains triangulated and 
untriangulated data that describes the topography of the site. An existing ground dtm 
describes the current state of the site. A design dtm describes what is to be constructed.

alg Geometry Project or alignment file. This file contains the horizontal and vertical geometry 
(alignments) for a design project. It is used by ROW/Survey to store Right of way, property, 
and easement lines.

itl Template Library. This file contains the templates (an InRoads version of the typical sec-
tions) used for a design project. It also contains various parts of templates (called sections 
and components) that are use to create finished templates.

ird Roadway Design file. This file is used to combine and compare the data from the dtm, alg, 
and itl files to create the design model of the proposed roadway. The alg file is used to 
define the Corridor of the proposed road, the itl file profides the cross section of the road 
prism, and the dtm is used as a target for the end conditions of the template to tie the design 
to the existing terrain.

rwk InRoads Project File. This is an ASCII text file that contains the name and directory path  to 
the InRoads data file used for a specific project. It is used to load and save all of the data 
files at one time.

fwd Fieldbook file. This file contains survey information translated from the data collector to 
the InRoads format.

sup Superelevation Rate Tables. These are ASCII text files that contain superelevation transi-
tion rate information based off of the ASSHTO Greenbook. sup files are used with in Road-
way Designer to calculate superelevation for a corridor’s horizontal alignment. The 
calculated data is stored in the ird file.

xin Preference file. This file contains all of the style settings that control how elements dis-
played from InRoads will look in MicroStation. It also contains dialog box Preferences  
(predefined settings for dialox boxes).

xsl Style Sheets. These files are used to format xml reports generated by InRoads

dft Drafting Notes file. This file contains formats for commonly used notes, like station and 
offset notes, that can be extracted from InRoads data.

vdf View Definition File. This file works with Plan and Profile Generator. It contains the data 
for plan view and profile view settings.

xsc Cross Section File. This file contains the data used to define a custom cross section set.
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Workflow MS 2 -  Useful MicroStation and 
InRoads Key-ins 

This document describes and provides syntax for commonly used MicroStation and InRoads key-ins. Where 
‘x’, ‘y’, and ‘z’ characters are entered in the Key-in Syntax column, the user will replace those characters with 
the desired numbers. Items in italics require the user to provide the desired cell name or view name.

MicroStation / InRoads Key-ins

Angle Key-ins and Precision Inputs

Key-In Command Key-In Syntax Description

Set Active Angle aa=xx^xx’xx.xx” This sets the Active Angle.

Set Active Angle by 
2 Points

Active angle pt2 Required input – two <D> clicks. This sets the Active 
Angle based on the angle defined by the two data clicks 
and the zero axis.

Coordinate Key-in xy=xx.xx,yy.yy,zz.zz This command inputs a <D> at the specified x, y, and z 
coordinate. The z (elevation) entry is not used in 2D draw-
ings and is optional in 3D drawings

Relative Coordinate 
Key-in

dl=xx.xx,yy.yy,zz.zz This command inputs a <D> at the specified x, y, and z 
distance from the last <D> or <T>. The z (elevation) entry 
is not used in 2D drawings and is optional in 3D drawings. 
The distances are measured along the design axes (x is left 
and right in the top view, y is up and down in the top view, 
z is into and out of the screen in the top view.)

View Coordinate 
Key-in

dx=xx.xx,yy.yy,zz.zz This command inputs a <D> at the specified x, y, and z 
distance from the last <D> or <T>. The distances are mea-
sured along the view axes so that x is left and right on the 
screen, y is up and down on the screen, z is into and out of 
the screen.

Distance / Angle 
Key-in

di=xx.xx,xx^xx’xx” This command inputs a <D> at the specified distance and 
angle from the last <D> or <T>.

Station / Offset    
Key-in

so=xxx+xx.xx,xx.xx This is an InRoads key-in and a geometry project must be 
loaded for it to work. The command inputs a <D> at the 
station and offset from the active alignment. The “+” is not 
required in the key-in

Station / Elevation 
Key-in

se=xxx+xx.xx,xx.xx This is an InRoads key-in and a geometry project must be 
loaded for it to work. An InRoads profile is also required. 
This command inputs a <D> at the station and elevation 
within the profile. The “+” is not required in the key-in.
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Distance / Grade 
Key-in

dg=xx.xx,x.xx% This is an InRoads key-in and a geometry project must be 
loaded for it to work. An InRoads profile is also required. 
This command inputs a <D> at the distance and grade 
from the last point entered in the profile. This command is 
primarily used with the Add Vertical PI command.

MicroStation / InRoads Key-ins

MicroStation Settings

Key-In Command Key-In Syntax Description

Set Key Point Divisor ky=x This command sets the key point devisor to the number 
indicated. The key point divisor divides an element in to 
the indicated number of equal parts and makes a snap point 
at each division

Set Active Scale as=xx.xx This command sets the X, Y, and Z scales to the specified 
value.

Set X Scale xs=xx.xx This command sets only the X axis scale to the specified 
value.

Set Y Scale ys=xx.xx This command sets only the Y axis scale to the specified 
value.

Set Z Scale zs=xx.xx This command sets only the Z axis scale to the specified 
value.

Set Active Line Ter-
minator

lt=cell name This command sets the line terminator to the specified cell.

Set Terminator Scale ts=xx.xx This command sets the line terminator scale factor to the 
specified cell.

MicroStation / InRoads Key-ins

Angle Key-ins and Precision Inputs

Key-In Command Key-In Syntax Description
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MicroStation / InRoads Key-ins

View Controls

Key-In 
Command

Key-In Syntax Description

Open Saved 
View

vi=saved view After executing the key-in, <D> in the view to be 
updated. In addition to user created saved views, 
the following default views can be used: top, bot-
tom, left, right, front, and back.

Create a 
Saved View

sv=saved view After executing the key-in, <D> in the view to be 
saved. This command is used to create a saved 
view without using the Saved Views dialog box.

Rotate View rv= xx^xx'xx", xx^xx'xx",xx^xx'xx" This command rotates the view around the design 
axes. The angles are for the x, y, and z axis. For 
example to rotate a Top view 90 degrees, the key-
in would be rv=0,0,90. This rotates the view about 
the z axis (the one that goes in and out of the mon-
itor.) The carat symbol is not required if the rota-
tion is in whole degrees.

Set Active Z az=xx.xx After executing the key-in, <D> in the view. This 
sets the elevation at which elements are placed. 
Snapping to an element overrides the active depth 
and uses the elevation of the item snapped to 
unless the ACS Plane Snap lock is toggled on.

Find Active 
Z

az=? After executing the key-in, <D> in the view. This 
displays the current active depth (elevation) in the 
MicroStation Message Center.

Set Delta Z dd=xx.xx After executing the key‐in, <D> in the view. This 
changes the active depth (elevation) by the 
amount specified in the key‐in.

Set Display 
Depth

dp=‐xx.xx,xx.xx After executing the key‐in, <D> in the view. This 
sets the viewable elevation range. The fist num‐
ber in the key‐in is the low elevation and the sec‐
ond is the high elevation. Elements outside of this 
range cannot be seen. If you cannot see some ele‐
ments or only partial elements are displayed, try 
setting the display depth to ‐100,000,100,000 
(dp=‐100000,100000)

Find Display 
Depth

dp=? After executing the key-in, <D> in the view. This 
displays the current display depth (elevation 
range) in the MicroStation Message Center.
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AccuDraw Key-ins

There are a number of key-ins that make working with AccuDraw easier. The table below lists some on the 
most commonly used key-ins and describes what they do.

Set Relative 
Display 
Depth

dd=? After executing the key-in, <D> in the view. This 
adjusts the current display depth (elevation range) 
by the amount specified. The fist number in the 
key-in is the low elevation and the second is the 
high elevation.

Set Active 
Level

lv= level name or number This command sets the active level to the specified 
level

Level On on= level name or number This command turns the specified levels on. Key-
in on=all to turn all levels on.

Level Off of= level name or number This command turns the specified levels off. Key-
in of=all to turn all levels (except the active level) 
off.

MicroStation / InRoads Key-ins

AccuDraw Key-ins

Key-In 
Command

Key-In 
Syntax

Description

Compass Type Space Bar This command toggles the AccuDraw compass between the distance/
direction (round) compass to the X, Y, Z (square) compass

View Rotation v This command rotates the AccuDraw compass so that it is orthogonal 
to the view.

Base Rotation b This command rotates the AccuDraw compass so that it is orthogonal 
to the element that was drawn last.

Top Rotation t This command rotates the AccuDraw compass so that it is orthogonal 
to the Top view. If you are in a Front, Back, or side view you will only 
see the edge of the AccuDraw compass.

MicroStation / InRoads Key-ins

View Controls

Key-In 
Command

Key-In Syntax Description
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Front Rotation f This command rotates the AccuDraw compass so that it is orthogonal 
to the Front view. If you are in a Top, Bottom, or side view you will 
only see the edge of the AccuDraw compass.

Side Rotation s This command rotates the AccuDraw compass so that it is orthogonal 
to the Side view. If you are in a Top, Bottom, Front, or Back view you 
will only see the edge of the AccuDraw compass.

X axis Lock x This command works when the AccuDraw compass is in the XYZ 
mode. This command locks the X axis to the distance that the cursor is 
from the starting point measured along the X axis.

Y axis Lock y This command works when the AccuDraw compass is in the XYZ 
mode. This command locks the Y axis to the distance that the cursor is 
from the starting point measured along the Y axis.

Z axis Lock z This command works when the AccuDraw compass is in the XYZ 
mode. This command locks the Z axis to the distance that the cursor is 
from the starting point measured along the Z axis. Note: the cursor can-
not move along the Z axis in a Top view.

Distance Lock d This command works when the AccuDraw compass is in the distance/
angle mode. This command locks the distance that the cursor is from 
the starting point of the element.

Angle Lock a This command works when the AccuDraw compass is in the distance/
angle mode. This command locks the angle that the cursor is from the 
starting point of the element based on the rotation of the AccuDraw 
compass.

Set Origin o This command allows you to place the next element a specific distance 
from the last entered point using the AccuDraw toolbox.

MicroStation / InRoads Key-ins

AccuDraw Key-ins

Key-In 
Command

Key-In 
Syntax

Description
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Workflow MS 3 - Setting  a Project Geographic 
Coordinate System

This document guides you through the steps required to create a project or local datum MicroStation 
Geographic Coordinate System (GCS). This will facilitate the integration of images, GIS data, and design files 
that use different coordinate systems.

These instructions are intended to be used by the Survey department at the beginning of a project, allowing 
other divisions, like Design, to coordinately attach imagery and shape files later in the project. Without this 
information, it is unlikely that imagery which is typically in a different coordinate system (like State Plane 
Coordinates or UTM) will line up with the MicroStation design files created by ROW Survey.

The following steps describe how to create a project specific datum in MicroStation followed with an example 
of how to attach imagery and GIS information from different coordinate systems.

It is very important that the projection information for all files is known!

CDOT Survey Project Files

MicroStation design files created by CDOT Survey are created in a project specific, local datum plane (project 
coordinate system). This coordinate system is typically defined by multiplying known coordinates by a scale 
factor or conversion factor. This factor is project specific and published in the Project Control Diagram created 
by Survey. Once created, the project GCS can be assigned to the individual models within the MicroStation 
design file. This means files with different GCS assignments can be reprojected to fit the project GCS.

Creating a Project Geographic Coordinate System in 
MicroStation

In order to create a project specific GCS the coordinate datum instructions must be obtained. These can be 
found on the Project Control Diagram sheet included in CDOT plan sets.

Factor Computation Worksheet

A worksheet has been created to assist the user in computing the necessary information for the custom project 
coordinate system. This file is called Factor Computation Worksheet.xlsx and can be found in the CDOT 
workspace under Standards‐Global\MicroStation\Data\. The worksheet is intended to help automate the 
process of creating a project specific Geographic Coordinate system in MicroStation. Information entered into 
this worksheet should be obtained from teh Project Control Diagram or the Surveyor when a PCD sheet is not 
available. The worksheet computes parameter information used in MicroStation to create a Geographic Project 
Coordinate System. Instruction on how to use the worksheet can be found on the first tab.
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1. Using the information from ROW Survey on the Project Control Diagram, the first step will be to complete 
the Factor Computation Worksheet.

2. Next, the appropriate information from the yellow highlighted area will be used to create a Project 
Coordinate System in MicroStation using the Geographic Coordinate System tools.

3. First the program Bentley Map must be activated from within InRoads.

Activating Bentley Map

In order to create and save a Geographic Project Coordinate system that can be assigned to a MicroStation 
design file, the program Bentley Map must be activated. Once Bentley Map has been activated, a customized 
GCS can be created. Otherwise the files are read only.

1. Begin by opening InRoads. Within InRoads, there is an application that needs to be activated called 
Bentley Map.

2. From the MicroStation menu bar, select Applications > Map >  Activate Map.

3. A dialog box requesting a connection to a database will appear. Click the Cancel button to close. Map is 
now activated.
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Once Bentley Map is activated, a customized geographic coordinate system can be created.

Project Geographic Coordinate File Creation

Geographic Coordinate Projections are created within MicroStation. A file located in the CDOT Data folder 
called CDOT-Projects.dty is used to store custom systems and a variable has been set in the CDOT 
configuration to access this file. Once this file has been created, it can be copied to other computers. The 
CDOT-Projects.dty file is found in the following location:

C:\Workspace\Workspace‐CDOT_V8i\Standards‐Global\MicroStation\Data.

When creating a project file, a copy of an existing coordinate system is used to create the Project Coordinate 
System. The following example lab takes you through the steps.

Example - Setting Project Geographic Coordinate System

The following is an example of setting up and using a Project Geographic Coordinate System. In this example 
a project coordinate system is setup using information from ROW Survey. The project coordinate system is 
then assigned to a MicroStation design file.

Once the project coordinate system has been assigned to the design file, a survey file is referenced, a project 
point control file is referenced which is in UTM coordinates, an image file is referenced which is UTM 
coordinates, and lastly GIS data is referenced into the design file.

Create Project Geographic Coordinate System

1. Open InRoads and create a new MicroStation design file. In this example the file will be called 
12345Des_Model.dgn.

2. From the Applications pulldown, activate Map and then cancel the window.

3. Create a Project Geographic Coordinates System using the information from this workflow. This data can 
also be found in the Factor Computation Worksheet using the Sample ‐Seed Points tab calculations.
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4. Open the Geographic Toolbox from the Tools pulldown menu. Select Tools > Geographic and then the 
Open as Toolbox.

5. This will open up the Geographic toolbox. <D> the Select Geographic Coordinate System icon from 
the toolbox.
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6. This opens up the Geographic Coordinate System dialog box. <D> the From Library icon (the second icon 
from the left) to open the Select Geographic Coordinate System dialog box (this contains the library of 
geographic coordinate systems).

Note: If the model you are in does not have a GCS assigned to it, the first icon is displayed diluted and 
will be unusable.

7. Select the Library tab to see all the available systems.
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8. Expand the Favorites folder by clicking on the plus box and then expand the Colorado folder the same 
way. Default Colorado geographic coordinate systems can be accessed from this folder. 

9. A copy of a base coordinate system is used to create the project coordinate system. 

Note: CDOT Project coordinates created by ROW Survey are generally modified Colorado State Plane 
NAD 83 coordinate systems in one of three zones (Northern, Central, and Southern).

10. Select the coordinate system to be copied and right click over it.
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11. <D> on the CDOT-Projects folder and Paste the copy into the folder.

After pasting the file in the CDOT‐Project folder it should be edited with project specific information.

12. <R> on the copied file and select Edit Coordinate System Properties.

13. Edit the Name and Description to represent the project. <D> in the right hand column to edit.

Do not close the Edit Geographic Coordinate System dialog box. Additional information is required for the 
project coordinate system before it can be saved. This information is obtained from the Factor Computation 
Worksheet.

14. The base system for the copied NAD83 Colorado State Plane system has a Projection of Lambert 
Conformal Conic. It is important to select a system similar to the original when modifying the project 
system. For example: Lambert Conformal Conic with Affine Processor is used to modify a Lambert 
Conformal Conic projection.
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15. <D> in the right had column over the projection. Using the down arrow, navigate to the appropriate Affine 
Processor.

16. Next the information from the worksheet tab for Seed Point’s should be entered. The information from the 
yellow highlighted area into the Edit Geographic Coordinate System dialog box.

17. Affine A0 Parameter is the Easting adjustment and the Affine B0 Parameter is the Northing adjustment.

18. Affine A1 Parameter and Affine B2 Parameter are the Scale parameters.
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19. In those cases when there is a rotation value, this would be entered in the Affine A2 and Affine B1 
parameter area.

20. Once the values have been entered they can be saved by selectin Ok to accept the changes and dismiss the 
Edit Geographic Coordinate System dialog box. 
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21. Select Ok in the Select Geographic Coordinate System dialog box to apply the custom project system. 
This project coordinate system can now be assigned to any design file within the project.

Attach Survey Topo File

Once the Project Coordinate System has be defined and assigned to the new design file, it is time to reference 
files.

Note: For more information on attaching imagery, review the workflow Using Geographic Images in 
Raster Manager.

1. Begin by referencing the survey existing data. This file is called 12345SURV_Topo100scale01.dgn. 

2. Set the Attachment Method do Interactive.
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3. Select Coincident ‐ World for the Orientation.

Reference UTM Control Points

Reference the file containing control points which are in UTM coordinates. This file has a UTM-13N 
Geographic Coordinate System assigned to it.

1. Attach reference the file UTM Control Points.dgn and set the Attachment Method to Geographic - 
Reprojected.

The UTM Control Points.dgn file appears as shown below represented by the blue dashed box. 
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Note: If the box does not appear, <D> the Fit view command (Files set to All and Expand Clipping Planes 
toggled on).

2. The control points in the referenced files should line up. The triangle is a control point in the Survey file 
and the circle is the same control point in the UTM control point file.

Reference GIS Shapefiles

Shape (shp) files created from GIS can be referenced in. In this example, highway linework in UTM 
coordinates will be referenced.
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1. Attach reference the HIGHWAYS.shp being sure to change the Files of type: to Shapefiles (*.shp) and 
setting the Attachment Method to Geographic - Reprojected.

2. Notice that after attaching the files, they all be line up even though there are two separate coordinate 
systems being used.



GPCS- 14 Colorado Department of Transportation

 Setting a Project Geographic Coordinate System CDOT  Workflows

Reference Image Files

CDOT has imagery covering the state of Colorado. This imagery is in two different coordinate systems. The 
greater Denver area is in NAD83Colorado State Plane coordinates and the rest of Colorado is in UTM 
coordinates. Either system can be referenced into a design file and reprojected to the project coordinate system.

Refer to the workflow CDOT Workflow Accessing Imagery Files to learn more on how to find images within 
the state of Colorado.

1. Using Raster Manger, attach the file UTM_Project_Image.tif.

In this example, the image is from a portion of Colorado where the coordinate system is UTM. These files are 
GeoTIFF files with the coordinate system written into the header of the file. There is no sister file 
accompanying the image.

Note: The same setting used below are also used for images that have a sister file.

2. In the Raster Attachment Options dialog box, set the Action tab setting - Place Interactively to No.

3. Under the Geometry tab, set the Geo Priority setting to Raster Header since the coordinate assignments 
are in the file.
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4.  Set the Inherit GeoCS from Model to Not Inherited since the coordinate system of the design file is 
different from that of the image.

5. Select Attach to reference the image.
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Workflow MS 4 - Working with Model Files and 
Sheet Files

This document defines how to use and manage model and sheet files in a typical CDOT workflow. The 
document begins by describing the data that each type of file should contain along with typical examples to 
illustrate the differences. The locations for storing these files are identified. The steps to create a new model 
and sheet files and how to change the file settings to work with different plotting scales are explained. Finally, 
the process for referencing model files for review or printing is covered.

File Types

Model Files

Model files usually contain design graphics that are placed at the correct real world coordinates or detail 
graphics that are not dependant on real world coordinates. Model files are files that are ready to be used as 
a reference file to other model files for further design or to be referenced by sheet files for the purpose of 
plotting. Typical data included in a model file that is drawn at the correct real world coordinates would 
include planemetrics for alignments, contours, utility lines, building outlines, structures, and any other 
DTM features. Model file data that is not dependent on real world coordinates would include typical 
sections, profiles, detail drawings, and tabulation sheets. 

A model file will usually contain only one type of data. For example, one model file would contain only 
existing topography data, while another would contain only geometry data. Separate model files should be 
used for cross-sections and profiles. Dividing the data types into separate model files will allow for the 
most flexibility in how the data is utilized both by the specialty group team members and the secondary 
users that need to reference the data. This method of managing model files also minimizes level 
management by not having unrelated data in the file. 

Another characteristic of the design file is that the graphics in the file usually represent the entire project. 
These graphics will later be referenced into a sheet file and clipped to fit the boundaries of the sheet.

A distinct type of model file is the working file.
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Working Files

Working files are model files that are being developed and/or revised and are not ready for use by other 
specialty groups or team members. These files usually have the owners’ initials included in the filename as 
a way to distinguish the file from the ready-to-use model file. The differences between a model file and a 
working file is the completeness of the file and its availability to others. 

Sheet Files

Sheet files are MicroStation DGN files that contain the data required for printing. They are created by 
referencing in various model files that either represent directly or add clarification to the features that will 
be constructed from the printed sheet and include a border file. In addition to containing reference files, 
typical data that would be included in a sheet would be informational text, such as callouts and dimensions, 
a directional arrow if appropriate, and other non-engineering information such as logos or stamps.

The graphics in a sheet file represent only a portion of the entire design and are usually included within a 
standard border. The image above is a portion of the graphic representing the design file shown on the 
previous page.

File Management

Each of these files is owned by the Project Manager of the specialty group whose data is contained in the 
file and updated by the assigned team member. A team member from one specialty group should not 
update the file(s) of a team member from another specialty group. 
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File Naming Conventions

The CDOT naming standard uses a formula that restricts the character placement, ensures unique file 
names, and identifies the information contained in the file. 

All CDOT projects must follow these file naming conventions. Standardizing file names is necessary for 
effective management of the large numbers of files needed to produce a set of design plans.

CDOT files are named in a standard format that identifies the file’s project, the data contained within it, 
and the product used for its creation. The naming convention is illustrated as follows:

♦ Job Project Code (JPC) is the CDOT project code, formerly known as the project subaccount 
number.

♦ Specialty Group is the standardized abbreviation for the specialty group that the owner of the file is 
with. 

♦ Standardized Name denotes the type of data that is contained in the file.

♦ Annotation Scale including the annotation scale in the file name is optional. However, it should be 
included in file names for projects that use multiple annotation scales.

♦ Description A brief description can be used to further identify a model file. For sheet files, this field is 
used as a counter to differentiate between multiple files of a specific type.

♦ File Extensions define the product used for its creation. Examples would be DGN for MicroStation, 
DTM for an InRoads surface, etc.

An example file name for a MicroStation design file would look like the following, 
12345DES_Model100US285.dgn

12345 indicating the CDOT Project Number, DES indicates it is Roadway Design’s model file and 100 
indicating it uses a 1”=100’ annotation scale, US285 is a description identifying the highway this model 
depicts. DGN is the default extension for MicroStation design files.

Note: A seventh segment is used on Working Files. This segment should be the initials of the designer or 
engineer who is working on the file. 
Example: CU12345DES_Model100.dgn where CU, are the initials of the designer or engineer (in 
this example, CU stands for “CDOT User”). 
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Storing Model Files and Sheet Files

Model File Location

Model files should be stored in the JPC#\SpecialtyGroup\Drawings\Reference_Files folder. The 
exception to this is for cross-sections (design or construction) which have their own sub-directory under 
\Drawings sub-directory. Cross sections are separated from the rest of the model files at the request of the 
Reproduction department to simplify the process of assembling plan sets.

Working File Location

Working files should be stored in the \JPC#\Specialty Group\Working folder.

Sheet File Location

Sheet files should be stored in the \JPC#\Specialty Group\Drawings folder. 

Creating a Model and Sheet Files

During the setup of a project, several model and sheet files are auto-populated into the 
\JPC#\SpecialtyGroup\Drawings\Reference_Files and \JPC#\Specialty Group\Drawings directories 
of each of the specialty group folders and have the CDOT standard file names already assigned. (Construction 
and Planning are exceptions and do not have any auto-populated files.) These auto-populated files can be 
modified to included project specific information before being used to create new drawings. In addition to the 
auto-populated files, standard 2D and 3D seed files are available from the C:\Program Files\Workspace-
CDOT\Standards-Global\MicroStation\Seed directory. These files are global standards and are write 
protected so that no changes can be made. 
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Several of methods can be used to begin a new drawing; 1) Use the Windows Explorer to copy, paste, and 
rename a file, or 2) use the MicroStation Manager window to create a new file using a seed file or to open a 
drawing and then use the “save-as” command to create the new file. If a new file with project specific data is 
required, use the Windows Explorer method. Otherwise, the MicroStation Manager method should be used.

Using Windows Explorer

1. Open the Windows Explorer window and navigate to the desired   \Projects\JPC#\Specialty Group\ 
folder. <R> on the desired file and select Copy from the menu.

 

2. In the blank area below the file list, right click and select Paste from the menu. 

3. A copy of the selected file is placed in the folder. Rename the new file according to the file naming 
conventions. To rename the file <R> on the file name and select 

4. Rename from the menu. Type in the new name and press the Enter key to finish. 
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Using a Seed File

1. Open MicroStation from the Start menu (or desktop icon if available). From the File Open dialog box 
select the New file icon. If MicroStation is already open, select File > New from the menu. Both operations 
will display the New window.

2. From the New window, click on the Browse button to display the Select Seed File window. 

3. From the Select Seed File window, highlight the desired seed file.

Note: All disciplines use the 2D-Seed_CDOT.dgn and the 3D-Seed_CDOT.dgn. The Bridge-2D-
Seed_CDOT.dgn and Bridge-3D-Seed_CDOT.dgn have specific settings for Bridge.

4. Click the Open button to accept the selection. This will dismiss the Select Seed File window. 
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5. In the New window, type the desired file name (refer to the naming conventions above). Click the Save 
button to accept the file name. MicroStation will open with the newly created file. 

Annotation and Line Style Scale

While the elements themselves are drawn at a 1’ = 1’ scale, a scale factor is set for line styles and text so that its 
size will be appropriate when printed.

Setting the Annotation Scale

Annotation Scale controls text, dimension, and linestyle sizes. It is set in the model properties dialog box 
or in the drawing scale toolbox docked at the bottom of the application screen.

1. Select the Models icon from the Primary Tools toolbar.

2. This displays the Models dialog box. From here, select the Edit Model Properties icon.
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3. In the Model Properties dialog box, select the desired Annotation Scale.

4. <D> the OK icon to accept the selection. This will close the Model Properties dialog box. The Models 
dialog box can also be closed.

5. Changing the Annotation Scale from the Drawing Scale toolbox is the faster way to make this change since 
it doesn’t require any dialog boxes to be opened.
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Line Style Scale Settings

The Line Style Scale settings are set based on the type of data that is in the model or sheet file. Graphics that 
are generated in MicroStation will behave differently than data that is generated from InRoads. Applying the 
wrong setting will display the linestyle symbology incorrectly in the model and when referenced into other 
drawings.

MicroStation graphics are drawn at a scale of 1 and utilize the annotation scale setting to view the linework in 
the appropriate print scale. InRoads hard codes the line style scale to the graphics based on the Project Options 
Factors.

1. Open the Line Styles dialog box by selecting, Element > Line Styles > Custom.

2. Verify the Scale factor: setting is toggled off. 

MicroStation graphics

1. Open the Model Properties.
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2. Verify the Line Style Scale setting is set to Annotation Scale. 

3. Close the Model Properties dialog box by selecting the OK button.

4. Changing the Annotation Scale will now modify the Line Style scales in the models

5. When referencing models that contain MicroStation generated graphics, set the Global LineStyle Scale: to 
Master

Note: This will force the reference line styles to read the sheet file annotation scale and apply it to the 
reference line styles.
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6. Settings for the Global LineStyle Scale are as follows:

♦ None - no scaling is applied, line styles will be viewed at a 1 to 1 scale 

♦ Master - the reference line styles will be scaled to the annotation scale setting in the open file

♦ Reference - the reference line styles will be scaled to the annotation scale setting in the referenced file

♦ Master*Reference - the line styles will be scaled to both annotation scales together

InRoads Graphics

1. Open the Model Properties.

2. Verify the Line Style Scale setting is set to Global Line Style Scale and set to a value of 1. 

3. Close the Model Properties dialog box by selecting the OK button.
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4. If the print scale of the sheet file changes, the InRoads graphics will have to be re-displayed with the new 
print scale set in the Factors tab in InRoads. The annotation scale settings will not affect this file.

5. When referencing models that contain InRoads generated graphics, set the Global LineStyle Scale: to None

Using Model Files From Other Users As References

A reference is a model that is attached to and displayed within the active model or sheet file for design or 
printing purposes. Elements in a reference display as though they were in the active model. Although you 
cannot manipulate the elements in a reference, you can snap to them and even copy them into the active 
model.

Model files created by other users can be used as references even if the file resides on a different computer. 
This is done by mapping the remote computer (the one containing the file to be referenced) to a drive letter 
on the local computer.
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Mapping a Remote Computer

1. Open the My Computer window from the Start menu or desktop icon (if available).

2. From the My Computer window, select Tools > Map Network Drive.

3. In the Map Network Drive dialog box, select the desired Drive letter.

4. In the Folder field, enter the desired computer name and directory. The Browse icon can also be used to 
locate and select this information. The following format is used when keying in the computer information: 
\\computer_name\Projects\JPC#\.

5. If the information on the remote computer will be required over a period of many days, check on the 
Reconnect at Login option.
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6. <D> the Finish icon to complete the process.

7. Files from the remote computer can now be referenced into local drawings. The procedures for referencing 
files are covered in the following workflows: CDOT Sheet File Creation, CDOT Sheet File Creation 
Multiple Scales.
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Nested Attachments

Reference attachment nesting determines what happens when a file containing attachments is attached to the 
active dgn file. The following examples are used to illustrate the different nesting options.

Four files are used in the examples. Blank.dgn is the active file.   Square.dgn, Triangle.dgn, and Circle.dgn 
will be used as attachments. For the purposes of the examples, Circle.dgn has been previously attached to 
Square.dgn and Triangle.dgn has been previously attached to Circle.dgn. 

No Nesting

1. With this option, only the selected file will visible in the active file.

Live Nesting

1. This option allows files that are attached to the selected file to be viewed. 
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2. The number of levels of attachments that can be viewed in this manner is controlled by the Depth setting. 
In the above illustration, Circle.dgn is attached directly to Square.dgn and is visible with a Depth setting 
of 1. By changing the Depth setting to 2, files attached to Circle.dgn (in this case Triangle.dgn) become 
visible.

3. With live nesting, any reference file settings changes affect all of the visible files. So, for example, if the 
Display is turned off for Square.dgn, Circle.dgn and Triangle.dgn are turned off also. 

Note: Level display of nested attachments is discussed below.) 

Copy Attachments

1. This option also allows multiple levels of attachments to be viewed, however, it also allows independent 
control of each attachment. Compare the illustration below with those for Live Nesting. Here, each 
attached file is listed in the References dialog box and its settings can be adjusted independently.



Colorado Department of Transportation   MFSF- 17

CDOT  Workflows  Working with Model Files and Sheet Files

Changing the Nesting Mode

The Nesting Mode for a single file or a group of attachments can be changed from the References dialog box. 
To change the nesting mode:

1. Highlight the desired files from the list.

2. Use the pull-down at the bottom of the dialog box to select the desired nesting mode.

Attachment Level Display

It is probable that elements in attachments will occupy levels that have the same name as levels in the active 
file or other attachments. This is possible because the level display operates independently on the active file 
and each attachment regardless of the nesting mode.

Turning Levels On and Off in Attachments

1. Select the Level Display icon from the MicroStation Primary Tools tool bar.
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2. Select the file whose levels will be turned on or off. The file display within the Level Display dialog box 
will be different depending on the nesting mode.

Note: On the left the files were attached separately or with the Copy Attachment nesting mode. On the 
right, the files were attached using live nesting.

3. Click on the desired level to change its view status. When using live nesting, if the file tree is not 
expanded, level display changes to a particular file will affect all the files collapsed underneath it.

4. Continuing the examples above, the attachments were made using Live Nesting with a Depth of 2. All of 
the elements shown were drawn on the DRAFT_CO-Red level (the line is in the active file, Blank.dgn). In 
the illustration below, the DRAFT_CO-Red level is turned off in Square.dgn with the file tree collapsed. 
This causes the elements in the files collapsed under Square.dgn to be turned off also. 
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5. In this illustration, the file tree has been expanded so that when the DRAFT_CO-Red level in Square.dgn 
is turned off the other files are unaffected and only the square disappears.

6. Levels that are used in nested attachments which are not used in the main attachment will be displayed in 
the Level Display dialog box. The name of the first attachment containing the level is displayed.

 

Note: With the tree view collapsed, turning on or off a level in a collapsed file will affect all collapsed 
files using that level.

7. Two more files have been added to the example, Green_Triangle.dgn and Green_Square.dgn. Each of the 
new files use the DRAFT_CO-Green level. These are attached to Square.dgn and are displayed by Live 
Nesting. With the file tree collapsed, turning off the DRAFT_CO-Green level turns off the display in both 
files.
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8. With the file tree expanded, the levels for the individual files can be manipulated without affecting the 
same named levels in other attachments.

Determining an Element’s File 

1. Just by looking, there is no way to determine which file an element belongs to. However, a <T> snap on the 
element will display a tool tip listing the element’s Type, Level, the Logical Name of the attachment, and its 
actual file name.

Logical Names and Slot Numbers for Reference 
Attachments

Logical Names

1. In MicroStation, a file can be used as an attachment within a single file numerous times. Logical Names are 
used to distinguish one version of the attachment from another. A logical name can be given to any 
attachment, but must be given to the second and subsequent attachments of a file.
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2. To give a logical name to an attachment, begin the attachment procedure as normal. When the Reference 
Attachment Settings dialog box displays, key in the desired logical name in the field provided. Finish the 
attachment process as normal.

3. The logical name is displayed in the References dialog box as illustrated below:

Slot Numbers

1. Slot numbers are assigned to attachments to provide another method of grouping the files. They are used to 
assign the processing order when making shaded color or grayscale prints. For more information on using 
slot numbers in this process, see the workflow CDOT Shaded Color And Grayscale Printing.
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Workflow MS 5 - Sheet File Creation

This document guides you through creating a new sheet file in MicroStation. We will be going over placing the 
sheet border around coordinate based model graphics. Setting up sheets this way maintains the coordinate 
based information and measurements are in real-world dimensions.

Workflow Outline

Setting up the Sheet File - The sheet file contains the sheet border and related data along with reference 
files of the project data. Setting up the Sheet File includes creating the blank dgn file, attaching the references 
and rotating the view to the correct orientation.

♦ Create a New Drawing File - The new drawing file will contain the sheet border and related 
material.

○ Commands Used: File > Open - Used to access the MicroStation Manager dialog box. From 
there, a new file can be created.

○ New File - Accesses the New File dialog box. The new file is created here.

♦ Attach Model Files - The model files are attached so that the view rotation angle can be determined.

○ Commands Used: File > Reference - Used to access the references dialog box. From there, the 
model files are attached.

○ Tools > Attach - Used to select the model files for attachment.

○ Reference Attachment Settings - Used to select the View and Scale for the model file.

♦ Rotating the View - Rotating the view so that the sheet is orthogonal to the screen makes the file 
easier to read and print.

○ Commands Used: rv=0,0,## key in - A method to rotate the view.

○ Rotate View > 3 Points - A method to rotate the view.

♦ Attaching Border and Related Cells - The sheet border, north arrow, and other cells are placed to 
create the sheet.

○ Commands Used: CDOT Menu > Drafting > Border - Used to set the rotation and scale, select, 
and place cells.

♦ Clipping Reference Files - When attached, the full contents of the reference files are displayed. 
Clipping reduces the visible portion of the reference files to the area within the sheet border.

○ Commands Used: CDOT Menu > Drafting > Border > Clip Boundary - Used to draw the 
clip boundary. The clip boundary is a shape that denotes the limits of the viewable area for the 
reference files.

○ References > Clip Boundary - Used to hide reference file data in areas outside of the clip 
boundary.

♦ Setting The Annotation Scale - For sheets that are printed at a scale other than 1” = 100’, the 
annotation scale must be changed to match that printing scale.

○ Commands Used: Models > Properties > Annotation Scale - Used to adjust text and 
linestyle scales to match the desired print scale.
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Setting up the Sheet File

1. Create a new drawing file from the File > Open dialog box, select the New File icon.

2. Enter a drawing file name that corresponds to the next consecutive sheet number and place it under the 
appropriate file location under C:\Projects\....... 



Colorado Department of Transportation   SFC- 3

CDOT  Workflows  Sheet File Creation

3. Verify that the desired Seed File is selected. If it is not, <D> Select and navigate to C:\Program 
Files\Workspace_CDOT\Standards-Global\MicroStation\Seed\.

4. Highlight the desired seed file (for this example: 3D-Seed_CDOT.dgn) and <D> Open.

Note: All disciplines except for Bridge use the 2D-Seed_CDOT.dgn and the 3D-Seed_CDOT.dgn. The 
Bridge-2D-Seed_CDOT.dgn and Bridge-3D-Seed_CDOT.dgn has specific settings for Bridge 
only.
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5. In the New dialog box, <D> Save. 

6. The file you created will be highlighted in the File Open. <D> Open to open that file.
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Attaching Model Files to the Sheet File

1. Select File > Reference. 

2. Or choose the Reference icon  from the Primary Tools toolbar.

3. From the Reference Manager tool bar select Tools > Attach .
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4. Or choose the Attach Reference icon .

 

5. Search for the model file and verify the Attachment Method is set to Interactive. <D> Open. 

Note: You can select more than one file at a time by holding the Shift or Ctrl keys down while making 
your selection. You can also Drag and Drop directly from Windows Explorer into the Reference 
Manager Tool box, selecting several files at one time as mentioned above.
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6. In the Reference Attachment Settings dialog box, key in a logical name and a description. For instance, 
the logical name might be Design for the Design Model drawing.   The other settings should not have to 
be edited.   Coincident-World is selected by default. Also the Scale (Master:Ref): is set at 1:1 by 
default. <D> OK.

Note: When Coincident World under Orientation is selected and a Scale factor of 1:1 is entered, plan 
graphics are being referenced to the sheet file with the true coordinate information. All other 
attachment methods will not maintain the true coordinate values.

7. The files will be shown in the References dialog box.   

Note: Whenever you make graphical model file changes, your sheet file will automatically update. 
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8. Fit View using the icon  so all graphics are displayed. 

9. Select File > Save Settings from the Primary toolbar.

Rotating the View 

1. After the references are attached, you may need to rotate the view depending on the layout of the sheet. 

Note: You are not rotating the reference file(s). You are only rotating the view. The coordinate system 
will not change.

2. One option to rotate the view is to Key-in rv = x,y,z and press <Enter> or <Tab>.
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Note: Entering the recommended values x = 0, y = 0, and z = Rotation Angle will ensure the view is 
roatated about the z-axis in a 3D file. You are rotating the view about the z-axis. This is the axis 
perpendicular to the view. Otherwise, if you are working in a 2D file the key-in would be rv = 
value of rotation. 

3. You will be prompted to select the view you would like to rotate in. <D> in the active view window to 
select the view.

 

4. The view will be rotated.

5. You can also elect to rotate the graphics using 3 Points. Select Rotate View.
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6. Change the Method to 3 Points.

Note: Make sure you are picking a data point near the 3D element.   Do not snap to 3D elements because 
you will be rotating along the z axis instead of just the x and y plane. Turn AccuSnap off or you 
can hold the <Ctrl> and <Enter> keys down at the same time to temporarily disable AccuSnap 
while you are locating the data points.   

7. The view will be rotated.
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Attaching the Border, Bar Scale, North Arrow, and 
Resident Engineer/Survey Supervisor Cells

1. From the CDOT Menu, select Drafting > Borders. 

2. <D> Settings if the desired sheet scale is something other than 1” = 100’.   In the Active Settings dialog 
box you can change the Active Scale and the Active Angle.    

Note: The Active Angle is view independent and not associated with view rotation. Therefore, the x-axis 
is always horizontal regardless of the view rotation. You will not need to set this for correct 
placement of the North Arrow or other cells.
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3. Select the desired sheet border cell from the list. 

4.  Once a sheet border is selected, you will be prompted to locate the lower left hand corner of the sheet 
border (the cell’s origin). Move the cell to the desired location and <D>.

5. Select the desired North Arrow. Move the cell to the desired location and <D>.
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6. Select a Bar Scale if desired. Move the cell to the desired location and <D>.

7. Finally, select the Border RE button, then select the desired Region Engineer cell. <T> to the location 
shown in the illustration below and <D> to accept placement. 

 

Note: Contact the CADD Manager if any edits need to be made to a Region Engineer cell. Remember, 
you can edit the cell with the Edit Text command until the changes are available in the next 
configuration.

8. Double click on any of the text fields in the border to add sheet specific information.

Note: Coordinate with the Region Surveyor when you are creating sheets that are not at a 1:100 scale. 
They will provide you with the topography and survey MicroStation files at a different scale. 
Otherwise, the line work and cells will not be the correct size for the print scale.
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Placing a Clip Boundary

1. From the CDOT Group Menus select Drafting > Border > Clip Boundary.

 

2. Verify the SHEET_Clip-Boundary level is active.

Note: The level SHEET_Clip-Boundary will not print.

3. The Place Smart Line  command will be active. Verify the option for Join Elements is checked ON 
and draw a closed shape that will represent your clipping boundary of the model file. 
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4. Otherwise, if the clipping boundary shape is rectangular, select the Place Block icon  from the Main 
toolbar. 

Clipping the Reference File

1. In References dialog box, highlight the Reference file to be clipped. Select the Clip Reference icon.

Note: You can select more than one reference file at a time by holding the <Shift> or <Ctrl> keys down 
while you are making your selection. You can clip multiple drawings in one step when they are all 
selected.      

2. The following dialog box will open. Verify Method is set to Element.
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3. You will be prompted to select the Element you want to clip the reference from. Select the rectangular 
element that was placed inside the border on GEN_SHEET_Clip-Boundary level. 

4. Fit the MicroStation view  and Save Settings after clipping the reference files. 

Note: Once the clipping boundary is placed, do not delete it. The clipping region of the reference file will 
be lost.

Additional Sheet File Information

1. Setting up text and dimension scale in the sheet file must change the Annotation Scale Factor if the border 
cell was scaled to a factor other than 1:100. Otherwise, the text size in the sheet file will not correspond to 
the scale factor chosen when placing the border cell. 

2. Select File > Models from the Primary toolbar. 
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3. Or select Models icon    from Primary Tools.

4. Select the Edit Model Properties icon 

5. The Annotation Scale factor defaults to 1:100. Select the arrow to change the scale factor. If you try to 
place text before setting this, it will be too large since the drawing plot scale is at a 1:40. 
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6. From the pull down, select the Annotation Scale factor to match the scale factor used when placing the 
border cell. 

7. In this example, an annotation scale factor of 1:40 is chosen. Select OK. 

Note: The annotation scale will take affect immediately.
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8. You can now add text to the new sheet file. It will be scaled to the correct height based on the plot scale or 
in this case 1:40. 

Note: Annotation Scale Lock must be turned ON when placing text or dimensions for the scale factor to 

take affect. Verify it is ON by hovering with your cursor over the  icon.    

9. Select File > Save Settings before you exit MicroStation.
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Workflow MS 6 - Sheet File Creation - Multiple 
Scales

This document guides you through creating a sheet file with multiple scales. First, we will be going over 
placing the sheet border around coordinate based model graphics. Then, we will go over attaching and scaling 
additional model files. Lastly, placing text and dimensions in the sheet file will be covered. For setting up plan 
sheets see the CDOT Sheet File Creation document.

Note: This example uses details from the Bridge discipline. This procedure applies to any sheet file with 
multiple scales. If you are in another specialty, please substitute with your specialty group’s 
information.

Setting up the Sheet File - The sheet file contains the sheet border and related data along with reference 
files of the project data. Setting up the Sheet File includes creating the blank dgn file, attaching the references 
and rotating the view to the correct orientation.

♦ Create a New Drawing File - The new drawing file will contain the sheet border and related 
material.

○ Commands Used: File > Open - Used to access the MicroStation Manager dialog box. From 
there, a new file can be created.

○ New File - Accesses the New File dialog box. The new file is created here.

♦ Attach Model Files - The model files are attached so that the view rotation angle can be determined.

○ Commands Used: File > Reference - Used to access the references dialog box. From there, the 
model files are attached.

○ Tools > Attach - Used to select the model files for attachment.

○ Reference Attachment Settings - Used to select the View and Scale for the model file.

♦ Rotating the View - Rotating the view so that the sheet is orthogonal to the screen makes the file 
easier to read and print.

○ Commands Used: rv=0,0,## key in - A method to rotate the view.

○ Rotate View > 3 Points - A method to rotate the view.

♦ Attaching Border and Related Cells - The sheet border, north arrow, and other cells are placed to 
create the sheet.

○ Commands Used: CDOT Menu > Drafting > Border - Used to set the rotation and scale, select, 
and place cells.

♦ Clipping Reference Files - When attached, the full contents of the reference files are displayed. 
Clipping reduces the visible portion of the reference files to the area within the sheet border.

○ Commands Used: CDOT Menu > Drafting > Border > Clip Boundary - Used to draw the 
clip boundary. The clip boundary is a shape that denotes the limits of the viewable area for the 
reference files.

○ References > Clip Boundary - Used to hide reference file data in areas outside of the clip 
boundary.

Adding Models of a Different Scale - After the basic sheet is set up, the detail reference files are added.

♦ Attach Model Files - The model files are attached so that the view rotation angle can be determined.

○ Commands Used: File > Reference - Used to access the references dialog box. From there, the 
model files are attached.
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○ Tools > Attach - Used to select the model files for attachment.

○ Reference Attachment Settings - Used to select the View and Scale for the model file. The scale 
factor = Border Scale / Detail Plot Scale.

Setting The Annotation Scale - For sheets that are printed at a scale other than 1” = 100’, the annotation 
scale must be changed to match that printing scale.

♦ Commands Used: Models > Properties > Annotation Scale - Used to adjust text and linestyle 
scales to match the desired print scale.

Setting up the Sheet File with Multiple Scales:

Beginning a New Drawing File

1. From the File > Open dialog box, select the New file icon.
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2. Enter a drawing file name that corresponds to the next consecutive sheet number and place it in the 
appropriate folder located under C:\Projects\.......

3. Verify that the correct Seed File is selected. If it is not, <D> Browse and Navigate to 
C:\Workspace\Workspace_CDOT_V8i\Standards-Global\MicroStation\Seed\.

o
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4. Highlight the desired seed file from the files list box (for this example: 3D-Seed_CDOT.dgn) and <D> 
Open.

Note: All disciplines use the 2D-Seed_CDOT.dgn and the 3D-Seed_CDOT.dgn. The Bridge-2D-
Seed_CDOT.dgn and Bridge-3D-Seed_CDOT.dgn has specific settings for Bridge.

5. In the New dialog box, <D> Save. 
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6. The file you created will be highlighted. <D> Open to open the file.

Attaching Model Files to the Sheet File

1. Select File > Reference. 

2. Or choose the Reference icon  from the Primary Tools toolbar.
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3. From the Reference Manager tool bar select Tools > Attach .

4. Or choose the Attach Reference icon .
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5. The first model file you reference should be the one containing coordinate based information. Search for 
that model file and verify the Attachment Method is set to Interactive. <D> Open. If you are creating 
a sheet file containing details only, with no coordinate based information, bring in the detail with the 
largest scale factor first and scale the border to this detail. Once the detail with the largest scale factor has 
been referenced, attach the remaining details into the sheet file following the procedure outlined below.
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6. In the Reference Attachment Settings dialog box, key in a logical name and a description. For instance, 
the logical name might be Plan View for the Bridge Model drawing.   The other settings should not have 
to be edited.   Coincident-World is selected by default. Verify the Scale is to set to 1:1, <D> OK. 

Note: When Coincident World under Orientation is selected and a Scale factor of 1:1 is entered, 
plan graphics are being referenced to the sheet file with the true coordinate information. All other 
attachment methods will not maintain the true coordinate values.

7. The file will be shown in the References dialog box.

Note: Whenever you make graphical model file changes, your sheet file will automatically update.
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8. Fit View using the icon  so the graphics for the first model file are displayed. 

9. Select File > Save Settings.

Rotating the View 

1. After the references are attached, you may need to rotate the view depending on the layout of the sheet.

Note: You are not rotating the reference file(s). You are only rotating the view. The coordinate system 
will not change.

2. One option to rotate the view is to Key-in rv = x,y,z and press <Enter> or <Tab>.
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Note: Entering the recommended values of x = 0, y = 0, and z = Rotation Angle will ensure the view is 
rotated about the z-axis in a 3D file. This is the axis perpendicular to the view. Otherwise, if you 
are working in a 2D file the key-in would be rv = value of rotation. 

3. You will be prompted to select the view you would like to rotate in. <D> in the active view window.

4. The view will be rotated.

5. Or you can rotate graphics using 3 Points. Select Rotate View.
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6. Change the Method to 3 Points.

Note: Make sure you are picking a data point near the 3D element.   Do not snap to 3D elements because 
you will be rotating along the z axis instead of just the x and y plane. Turn AccuSnap off or you 
can hold down the <Ctrl> and <Enter> keys down at the same time to temporarily disable 
AccuSnap while you are locating the data points.   

7. The view will be rotated.
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Attaching the Border and Resident Engineer Cell 

1. From the CDOT Menu, select Drafting > Borders. 

2. <D> Settings if the desired sheet scale is something other than 1” = 100’.   In the Active Settings dialog 
box you can change the Active Scale and the Active Angle.   In this example, the standard 11x17 sheet 
border is too large for the plot area when the Active Scale is set at 1” = 100’. 

3. Prior to placing the border and border information, set the Active Scale. This should be set to the largest 
proposed scale factor you plan to have on your sheet. For example, if you have a plan view that should be 
plotted at 1” = 40’ and a detail that should be plotted at 1” = 5’, the largest scale detail would be 1” = 40’. 
Choose a scale factor in even increments such as 10, 20, 30, 40, 50, 60, 100, etc. <D> Apply.

Note: The Active Angle is view independent and not associated with view rotation. Therefore, the x-axis 
is always horizontal regardless of the view rotation. You will not need to set this for correct 
placement of the North Arrow or other cells.
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4. Select the desired sheet border cell from the list. 

5. You will then be prompted to locate the lower left hand corner of the sheet border (the cell’s origin). Move 
the cell to the desired location and <D>.

6. Select the desired North Arrow. Move the cell to the desired location and <D>.
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7. Select a Bar Scale if desired. Move the cell to the desired location and <D>.

8. Lastly, select the Border RE button, then select the desired Region Engineer cell. <T> to the location shown 
in the illustration below and <D> to accept placement. 

 

Note: Contact the CADD Manager if any edits need to be made to a Region Engineer cell. Remember, 
you can edit the cell with the Edit Text command until the changes are available in the next 
configuration.
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9. Double click on any of the text fields in the border to add sheet specific information. 
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Adding Additional Model Files to the Sheet File

1. Once you have referenced the model file with coordinate based information and added the border, you can 

begin referencing additional files with various scales. Select the Attach Reference icon  located on the 
reference file dialog box. Locate the file you want to attach. <D> Open. 
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2. In the Reference Attachment Settings dialog box, key in a logical name and a description. Set the 
Orientation to Standard Views > Top and set the Scale. When you set the Scale, key-in the scale factor of 
the border sheet into the first field. In this example it is 40. In the second field, key-in the scale factor you 
want the detail to be plotted at. In this example 5 represents 1”=5’. The overall scale factor for the detail is 
40/5 = 8. MicroStation will calculate this for you.

Note: Custom Line Styles will be scaled equal to the 
scale defined in the Scale (Master:Ref) field. If 
referencing topography drawings provided by the Survey 
discipline and uniform symbology is desired set the 
Global LineStyle Scale field to None to negate scaling 
referenced Line Styles by the active models Line Style 
Scale factor.  Additionally toggle off Scale LineStyles by 
Reference Scale to eliminate scaling referenced Line 
Styles by the Master:Ref scale factor.

Formula:

Border Scale: scale the 
border cell was inserted

Detail Plot Scale: scale 
for specific detail to be 
plotted (See Step 22)

Scale Factor: model file 
insertion value

Scale Factor = Border 
Scale / Detail Plot Scale

Alternatively, you could 
key-in 8 into the first field 
and 1 in the second field.   
This means the new detail 
is 8 times larger than the 
first detail
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3. With the Orientation set to Top, the model file is anchored to your cursor and you can place it 
interactively.

4. After the model file is positioned in the area you would like, <D> to accept the placement of the additional 
model in the sheet file. The model file is placed relative to your active Z. Verify the active Z by snapping 
somewhere in the view, prior to placing the new detail. If the Z is not correct, you can interactively key-in 
AZ=0, select the view, hit reset and continue with the reference attachment.
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5. Attach additional model files you would like to add to the sheet file. 
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6. In the Reference Attachment Settings dialog box, key in a logical name and a description. Set the 
Orientation to Standard Views > Top and set the Scale. In this example the border cell was inserted at 
40. If you want the last detail to be plotted at a 1”=10’ scale, leave 40 in the first field and key-in 10 to the 
second field. The overall scale factor for the detail is 40/10 = 4. MicroStation will calculate this for you. 

Formula:

Border Scale: scale the 
border cell was inserted

Detail Plot Scale: scale 
for specific detail to be 
plotted (See Step 22)

Scale Factor: model file 
insertion value

Scale Factor = Border 
Scale / Detail Plot Scale

Alternatively, you could 
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7. Place the model file interactively and <D> to accept placement in the sheet file. 

Additional Sheet File Information

Setting up Text and Dimension Scale in the Sheet File 

1. You must change the Annotation Scale Factor if the border cell was scaled to a factor other than 1:100. 
Otherwise, the text size in the sheet file will not correspond to the scale factor chosen when placing the 
border cell. 
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2. Select File > Models from the Primary toolbar. 

3. Or select Models icon  from Primary Tools.

4. Select the Edit Model Properties icon .
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5. The Annotation Scale factor defaults to 1:100. Select the arrow to change the scale factor. If you try to 
place text before setting this, it will be too large since the drawing plot scale is at a 1:40. 

6. From the pull down, select the Annotation Scale factor to match the scale factor used when placing the 
border cell. 
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7. In this example, an annotation scale factor of 1:40 should display. <D> OK to accept. 

8. Now, you can add text to the new sheet file. It will be scaled to the correct height based on the plot scale or 
in this case 1=40. 

Note: Annotation Scale Lock must be turned ON when placing text or dimensions for the scale factor to 

take affect. Verify it is ON by hovering with your cursor over the  icon.    

9. You can dimension the model files in the new sheet file. The dimensions will be scaled to the correct size 
based on the plot scale or in this case 1:40. 
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Note: Annotation Scale Lock must be turned ON when placing text or dimensions for the scale factor to 

take affect. Verify it is ON by hovering with your cursor over the  icon.    Also, verify the 
Association is ON so the dimensions will dynamically update when model changes are made. 
This setting is turned on by default. 

10.  The Sheet file now includes text and dimensions for multiple scaled details.

11. Select File > Save Settings before you exit MicroStation.
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Workflow MS 7 - Creating Multiple Plan Sheets

This document guides you through manually assembling multiple plan sheets using MicroStation. Your first 
step will be to create a layout of how you want all your sheets printed out. Second, you will create the 
individual sheet files using those layouts. The major benefit of this workflow is the limits and orientations of 
plan sheets are determined early in the process. These sheet limits can be used to identify proper position, size, 
and rotation of text and tables. 

Workflow Outline

Placing the Sheet Plan Limits Cell - The sheet limits cells are used to mark the location of each sheet on 
the project. The cells are placed along the project’s alignment and rotated so that the alignment runs across the 
cell.

♦ Commands Used: CDOT Menu > Drafting > Border - Used to set the rotation and scale, select, and 
place cells.

♦ Measure Angle - Used to determine the rotation angle for the sheet.

♦ Rotate - Used to rotate the cell by the angle determined above.

♦ Edit Text - Use to record rotation angle and scale on the sheet limits cell.

Assembling the First Plan Sheet - The first sheet is created by rotating the view if necessary, adding the 
sheet border and other cells, and clipping reference files to the sheet limits.

○ Commands Used: rv=0,0,## key in - A method to rotate the view.

○ CDOT Menu > Drafting > Border - Used to set the rotation and scale, select, and place cells.

○ References > Clip Boundary - Used to hide reference file data in areas outside of the clip 
boundary. The Element method is used to clip the references.

Assembling the Remaining Plan Sheets - The remaining sheets are created by Copying the first sheet 
then modifying the copy. This is done by moving the sheet border and other cells to the location of the new 
sheet, rotating them to match the sheet orientation, and reclipping the reference files.

sheet border and other cells, and clipping reference files to the sheet limits.

○ Commands Used: File > Save As - Used to make a copy of the first pan sheet.

○ Move - Used to reposition the border and other cells.

○ Rotate - Used to rotate the cells to the proper angle for the new sheet.

○ rv=0,0,## key in - A method to rotate the view.

○ References > Clip Boundary - Used to hide reference file data in areas outside of the clip 
boundary. The Element method is used to clip the references.
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Placing the Sheet Plan Limits Cell

1. Open a MicroStation model file that you will be basing your plan sheets on. 

2. On the CDOT Menu, select the Drafting group.

3. <D> the Border button.

4. <D> on Border Limits (11”x17”) in the options list.
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Note: About the Sheet Plan Limit cell: This cell helps to define the plan sheet limits in the model file 
before placing the border. It contains text characters that can be edited to indicate sheet name, 
rotation, & scale. The outer line-work depicts the maximum display limits for graphics as it relates 
to the border sheet. The inside shape reflects ½ inch inside this maximum limit and is the clipping 
boundary. All graphical information for this cell is on the MicroStation level, DRAFT_INFO_No-
Plot. 

5. In the Place Active Cell dialog box, set the Active Scale to the desired plot scale and set the Active 
Angle to 0.
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6. Position the Sheet Plan Limit cell as you see fit in the MicroStation view, then place the cell in the model 
file.

7. Use the Edit Text command to update the text at the bottom of the sheet. This will assist you in managing 
the sheet plan limits. Select the text at the bottom of the layout sheet and replace the appropriate sheet 
information in the Text Editor.
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8. The plan sheet information text will be updated.

9. Use the MicroStation Copy command to duplicate the cell graphics for the second sheet.

10. Use the MicroStation Rotate command to align the graphics for the second sheet. 

Note: Rotate the cell only and not the model file. 
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11. Edit the information based on the Sheet name and Rotation angle for the second sheet using the Edit Text 
command.

Note: If the Sheet Plan Limits cell is placed at an arbitrary rotation angle, you will have to manually 
measure the angle. This is done by drawing a line horizontal from the lower left hand corner of the 
Sheet Plan Limits cell and then using the Measure Angle command in MicroStation. Measure 
the angle in-between the horizontal line drawn and the bottom edge line of the cell. 
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12. Continue planning the sheet layout for the remainder of the project.

Note: The Sheet Plan Limit cell is to be placed side by side. This cell is setup to have no overlap in the 
plan view. 

Assembling the plan sheets

1. Open up a MicroStation Sheet file and attach the model file that contains the Sheet Plan Limit cells. 
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2. Window or Zoom into the beginning of the project so you can begin placing the border cell. 

3. From the CDOT Menu select the Drafting from the group display area, <D> the Border button, use the 
All filter, and then select Border (Plan 11x17) from the item list. 
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4. <D> Settings if the desired sheet scale is something other than 1”=100’.   In the Active Settings dialog 
box you can change the Active Scale and the Active Angle.

Note: The Active Angle is view independent and is not associated with view rotation. Therefore, the x-
axis is always horizontal regardless of the view rotation. You will not need to set this for correct 
placement of the North Arrow or other cells.

5. <D> Apply in the Active Settings dialog box after desired changes are made. 

6. <D> at the desired location in the MicroStation view to accept placement of the border. 

7. Select the Scale Horizontal from the item list.   

8. <D> at the desired location inside of the sheet border to accept the placement of the bar scale.
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9. Select the North Arrow Standard from the item list.

10. <D> to accept the placement of the North Arrow inside the sheet border. 

11. Select the Border RE button and then select the appropriate Region Engineer from the item list.

12. <T> the point as shown below and then <D> to accept placement of the cell. 
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Note: Contact the CADD Manager if any edits need to be made to a Region Engineer cell. Remember, 
you can edit the cell with the Edit Text command until the changes are available in the next 
configuration.

13. Double click on any of the text fields in the border to add sheet specific information.

Note: Coordinate with the Region Surveyor when you are creating sheets that are not at a 1:100 scale. 
They will provide you with the topography and survey MicroStation files at a different scale. 
Otherwise, the line work and cells will not be the correct size for the print scale.

Placing a Clip Boundary

1. Select the Border button and then select the Clip Boundary from the item list.

2. Once Clip Boundary has been selected, verify the SHEET_Clip‐Boundary level is active.

Note: The level SHEET_Clip-Boundary will not print.

3. The Place Smart Line command will be active. Verify the option Join Elements is checked ON and draw 
a closed shape that will represent the clipping boundary of the model file. 
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4. If the clipping boundary shape is rectangular, select the Place Block command  from the Drawing 
task tab.

Clipping the Reference File

1. In the References dialog box, highlight the Reference file to be clipped. <D> the Clip Reference icon.

Note: You can select more than one reference file at a time by holding the Shift or Ctrl keys down as 
you are making your selections. Multiple drawings can be clipped in one step when they are all 
selected.      

2. The Set Reference Clip Boundary dialog box will open. Verify Method is set to Element.
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3. You will be prompted to select the Element you want to clip the reference from. Select the rectangular 
element that was placed inside the boarder in the previous steps on the SHEET_Clip-Boundary level. 

4. Fit the MicroStation view  and Save Settings after clipping the reference files. 

Note: Once the clipping boundary is placed, do not delete it. If it is deleted, the clipping region of the 
reference file will be lost.   

5. Edit the title block text and add any sheet specific information. You can turn off the level 
DRAFT_INFO_No-Plot so the Sheet Plan Limits cell information does not display. 

6. Select File > Save Settings.

Note: This completes the first sheet. It should be noted that setting up sheets this way maintains the 
coordinate based information and measurements are in real-world dimensions. 

Subsequent sheet creation is accomplished by duplicating the first sheet. This process is 
streamlined because all the reference files already attached. The process for creating subsequent 
sheets involves moving the border sheet and redefining the clipping boundaries.
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7. Select File > Save As and input the name of the next sheet file to be created (sheet file names should be 
numbered consecutively).

 

Note: The Save As command will automatically save the current drawing to the current directory, then 
copy and rename to the specified file name and open the new drawing.
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8. Place a MicroStation fence over an area that would encompass the next sheet in the set.

9. In the References dialog, highlight all files and Select Tools > Clip Boundary. The Method should be 
set to Active Fence.   <D> on the MicroStation screen to accept the new clip boundary. This will re-clip 
the previous Clip Boundary placed inside of the border cell. 

10. Turn On the level, DRAFT_INFO_No-Plot in the model file where the Sheet Plan Limits cells where 
placed. 
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11. Use the MicroStation Move command to relocate the border cell. Also Rotate the border sheet to align 
with the predefined sheet limits if the Sheet Limits cell was placed at an angle. Remember, the value of the 
angle is located in the text of the Sheet Limits cell.

12. You may need to rotate the MicroStation view depending on the layout of the sheet. If you are in a 3D file, 
key-in rv =x,y,z and press Enter or Tab. 

Important!  Use the following values when rotating a 3D view: x = 0, y = 0, and z = Rotation 
Angle. You are rotating the view about the z-axis because this is the axis perpendicular to 
the view. If you are in a 2D file, key-in rv = angle of rotation. 

<D> in the active view window to initialize the rotation. 

Note: Rotating a MicroStation view simply rotates the viewing of the graphics. The coordinate system is 
still relative to the graphics and any coordinate or alignment information extracted will be correct.

13. Define the reference file clip boundaries as in the previous steps.

14. Update information in the title block of the sheet as necessary

15. Select File > Save Settings.

16. Repeat this procedure to complete the remainder of the sheets.



Colorado Department of Transportation   TSVM- 1

Workflow MS 8 - Title Sheet Vicinity Map

This document defines the procedure for inserting a Vicinity Map into the Project Title Sheet. 

Vicinity Map Insertion Procedure

1. Open the file JPC#DES_TitleSht.dgn under C:\Project\......\Design\Drawings or 
JPC#ROW_TitleSht.dgn under C:\Projects\.....\ROW_Survey\Drawings that is automatically created 
when you run the Create Project Utility program upon project startup. 

Note: The ‘JPC#’ will be replaced by the 5 digit Job Project Code.

2. County Maps for all counties within Colorado have been translated from GIS information, and can be 
found on the Shared Drive \\public\CADD County Maps\. These maps should be used to build your 
Vicinity Map. The County of interest should be copied down to your project location Drawings folder and 
so it can then be attached as a reference file to the Title Map. The local map can be edited as desired 
without affecting the original.

Note: If you choose to attach the map directly from the Shared Drive as a reference file, the map will 
remain in a read-only state. No editing will be allowed nor will saving additional views be 
permitted.

3. The CDOT-PenTable.tbl has been updated to plot the title map with dithering on certain entities. It should 
be set by default. No adjustments will need to be made.

Title Map Example

\\public\CADD County Maps\
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Reference File Attachment

1. The county map should be attached as a reference file to the Title Sheet. Once the desired County 
has been copied down your Project location, select File > Reference to open the References dialog 
box. Select Tools > Attach, then navigate to the file, select it and <D> OK.

2. The Reference Attachment Settings dialog box will appear. The Map has been designed to be 
inserted at a scale factor of 1:5280 (Master: Reference). Select Coincident - World.
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3. When <D> OK, the map will be attached to the end of the cursor. Place the map within the limits of 
the Title Sheet drawing, Project Location Map area, located in the middle of the sheet. If the limits 
of your project are not shown within the area on the screen, you can zoom out in the view, place a 
large Fence Block, and perform a Reference File Clip Boundary command. This will re-clip the 
limits of the Reference File, allowing you to see much more of the map.

Note: Your Fence Type should be set to Block not to Element. 

4. Once you have located your project limits, Zoom into the area where it is located. Re-position the 
project limits within the center the Title Sheet with the Move reference file command. Re-Clip the 
limits of the project as desired. This time you can use either a Fence Type of Block or Element, 
whichever you prefer. If you are going to use Element, <D> the Blue shape in the middle of the 
Title sheet and accept it on the screen. If you choose a Fence Type of Block, <T> to either corner 
of the Blue shape and <D> to accept it. This will re-define the limits of the Project Location Map. 

5. A DGNLIB including the GIS levels has been included in the configuration and has been assigned 
to all the County Model Files by default. The Reference Levels can be manipulated as desired 
from the Level Manager dialog box.

6. The Township and Range Text can be copied into your sheet and positioned where you want it. 
Turn off the Reference file level GIS_Townships-Text if you have copied it into your file. 
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Note: If you want the map at a different scale other than 1:5280 (1 inch = 1 mile) it can be rescaled 
through the reference dialog box. It should be noted that the linestyle scale factors and text were 
defined based on a 1 mile insertion. The linework and text can be re-scaled within the original 
Region area, only if it has been saved to your hard drive. 



Colorado Department of Transportation   SAQS- 1

Workflow MS 9 - SAQ Sheets

This document guides you through opening the Summary of Approximate Quantities Sheet created within your 
project folder and attaching the DXF files created from the Sumgraph software, through the use of 
MicroStation Reference file tools.  Upon completion of the following procedures, the Sumgraph sheets can be 
plotted with the CDOT Batch Printing Process. 

Summary of Approximate Quantities (SAQ) Sheets 
Creation 

Saving the SAQ Sheets

1. Generate your SAQ Sheets through the Sumgraph program.  Ensure that the Directory Path for the DXF 
files is set to the Project Specific Design\Drawings\Reference_Files folder.  The MicroStation levels have 
been adjusted in Sumgraph to accommodate the latest CDOT configuration.  The following Menu has been 
modified.  The default selection is shown below:

Note: The designer no longer has the option to select the Sumgraph sheet creation that includes a 
17x11 border.  The only method available is the No Title Block option.

Creating the MicroStation Sheet Files

1. The Drawing Sheet file to be used is located in the project directory structure under the \Design\Draw-
ings folder called 45454DES_SAQ##.dgn.  The Project Creation Utility has replaced the JPC#  portion 
of the file name with the unique Project Code, in this example shown as 45454.  The file can be renamed to 
45454DES_SAQ01.dgn, replacing the ## with a sheet number value.  The Windows Explorer Copy & 
Rename can also be used in order to preserve the orginal drawing file, if desired.  
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Note: It is an acceptable procedure to place all your SAQ sheets within one file if desired, but this 
exercise will only cover the placement of one SAQ sheet per Drawing file. 

2. Open the 45454DES_SAQ01.dgn.  Notice that the Border Cell has already been placed within the file.  
The cell should not need to be relocated or scaled, as it has been positioned at the correct coordinates and 
scaled appropriately to accommodate the Sumgraph DXF reference file attachment.  Additionally, the 
drawing has been scaled to 1”=200’ and the coordinates for the lower left hand corner of the border read 
X=43.50, Y=-1.00, Z=0.

3. From the MicroStation Main Menu, select File > Reference to open the Attach Reference dialog box.  
Navigate to the project specific \Design\Drawings\Reference_Files folder and select the Sumgraph 
DXF from the Files list.  It may be necessary to manually move the desired files to this location, prior to 
attachment, if the sheets were not placed in this folder in step 1 above.  <D> OK to proceed.  

Note: If the DXF file does not show up in the list, it may be necessary to change the List Files of Type to 
show CAD Files (*.dgn, *.dwg, *.dxf).  After making the change, the list should contain the 
desired file.
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4. The DWG/DXF Units dialog box will now appear.  The units should be set by default to Survey Feet.  
Accept this setting by <D> OK.

Note: Do not check the “Do not Display again” settings box, as this reminder is necessary for all DWG/
DXF attachments and may vary on occasion.

5. The Sumgraph DXF sheet will now be attached as a reference file in the correct location for printing.  
Place the appropriate Resident Engineer Identification cell and update any other Titleblock information 
desired.  The CDOT Titleblock can be updated with the Edit Text command.

6. After the initial sheet has been created, each consecutive sheet can be copied and renamed using the 
Windows Explorer or through the File > Save As command in MicroStation.  The reference file 
attachment will need to be updated for each sheet.  Select File > Reference to open the References 
dialog box, Double click on the attached Reference file to display the Attachment Settings dialog box.  
Navigate to the desired location, select the desired sheet and <D> OK twice.  The Sheet file will now 
contain the correct Sumgraph DXF sheet.

7. After creating the desired SAQ sheets, proceed with the CDOT Batch Printing Process.  Instructions for 
batch printing can be found on the Start> All Programs > _CDOT_CADD_Information > Workflows 
> CDOT Batch Printing or on the CDOT Menu under Help > Workflows.

8. The Sumgraph program may need to be re-run during the course of the Design Project so that SAQ DXF 
Sheets are updated with revised information.  Make sure to maintain the identical naming convention for 
the DXF files that are updated and save the files to the correct folder in the Project directory structure and 
proceed with CDOT Batch Printing.

9.
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Workflow MS 10 - Converting AutoCAD Files to 
MicroStation

This document guides you through translating AutoCAD files into MicroStation using a .CSV remapping file. 
The MicroStation dgn files produced using this workflow will have standard CDOT levels using bylevel 
symbology. For plotting AutoCAD files only, see the workflow, CDOT Printing AutoCAD Files in 
MicroStation. 

Workflow Outline

Batch Conversion Of AutoCAD Files - All of the file within a directory can be converted at one time 
using Batch Processing. Because the level conversion table will be set up for only the open drawing it may no 
convert all AutoCAD level into Microstation levels. When these unconverted levels are discovered, repeat this 
process to convert the remaining AutoCAD levels.

♦ Commands Used: File > Open - Used to access the MicroStation Manager dialog box. From there, 
the desired AutoCAD file can be selected.

♦ DWG/DXF Units - This is a message window displayed when an AutoCAD file is opened in 
MicroStation. Set the Units to Survey Feet.

♦ Utilities > Batch Converter - This command is used to select the AutoCAD files for conversion, set 
up the conversion table, and convert the files.

○ Edit > Add Files - Used to select the AutoCAD files for conversion

○ Edit > V8 Save Options - Used to access the remapping CSV file.

○ Excel > Level - This button (in the Excel spreadsheet) queries the dgn file for AutoCAD level 
names and places them into the spreadsheet.

○ Excel Cut and Paste - In the Spreadsheet, MicroStation level names are cut from their current 
location and pasted next to the corresponding AutoCAD level. This tells the batch converter what 
to rename the AutoCAD levels too.

Fixing Converted Files with Mutiple Models - Some AutoCAD files may have multiple models, usually 
a sheet border model and a data model. Because the CDOT standard is one model per dgn, these will have to be 
separated

♦ Commands Used: File > Save As - Used to create a dgn file to contain the sheet border data.

♦ Delete - Used to remove the data from the Default Model.

♦ References > Attach - The file is attached to itself so that the sheet border data can be moved into 
the Default Model.

♦ Copy - Used to copy the referenced sheet border data into the Default Model.

♦ Models > Delete - Used to remove all models except the Default Model.

♦ Color Table > File > Default - Used to set the CDOT standard color table active.

♦ CDOT Menu > Drafting > Dimensions - Used to replace the AutoCAD dimensions.

♦ CDOT Menu > Tools > Text to Node - Used to group lines of text into paragraphs.

♦ annotationscale add - A MicroStation key in that adds the annotation scale attribute to the text.

♦ Change Text Attributes - Used to assign a CDOT text style to the text.
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Batch Conversion Of AutoCAD Files

Entire directories can be processed at one time using the Batch Converter. Using this option, a large number of 
files can be processed quickly. However, because only one of the files can be used to create the CSV file (the 
open file), many AutoCAD levels may be transferred to the MicroStation files. As the user finds MicroStation 
files with AutoCAD levels, those files can be used to create a new csv file and the Batch Converter can be re-
run on all the files. By repeating this process all of the AutoCAD levels will be gradually eliminated.

The steps below describe how to set up and run the Batch Converter.

Opening an AutoCAD file in MicroStation

1. From the File Open, open an AutoCAD (*.dwg) drawing file. (Change List Files of Type to CAD Files 
(*.dwg, *.dgn, *.dxf) to see the AutoCAD files in the selected directory). 

2. <D> the desired file then <D> OK. 

3. The DWG/DXF Units dialog box will appear. Verify the Units are set to Survey Feet and <D> OK. 
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4. Select Utilities > Batch Converter from the MicroStation menu. The Batch Convert dialog box is 
displayed.

5. Select Edit > Add Files from the menu.
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6. From the Select Files and Directories to Convert dialog box, Navigate to the directory containing the files 
to be converted, then highlight the files to be converted. <D> Done to complete the selection. 

7. Back on the Batch Convert dialog box, select Edit > V8 Save Options from the menu.
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Editing the CSV file

1. In the Save As V8 Options dialog box, <D> the Browse for CSV remapping file icon to edit the CSV 
file.

2. Navigate to the following directory: C:\Workspace\Workspace-CDOT_V8i\Standards-
Global\MicroStation\Tables\Level_Translation and select the V050000_Level_Update.csv 
file. The CSV file maps all of the previous AutoCAD layers to the standard CDOT MicroStation levels. 

0
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3. The CSV File field will be populated with the correct level mapping file. In the Save As V8 Options dialog 
box, <D> the Edit CSV remapping file icon. 

 

4. Microsoft Excel will activate. If the Security Warning dialog box appears, <D> Enable Macros. 
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5. In Excel, the Level tab will be active. <D> the  icon that is embedded in the Level cell.
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6. The fields under Level will be populated with the layers that are defined in the AutoCAD file.

In the example above, the first 12 levels listed are the AutoCAD layer names. The levels below them are 
the CDOT standard MicroStation levels.
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7. In order to remap the AutoCAD layers to the standard CDOT levels, you will need to manually populate 
the V8OutputLevel fields. To do this, find the desired CDOT standard MicroStation level in the Level 
column. Copy/Cut the level and paste it in the V8OutputLevel column directly across from the AutoCAD 
layer it is to replace.

In the above example, elements that were on the AutoCAD ‘TEXT’ layer will be placed on the 
‘DRAFT_Text-3’ level’ after conversion.

Note: Not all levels need to be populated. Blank entries in V8OutputLevel column will be ignored when 
processed and the AutoCAD layer (if occupied) will be brought into the MicroStation file as a new 
level. Be aware that some of the MicroStation levels are not in alphabetical order. And take care to 
search the entire list for the desired level.

Layers generated in AutoCAD that will be recreated as cells in MicroStation such as the Border, 
North Arrow, and Bar Scales do not need to be remapped because they will automatically come in 
on the correct levels when the standard CDOT workflows are followed.   Also, the layers used for 
creating AutoCAD viewports do not need to be remapped. Items on the Defpoints layer should be 
remapped to the level DRAFT_INFO_No-Plot.

The line styles, color, and weight of each level has already been taken into account through the 
CSV file. The translation variables in the CSV file have been set to remap all levels to bylevel 
symbology.

Note: Steps 13 and 14 below are available when converting a single file only. When doing a batch 
conversion, all of the models within the file will be converted.

8. In the Save As V8 Options dialog box, <D> the Filter tab. 
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9. Toggle off the Sheet Models check box.

10. <D> the Remap tab.

11. Check on the fields for Apply Level Mapping, Apply Line Style Mapping, Apply Color 
Mapping, and Apply Weight Mapping. <D> OK. 
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12. From the Batch Convert dialog box, <D> the Process Batch Convert Job icon.

13. The Files To Convert dialog box is displayed. From this dialog, <D> the Convert button.

14. When the processing is complete, <D> the Done icon to dismiss the dialog box.

This will convert all of the levels in the active file (as specified in the csv file) and convert the same levels in 
the other specified files. 

It is possible that the other files processed will have other AutoCAD levels. When these are discovered, repeat 
this conversion process on the previously converted MicroStation files. This will clean up the file that is 
currently being used and update the levels in other specified files. 
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Fixing Converted Files With Multiple Models

Sheet Layout models are not used in the standard CDOT configuration. However, those models will be retained 
in batch converted files. If the Sheet Layouts contain information that is needed, they will need to be saved to 
individual dgn files. To do this we will reference a dgn file to itself, selecting the desired sheet model, in order 
to copy information from the sheet layout to the default model.

1. Open the converted dgn file that contains the Sheet Layouts to be saved.

2. Select File > Save As and name the file appropriately for the Sheet Layout to be saved and <D> 
OK.

3. This will open the copy of the file. Delete all of the elements from the Default Model.

4. <D> the References icon from the MicroStation Primary Tools toolbar.

5. Select Tools > Attach from the References dialog box.

6. Select the open dgn file to attach it to itself. <D> Open.
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7. In the Reference Attachment Settings dialog box, select the desired Sheet Layout from the Model 
drop down menu. <D> OK.

8. <D> the Fit view control icon to display all of the elements in the view.

9. All of the elements in the view must be copied into the default model. This can be done using the Element 
Selector or with a Fence. 

Note: When making the copy be sure to snap to an element when copying and the same point on the 
element when placing the elements. This will ensure that they are at the same coordinates in the 
default model as they were in the sheet layout model.

10. After the elements have been copied, Detach the reference file. 
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11. <D> the Models icon from the MicroStation Primary Tools toolbar.

12. In the Models dialog box, <D> to highlight all of the models except the Default Model. <D> the 
Delete icon to remove all of the sheet layouts. <D> the ‘X’ to close the Models dialog box.

13. Steps 19 through 30 will have to be repeated for each sheet layout.

Converting a Single AutoCAD file

1. Open the desired AutoCAD file in MicroStation as described in steps 1 and 2 above.

2. Select File > Save As. 



Colorado Department of Transportation   CATM-  15

CDOT  Workflows  Converting AutoCAD Files to MicroStation

3. Change the Select Format to Save to MicroStation V8 DGN Files (*.dgn) and navigate to the 
appropriate folder under the Projects directory. The file will be automatically saved with the same name as 
the AutoCAD file with a different extension. You can rename the file at this time if you choose to do so. 
<D> Options. 

Note: Model files should be saved to the specialty group’s Reference_Files folder. Sheet files are saved 
under the specialty group’s Drawings folder. 

4. <D> Save in the Save As dialog box. The CSV file will execute and the AutoCAD drawing file will be 
converted to a MicroStation file. 

5. The file that is now open in MicroStation is the converted file. Running the CSV file changed the levels in 
the Model file to the CDOT Standard levels with bylevel symbology. 
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6. From the MicroStation menu, selected Settings > Color Table after the MicroStation drawing file has 
been created. 

7. In the Color Table dialog box, select File > Default.

8. <D> Attach. 

9. Verify that the conversion was successful. <D> the Level Display icon from the MicroStation Primary 
toolbar.



Colorado Department of Transportation   CATM-  17

CDOT  Workflows  Converting AutoCAD Files to MicroStation

10. In the Level Display window, <D> on the Used tab to sort the levels by those that have elements.   

Note: levels with elements will have a dot in this column. If no used levels are visible, <D> on the tab 
again. If the triangle on the tab is pointing down, the used levels are at the top of the window.)

Other Drawing Elements

Other updates will need to be made to the files so all drawing elements and sheet setups conform to the CDOT 
standards. 

All of the Sheet Layouts will need to be recreated using CDOT standard workflows. This means there can only 
be one Model for each MicroStation file. All of the sheet borders will need to be placed in their own separate 
file, called a Sheet File. Then, the Model file will be referenced to the Sheet File.   Please refer to the 
documents CDOT Sheet File Creation, CDOT Sheet File Creation Multiple Scales, and CDOT Creating 
Multiple Plan Sheets for additional information about this procedure. 
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1. Recreate all Dimensions and leader lines (placed by AutoCAD) using the standard CDOT dimension 
styles. The dimensioning commands are found in the CDOT menu under Drafting > Dimensions.

2. Erase all hatch patterns generated in AutoCAD recreate using the MicroStation Patterns tools, shown 
below. 

3. All blocks generated in AutoCAD will need to be replaced with the standard CDOT MicroStation Cells. 
The cells are found on the CDOT menu. Use the CDOT Menu Explorer to select the desired specialty 
group. Use the Category buttons and the Filter buttons to locate the cells within the menu. Select the 
desired cell from the list.



Colorado Department of Transportation   CATM-  19

CDOT  Workflows  Converting AutoCAD Files to MicroStation

Updating Text

Text created in AutoCAD with multiple text strings can be converted to a text node in MicroStation. Some 
multiple text strings created in AutoCAD will be translated into a text node when the file is converted. 
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1. To verify this, <D> the Element Information icon . Text Nodes will display under the General 
Tab. 

2. If not, select all text that will be combined into a text node using the Element Selection tool. While in 
the Element Selection command, hold down the Ctrl key to select individual text strings. Highlight 
them in the order they are to be placed into the text node. 

Note: Do not Window around the multiple lines of text because the text strings may not merge in the 
desired order.
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3. Select the Text to Node utility from the CDOT Menus under Add On’s. 

4. <D> the Convert Text Element to Text Node icon 

5. The following dialog box will appear. The selected text will be anchored to the cursor. 



CATM- 22 Colorado Department of Transportation

 Converting AutoCAD Files to MicroStation CDOT  Workflows

6. Check on Delete Original, set the Justification, and leave the Line Spacing set to 1.00. Place the text in 
the desired location.

Note: If the Justification is set to anything other than Left Bottom, double <D> on the text after it is 
placed. The text will be brought into the Text Editor dialog. <D> again on the screen to place the 
text to its proper location and close the dialog.

7. Select all text and key-in annotationscale add. The text will now recognize the MicroStation 
Annotation Scale Factor. 

8. Update the text style by <D> Change Text Attributes. Select the desired CDOT Text Style and select 
the text placed previously in AutoCAD.

  

9. All fractions placed in AutoCAD will need to be re-typed in MicroStation so the format conforms to 
CDOT standards.
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Compressing the Model File

1. After all changes and updates have been made to update the drawing into MicroStation using CDOT 
standards and standard workflows, you will need to compress the drawing in order to remove all AutoCAD 
information stored in the drawing buffer. This will ensure that AutoCAD data does not get repopulated into 
the drawing. Select File>Compress>Options.

2. Under Compress > Options, verify that all options are checked ON except Delete Text Elements 
Containing Only Spaces. 

3. Once the correct options have been selected, <D> the Compress button.
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Workflow MS 11 - Update Project Sheet Border 
to a ProjectWise Sheet Border

This document guides you through the conversion of an existing project sheet border that was built and stored 
on a local computer to a ProjectWise sheet border stored within ProjectWise. The benefits of using ProjectWise 
sheet borders stored in ProjectWise are; automatic backup of data, content management to reduce the potential 
of overwriting data, and having title block information automatically filled in using ProjectWise attribute data.

Workflow Outline

Request a ProjectWise Project - When migrating a project from the local computer to the ProjectWise 
server, the first step is to have the project directory built on the ProjectWise server.

♦ Commands Used: E-mail Request - to help@dot.state.co.us.

Store Sheet File in ProjectWise - Once the project directory has been built on the ProjectWise server, the 
existing sheet border files are copied to the proper location within that directory.

♦ Commands Used: Drag and Drop - Drag the sheet border files from a Windows Explorer window 
and drop them into the ProjectWise Explorer window.

Modify Sheet File Attributes - Attributes are project specific data that can be assigned to the dgn file once 
it is in ProjectWise. These attributes are used to populate tags within the dgn file to fill in sheet border 
information.

♦ Commands Used: Properties > Attributes - This is form used to fill in the attribute data.

Replace Border - The original sheet border in the drawing does not have the ProjectWise tags, therefore, it 
cannot use the attribute data added to the file. The existing border is replaced with a ProjectWise sheet border 
and the tags are updated with the attribute data.

♦ Commands Used: Place Line - Used to mark the insertion point for the sheet border.

♦ Delete - Used to remove the existing sheet border cell.

♦ CDOT Menu > Drafting > Border ProjectWise - Preferred method for placing the ProjectWise 
sheet border cell.

♦ Place Active Cell - An alternate method for placing the ProjectWise sheet border cell.

♦ Delete - Used to remove the insertion line drawn above.

Populate Tags with ProjectWise Attributes - Because the ProjectWise sheet border did not exist in the 
file when it was opened, the tags in the border have to be manually updated.

♦ Update MS Tag Values with PW Attributes - Used to add the ProjectWise attribute data the sheet 
border tags.

Request a ProjectWise Project

If existing project data currently exists on your local computer or on a shared network drive, it is important that 
the extended team is aware of the transition to ProjectWise.

If your project has not been built in ProjectWise, submit an e-mail request to help@dot.state.co.us to have it 
done. This request should include the Project Manager’s name and the Project Number.

mailto: help@dot.state.co.us
?subject=Project setup in ProjectWise
mailto: help@dot.state.co.us
?subject=Project setup in ProjectWise
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Store Sheet File in ProjectWise

1. Open a Windows Explorer and browse to your project sheet border file.

2. Open and login into ProjectWise then browse to your project.
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Note: In ProjectWise you will see one of two different icons for your project or discipline folder called a 

sub project. A project folder has this icon,  and a non project folder has this icon, 

. Regardless of this folder difference the drag and drop function works the same. 

3. Drag and Drop the local copy into the ProjectWise folder to store the file.
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Modify Sheet File Attributes

1. Double click on the sheet border in the ProjectWise Explorer to Check Out and open the drawing in 
MicroStation.

Note: A red check mark will be displayed in ProjectWise Explorer noting you have this file checked out 
and have read/write access.

2. In ProjectWise Explorer, <R> on the dgn filename and select Properties.

6

3. <D> on the Attributes Tab.

Note: Since the sheet border file was placed in a ProjectWise folder, the Attributes applied to the 
ProjectWise folder were automatically applied to the sheet border file.
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4. Fill out the following Attributes based on the values in the existing sheet border. In the example below the 
following values are used:

a. Sheet Title Line 2 - TYPICAL SECTION

b. Subset - Typical Sections

c. Subset Page Number - 1

d. Subset Total - 3

e. Sheet Number - 65

5. <D> Save and <D> Close to apply the changes to the ProjectWise Attributes.
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Replace Border

In the next steps, the original sheet border is replaced with a ProjectWise sheet border. The ProjectWise sheet 
border has MicroStation tags that are populated with the ProjectWise Attribute data entered above. The 
attribute data is displayed as text within the title block of the sheet border.

1. In MicroStation, draw a line from the bottom left corner to locate the insertion point of the new sheet 
border.

2. Delete the existing sheet border leaving the line drawn in step one and any project data in the file.
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3. Place the ProjectWise Plan sheet border at the insertion line. There are two ways to achieve this:

a. The first is through the Cell Library dialog box.

○ Open the Cell Library dialog box, Select Element > Cells.
○ Attach the General.cel library if it is not already attached.

○ Set SHEET_PW_Design‐Plan‐Sheet as the active cell.

○ Place the cell at the insertion point.

Note: Be sure to set the correct scale for the sheet border prior to placing the cell.
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b. The second and preferred method is to use the CDOT Menu to locate and place the ProjectWise sheet 
border.

○ From the CDOT menu select the Drafting group.

○ Choose the Border ProjectWise tab.

○ Select PW Design Border (Plan 11”x17”)

○ Place the cell at the insertion point.
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4. Delete the insertion line.

Populate ProjectWise Attributes

Typically when a sheet drawing is opened from ProjectWise the tag attributes are refreshed. Since this file was 
opened to place the tag set (embedded in the sheet border) they could not be populated. There are two options 
to refresh the attributes; reopen the drawing or manually update the attributes.

Note: The menu used in this section has two icons which will produce opposite results. The first icon takes 
data from the files existing sheet border and writes it to the ProjectWise attributes. The second icon 
takes the ProjectWise attributes and writes them into the sheet border.

If you select the first icon after you place a new sheet border into the file it will erase the ProjectWise 
attributes attached to the file.
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1. To manually refresh the tags with the ProjectWise attributes, open the Colorado DOT Task menu.

The second line of icons are the ProjectWise commands for attribute data.

2. <D> Update MS Tag Values with PW Attributes icon to populate the new sheet border. The second 
icon, updates the MicroStation tag values with ProjectWise attributes. When this icon button is used all the 
ProjectWise attributes for the drawing will overwrite the MicroStation tags.

Important! Only use the first icon on a file with an existing ProjectWise sheet border that has had 
the tags refreshed then manually modified. If this command is ran on an unpopulated 
sheet border is will erase all of the attributes from the ProjectWise database.
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Below is an example of a sheet border with the ProjectWise tags filled in.
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Push Tag Edits to ProjectWise Attributes

At anytime you can edit the tag attributes by double clicking on the blank tag value and use MicroStation to fill 
in the border information.

The insert point of the tag data is marked by a point. 

Near that point is the place holder for the tag.
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1. Double click the place holder to open the Edit Tags dialog box. The Tag Set name is displayed in the header 
of the dialog box. The tag set name should be pwise.

Note: You make find it easier to locate the tag by selecting the Edit Tag command then clicking in the 
area of the tag.

Note: The highlighted tag will be the place holder you double clicked on. In the example above this was 
the designer_name.
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2. If a place holder can’t be found, use the Edit Tag button from the Drawing Tasks menu and select any 
element of the border cell.

Note: This method will highlight the first tag field and will not highlight the tag in the MicroStation 
view. This will require some knowledge of the tag field names. 

3. Modify the Value column for the desired tag and <D> OK.
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4. The new value is displayed in MicroStation. In this example, the designer’s initials are displayed.

However, this value is not in the ProjectWise File attributes.

5. <D> on the Update PW Attributes from MS Tag Values icon.
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The attribute is now listed in ProjectWise File Attributes dialog box.

Troubleshooting

If for some reason the ProjectWise attributes will not populate into the MicroStation tags or MicroStation tags 
will not populate the ProjectWise attributes, check the MicroStation Tag Set name.

1. In MicroStation, <D> Elements > Tags > Define.
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2. Verify that the Tag Set name of pwise is listed.

Note: Any variation of this name should be renamed to pwise. Typical variations would be pwise1 or 
pwise2.

3. Highlight the pwise variation name in the Sets field.

4. <D> the Rename button.

5. Key-in pwise for the Name.

6. <D> OK to accept the new file name.

Important! Do not use the Remove button under the Sets or Tags sections. This will result in having to 
replace the sheet border cell in MicroStation to get those items back.
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Workflow MS 12 - Accessing Imagery Files

This document guides you through the process of locating and downloading imagery stored on CDOT servers. 

Obtaining Image File Names 

In order to download the correct image files for a project, the names of the image files must first be determined. 
The file names can be identified by using the DRAPP Imagery Viewer for Denver area files or the NAIP 
Imagery Viewer for statewide files. The process of identifying the image names is the same for both viewers. 
The steps below use the DRAPP Imagery Viewer.

1. Open an Internet Explorer window.

2. In the CDOT internal web site, navigate to Organizations. Scroll down to the Project Development 
heading and select the Data Files Imagery Viewer (or Statewide Imagery Viewer) link. or use the 
following link: http://dtdintapps/drappviewer/ (http://dtdintapps/naipviewer/ for statewide images). 

This displays the DRAPP Imagery Viewer in the Internet Explorer window.

3. In the Map Layers dialog box, <D> the arrow next to Roadways & Image Tiles to expand the layer list.

http://dtdintapps/drappviewer/
http://dtdintapps/naipviewer/
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4. Toggle on the desired image formats. The grid lines and names of the image tiles are displayed in the 
viewer.

5.  Use the view controls at the top of the window or the mouse scroll wheel to zoom in to the area of your 
project.

6. <D> the Identify icon to display the Identify dialog box. The name of the selected image file is displayed 
in this dialog box.
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7. In the map area, <D> in the location that contains the image needed. This places the Identify icon at the 
point you picked and shows the image name in the Identify dialog box.

8. In the Identify dialog box, highlight the image name.

9. <R> on the filename and select Copy from the menu. You can also press the Ctrl + c keys to make the 
copy.

This image name is used as a search string in the next section of the workflow.
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Downloading an Image From the Server

Once the name of the image has been identified, it can then be retrieved from the server for use. There are two 
servers that contain the image data, one for Denver area data and one for Statewide imagery data.The servers 
can be accessed from either the Start Menu or from the Windows Explorer. The process is the same for each 
server. The steps below use the DRAPP Imagery server.

1. In either the Start Menu Search field or the Windows Explorer address field, key in 
\\tocaerials\Aerials_2010 (\\hqprdgisimg\NAIP09 for statewide images) .

2. Open a second Windows Explorer session and navigate to the project folder where the images will be 
stored.

3. In the \\tocaerials\Aerials_2010 Windows Explorer session, paste the image name copied above into the 
Search field. The files found that match the name are displayed in the window.

file:///\\tocAerials_2010
file:///\\tocAerials_2010
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4. Copy the desired image from the \\tocaerials\Aerials_2010 Windows Explorer session and Paste it into 
the Project Windows Explorer session.

Note: Some image formats also have an associated sister (or world) file.   If the file you are retrieving has 
a sister file, it will need to be copied as well. Otherwise it will not display at the correct location 
when referenced into MicroStation. NAIP09 image files have the georeferencing data embedded 
within the file, so there are not sister files associated with these images.

For information on how to use georeferenced images with MicroStation, refer to the following workflows:

♦ CDOT Workflow Raster Manager

♦ CDOT Workflow Setting Geographic Project Coordinate System 

♦ CDOT Workflow Placing Images to Project Datum

♦ CDOT Workflow Using Georeferenced Images in Raster Manager

file:///\\tocAerials_2010
file:///\\tocAerials_2010
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Workflow MS 13 - Image Draping

This document guides you through the basic functions for draping a aerial photo over a digital terrain 
model (DTM). It is used to create a visual representation of the image in 3D. Make sure the MicroStation 
design file, Raster Imange, and InRoads DTM files coordinately match up.

Workflow Outline

Setting up Preferences - The default value for a dgn background color is black. However when making 
images for printed material, a white background is preferred. 

♦ Commands Used: Workspace > Preferences > View Options - Used to change the background 
color from black to white.

Attaching the Raster Image - A raster image will be used to texture the triangles of the surface. In order to 
specify a raster image as a texture, it must be attached to the drawing.

♦  Commands Used: Raster Manager - Used attach a raster image to a dgn file.

Displaying Triangles - Trinagles are used to give the image shape. 

♦ Commands Used: InRoads > Surface > View Surface > Triangles - Used to display the surface 
triangles within the drawing.

Draping the Image on to the Triangles - Now that both the image and the triangles are in the drawing, 
the image is draped on to the triangles to a textured surface. 

♦ Commands Used: Rotate View > Isometric - Used to adjust the view angle so that the image and 
the triangles can be seen as separate elements.

♦ Fit View - Used to all elements within the drawing visible on the screen.

♦ Visualization > Assign Material - Used to drape the image to the triangles.

○ Assign by Level/Color - Used to Identify the level of the triangles so the the image will know 
what elements to drape to.

○ Raster Manager > Draping - Used to identify which image to drape.
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1. For printing purposes, begin by changing the background color of MicroStation to white. This can be com-
pleted through Workspace > Preferences. This will open up the Preference dialog box

 

2. Under the Category column, select View Options. Toggle ON the box for Black Background -> 
White then select OK to close teh dialog box.
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3. Begin by attaching an image using Raster Manager. Refer to the workflow document CDOT Raster 
Manager.pdf for guidance. Be sure Open as read-only is turned off.
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4. From InRoads, view the surface triangles for the DTM.
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5. Rotate the view to Isometric and then complete a Fit View.
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6. From the Task Menu, select the Visualization tab.

7. Select the Apply Material command. This will bring up the Assign Material dialog box.



Colorado Department of Transportation   ID- 7

CDOT  Workflows  Image Draping

8. Select the Open Palette icon and navigate to dcdrape.pal and select OK.

9. From the Assign Material dialog box, select Assign by Level/Color. MicroStation will ask you to 
Assign Material.

10. In the MicroStation Isometric view, select the DTM triangles and then accept by clicking a data point in 
the MicroStation view window.
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11. Open Raster Manager and Right Click on the column bar. This will bring up a drop down menu.

12. From the drop down menu, Toggle ON the Draping function.

13. From the View Attributes, change the Display Style to Smooth with Shadows.

14. Complete a Fit View.

Note: The image will be clipped to the DTM triangles. Any part of the image that is not draped onto the 
DTM will not show.
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15. Using the View Rotation command, rotate the view to a final position.

Note: The image brightness can be controlled by turning on Default Lighting and adjusting the view 
brightness.
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Workflow MS 14 - Raster Manager

This document guides you through MicroStation Raster Management including Attaching Rasters, 
Clipping Rasters, Masking Rasters, and setting Raster Transparency. For additional settings on raster 
images including text clarity see CDOT Printing Raster Images.pdf .

Raster Manager Dialog Box

1. The Raster Manager is used to display images as a reference to a DGN file. To access Raster Manager 
select File > Raster Manager or <D> the Raster Manager icon from MicroStation’s Primary Tool Bar.

Attaching a Raster Image

1. In the Raster Manager dialog box, select File > Attach >Raster (This Workflow uses C:\Proj-
ects\12345\Design\Drawings\12345DES_PnP10.dgn as the master design file.)

2. In the Attach Raster Reference dialog box, navigate to the folder containing the image that will be 
referenced.

3. Highlight the file to be attached.
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4. Toggle On or Off Place Interactively as desired.

Note: If the file is Georeferenced, then Place Interactively should be toggled off. 

Note: Placing a non-georeferenced file with the Place Interactively toggled off will cause the image to be 
placed at the Global Origin.

Toggle on Open Settings Dialog. This will display the Raster Attachment Options dialog box which is 
used below.

5. <D> Open.

6. In the Raster Attachment Options dialog box, expand the Image leaf and key in a Logical Name and 
Description 
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7. If the file attached is a georeferenced file, expand the Geometry task.

8. Verify that the GeoPriority is set correctly for the file being attached.

Note: The the Raster Attachment Options dialog box may appear different based on the size the box has 
been set to and the options selected when starting the attachment. However, the Image leaf will 
always be available. The Geometry leaf is only available when Place Interactively is toggled off. 

9. Select Attach.

Note: A Fit View may be required to see the raster image.
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Note: The above screen capture was captured with a white MicroStation background for ease of 
viewning (the referenced image has a black background). To rid raster image of black borders see 
Setting Raster Transparency at the end of this document. Geo-Referenced Files typically will not 
need any modifying or relocating. These files have their coordinates and scaling embedded either 
within the tif itself or in an accompanying world file (.twf).

Clipping and Masking Raster Images

If for some reason there are portions of the raster image that you do not want to see, two commands are 
available to accomplish this: Clip Raster and Mask Raster. These parallel the options available for 
MicroStation reference files. Clip Raster hides the image outside the selected area while Mask Raster 
hides the image inside the selected area. 

1. Window Area to show your area of interest.
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2. From Raster Manager, select Edit > Clip.

 

3. The Clip dialog box presents the clipping options. Select the appropriate Method and Mode from the 
drop-down lists.

4. Define the clip boundary. 

Note: To use the Fence option, the fence must be in place before the Clip command is selected. 

5. <D> to accept element selection. 

6. <D> in the view to complete the command. The illustration below shows and example of a Clip Boundary.
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This illustration shows and example of a Clip Mask.

Note: Once defined, Clip Boundaries can be modified by selecting Edit > Modify Clip from the Raster 
Manager menu. Clipping can be defined by the methods Blocks, Elements, and Fences.

Setting Raster Transparency

The dark, unused portion of your raster image (see black image outlined below) can be set to transparent 
allowing the user an alternative to clipping that is easier. This is extremely useful when printing raster 
images as this portion of the drawing is omitted. (This workflow uses the file 
C:\\Project12345\Design\Drawing\ Reference_Files\12345DES_Model.dgn)

1. Open Raster Manager.
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2. <R> on a raster attachment file and select Transparency from the fly-out menu.

3. In the Attachment Settings dialog box, place a check in the Transparent check box, make sure the 
Transparent Color is at 100%, <D> OK.

4. Repeats step 2 and 3 for any additional attachments.

Note: Transparent color can be set to any color, but is black by default (Red:0, Blue:0, Green:0). Use 
graphics programs such as Adobe Photoshop to determine the RGB settings of your raster images.
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Workflow MS 15 - Using Georeferenced Images 
in Raster Manager

This document guides you through the Raster Manager settings in MicroStation for accurate placement of 
georeferenced image files. The section Setting the Default Preferences only needs to be done once. If your 
Raster Manager preferences have been previously set correctly you may proceed directly to Placing 
Georeferenced Images section of this document.

Setting the Default Preferences

1. From the MicroStation pull-down menu select Workspace > Preferences. The Preferences dialog will 
appear.

2. Select the Raster Manager option in the Category list in the left pane.

3. The User Preferences for Raster Manager have been broken out into four tabs:

♦ General

♦ Default Attributes

♦ Georeference

♦ Memory

4. Many of the setting are the same as they are in previous version and new functionally has been added to 
enable users to change the functionality of MicroStation.
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5. In the General tab set the following toggles.

Note: The settings in this tab help MicroStation process imagery faster and select the rasters images.

6. In the Default Attributes tab, toggle on the following.

Note: These settings only apply to the level, symbology and element properties of the raster image 
borders when they are attached.
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7. The Georeference tab has the most important settings. Set the following settings for the Sister file and Unit 
Settings to ensure the proper placement of your raster images.

8. The Memory tab has been added to the Raster Manager User Preferences. These settings were only 
possible in previous versions through a series of configuration variables. The default values are set as seen 
below, but if you are having problems seeing your raster images these settings should be adjusted.

Note: When adjusting these settings take into account the computer’s hardware.
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9. <D> OK button to save these preferences. Once these preferences have been saved they should not have to 
be changed again.

Note: Some settings will require you to restart MicroStation before they will take affect.

Placing Georeferenced Images

1. From the MicroStation pull-down menu select File > Raster Manager. The Raster Manager dialog will 
appear.

2. From the Raster Manager menu select File > Attach > Raster... The Attach Raster Reference dialog will 
appear.

3. Navigate to the location of the raster image files and select the file(s) to attach.

4. It is important that the Place Interactively check box is unchecked. <D> Open to attach the image(s).

Note: Having the Open Settings dialog toggled on is optional.  When toggled on you can review the 
Raster Attachment Options before attaching the rasters.
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5. Click on the arrows to expand the settings. <D> Attach when finished.

6. After attaching the image a Fit View may be needed to display the image.

7. If the image does not appear in the correct location adjust the placement location. Select the image from 
the Raster Manager dialog box.

8. From Raster Manager select all the images.

9. Click on the Element Information icon on the Primary tool bar.
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10. Expand the Geometry field and change the Geo Priority to Sister File.

11. Fit View to display the image. The image should now appear in the correct location.
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Workflow MS 16 - Image Reprojection to 
Project Coordinate Datum

Images to Project Datum Coordinate System

Images at CDOT are typically oriented to Colorado State Plane coordinate systems. This workflow 
guides you through the steps required to attach an image in a Colorado State Plane Coordinate system 
and modify its location so the image will re-project to the Project Datum coordinate system.

In order for this to be completed, information from the Survey must be obtained. This information can 
be found on the Project Control Diagram sheet of the plan set.

Project Coordinate Datum

A modified coordinate system is computed for each CDOT project to provide horizontal values for mapping 
and surveying purposes. CDOT project modified coordinates are based on the Colorado State Plane Coordinate 
System of 1983(92) in unites of US Survey Feet.

Project Control Diagram sheets are included in CDOT plan sets and a note explaining the Project Coordinate 
Datum can be found on this sheet. 

An example:

Project coordinates are modified Colorado State Plane XXXXXX Zone NAD ‘83/(XX) coordinates. The 
combined elevation/scale factor used to modify the coordinates from state plant to project coordinates is 
1.XXXXXXXXXXX. The resulting project coordinates are truncated by 200,000m in the Northing and 
400,000m in the Easting after converting from state plane coordinates to project coordinates. The CHARN 
is based on the NAD ‘83(XX) datum.
Project Coordinates Northing US Survey Feet = (State Plane Coordinate Northing * 1.XXXXXXXXXXX 
- 200,000) * (3937/1200).
Project Coordinates Easting US Survey Feet = (State Plane Coordinate Easting * 1.XXXXXXXXXXX - 
400,000) * (3937/1200).

Relocate the Image

The workflow to relocate an image that is defined with Colorado State Plane Coordinates into a Project 
Coordinate Datum can be completed by editing the origin and pixel size of the referenced image.

1. Create a new design file and using Raster Manager, attach the project image. Be sure the Place Interactive 
option is Not selected.

2. The Raster Attachments Options dialog box opens.

3. Expand the Geometry tab and set the Geo Priority to Sister File.
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4. Click the Attach button.

5. Select the attached image by using the Element Selection tool.

6. Expand the Geometry tab and change the Geo Priority to Attachment.

7. Modify the Origin X and Y using the procedures for the Project Control Diagram.

8. For example: (State Plane Coordinate Northing * 1.XXXXXXXXXXX - 200,000) * (3937/1200) and 
(State Plane Coordinate Easting * 1.XXXXXXXXXXX - 400,000) * (3937/1200).

9. Next, modify the pixel size X and Y.

10. For example: Pixel Size X * 1.XXXXXXXXXXX and Pixel Size Y * 1.XXXXXXXXXXX.

Note: The precision is set to 3 decimals places so the pixel size values may not appear to change.

11. Once values have been adjusted, close the Element Information dialog box.
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Workflow MS 17 - Batch Processing

This document guides you through using the Batch Process tool in MicroStation. Additional Batch Process 
files can be substituted into this workflow. This example uses a specific batch process file that changes the 
level of the North Arrow cell and the Match Lines. In 2.04 and prior versions of the configuration, Plan and 
Profile Generator placed the North Arrow cell and the Match Lines on the incorrect level. This process will 
correct this error in multiple sheets at the same time.

1. Select Utilities > Batch Process in MicroStation.

2. <D> on the Search icon to browse for the Batch Process command file.

3. Navigate to C:\Workspace\Workspace-CDOT_V8i\Standards-Global\MicroStation\Data. 
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4. <D> the command file PnP_Cell‐Fix.txt then <D> Open. 

Note: The file, PnP_Cell‐Fix.txt, changes the level of the North Arrow cell and the Match Lines from 
Default to the correct levels, GEN_SHEET_North-Arrow and GEN_SHEET_Match-Line.

5. <D> the Add Files icon.
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6. Select the sheet files created by the Plan and Profile Generator in InRoads. Then <D> Done

Note: You can hold down the Ctrl or Shift key to select multiple files.

7. <D> the Process Batch icon. This will execute the Batch Process command file.
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8. Review the file list before processing. If this is correct, <D> Process.

9. Review the Status field to make sure all files were processed without an error. 

10. After verifying this, <D> Done. 

11. <D> the Save icon to save the files included in the Batch Process. Every time you rerun the Plan and 
Profile generator in InRoads, the changes to the North Arrow cell and the Match Lines will be lost. You 
can recall the *.bprc file to execute the batch process.

Note: If additional Plan and Profile sheets are created, be sure to update the file list.
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12. Give the saved file an extension of *.bprc. Navigate to C:\Projects\.....\Design\Working and <D> OK.

13. Verify the name in the dialog header.

14. To open a Batch Process file <D> the Open icon.

15. Navigate to the *.bprc file previously saved, <D> the filename then <D> Open. Follow steps 7-9 to 
execute the Batch Process command file.
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Workflow MS 18 - Two Line Note Placement

This document guides you through placing a note with two lines of text with a leader line located between the 
lines of text.

Setting Symbology

1. To set the proper symbology for the note, select Drafting from the CDOT Menu Explorer.

2. Select the Dimension category button from the Drafting area.

3. Select any one of the items displayed in the item list.

4. This sets the level to DRAFT_Text-1 and the symbology to By-Level. The CDOT Menu can now be 
minimized.

Placing A Two Line Note

1. Turn AccuDraw On from the Primary Tool Bar. This will display the AccuDraw window.
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2. Select Place Note icon from the Tasks > Drawing.

3. In the Place Note dialog box:

a. Select the desired Text Style from the drop-down list.

b. Use the Dimension Style drop-down list to set the desired dimension style.

c. <D> on the Expand arrow.
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4. In the Expanded Settings area:

a. Set the Location to Manual using the drop-down list.

b. Set the Leader Type to Line using the drop-down list.

c. Remove the check from the In-line Leader check box.

Note: Depending on the Dimension Style selected, some of the above settings may be set by default.

5. Key-in the desired text. Type the first line of text; press the Enter key then, type the second line of text.

6. <T> (if desired) then <D> on the location of the note terminator.

Note: In the example above a <T> then <D> was used to place the note terminator on the corner of the 
red linestring. If AccuSnap is on, it can be used to locate the terminator end of the leader.
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7. <D> to place the end of the first leader segment. The AccuDraw compass will now be centered on this 
point.

8. Move the cursor on to the AccuDraw compass point that is in the direction the second segment is to be 
placed, then key in the desired length. The keyboard automatically defaults to the AccuDraw window and 
the proper field will be active. <D> to place the end of the second segment.

Note: Placing the cursor on the AccuDraw compass point “locks” in the angle of the line. Also, the 
second segment of the leader can be placed dynamically if desired.

9. Move the cursor on to the leader segment that was just drawn and <R>. This action will place the text on 
the leader line. 
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10. The finished note is shown in the illustration below.
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Workflow MS 19 - Greek Characters

This document guides you through placing Greek characters using the MicroStation Text Editor. Greek 
characters can be placed within the typed text string using this procedure.

Available Characters

The following is a list of available characters in the GREEK font (Font 5).

Note: This Graphic shows what Keyboard Characters will produce the desired Greek Character. The 
Keyboard characters will show up in the Text Editor Dialog Box when placing and editing these 
characters. The actual Greek Character will show up in MicroStation and print.

Placing Text with Greek Characters

1. Before entering text into the Word Processor, uncheck the Apply Changes To All Text check box.
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2. When placing text using the MicroStation Word Processor, select Font 5 (GREEK) from the drop-down 
list as shown below, and type the appropriate character from above into the Word Processor. Switch back to 
the original font to continue typing text.

Note: The F is automatically changed to the Theta symbol in the Word Processor.

 

3. Example of text placed in MicroStation.
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4. Example of text being edited with MicroStation Text Editor

Note: The keyboard character does not display in the editor, the actual Greek Character does.
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Workflow MS 20 - Using Curb Ramp Cells

This document guides you through the use of the pedestrian curb ramp cells. These are dynamic cells that can 
be modified “on the fly” using predefined parameter sets and user input.

The pedestrian curb ramp cells are designed to be placed at a 90º angle to the curb. The steps below describe 
the method used to set the Active Angle for the ramp.

Preparation

1. Zoom in around the area on the curb where the ramp is to go. Select the Construct Line At Active Angle 
command from Tasks > Drawing > Linear.

2. Set the Active Angle to 0º.

3. <D> on the curb face where the center of the ramp is to be located and extend the line in a direction tangent 
to the back of the ramp at the center.

4. In the MicroStation Key-In window, type active angle pt2 and press the Enter key. This is used to set 
the active angle to that of the line that was just drawn.
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5. <T> to the end of the line on the curb face and <D>. Then, <T> to the other end of the line and <D>. The 
Active angle is now set to the angle of the line.

Placing A pedestrian Curb Ramp Cell

1. <D> Design from the CDOT Menu explorer.

2. <D> the Roadway category.

3. <D> the Cell filter.

4. <D> the desired pedestrian curb ramp cell from the list.
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5. Select the desired parameter set from the Params drop-down list.

6. Some parameter sets have options for user defined values for some variables. These will typically have 
“variable” in the name. To modify a variable, select the expand icon in the lower right corner of the tool 
settings box.

7. In the list, locate the variable to be changed (grayed out settings can not be changed). Highlight the desired 
variable then <R> in the Value field and key in the desired number. Press the Enter key to accept the key 
in.

8. The cell is now ready for placement. The origin of the cell is at the curb face in the center of the ramp.
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9. Follow the steps above to select a cell. Once the cell is selected and set up (if it has an undefined variable), 
<T> to the line at the curb face and <D> to place the cell.

10. Finally, Delete the construction line. 
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This document guides you through the use of the AutoTrack software. AutoTrack is used to determine the 
space required to maneuver vehicles.

Workflow Outline

Opening AutoTurn - AutoTurn runs within MicroStation. Once MicroStation is running, AutoTurn can be 
launched.

♦ Commands Used: CDOT Menu > Tools >AutoTURN  - Used to launch the AutoTURN program.

Setting up AutoTURN - Before a path can be laid out, there are a number of settings that should be made.

♦ Selecting a Vehicle - The first step in defining a vehicle path is selecting the vehicle to be used.

○ Commands Used: Vehicles icon - Used to open the Select Current Vehicle dialog box.

○ Group Vehicles by - Used to arrange the vehicles in the list.

○ Select Vehicle - Used to identify the vehicle to be used.

♦ Drawing Settings - These control things like units of measure and steering angles.

○ Commands Used: Program Settings - Used to launch the AutoTURN program.

Creating a Path - This is what the vehicle will follow to generate the turning data. There are a number of 
methods available for creating a path.

♦ Generate Arc Path, Generate Corner Path, and Generate Oversteer Corner Path - Each 
of these methods uses input into Smartpath Tools dialog box and user defined start and stop locations 
to define the vehicle path.

○ Commands Used: Generate Arc Path - Use to follow a bend in the road.

○ Generate Corner Path - Used when turning a corner from one road to another.

○ Generate Oversteer Corner Path - Used when large vehicles are turning a corner from one 
road to another.

♦ Steer a Path - This option tracks the cursor’s motion to define the vehicle’s path.

○ Commands Used: Steer a Path - Use to create an interactive path.

Modifying a Path - Once a path has been completed, modifications to that pah can be made with a number of 
tools.

♦ Commands Used: Restart Path - Used to add additional segments to the path.

♦ Delete Last Section - Used to remove segments of the path.

♦ Path Control - Used to modify an existing segment.

Creating a Path from MicroStation Graphics - With this option the vehicle’s path is drawn in advance, 
using MicroStation drawing commands. These elements are then identified as an AutoTURN path.

♦ Commands Used: Select Active Path - Used to identify the MicroStation elements to be used for 
the path.

♦ Place Simulation - Used to place a vehicle on the path.

♦ Place Offset Simulation - Used to create a parallel path offset to the left or right of the MicroStation 
elements.
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Placing and Deleting Vehicles - Vehicle cells can be placed on the path without creating all of the 
envelope data. This can be used to check clearances at critical locations for example. Vehicle cells placed in 
this manner ca also be deleted.

♦ Commands Used: Select Active Path - Used to identify the path 

♦ Place Vehicle - Used to put a vehicle cell on a path.

♦ Delete Vehicle - Used to remove a vehicle cell from the path.

Opening AutoTurn

1. From the CDOT Menu, select CDOT Tools > AutoTURN.

2. The AutoTURN toolbar will also displayed along with the Welcome to AutoTURN wizard.
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Setting Up AutoTURN

There are a number of settings that control the behavior of AutoTURN. These settings include: vehicle 
type, drawing units, display options, and vehicle defaults.

Selecting a Vehicle

1. <D> the Vehicles button from the toolbar or the wizard to display the Select Current Vehicle dialog box.

The vehicles in the library can be sorted by Library, Class, number of parts, Recent selections, Style, 
Region, or No Group. 

Note: All options except Library show vehicles from all of the other libraries.

2. <D> one of the seven buttons to choose a sorting method. 
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3. To select a vehicle, highlight the name from the list box at the bottom, and <D> OK. The Select Current 
Vehicle dialog box will be dismissed.

Drawing Settings

The remaining settings mentioned above are controlled through the Program Settings dialog box.

1. <D> the AutoTURN Program Settings button from the toolbar to display the Program Settings dialog 
box.
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2. Select the General category to set the Units. This should be set to the Master Units used in the 
MicroStation dgn file. Feet is equivalent to Survey Feet for this purpose.

Creating a Path

Once the desired settings have been made, a path can be created for the vehicle to use. There are five 
commands that are used to create a path: Generate Arc Path, Generate Corner Path, Oversteer Corner Path, 
Steer a Path, and Place Offset Simulation.

Creating a Path with Generate Arc Path, Generate Corner Path, 
or Oversteer Corner Path

1. Zoom in on the area where the path is to begin.

2. Select one of the three Generate Path icons.

A cell of the vehicle is attached to the cursor. 

Note: If you cannot see the vehicle, left click twice in the view in the area where you would like to place 
the vehicle. This will place the vehicle. Do a Fit View this will make the vehicle visible. Zoom in 
on the vehicle, delete the cell, and reinitiate the command.
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3. Move the cursor to the desired start point and <D> to identify the vehicle’s starting location. 

4. The vehicle cell will pivot around the selected location. Rotate the cell to the desired orientation and <D>.

5.  If desired, the SmartPath Tools dialog box can be used to set the angle. To use this option, key in the 
desired angle in the Vehicle Starting Angle field, then <D> the Apply button. Be aware that the angle is 
based on the MicroStation compass, with 0.00 facing right.

 

Once the starting angle is defined, the first leg of the path can be defined.
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6. Set the desired Speed in the SmartPath Tools dialog box.

7. Set the Sweep in the SmartPath Tools dialog box.

 

8. To identify the end of the first leg <D> at the desired location.
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9. If additional legs for the vehicle path are required, the type of path is selected from the SmartPath Tools 
dialog box. The second leg is extended from the end of the first.

10. <R> to end the Path.

Creating a Path with Steer a Path

The Steer a Path command tracks the cursor location to define the vehicle path. To create a path using this 
option:

1. Zoom in on the area where the path is to begin.

2. Select the Steer a Path icon.

A cell of the vehicle is attached to the cursor. 

3. Move the cursor to the desired start point and <D> to identify the vehicle’s starting location. 

4. The vehicle cell will pivot around the selected location. Rotate the cell to the desired orientation and <D>. 
If desired, the SmartPath Tools dialog box can be used to set the angle. To use this option, key in the 
desired angle in the Vehicle Starting Angle field, then <D> the Apply button. Be aware that the angle is 
based on the MicroStation compass, with 0.00 facing right.

5. Move the cursor along the desired path and the vehicle will follow.

Note: The vehicle moves toward the location of the cursor only while the cursor is in motion.

Note: It can be helpful to toggle off AccuSnap while using the Steer a Path command.

6. <D> to stop the vehicle and display the vehicle envelope. 

7. <D> again to restart the vehicle along the path.

8. To end the path, <D> then <R>.
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Restarting a Path

To add to a completed path:

1. <D> the Continue Simulation button on the AutoTURN toolbar.

2. <D> on the vehicle at the end of the desired path. The additional leg will use the last selected mode. A 
different mode can be selected from the SmartPath Tools dialog box. Additional legs are added in the 
same manner described above.

Deleting the Leg of a Path

To delete the last leg of a path:

1. <D> the Delete Last Section button on the AutoTURN toolbar.
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2. <D> on the vehicle cell at the end of the desired path. The last leg of the path is removed.

Modifying a Path

Minor changes can be made to Arc, Corner, and Oversteer Corner path legs. To make a change in one of these 
legs:

1. <D> the Path Control button on the AutoTURN toolbar.
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2. <D> on an element that makes up the path to be edited. This can be the vehicle cell or one of the lines that 
make up the envelope.

3. <D> and hold on a circle in the path, then move the circle to the desired location.

4. Release the button in the desired location, then <R> to exit the command.
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Creating A Path To Follow A Graphic Element

There are two methods of creating an AutoTURN path that follows a MicroStation graphic element or 
elements. One method identifies the element as an AutoTURN path then applies a vehicle to that path. The 
second method works similarly, but allows the user to apply an offset from the selected element.

1. Select the desired vehicle as described above.

2. <D> Select Active Path from the AutoTURN toolbar.

3. <D> on the element(s) that describe the path, then <D> to accept. The path is indicated with a circle at the 
beginning and an arrowhead at the end.

Note: If the element selected is a complex chain, <D> the element near the starting end for the path. If 
the path is a series of individual elements, identify the elements in order, from the beginning of the 
path.

4.  <D> Place Simulation from the AutoTURN toolbar.
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The vehicle and envelope are placed on the path.

Place Offset Simulation

1. <D> Place Offset Simulation from the AutoTURN toolbar.

2. <D> the element(s) that describe the path, then <D> to accept. The path is indicated with a circle at the 
beginning and an arrowhead at the end.

Note: If the element selected is a complex chain, <D> the element near the starting end for the path. If 
the path is a series of individual elements, identify the elements in order, from the beginning of the 
path.

3. The Place Offset Simulation dialog box is displayed. In the Place Offset Simulation dialog box, key in the 
desired offset value in the Minimum Offsets field. This is the distance from the path to the near edge of the 
envelope.
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4. Use the Direction drop down menu to identify which side of the path the offset is applied to.

5. <D> the Apply button.

The vehicle and envelope are placed in the drawing.

Placing and Deleting Vehicles

Vehicles may be placed along a path without generating the envelope. Vehicles placed in this manner can also 
be deleted.

Place Vehicle

1. Select the desired vehicle as described above.

Note: If there is an existing simulation on the desired path, the vehicle cell used in that simulation will be 
used by this command.

2. <D> Select Active Path from the AutoTURN toolbar.

3. <D> the element(s) that describe the path. The <D> to accept.
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4. <D> Place Vehicle from the AutoTURN toolbar.

5. The Vehicle cell is shown on the path. The cell is moved along the path by moving the mouse.

6. <D> in the desired location to permanently place the cell in that location. Additional vehicle cells can be 
placed in this manner.

7. <R> to exit the command.

Delete Vehicle

Vehicle cells displayed using the Place Vehicle command can be removed from the path using the Delete 
Vehicle command.

1. <D> Delete Vehicle from the AutoTURN toolbar.
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2. <D> inside the vehicle cell to be removed.

Note: Cells placed at the beginning, the end, or at a direction change (from forward to reverse, for 
example) cannot be deleted.
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This document guides you through the use of the MicroStation rendering tools. In this example, a roadway 
design project is rendered so that images can be created that are suitable for exhibits at a public meeting. These 
images give the general public a better idea of what the finished project will look like. This workflow uses both 
MicroStation and InRoads data, as well as aerial photos and other raster images.

When creating a rendering of a project, the existing surface outside of the construction area should be rendered 
along with the design surfaces. Because the design surface may be below the existing ground in some 
locations, the existing surface should be removed in the area of the project.

Once the surfaces are modified, the surface data is displayed in the drawing and materials are applied to give 
the surfaces a more natural appearance. Then, to enhance the appearance of the model, 3 dimensional cells that 
represent a variety of landscape and other features.

Workflow Outline

The following outline describes the steps needed to complete a rendered drawing along with a brief 
explanation of what each step does.

Modifying the Existing Ground - The first section describes how to create a modified existing ground 
surface that can be modified for the rendering.

♦ Copy the Existing Ground DTM - This workflow requires the existing ground surface to be 
modified. So that the surveyed dtm is not altered (which could adversely affect the design) a copy of 
the existing ground is made.

○ Command Used: Copy Surface.

♦ Clip Out the Area Of the Design Ground - Parts of the design surface may lie underneath the 
existing ground. These areas will not be visible in the rendering if the existing ground triangles are left 
intact. The design surface’s perimeter is used to define an untriangulated area within the existing 
ground surface, thus exposing the entire design surface.

○ Commands Used: View Perimeter - Used to display the surface design perimeter.

○ Import Surface From Graphics - Used to incorporate the design perimeter into the existing 
ground surface and an Interior breakline.

○ Triangulate Surface - Used to recalculate the triangles of the existing ground surface so that 
triangles within the design perimeter are excluded.

Assigning Material to the Existing Ground - By themselves, rendered triangles look rather plain. by 
applying a natural looking material or an aerial photo to the triangles a more visually appealing appearance can 
be achieved. In this example an aerial photo is used.

○ Commands Used - View Triangles - Used to display the triangles of the modified existing 
ground surface.

○ Raster Manager - Used to attach the photo to the dgn file.

○ Assign Material - Used to drape the aerial photo over the modified existing ground triangles.

Assigning Material to the Design Surface - There are a wide variety of materials that can be used to 
render a drawing. There are options that allow you to assign different materials to parts of your design model. 
For the majority of the design model surface components can be displayed and rendered. However, because of 
the way that side slope components are built in InRoads, these areas are better suited to having the triangles 
rendered.
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♦ Creating Side Slope Surfaces - The components for cut and fill are not suitable for rendering 
because the components are not created in areas where the slope changes. (This does not affect volume 
calculations because the surface is still triangulated in these areas). Therefore a separate surface for 
these areas is created.

○ Commands Used: View Features - Used to display the POSS, Top of Cut, and Toe of Fill 
features that will be used to create the side slope surfaces.

○ Place Smartline - Used to connect the toe of slope features to the POSS feature. This defines the 
boundary for the new surface

○  Create Complex Shape - Used to create a single closed shape element from the toe of slope 
features to the POSS features. This will be used as the data and exterior boundary for the side slope 
surface.

○ Import Surface From Graphics - Used to create the new side slope surface and to add the data 
to it.

♦ Displaying the Design Components and Surfaces - The design components and side slope 
surfaces are displayed so that materials can be assigned to their levels.

○ Commands Used: View Surface Components - Used to display the surfacing and Z-Slope 
components.

○ View Triangles - Used to display the side slope surfaces. Remember to use a different preference 
than was used for displaying the existing ground triangles.

♦ Assigning Material to the Design Surface - This is done to make the rendered components and 
surfaces appear more lifelike.

○ Commands Used: Assign Material - Used to apply different materials to the components and 
side slope surfaces.

Adding Additional Details - Items other than the surfaces can be added to the rendering in order to better 
illustrate the impact of the proposed design.

♦ 3D Cells - These are like other MicroStation cells except they are as 3 dimensional elements that can 
be rendered. An assortment of 3D cells is available from the landscape3d.cel library, delivered with 
MicroStation. Others can be found on-line.

○ Commands Used: Attach Cell Library - Used to make the cells in the library file available for 
placement in the drawing.

○ 3D Warehouse Import Model - Used to obtain additional 3d cells from the internet.

○ Place Cell - Used to place the cell into the dgn file.

♦ Using A Background Image - A background image is used to replace whitespace with a more 
realistic looking image.

○ Command Used: Design File Settings > Views - Used to identify the raster image to be used for 
the background.

♦ Lighting Adjustments - These are used to make the rendering more visually appealing by adjusting 
brightness, lighting direction, and the definition of shadows. All of these adjustments are made in the 
Lighting Manager.

○ Commands Used: Lighting Manager - Brightness - Used to adjust the overall lighting for the 
rendering.

○ Lighting Manager - Ambient - Used to adjust the environmental lighting for the rendering. It 
is used to reduce the harshness of shadows.
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○ Lighting Manager - Solar - Used to adjust the direction from which the light comes.

Modifying the Existing Ground

Copy the Existing Ground DTM

The first step in the rendering process is to clip out the existing ground in the area of the project. For this, a 
copy of the existing ground surface is made. Then the perimeter of the design surface is imported into this copy 
as an Interior Breakline. This will insure a seamless edge between the existing and design surfaces.

1. Open MicroStation and InRoads.

2. Load the appropriate InRoads data files. DTM the alg file are required. (The .alg file is required below to 
display the design components.)

3. From the InRoads main menu, select Surface > Copy Surface.

4. In the Copy Surface dialog box, verify that the existing ground surface is selected for the Name field in the 
From area.

5. In the Name field of the To area, key in the desired name. Existing Ground Rendered is used in this 
example.

6. In the Description field, key in the desired description.

7. Using the drop down menu, select the desired Preference for the surface. 

Note: Be sure to make the name and description for this copy unique and specific to its use so that it isn’t 
confused with the original existing ground surface when doing design work on the project.

8. <D> the Apply button. This writes the copy to memory and displays the surface in the InRoads Explorer.
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9. <D> Close to dismiss the Copy Surface dialog box.

Note: You can close the original existing ground file if desired, to avoid accidentally modifying the 
wrong surface.

 Clip Out the Area Of the Design Ground

Now that there is a working copy of the existing ground, it can be modified to exclude data within the limits of 
the design surface. The perimeter of the design surface is used to define the clipping area.

1. Set the Design Surface active. In this workflow Design_Model is used as the design surface.

2. From the InRoads Main menu, select Surface > View Surface > Perimeter. This displays the View 
Perimeter dialog box.

3. Verify that the Design Surface is selected as the Surface.

4. <D> the Apply button. This displays the perimeter in the dgn file.

5. <D> Close to dismiss the View Perimeter dialog box.
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Below is an illustration of the results.

Next, the design surface’s perimeter graphic is imported into the working existing ground dtm as an Interior 
breakline.

6. From the InRoads main menu, select File > Import > Surface. The Import Surface dialog box is 
displayed.

7. In the Import Surface dialog box, Set the Surface to the working existing ground dtm. (Existing Ground 
Rendered in this example)

8. Set Load From to Single Element.

9. Set Elevations to Use Element Elevations. 

10. In the Features area, key in a Seed Name. In this example Design Perimeter is used. Use a name that 
describes what the feature represents. This will make it easier to identify the feature if it needs to be 
modified in the future.

11. Set the Feature Style to DTM_Interior. This matches the Point Type for the line being imported.

12. Set the Point Type to Interior. The Interior point type excludes data from being triangulated within the 
boundary of the feature. This will prevent existing ground data from covering over design data in cut areas.
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13. <D> the Apply button then <D> on the design perimeter line. <D> again in a blank area of the view to 
accept the element.

14.  <D> Close to dismiss the Import Surface dialog box.

The working existing ground surface now has the cutout for the design surface. It needs to be retriangulated 
and have the triangles displayed.

15. Delete the perimeter that is currently displayed in the view. When the MicroStation Display Style is 
changed to show shading, the perimeter will be displayed filled, which can obstruct the view of the other 
design data.

Applying Materials to the Surfaces

Materials are associated to levels and closed element on that level will take on that material. The process for 
assigning materials is the same for the existing ground surface as it is for the design surface. In this example, 
the existing ground surface uses an aerial photo as its material. For the Design surface, each component type 
will be assigned a different material from the available material libraries.

Assigning Material to the Existing Ground

 

1. In the InRoads Explorer pane, select the Surfaces tab.
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2. <R> on the working existing ground dtm and select Triangulate from the right click menu. This updates 
the triangles of the surface to incorporate design perimeter.

3. From the InRoads main menu, select Surface > View Surface > Triangles. This displays the View 
Triangles dialog box.

4. In the View Triangles dialog box, set the Preference to Existing.

5. Select the working existing ground dtm for the Surface and <D> the Apply button.
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6. <D> Close to dismiss the View Triangles dialog box. Below is an illustration of the modified surface.

7. Follow the instructions in the CDOT Workflow Image Draping to apply the aerial photo to the existing 
ground surface. Other helpful workflows are: CDOT Workflow 5 - Raster Manager and CDOT Workflow 
13 - Using Georeferenced Images in Raster Manager.

http://www.coloradodot.info/business/designsupport/cadd/cadd-workflows/v8i-ss2/CDOT Workflow Raster Manager.pdf/view
http://www.coloradodot.info/business/designsupport/cadd/cadd-workflows/v8i-ss2/CDOT Workflow Raster Manager.pdf/view
http://www.coloradodot.info/business/designsupport/cadd/cadd-workflows/v8i-ss2/CDOT Workflow Using Georeferenced Images in Raster Manager.pdf/view
http://www.coloradodot.info/business/designsupport/cadd/cadd-workflows/v8i-ss2/CDOT Workflow Using Georeferenced Images in Raster Manager.pdf/view
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At the completion of the Image Draping workflow, the existing ground surface is shaded with the aerial photo. 
Notice that the area of the design surface is not shaded with the aerial photo.

Assigning Materials to the Design Surface

In this section the components of the design surface are displayed and given a material. Because of the way 
Roadway Designer creates side slopes, those will have to be created a separate surfaces.

Creating Side Slope Surfaces

Side slope surfaces can be created from the Top of Cut, Toe of FIll, and POSS features from the design model.

1. From the InRoads main menu, select Surface > View Surface > Features.

2. In the View Features dialog box, select the design surface from the Surface drop down menu.

3. In the Features list box, highlight all of the POSS and cut and fill features.
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4. <D> the Apply button to display the features.

5. <D> Close to dismiss the View Features dialog box.

6. Using the MicroStation Place Smartline command, connect the POSS line to the toe of slope line on each 
end.

Next, these features are chained together to create a Complex Shape.

7. Select Create Complex Shape from the MicroStation Task menu.

8. In the Create Complex Shape tool settings dialog box, set the Method to Automatic.
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9. <D> on one of the elements then <D> in a blank area to create the chain.

10. Repeat steps 6 through 9 for the other side slope. An example of the result is shown below.

Finally, Each shape will be imported into a new surface.

11. From the InRoads main menu, select File > Import > Surface. This displays the Import Surface dialog 
box.

12. In the Import Surface dialog box, key in the desired name in the Surface field. LT_Side is used in this 
example.

13. Set Load From to Single Element.

14. Set Elevations to Use Element Elevations.

15. In the Features area, key in the desired name in the Seed Name field. LT_Side is used in this example.

16. Set the desired Feature Style. D_Toe-of-Fill is used in this example.
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17. Set the Point Type to Exterior. This feature type will allow all of the data to be triangulated but prevent 
triangles from being formed outside the data area.

18. <D> the Apply button then <D> on the appropriate shape. This creates the surface and imports the shape 
as data.

19. Change the Surface name and Seed Name for the other side slope and import the other shape.

20. <D> Close to dismiss the Import Surface dialog box.

21. Delete the shapes that were just imported.

Displaying the Design Components and Surfaces

1. Display the triangles for the two new surfaces. Be sure to use a different preference (this example uses the 
Proposed preference) than that used to display the existing triangles. If they are displayed on the level with 
the existing ground triangles, they will be rendered with the aerial photo.

2. From the InRoads main menu, select Surface > View Surface > Components. This displays the 
View Surface Components dialog box.

3. Set the Surface to the desired design model. (Design Model is used in this example)

4. In the View Surface Components dialog box, select the desired design surface using the Surface drop 
down menu.

5. In the Component area, highlight the desired components. These should be the topmost pavement 
components, curb and gutter components, Z-Slope components, etc. In this example HMA_Lift 1, LT_Z-
Slope_12_6_to_1, and RT_Z-Slope_12_6_to_1 are used.
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6. <D> Apply. The components of the design surface are displayed in the hole in the existing ground.

7. <D> Close to dismiss the the View Surface Components dialog box. Below is an example of the 
displayed components.

8. From the MicroStation task menu, select the Visualization tab.
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9. <D> the Apply Material button. This will display the Assign Material dialog box.

10. In the Assign Material dialog box, <D> the Open Palette button and select the desired palette from the 
Open Palette dialog box. In this example, the concrete.pal is selected.

11. <D> OK to dismiss the Open Palette dialog box.

12. From the Material drop down menu, select the desired material. In this example Asphalt (Black) is used.

13. <D> the Assign by Level/Color button then <D> on the desired element. <D> in an open area to accept 
the assignment.In this example a surfacing component is selected.

14. Repeat steps 8 through 11 for the remaining components and the side slope surfaces.
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The illustration below shows the design surface rendered.

Adding Additional Details

3D Cells

There are a variety of cells that can be used to add interest to your rendering. MicroStation comes with a 3d 
landscape cell library (landscape3d.cel). This library has been copied to the following directory:

 C:\Workspace\Workspace-CDOT_V8i\Standards-Global\MicroStation\Cell 
When selecting a cell, check the preview to be sure that the cell is a full 3D cell. The illustration below shows 
and example of two cells from the landscape3d.cel library; the cell on the left is a full 3D cell, the one on the 
right is not.
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The origin of these cells is at the bottom center of the object. Therefore, they can be easily placed on the 
surface by tentative snapping to a triangle or component.

Another location for finding 3D cells to spruce up your rendering is the 3D Warehouse. To access the 3D 
Warehouse:

1. Open a blank drawing.

2. From the MicroStation main menu, select Utilities > 3D Warehouse > Import Model. This opens 
Internet Explorer to the Google 3D Warehouse web site.

3. In the search field, key in the item you are looking for. In this example, "light posts” was used.

4. When the desired item is found, <D> the Download Model link.

5. The item is added to the dgn as a new models or you can add additional models if desired. 

6. Close the Internet Explorer when you have finished downloading models.

Note: Some of these models may require additional work after they are downloaded. A common problem 
with these cells is that their origin is not at 0,0,0.

7. While in the new model, open the Model Properties dialog box.
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8. Toggle on Can be placed as a cell. <D> OK to accept the change and dismiss the Model Properties 
dialog box.

9. Open your rendering dgn file.

10. From the MicroStation menu, select Element > Cells. This displays the Cell Library dialog box.

11. In the Cell Library dialog box, select File > Attach File.

12. Navigate to the location of the 3D cell library created above highlight the filename and <D> Open. The 
cells are now ready for use.

13. To use a cell, highlight the cell name then <D> the Placement button in the Cell Library dialog box.

14. The Cell Library dialog box can be dismissed. Select the Place Cell command from the task menu and place 
the cell at the desired locations.

Using a Background Image

Adding a background image to your rendering can help bring the image to life. To add a background image:
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1. From the MicroStation main menu, select Settings > Design File. This displays the Design File Settings 
dialog box.

2. In the Category pane of the Design File Settings dialog box, <D> Views.

3. In the Modify View Settings area, toggle on Background.

4. Use the search icon   to locate and select the desired background image.

5. <D> the OK button to accept the changes. The background image is now displayed and the Design File 
Settings dialog box is dismissed.
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Below is an example of a rendering without the background on top and with the background on bottom.

Lighting Adjustments

Lighting is used to highlight your rendering and make it more visible. To adjust the lighting:

1. Select the Light Manager from the Visualization task tab. This displays the Light Manager dialog box.

There are three areas that are generally used to adjust the lighting for the rendering. These are Brightness, 
Ambient, and Solar.
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Brightness

This setting adjusts the overall lighting of the drawing.

1. Highlight Brightness in the Light Name list.

2. Use the slider in the Display Brightness area to modify this setting.

Ambient

The Ambient settings can be used to reduce on increase the harshness of shadows.

1. Highlight Ambient in the Light Name list.

2. In the Properties area toggle on the On check box.

3. Use the Lux slider to modify this setting.
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Solar

The Solar settings can also adjust the overall brightness of the rendering. It is also used to orient the sun in 
relation to the drawing. 

1. Highlight Solar in the Light Name list.

2. In the Properties area toggle on the On check box.

3. Use the Intensity slider to modify this setting. This adjusts the brightness of the rendering.

4. <D> on the Solar Position tab.

5. Use the Azimuth and Altitude dials to adjust the sun’s orientation.
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Below is an example of the finished rendering.



MicroStation Printing
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Workflow MP 1- MicroStation Printing

This document guides you through the basic functions of MicroStation printing. It is used for printing single 
sheets on a sheet by sheet basis. See workflow document CDOT Workflow Print Organizer for guidance on 
printing multiple sheets at one time.

There are two procedures that can be used to set printing properties. The first is using a Print Style (new in 
MicroStation V8i SS2) and the second is using a Print Driver (similar to past versions of MicroStation).

Note: Mixing the two printing procedures is known to create some inconsistencies. If you find that 
something does not look correct, it is best to cancel out of the Print dialog box and start over using 
only one of the  procedures.

Using Print Styles

A Print Style is a collection of frequently used print properties that have been saved for later use. Default 
CDOT Print Styles have been created for common settings and are included in the CDOT workspace. These 
Print Styles automatically set a Printer Driver, Pen Table, scale, page size of 11x17 landscape orientation, 
toggles on line styles and line weights, and sets the printer.

1. Print Style settings are accessed from the Print dialog box.

2.  From the Settings pull down menu, select Apply Print Style.

3. Nine Print Styles have been created. Two drivers have been created for default Adobe PDF file creation; 
one for draft quality and one for high quality outputs.
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4. Select a Print Style and <D> OK. This will automatically set the appropriate print settings.

5. <D> the printer icon or use File > Print to print the document.

6. If a Print Style was selected for a printer or plotter, the file will be sent to the device.

7. If a Print Style was selected for Adobe PDF creation, the user will be asked to name the file and save it. 
Navigate to the correct directory and enter a file name to save the file. Select Save.

Note: For tips on printing raster references (e.g. aerial photos), see the workflow Printing Raster 
Images.

Using Default Printer Driver Settings

Note: When using this method of printing, it is important to check the line weight setting under the print 
attributes to make sure it is toggled on before creating a plot.

1. In MicroStation V8i, place a fence to define the print area.

 

Note: As of this printing if you place the fence BEFORE activating the Print command, the line weight 
toggle will be turned off. This will be fixed in the next service pack (SS3) from Bentley due out in 
the fall of 2011.
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2. Set the Fence Type to Block. This Fence Type will work for both sheet borders placed as reference files 
and as cells.

3. Place the fence by snapping to the outer corners of the plot boundary. The shape defining the outer edge of 
the border (in this example) is called SHEET_Plot-Boundary.
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4. Open the Print dialog box by selecting File > Print.

5. Optionally, <D> the Printer icon an the Standard Tool Box.

6. The current Printer Driver will display in the title bar at the top of the Print dialog box.
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7. Make sure the Fence option is selected under General Settings.

8. The current Pen Table will display under the General Settings area of the dialog box.
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9. If these settings are correct (default printer using CDOT-PenTable.tbl), check to make sure pen weights 
have been toggled on under the Settings > Print Attributes pull down.

10. Once toggled on, <D> OK to close the Print Attributes dialog box.

11. <D> the printer icon or use File > Print to print the document to the default printer.

Changing the Default Printer Driver Settings

Seven default CDOT printer drivers have been created for common settings and are included in the CDOT 
workspace. Settings like Pen Table can be changed by the user. Follow the same steps in the above section 
Using Default Printer Driver Settings to start the printing workflow.
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1. The default printer driver sets the CDOT-DefaultPrinter_V8i printer driver. To change this, <D> the mag-
nify glass icon under the Printer and Page Size section in the print dialog box.

2. Select the appropriate Printer Driver (for example, CDOT-PDFHighQuality_V8i.pltcfg) and <D> Open.
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3. Check the Pen Table setting. If it needs to be changed (for example to the color pen table), select the 
PenTable pulldown and <D> Attach.

4. Select the appropriate pen table and <D> Open.
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5. Once the settings are correct, check to be sure pen weights have been toggled on under the Settings > Print 
Attributes pull down.

6. Once toggled on, <D> OK to close the Print Attributes dialog box.

7. <D> the printer icon or use File > Print to print the document to the default printer.
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Workflow MP 2 - Printer Driver Adjustments

This document guides you through the basic steps you will need to edit a CDOT Printer Driver.

The Print Driver configuration file format was changed with MicroStation XM and is now stored in XML 
format. Each of the new print driver configuration files now has an extension .pltcfg. Each default Print Driver 
configuration file has default settings that should not have to be edited. However, printers can vary in the 
naming convention for 11x17 inch sized paper and default plotters are usually not set as user default printers. If 
the default paper size does not set automatically, you can make the necessary adjustments. Also, if you have a 
default plotter, you can set the network path in the printer driver configuration path. The CDOT default printer 
driver configuration file is located under: C:\Workspace\Workspace-CDOT_V8i\Standards-
Global\MicroStation\Plotter Driver\.

1. The name of the file is CDOT_DefaultPrinter_V8i.pltcfg. Open the file from within MicroStation V8i 
using the Print Driver Configuration Editor. It can be invoked from the MicroStation Print dialog’s File/
Edit Printer Driver Configuration menu.
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2. Navigate to C:\Workspace\Workspace-CDOT_V8i\Standards-Global\MicroStation\Plotter Driver\ and 
open the printer driver.

3. You will see this display after the file is opened.
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Setting the Default Form Size

1. The line item highlighted in the above screen capture needs to be edited with the proper sheet size defini-
tion for the default printer. Check your printer preferences for the sheet size definition. Typically the sizes 
will be one of the three: 11x17, Tabloid or “11x17”.

2. Once the file has been edited, save a copy of CDOT-DefaultPrinter_V8i.pltcfg in your project’s Plot_Sets 
folder. If you save the changes back to the original file located at C:\Workspace\Workspace-
CDOT_V8i\Standards-Global\MicroStation\Plotter Driver\, the file will be overwritten the next time you 
log into your workstation.
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3. In the Print dialog box, <D> the Search icon next to the Bentley driver. Navigate to your project’s 
Plot_Sets directory and select the edited pltcfg file. This will now become the default settings until you 
select a different pltcfg file.

4. Once you have selected the correct pltcfg file, you will notice the Paper size is defaulting to the new 
settings and the print view is now correct.
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Setting the Default Plotter Path

The default path for a plotter or non default printer can be edited and set inside the Print Configuration file.

1. The name of the file that should be edited for a default plotter is CDOT_DefaultPlotter_V8i.pltcfg. Open 
the file from within MicroStation V8i using the Print Driver Configuration Editor. It can be invoked from 
the MicroStation Print dialog’s File > Edit Printer Driver Configuration menu.

2. Navigate to C:\Workspace\Workspace-CDOT_V8i\Standards-Global\MicroStation\Plotter Driver\ and 
open the printer driver.
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3. The line item in the above screen capture needs to be edited with the proper default plotter path. Typically 
the path will be: \\Server_Name\Plotter_Name.
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Workflow MP 3 - Print Organizer

This document guides you through the basic functions for using Print Organizer. Print Organizer is a new 
utility in MicroStation that replaces the Batch Print utility in MicroStation and MicroStation PDF 
composer. Any past Batch Print job set (.job) files can be opened and converted to the new format.

For more information on using Print Organizer for Batch Printing, watch the training video “Using Print 
Organizer for Batch Printing”. This can be accessed from within MicroStation by using the CDOT Help 
pull down menu and selecting Print Organizer.
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Basic Print Organizer Workflow

1. Select File > Print Organizer from the MicroStation pull down menu.

 

Note: You can be in any MicroStation file when you run Print Organizer.

2. The Print Organizer dialog box will display. The print set name is Untitled. When you save the print set 
with a project related name, the root folder in the left hand column will change along with the file name. 
The saved file will have an extension of PSET.
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3. Files can be added either by <D> the Add Files to Set icon, or by dragging and dropping files from 
Windows Explorer.

4. When the Add Files to Set icon method is used, the Create Print Definitions dialog will appear. Here 
you can add files and set a print style. Begin by <D> the Add button to add files.
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5. Navigate to your project directory and select the files you want to add to Print Organizer. <D> Done to 
add the files.

Note: You can hold down the Ctrl or Shift key to select multiple files.

6. Print Styles have been created to control print settings such as print area, paper size, workspace, color, rater 
quality, and fence area. <D> the Browse icon (magnify glass) to select the appropriate print style.
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7. The default print style names match the CDOT Print Driver naming conventions. For more on Print Styles, 
watch the “Using Print Styles” training video.

8. After selecting the appropriate print style, <D> OK in the Apply Print Style dialog box.

Note: Any additional files that are added in the future will take on the definitions of these first files 
unless you select otherwise.

9. Next <D> Manually Specified Options to bring up the Print Definition Creation Option dialog box. Here 
is where you define the printing area. 

10. When adding sheet files, there is a layer defined for the printing border called SHEET_Plot-Boundary. 
This can be used as the fence definition.
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11. From the Fence tab, there are two settings. First set the Create Print Definitions from Models to All 
models.

12. Next select Define from shape and enter the shape properties. For example SHEET_Plot-Boundary. <D> 
OK.

Note: When adding cross sections, toggle on Create one definition for each matching shape. This will 
create a seperate file for each cross section in the model.

13. <D> OK in the Print Definition Creation Option dialog box.

14. <D> OK in the Create Print Definitions box. This will add the file(s) to your print organizer.
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15. To view the print style assignments or override them, double click on the file name. This will open the 
Properties dialog box for that file.

16. Print definitions can be edited on more than one file at a time. If you select more than one file and then 
right click and select Properties, the Modify Properties dialog box becomes available.
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17. Changes can also be made to a single file by using in‐place print definition editing. This can be done by 
selecting the file you wish to edit in the right hand pane and double-clicking on the property in a specific 
column.

18. Once all the settings have been assigned, select File > Save As.
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19. Navigate to the appropriate project folder and assign a new name to the file. <D> Save when complete.

Printing From Print Organizer

The files in the Print Organizer file will be printed in the order the sheets appear in the display. If they are 
displayed in the incorrect order this will have to be changed. 

1. Select the sheets to change. Using the Move buttons, move the selected sheets to the desired location.

2. Be sure to save the changes.
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3. Once all settings have been completed, select File > Print or <D> the printer icon to print the files.

4. The print dialog box will appear.

5. The entire plot set can be printed or individual files. Select All or Selection for the print range.
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6. Printer Driver settings can be changed at this time if needed. Select the Printer Setup to select a different 
printer driver.

7. Finally, if you are creating an Adobe PDF file using a PDF driver, select the location where the file will be 
saved by <D> the Browse button

8.  Navigate to the appropriate project folder. Enter a file name and <D> Save.
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9. <D> Ok to activate the Print command.

Print Preview Files

1. Select the Print Preview icon to review files
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2. If more than one sheet has been selected, use the navigation buttons to page through the sheets.
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Workflow MP 4 - Printing Raster Images

This document guides you through the display settings of raster images and modifying text for better clarity.

Adjusting Raster Display Settings

1. Contrast and Brightness controls are used to adjust the display characteristics of raster images. Select Tools 
> Raster > Raster Display > Open as ToolBox.

2. The Raster toolbox will appear. <D> the Contrast/Brightness icon.

3. If more than one raster image is displayed in the drawing, the image you want to adjust may not be active. 
To select a different image, <R> then select the desired image (<D>) from the view.

4. Determine how you want to adjust the selected raster image. To make an image appear lighter, move the 
Brightness slider to the right or key in a positive value. To increase the contrast of the image (setting apart 
the display of different entities within the raster file), move the Contrast slider to the right or key in a 
positive value. Using a negative value for contrast will result in a darkened image.

5. Continue adjusting Brightness and Contrast until the desired result is achieved then dismiss the setting 
dialog.
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Using a Text Style with a Background

If a raster image is dominated by dark colors, it may be necessary to use a text style with a background. 

Placing Text with a Background

The only change required for placing text with a background is to select one of the “Filled” Text Styles. 

1. Select the Place Text icon from the Main toolbar.



Colorado Department of Transportation   PRI- 3

CDOT  Workflows  Printing Raster Images

2. In the Place Text settings dialog box, use the Text Style pull down menu and select the desired “Filled” 
Text Style.

3. In the Text Editor, key in the desired text and place as normal. The result will look like the example below:

Note: The color of the text in this example has been changed for clarity. 
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Modifying InRoads Text to Have a Background

1. InRoads does not use Text Styles or Annotation Scale. Therefore, text displayed by this program will have 
to be modified to display a background. 

2. Turn off the Graphic Group Lock. All Cardinal Point text and all P.I. text are contained in graphic groups. 
Turning off the Graphic Group lock will allow the justification to be set for each piece of text as needed.

3. Select Change Text Attributes from the Main toolbar.
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4. In the Change Text Attributes dialog box, set the Text Style. Use.10” ENG-100 Filled for Major 
Stations and.07” ENG—100 Filled for PC, PT, and PI stationing Points. Also, set the desired 
Justification.

Note: Note: the following justifications are used by InRoads:
Major Stations - Left Center
P.I. Left of Centerline - Right Center
P.I. Right of Centerline - Left Center
Cardinal Left of Centerline - Right Bottom
Cardinal Right of Centerline - Left Bottom

5. Select the desired text from the MicroStation view. Text may be selected individually or use the 
MicroStation element selection tools to select multiple text entities. Use the element selection tools to 
select a large number of elements that have the same Text Style and Justification (like Major Stations, for 
example). For Cardinal Points and P.I. stations, selecting them individually may be a better option as their 
justification is dependent on the direction of the curve.
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Note: The text will change to a very small size. Do not worry about that for now. An Annotation Scale 
will be added to all of the text that was modified at one time. This will restore the text to its proper 
size. As shown below, the text size in the image on the left is correct, but the text styles are wrong. 
The text in the image on the right has the correct text style applied, but no adjustment to the text 
size has been made.

6. Repeat steps 10 and 11 for all of the text placed by InRoads.

7. Highlight all of the InRoads placed text that has been changed to a “Filled” text style.

8. If no text is highlighted when the “annotationscale add” keyin is run, then the annotation scale is applied 
to all text. This will enlarge InRoads geometry symbols (which come from symbol fonts) by the annotation 
scale factor.

9. In the Key-in window, type “annotationscale add” and <D> the Run Key-in icon or press the Enter key. 
This will restore the text to its proper size.
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10. Below is an example of InRoads text with a filled background and correct annotation scale.
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Workflow MP 5 - Shaded Color and Grayscale 
Printing

This document guides you through the set-up and printing process for shaded and grayscale Sheet 
Files. This workflow may be used any time the user wants to highlight specific areas for things such 
as phasing plans, public meetings, ROW exhibits, etc. Please note that the use of raster images (jpg, 
bmp, tif, etc.) will dramatically increase the processing time during printing

Reference File Management

Adjustments must be made to some of the reference file settings in order to achieve the desired print quality. 
The settings that may need changing are the Slot Numbers and Update Sequence. Slot Numbers are unique 
identifiers assigned to reference files and can be called out individually or in groups within a pen table for 
special processing during printing. Update Sequence determines the order in which files are refreshed on the 
screen and printed on paper. 

Reference File Slot Number Categories:

0= Sheet File (black) - this is the active dgn file

1-99 = Proposed Primary Discipline (Black)

100-199= Existing Topo (light gray)

200-299= Proposed Other Discipline (dark gray)

300-399= Color Shaded Areas 

Note: All data placed in the Sheet File will be printed black. Items to be printed in color should be 
contained in their own file. Create a new file using the standard CDOT seed file and reference 
design elements to create color areas. If printing to a black and white printer all colors will be 
printed grayscale. Files can still be printed using the default printer drivers and pen tables, 
however shaded areas will lose their transparency and may print black depending on their 
level.
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Assigning Slot Numbers

1. Open the Reference Files dialog by selecting File > Reference or <D> the Reference icon on the Primary 
toolbar.

2. Highlight the desired reference file that you want to apply shaded color, grayscale or a combination of both 
to for printing purposes.

 

3. Once a reference file is highlighted, <D> in the Slot Number field. 
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4. Key-in the desired number and press the Enter key. Refer to the Reference File Slot Number Categories 
on Page 1. In this example, 200 is entered, which will result in reference file information be plotted Dark 
Gray, indicating Other Discipline. The reference files will be re-ordered in the window based on their slot 
numbers after you have updated the Slot Numbers for all reference files.

5. Repeat this process for each of the reference file attached. The illustration below shows a group of files 
with updated slot numbers.

Note: Reference files whose slot numbers are not changed will print black because they will be in the 1-
99 range.
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Re-Ordering Sequence

1. Select Settings > Update Sequence. This displays the Update Sequence dialog box.

2. If a reference file in the list contains shaded areas, move it directly below Raster References. If there 
are no raster references, move it to the top.

3. Move the Active Design File to the bottom of the list. When updating the sequence of reference files, 
highlight the desired file then <D> the Move Up or Move Down icon until it is in its desired location. 
The Move Up icon is outlined below.

4. Any file containing Area Patterns should be moved under the files containing shaded areas. Highlight the 
desired file then <D> the Move Up icon until it is in its desired location. <D> OK to proceed with 
plotting.

Note: If area patterns are to be printed in color they should reside in the file containing shaded areas to be 
printed in color, or in their own file.
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5. Select File > Save Settings from the MicroStation main menu after reordering slot numbers so these 
changes will remain each time this file is plotted.

Selecting the Pen Table

1. Select PenTable > Attach from the Print dialog pull-down menu.
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2. From the Select Pen Table File dialog, select the CDOT‐Shading_GrayscalePenTable.tbl then <D> OK.

3. Select File > Save Settings from the MicroStation main menu before exiting the file.

4. The remainder of the printing process does not change. For additional information refer to the workflow 
document CDOT Workflow MicroStation Printing.

Creating A PDF File

To create a PDF file of the shaded print follow the steps above, then continue by completing the steps below.
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1. <D> the Select Print Driver icon from the Print dialog.

2. From the Select Printer Driver File dialog, select the correct Printer Driver file. <D> OK to accept the 
change and dismiss the window.

3. <D> the Print icon in the Print dialog box. The Save Print As dialog box will be displayed.

4. Set the desired directory path for the file in the Directories area.

5. Key in the desired name for your file in the Files filed and <D> Save.

Note: A default name (the DGN file name with the pdf extension) is supplied by the computer.
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6. <D> OK to accept the changes and create the PDF file.
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Workflow MP 6 - Printing AutoCAD Files in 
MicroStation

This document guides you through printing AutoCAD files in MicroStation. 

Workflow Outline

Open an AutoCAD File in MicroStation - To ensure that the printed AutoCAD file matches printed 
MicroStation files, the AutoCAD file is printed from MicroStation.

♦ Commands Used: File > Open - Used to access the MicroStation Manager dialog box. From there, 
the AutoCAD file is opened.

♦ DWG/DXF Units - This sets the units for the AutoCAD file to match MicroStation units.

Print the File - There are two items that need to be set before sending the file to the printer; the printer driver 
and the pen table.

♦ Commands Used: Print - Used to access the Print dialog box.

♦ Printer Driver - Used to select the proper driver for the desired print type.

♦ Pen Table > Attach - Used to attach the CDOT_ACAD.tbl pen table.

♦ Send Print - Used to submit the file to the drawing to the printer (or file for a pdf).

Opening an AutoCAD file in MicroStation

1. From the Open dialog, select an AutoCAD (*.dwg) drawing file. Change Files of Type to Autodesk(R) 
DWG Files (*.dwg) to view all the AutoCAD files residing in the specified directory. Select a file and 
<D> Open. 
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2. The DWG/DXF Units dialog box will appear. Verify the Units are set to Survey Feet and <D> OK. 

Note: If the AutoCAD drawing file contains the WWWW PICS linestyle then change these elements and 
place them on the standard CDOT MicroStation Level called ROW_MONUMENT_City-Limit-
Line-Text and update to use bylevel symbology. 

3. Select File > Print to open the Print dialog box.
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4. Optionally, <D> the printer icon on the Standard Tool Bar.

5. The current Printer Driver will display in the title bar at the top of the Print dialog box and the current Pen 
Table is displayed under the General Settings area. 

Note: If you are printing Sheet Layouts, Print Scale and Size settings will update automatically. If you 
are printing from a Model Layout set the scale as desired. For more information or additional 
printing questions, see the workflow document CDOT Workflow MicroStation Printing. 

6. The default Printer Driver is CDOT-DefaultPrinter_V8i.pltcfg and the default Pen Table is CDOT-
PenTable.tbl. To change the Printer Driver, <D> the magnifying glass located under Printer and Paper 
Size. 

7. Seven printer drivers are available in the... \Microstation\Plotter Driver directory.

 CDOT-DefaultPrinter_V8i.pltcfg should be used to send plots to the default printer.
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 CDOT-DefaultPlotter_V8i.pltcfg should be used to send plots to the default plotter.

 CDOT-PDFDraftQuality_V8i.pltcfg should be used for the creation of draft quality (300psi) Adobe PDF 
files.

 CDOT-DPDFHighQuality_V8i.pltcfg should be used for the creation of high quality (600psi) Adobe PDF 
files.

 CDOT-Shaded_PrinterDriver_V8i.pltcfg should be used for MicroStation drawings only.

 CDOT-ROW-DefaultPlotter_V8i.pltcfg should be used to send ROW plots to the default plotter.

 CDOT-ROW-DefaultPrinter_V8i.pltcfg should be used to send ROW plots to the default printer.

8. For printing AutoCAD files, change the Pen Table. Select PenTable > Attach from the pull-down menu. 
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9. Select the CDOT_ACAD.tbl Pen Table. The other options are for printing MicroStation Files only. <D> 
Open. 

Note: The CDOT-ACAD.tbl includes the standard colors and pen weights represented in the CDOT 
Design Manual - Volume IV, Section 6.2.8. If the standard colors were not used, the printout will 
contain actual colors or a grey scale representation of that color. To get a correct print out, the user 
must update the file to match the CDOT Design Manual.

10. Once everything has been set, <D> the print  icon. This will send your plot to the designated printer.
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11. If you selected the CDOT_PDFDraftQuality_V8i.pltcfg or CDOT_PDFHighQuality_V8i.pltcfg printer 
driver to create an Adobe PDF file, you will be prompted to define a file name and a location to save the 
PDF file.



MicroStation Information and Administration
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Workflow MA 1 - Directory Structure

PROJECT DESIGN FILES

The CDOT workflow of projects requires that graphic and design data be created into multiple design files 
during the course of project development. These design files need standard, informative, and unique file 
names.

File Naming Conventions

The CDOT naming standard uses a formula that restricts the character placement, ensures unique file names, 
and identifies the information contained in the file. All CDOT projects must follow these file naming 
conventions. Standardizing file names is necessary for effective management of the large numbers of files 
needed to produce a set of design plans.

CDOT files are named in a standard format that identifies the file’s project, the data contained within it, and the 
product used for its creation. The naming convention is illustrated as follows:

♦ Job Project Code (JPC) is the CDOT project code, formerly known as the project subaccount 
number.

♦ Specialty Group is the standardized abbreviation for the specialty group that the owner of the file is 
with. 

♦ Standardized Name denotes the type of data that is contained in the file.

♦ Annotation Scale including the annotation scale in the file name is optional. However, it should be 
included in file names for projects that use multiple annotation scales.

♦ Description A brief description can be used to further identify a model file. For sheet files, this field is 
used as a counter to differentiate between multiple files of a specific type.

♦ File Extensions define the product used for its creation. Examples would be dgn for MicroStation, 
DTM for an InRoads surface, etc.

An example of a MicroStation design file would look like the following.

12345DES_Model100US285.dgn
12345 indicating the CDOT Project Number, DES indicates it is Roadway Design’s model file and 100 
indicating it uses a 1”=100’ annotation scale, US285 is a description identifying the highway this model 
depicts. DGN is the default extension for MicroStation design files.



DS- 2 Colorado Department of Transportation

 Directory Structure CDOT  Workflows

Note: A seventh segment is used on Working Files. This segment should be the initials of the designer or 
engineer who is working on the file. For example, CU12345DES_Model100.dgn where CU, are the 
initials of the designer or engineer (in this example, CU stands for “CDOT User”). 

DIRECTORY STRUCTURE

Project files follow a standardized scheme. This section describes the location of project files and the standard 
directory structure for each group within CDOT.

Project Directory

At the beginning of each project, the Project Manager will create a project directory structure using the 
CreatePrjDir.exe. This executable will create a directory that is the single storage location for all information 
pertaining to a given project. The Project Manager is required to assign access permissions to every person on 
the design team and is also responsible for maintaining the access list to keep it current.

Top Level Directory

Each project includes a unique top-level directory and a set of standardized sub-directories. The job project 
code (JPC) indicates the top-level directory name.

Group Sub-Directories

Below the top-level directory, you will find sub-directories for each group. Each group at CDOT which 
works on the project is required to store its data in the appropriate sub-directory for that group.

Group Sub-Directory Structure

The following tables show the project directories for each group and the file types that go into these 
directories.

Bridge Project Folder (\Bridge)

Sub-directories Description    

\Calculations
\Construction_Engineering

\Computer_Files

\Hand_Calcs

\Submittals

\FIR_Design

\Computer_Files

\Hand_Calcs

\FOR_Design

\Computer_Files

\Hand_Calcs

\Correspondence
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\Email

‘ \Memos

\Drawings Sheet Files - Plan set sheets and detail sheets

\Reference_Files

All final Model files to be referenced to the sheets

JPC#BRDG_Model.dgn

JPC#BRDG_Prof.dgn

\Tabs
\Geometry Bridge Geometry Files and output

########.dat Structure Number and File Extension

########.cmd

########.dxf

########.lis

########.pcf

########.scr

########.dgn

\InRoads All InRoads data: dtm, alg, tml, rwl, rwk and reports.

\Photos Electronic photo files or scanned photos concerning the project and 

surroundings

\Reports
\Schedules
\Working Design iterations and miscellaneous drafting without impacting final  

Model Files found in the Reference_Files subdirectory. The designers’ 
initials should pre-fix all files in this directory so multiple designers can 
work in this directory. No working files should be used as Reference 
Models. When a working design is complete, copy it into the 
Reference_Files Folder and rename it to the standard naming convention. 
This directory will be deleted at project close-out.

Construction Project Folder (\Construction)

Sub-directories Description    
\Construction
\Calculations
\Change_Orders
\Claims
\Correspondence
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\Diaries
\Drawings Sheet Files - Plan set sheets and detail sheets

\Cross_Sections All cross section Models and Cross Section *.job files

\Reference_Files All final Model files to be referenced to the sheets

\Tabs
\EEO
\Estimates
\Final_Documentation
\Photos Electronic photo files or scanned photos concerning the project and 

surroundings

\Public_Relations
\Speed_Memos
\Working Design iterations and miscellaneous drafting without impacting final 

Model Files found in the Reference_Files subdirectory. The designers’ 
initials should pre-fix all files in this directory so multiple designers can 
work in this directory. No working files should be used as Reference 
Models. When a working design is complete, copy it into the 
Reference_Files Folder and rename it to the standard naming convention. 
This directory will be deleted at project close-out.

Consultants Project Folder (\Consultants)

The Consultant Project Folder does not contain any folders or files. This will be the location of the CDOT 
approved directory structure delivered from the consultant. The project manager is responsible for ensuring the 
folder and file structure conforms to the CDOT standard directory structure.       

Roadway Design Project Folder (\Design)

Sub-directories Description    
\Calculations
\Correspondence
\Drawings Sheet Files – Plan set sheets and detail sheets

JPC#DES_EarthworkQuant##.dgn

JPC#DES_GenlNote.dgn

JPC#DES_Plan##.dgn

JPC#DES_PnP##.dgn

JPC#DES_Prof##.dgn

JPC#DES_SAQ##.dgn

JPC#DES_StdPlanList.dgn

JPC#DES_SWMP.dgn
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JPC#DES_TabConc##.dgn

JPC#DES_TabMisc##.dgn

JPC#DES_TabRem##.dgn

JPC#DES_TitleSht.dgn

JPC#DES_TyplSect##.dgn

JPC#SURV_Tab##.dgn

JPC#SURV_WUTab.dgn

M&S Standard Plans List Index.dgn

\Cross_Sections All cross section Models and Cross Section *.job files

\Reference_Files All final Model files to be referenced to the sheets

JPC#DES_Interchange.dgnJPC#DES_Intersec.dgn

JPC#DES_Model.dgn

JPC#DES_Phasing.dgn

JPC#DES_Prof.dgn

\Tabs All tabulation support data: xls, doc, and pdf files

JPC#DES_GenNote.doc

JPC#DES_SWMP.doc

JPC#DES_TabEarthwork.xls

JPC#DES_TabMisc.xls

JPC#DES_TitleSht.xls

\InRoads All InRoads data: dtm, alg, tml, rwl, rwk and reports

\Photos Electronic photo files or scanned photos concerning the project and 
surroundings

\Reports
 \Working Design iterations and miscellaneous drafting without impacting final 

Model Files found in the Reference_Files subdirectory. The designers’ 
initials should pre-fix all files in this directory so multiple designers can 
work in this directory. No working files should be used as Reference 
Models. When a working design is complete, copy it into the 
Reference_Files Folder and rename it to the standard naming convention. 
This directory will be deleted at project close-out.

Hydraulics Project Folder (\Hydraulics)

Sub-directories Description    
\Calculations

\Cost_Estimates

\Hydrology_Ponds
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\Spread_Width_Inlets

\Storm_Sewer_Culverts_Channels

\Correspondence
\Email

\Meeting_Minutes

\Memos

\Drawings Sheet Files – Plan set sheets and detail sheets

JPC#HYDR_StrQuant##.dgn

\Reference_Files      All final Model files to be referenced to the sheets

JPC#HYDR_Model.dgn

JPC#HYDR_Prof.dgn

\Tabs
JPC#HYDR_TabStrmsewer.xls

\InRoads All InRoads data: dtm, alg, tml, rwl, rwk and reports

\Manufacturers_Data
\Photos Electronic photo files or scanned photos concerning the project and 

surroundings

\Program_Data
\HEC-2

\HEC-RAS

\Report
\Field_Notes

\Final

\Preliminary

\Technical_Memorandum

\Working Design iterations and miscellaneous drafting without impacting final 
Model Files found in the Reference_Files subdirectory. The designers’ 
initials should pre-fix all files in this directory so multiple designers can 
work in this directory. No working files should be used as Reference 
Models. When a working design is complete, copy it into the 
Reference_Files Folder and rename it to the standard naming convention. 
This directory will be deleted at project close-out.

Landscape Project Folder (\Landscape_Environmental)

Sub-directories Description    
\Calculations

\Correspondence
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\Drawings Sheet Files – Plan set sheets and detail sheets

\Reference_Files All final Model files to be referenced to the sheets

JPC#LAND_ENVI_Model.dgn

\Tabs \Form_128

\InRoads All InRoads data: dtm, alg, tml, rwl, rwk and reports

\Natural_Resouces
\4(f)_6(f)

\Air_Noise_Farmland

\Cultural

\Hazmat

\T&E

\Wetlands_Delineation_Findings

\Permits
\Photos Electronic photo files or scanned photos concerning the project and 

surroundings

\Public Involvement
\Reports
\NEPA
\Technical
\Social_Resources
\Working Design iterations and miscellaneous drafting without impacting final 

Model Files found in the Reference_Files subdirectory. The designers’ 
initials should pre-fix all files in this directory so multiple designers can 
work in this directory. No working files should be used as Reference 
Models. When a working design is complete, copy it into the 
Reference_Files Folder and rename it to the standard naming convention. 
This directory will be deleted at project close-out.

Materials Project Folder (\Materials_Geotechnical)

Sub-directories Description    
\Calculations
\Correspondence
\Drawings Sheet Files - Plan set sheets and detail sheets

\Reference_Files All final Model files to be referenced to the sheets

\Tabs
\InRoads All InRoads data: dtm, alg, tml, rwl, rwk and reports
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\Photos Electronic photo files or scanned photos concerning the project and 
surroundings

\As-Built
\Construction
\Existing_Condition
\Reports
\Working Design iterations and miscellaneous drafting without impacting final 

Model Files found in the Reference_Files subdirectory. The designers’ 
initials should pre-fix all files in this directory so multiple designers can 
work in this directory. No working files should be used as Reference 
Models. When a working design is complete, copy it into the 
Reference_Files Folder and rename it to the standard naming convention. 
This directory will be deleted at project close-out.

Miscellaneous Project Folder (\Miscellaneous)   

Typical Section Program Data input files, JPC#.csv (used for converting nonstandard levels to CDOT 
standards.), and other project specific files that do not have a designated folder.

Planning Project Folder (\Planning)

Sub-directories Description    

\Correspondence
\RTP_TIP_STIP
 \Working Design iterations and miscellaneous drafting without impacting final 

Model Files found in the Reference_Files subdirectory. The designers’ 
initials should pre-fix all files in this directory so multiple designers can 
work in this directory. No working files should be used as Reference 
Models. When a working design is complete, copy it into the 
Reference_Files Folder and rename it to the standard naming convention. 
This directory will be deleted at project close-out.

Plot Sets Project Folder (\Plot_Sets)

The files located in this folder are project specific General Plan Set Sheets. The files located in the subfolders 
will be files reflecting plan set sheets captured at time of submittal. Final Plan Sets should be in Adobe Acrobat 
PDF file format for the Reproduction Department. The Reproduction Department will access the PDF from 
this location for submittals.

Sub-directories Description    
\Plot_Sets
\AD Advertisement

\Revisions

\FIR Field Inspections

\FOR Final Office Revisions
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\ROWPR

Project Specific Configuration (\Project_Configuration) 

This folder contains copies of the CDOT Workspace InRoads Preference files only when a project is archived 
and will be brought back at a later date.  Software changes and Configuration upgrades affect InRoads 
preference files. It is important to have copies of the preference files used when the project was created. The 
files will be useful for reviewing how InRoads Features, Styles and Survey Data displayed for the duration of a 
specific configuration release. However, software and configuration upgrades may not work seamlessly with 
these preference files because levels and features are renamed and linestyles are redefined.  

The following files should be saved in this folder: 

 C:\Program Files\Workspace-CDOT\Standards-Global\InRoads\Preferences\CDOT-Preferences.ini

 C:\Program Files\Workspace-CDOT\Standards-Global\InRoads\Preferences\CDOT-Styles.ini

 C:\Program Files\Workspace-CDOT\Standards-Global\InRoads\Preferences\CDOT-Survey_Features.fwf

 C:\Program Files\Workspace-CDOT\Standards-Global\InRoads\Preferences\CDOT-
Survey_Preferences.fxp

 C:\Program Files\Workspace-CDOT\Standards-Global\InRoads\Notes\CDOT-Notes.dft.

All other InRoads data files should be stored in the appropriate Project InRoads folders.

Project Manager Project Folder (\Project_Manager)

Sub-directories Description    

\Budget
\Clearances
\Contract_&_Task_Order
\Correspondence
\Bridge
\Construction
\Design
\EEO
\Environmental_Landscape
\Governmental_Agencies
\Hydraulics
\Letters
\Materials_Geotechnical
\Public_Relations



DS- 10 Colorado Department of Transportation

 Directory Structure CDOT  Workflows

\ROW
\Senior_Management
\Traffic
\Utilities
\Meeting_Minutes
\Schedules

Redline Project Directory (\Redline)

Right Of Way and Survey Project Folder (\ROW_Survey)

Sub-directories Description    
\Correspondence
\Acquisition
\Appraisal
\Permission_To_Enter
\Property_Management
\ROW
\Survey
\Drawings Sheet Files - Plan set sheets and detail sheets

JPC#ROW_Cnty-24x18_##.dgn

JPC#ROW_Cnty-24x36_##.dgn

JPC#ROW_Mon##.dgn

JPC#ROW_Ownership##.dgn

JPC#ROW_Plan##.dgn

JPC#ROW_TabProp01.dgn

JPC#ROW_TabProp02.dgn

JPC#ROW_TabProp03.dgn

JPC#ROW_TabProp04.dgn

JPC#ROW_TabProp##.dgn

JPC#ROW_TitleSht.dgn

JPC#ROW_MonRcrd##.dgn

JPC#SURV_PlanLSCD##.dgn

JPC#SURV_PlanPCD##.dgn

JPC#SURV_TitleLSCD.dgn

JPC#SURV_TitlePCD.dgn
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\Reference_Files All final Model files to be referenced to the sheets

JPC#ROW_Model.dgn

JPC#SURV_Model.dgn

JPC#SURV_Topo##Scale##.dgn

JPC#SURV_TopoCodes##Scale##.dgn

JPC#SURV_TopoContour##Scale##.dgn

JPC#SURV_TopoElevations##Scale##.dgn

JPC#SURV_TopoNames##Scale##.dgn

JPC#SURV_TopoNotes##Scale##.dgn

JPC#SURV_TopoSymbols##Scale##.dgn

\Tabs

JPC#ROW_TabMon.xls

JPC#ROW_TabProp.xls

\InRoads All InRoads data: dtm, alg, tml, rwl, rwk and reports

\DTM DTM files

\Field_Books Field Books

\Geometry Geometry Files

\Legals
\Reports ROW Report Files

\Research
\Government
\Miscellaneous
\Plans
\Title
\Survey
\Level
\Monument_Information
\Photogrammetry
\Photos Electronic photo files or scanned photos concerning the project and 

surroundings

\Raw_Data  
\TGO Trimble Geomatics files in a zipped format.
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\Working Design iterations and miscellaneous drafting without impacting final 
Model Files found in the Reference_Files subdirectory. The designers’ 
initials should pre-fix all files in this directory so multiple designers can 
work in this directory. No working files should be used as Reference 
Models. When a working design is complete, copy it into the 
Reference_Files Folder and rename it to the standard naming convention. 
This directory will be deleted at project close-out.

Specifications Project Folder (\Specifications)

Project Specifications (DOCand PDF formats only). Post the Project Specifications for the Reproduction 
Department in one Adobe Acrobat PDF file. The Reproduction Department will access the PDF file from this 
location.

Traffic Project Folder (\Traffic_ITS)

Sub-directories Description    
\Calculations
\Traffic_Modeling
\Correspondence
\Access
\Email
\Drawings Sheet Files – Plan set sheets and detail sheets

JPC#TRAF_Schedule##.dgn 

JPC#TRAF_TabPvmtMrk##.dgn

JPC#TRAF_TabSigns##.dgn

\Reference_Files All final Model files to be referenced to the sheets

JPC#TRAF_Light.dgn

JPC#TRAF_Model.dgn

JPC#TRAF_Signal.dgn

\Tabs All tabulation support data: xls, doc, and pdf files

JPC#TRAF_Tabs.xls 

\InRoads All InRoads data: dtm, alg, tml, rwl, rwk and reports

\Photos Electronic photo files or scanned photos concerning the project and 
surroundings

\Reports
\Signs SignCAD drawing files & other Misc. sign files
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\Working Design iterations and miscellaneous drafting without impacting final 
Model Files found in the Reference_Files subdirectory. The designers’ 
initials should pre-fix all files in this directory so multiple designers can 
work in this directory. No working files should be used as Reference 
Models. When a working design is complete, copy it into the 
Reference_Files Folder and rename it to the standard naming convention. 
This directory will be deleted at project close-out.

Utilities Project Folder (\Utilities)

Sub-directories Description    
\Calculations
\Correspondence
\Drawings Sheet Files – Plan set sheets and detail sheets

\Reference_Files All final Model files to be referenced to the sheets

JPC#UTIL_Model.dgn

\Tabs
\InRoads All InRoads data: dtm, tml, rwl, rwk and reports

\Photos Electronic photo files or scanned photos concerning the project and 
surroundings

\Reports
 \Working Design iterations and miscellaneous drafting without impacting final 

Model Files found in the Reference_Files subdirectory. The designers’ 
initials should pre-fix all files in this directory so multiple designers can 
work in this directory. No working files should be used as Reference 
Models. When a working design is complete, copy it into the 
Reference_Files Folder and rename it to the standard naming convention. 
This directory will be deleted at project close-out.
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This document explains how the Project Configuration File (PCF) is created, where it is saved, and how to 
update it. The PCF file defines a specific directory that MicroStation defaults to when opening up a DGN file 
or referencing model files. PCF files are extremely useful when multiple users are accessing the same project 
directory across the network, or when DGN files are moved from one directory to another.

ProjectWise and PCF’s

Projects that reside in ProjectWise do not require a MicroStation PCF file. The ProjectWise engineering 
document management system replaces the functionality of the MicroStation PCF files.

Creating the PCF File

For all projects outside of ProjectWise the following steps are required.

1. The PCF file is created when the CDOT Project Creation Utility program is run. This program is accessed 
from the CDOT Workspace C:\Workspace‐CDOT_V8i\Standards‐Global\MicroStation\exes.

2. If you typically create projects, adding this as a shortcut on your desktop is recommended.

3. Right click on the ProjectCreationUtility.exe and select Send To > Desktop (create shortcut).
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4. After selecting the ProjectCreationUtility program, the CDOT Project Creation Utility dialog box will 
appear. The Project Template Browse button can be used to identify a different Project Template. The 
Destination Browse button can be used to specify a different location for the new project directory. 

5. Enter the 5 digit Job Project Code (JPC) in the Job Project Code (JPC) field. For this example we will use 
99999. Verify the Create Project Configuration File check box is checked On. This should be on by 
default. <D> Apply. After the program has executed, <D> Close. 

Note: The CDOT Project Creation Utility program now allows the creation of “M” projects. Use an M to 
start the JPC number.

6. Open up Windows Explorer again and browse to C:\Projects\99999 to verify the project folder and 
corresponding folder structure was created. 

Opening the PCF File

1. View the PCF file that was created when the CDOT Project Creation Utility program was executed. In 
Windows Explorer browse to C:\Workspace\Workspace‐CDOT_V8i\Standards‐Local\Projects and open 
the 99999.pcf file using Notepad. 
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2. Notice that the second line of text displays MS_DEF=C:/Projects/99999/. The CDOT Project Creation 
Utility program places the newly created project location on this line. MicroStation reads this line as a 
configuration variable and sets the primary Search Path to this location. When MicroStation reads the 
variable ‘MS_DEF’ it substitutes the default project location (C:/Projects/99999/). If we look under the 
Reference Files heading below, you will see that all of the paths are set with the (MS_DEF) substitution. 
This means, whenever you browse for a file to reference (or more specifically a ‘model’ file), MicroStation 
will automatically point to the desired directory.

Editing the PCF File

1. If multiple users are accessing the same project directory, the PCF file will need to be distributed to 
everyone on the team accessing the project directory. Each member of the team should have their own 
copy of the PCF file and it should be saved to the same location, C:\Program Files\Workspace-
CDOT\Standards-Local\Projects. 

2. When team members are sharing the project manager’s machine, the path MS_DEF=C:/Projects/99999/ 
will need to be updated to reflect the path of the computer that is being shared i.e., MS_DEF=//CDOTUSER/
Projects/99999/ (Be sure to note the double // as in MS_DEF=//SMITHS/Projects/99999/. After the 
edit has been made to the PCF file, select File > Save in Notepad.   
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Note: Each person wanting to work on the project must be given appropriate access to the folders they 
will be working with. The Project Manager should determine the level of access. Contact the help 
desk for additional assistance on sharing files and changing security settings. 

Using the PCF File with MicroStation

1. In the MicroStation Manager, the PCF file can be selected from the Project field drop-down list found in 
the Workspace portion of the MicroStation Manager.

2. If you are working on multiple projects, you will have more than one PCF file to choose from. You can 
easily switch between projects using this drop-down list. <D> the arrow to display the list, than choose the 
project to work on. 
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3. The file path in MicroStation will be redirected to the project folder after the desired project has been 
selected. All dialog boxes within MicroStation that require a path to be defined will default to the root 
directory chosen at the Workspace > Projects location. 

4. If your folder structure changes and/or files are moved to different locations than initially path to, you can 
update your reference file attachment location here without having to reattach the files in MicroStation. 
Simply edit the reference file paths in the PCF file and open MicroStation. You will notice that the files are 
now being found. 

Note: It should be noted that Save Full Path when referencing files within MicroStation should never 
be used if you want the PCF file changes to take affect.
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Workflow MA 3 - Level Update for V05.04.00

This document guides you through updating the MicroStation levels that were changed, deleted, and renamed 
from the Configuration Releases prior to V05.00.00. All drawing files created in prior Configuration Releases 
will need to be updated to the current CDOT standard levels. See CDOT Configuration Readme.pdf file 
located in the level library section.

Converting Levels in MicroStation as a Batch Routine

1. From the MicroStation Manager, Open a drawing file

2. It is recommended that a new project folder is created for the translated data to insure the original project 
data is not lost. Using the same JPC# number appended with a “–(initials)”. Once the data is verified the 
original data can be backed up to disc and deleted. The “–(initials)” then can be dropped from the project 
folder. The example used for this workflow will be 12345‐NLJ.

3. It is recommended to change a User Preference before proceeding that sets the open dialog box settings. 
Open the User preferences by clicking Workspace > Preferences

4. Select the Look and Feel Category

5. Toggle off the option for Use Windows File Open Dialogs. Turn this feature off will allow a toggle later to 
open all files in a directory.

6. Select Utilities > Batch Converter
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7. Change the Default Destination to the temporary project folder

8. Navigate to the temporary project folder and <D> OK

9. <D> the Add Files or Directories to Convert icon.
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10. Using the Add Files or Directories dialog box, files or entire directories can be added to the list of Selected 
Files to be processed. Check On Include Subdirectories prior to specifying entire folders to a convert 
process. <D> to highlight the folder name, then <D> Add. <D> Done when you are finished adding files 
and/or folders.

11. Select Edit > V8 Save Options… from the Batch Convert dialog box
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12. In the Save As V8 Options dialog box, a standard CSV file is located in the configuration which is already 
set up to remap all of the previous versions’ levels to the standard CDOT MicroStation V05.00.00 levels.

Note: If not already there, browse to C:\Workspace\Workspace‐CDOT_V8i\Standards‐
Global\MicroStation\Tables\Level_Translation. Select the file V050000_Level_Update.csv. 
<D> OK.

13. In the Save As V8 Options dialog box, check on the option to Apply Level Mapping. <D> OK.

14. <D> the Process Batch Convert Job icon when all files and directories have been added to the conversion 
tasks list.



Colorado Department of Transportation   LU- 5

CDOT  Workflows  Level Update for V05.04.00

15. <D> Convert

16. The conversion process runs and the status column will be updated from Pending to Converted once 
completed. The Up to date items will not be processed.

17. When all the files have been converted <D> Done.

18. Take time to verify your data. The translation will only build folders and copy the translated data. You will 
need to copy all missing folders and data from you original project to the translated project folder. When 
folders and data have been verified, either delete or archive your original project folder and rename the 
translated project folder by removing your initials. This step will ensure that all references will display.

Converting Levels in MicroStation

1. From the MicroStation Manager, Open a drawing file.

2. Open the User preferences by clicking Workspace > Preferences
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3. Select the Look and Feel Category

4. Toggle on the option for Use Windows File Open Dialogs. Turn this feature off will allow a toggle later to 
open all files in a directory.

5. Select File > Save As.

6. Enter a new name into the File name: field to rename the current open drawing file, then <D> Options. 
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7. A standard CSV file is located in the configuration which is already set up to remap all of the previous 
versions’ levels to the standard CDOT MicroStation V03.01 levels. The CDOT configuration 
automatically loads the remapping CSV file.

8. By chance the file is not found, in the Save As V8 Options dialog box, <D> the Browse for CSV remapping 
file icon. 
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9. Navigate to C:\Workspace\Workspace‐CDOT_V8i\Standards‐Global\MicroStation 
\Tables\Level_Translation. Select the file V03.02_Level_Conversion.csv. <D> OK. 

10. In the Save As V8 Options dialog box, check On the option to Apply Level Mapping. <D> OK.
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11. <D> OK in the Save As dialog box. The CSV file will execute and the previous levels will be converted to 
the updated levels in the V03.01 configuration release.

Note: Once the new file is created, there will be two files with the same data. From windows explorer 
delete the old file and rename the newly created file to the old name. This will allow all reference 
file calls to be correct and will eliminate having duplicate data 

Compressing the Model File

1. After the level updates have been made to the drawing files created in previous versions, select File >   
Compress Design > Options.
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2. In the Compress Options window, all options should be checked on except Delete Text Elements 
Containing Only Spaces. <D> the Compress button, then <D> OK.
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Workflow MA 4 - Workspace Update

This document describes the steps to update an existing project when a new workspace is released.

1. Review the CDOT Configuration ReadMe file before processing any files.

2. To update the MicroStation files to the latest levels refer to workflow, CDOT Level Update for VXX_XX, 
where the X’s represent the version number. Using the batch process on the project directory is 
recommended to ensure all files are updated.

3. Next, the InRoads Feature Styles for the project’s design surfaces need to be updated. Follow the 
workflow, CDOT Update InRoads Features to update these files.

4. The project directory structure and PCFs need to be verified. All changes to the directory structure are 
documented in the ReadMe file. For example, in V03.02 there was a folder added, Redline. Going forward 
this folder will have to be added to existing projects. All new projects will have this folder built. The same 
is true for the PCF file. If a folder is added to an existing project that contains dgn files, it will have to be 
added to the existing PCF file. If in doubt run a sample project and compare the PCF files.
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Workflow MA 5 - Consultant Workspace

This document describes the setup of the CDOT Workspace if it is to reside on a server.

1. Read the CDOT MicroStation/InRoads Configuration requirements and installation instructions. This 
information is found at the following link on the CDOT website: 

http://www.coloradodot.info/business/designsupport/cadd/microstation-inroads-configuration

2. This will place the workspace on the server at the specified location.

Note: In the examples below, the following server location is used. “S:\Client Standards\CDOT\”

3. Open and review the CDOT Configuration ReadMe file. It is located in S:\Client 
Standards\CDOT\Workspace‐CDOT_V8i\CDOT Notes.

4. Follow step 8 on the installation instructions to activate the server based workspace for MicroStation and 
InRoads. For MicroStation and InRoads, edit the following file:

 For 64-bit operating systems, C:\Program Files (x86)\MicroStation V8i (SELECTseries)\MicroStation\ 
config\system\zCDOT_System.cfg

For 32-bit operating systems, C:\Program Files\MicroStation V8i (SELECTseries)\MicroStation\config\ 
system\zCDOT_System.cfg

5. The exe folder in the configuration must be copied onto the user’s computer in order for the programs to 
function properly. The exes folder should be placed in the following location: C:\Workspace\Workspace‐
CDOT_V8i\Standards‐Global\MicroStation\. This is required because the custom extensions are built on 
.NET framework and there are Windows securities that forbid running them on a server.

http://www.coloradodot.info/business/designsupport/cadd/microstation-inroads-configuration
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6. For those using the CreatePrjDir.exe, the following workspace folders (and their data) must be copied to 
the C:\Workspace\ directory:

♦ Workspace‐CDOT_V8i\Standards‐Local\Projects

♦ Workspace‐CDOT_V8i\Standards‐Global\InRoads\Preferences

♦ Workspace‐CDOT_V8i\Standards‐Global\MicroStation\Sheet Borders

7. The pcf file created by the CreatePrjDir.exe program will be placed in the following location on the 
computer used to run the program: 

♦ C:\Workspace\Workspace‐CDOT_V8i\Standards‐Local\Projects\

8. This pcf file should be copied to the S:\Client Standards\CDOT\Workspace‐CDOT_V8i\               
Standards‐Local\Projects. All users accessing this project will use the pcf file located on the server 
because the MicroStation configuration variables point to this directory.

9. Below is an example of the folder structure required on the local drive for those using the 
CreatePrjDir.exe:

10. The folder structure required on the local drive for those not using the CreatePrjDir.exe is:

11. These folders and files do not control the resources used by the program.

12. Follow step 14 on the installation instructions to deactivate the workspaces.
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Workflow OP 1 - Linking Word Documents to 
MicroStation

This document guides you through the creation of CDOT Notes sheets. This includes general notes for each of 
the specialty groups, SWMP notes for Landscape and Environmental, as well as any other sheets with notes. 
The Design general notes will be illustrated in this workflow, but the process is the same for each type of notes 
sheet.

Workflow Outline

Updating Links to the Word Doc - The existing link in the notes file points to the seed Word document. 
This needs to be changed to point to the Word document in the project folder.

♦ Commands Used: Edit > Links > Change Source - Used to change the directory path to the linked 
Word document.

Editing the Notes - How the notes are edited will depend on the extent of the editing. If the edits do not 
change the line count of the document, the current link can be edited. If the edits will change the line count then 
the notes should be opened through Word and edited. After editing, the existing links in MicroStation must be 
deleted and re-created. 

♦ Commands Used: Double Click on Link - Used to open Word from MicroStation so that the existing 
link can be edited.

Setting Up a Word Document for Linking - If you are building a notes file from scratch, the page layout 
must be set up.

♦ Commands Used: Word > Page Layout - Used set up the page formatting.

○ Margins - Used to set the margins.

○ Size - Used to define the paper size.

○ Columns - Used to format to two columns.

○ Indents - Used to set the indents.

Creating a New Link - If a new notes file was created or if extensive edits were done on an existing file, a 
new link will need to be made.

○ Commands Used: MicroStation > Delete - Used to remove the old link.

○ Word > Copy - Used to identify the text to be linked.

○ MicroStation > Paste Special - Used to create the new link in MicroStation.

Updating Links to the Word Doc

The JPC#DES_GenlNote##.dgn is created in …\Design\Drawings project folder when the Create Project 
Utility is run. This file is linked to a Word document that contains generic notes. The links are pointing to the 
JPC#DES_GenNote.doc that resides in the Project Template and must be redirected to the file in the specific 
folder.

Note:

 A Word 2007 document has a maximum viewable width of 13” when linked to MicroStation.
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 A Word 2010 document has a maximum viewable width equal to the paper size when linked to 
MicroStation.

 When changing the source of a linked Word document in MicroStation, the viewable area of the document 
will match the version of Word installed on the computer.

♦ If a link containing a Word 2010 document has the source changed on a computer with Word 2007 
installed, the reduction of the viewable area will result in approximately 3” of data on the right side of 
the document being hidden. It may also affect fonts used in the Word document.

♦ If a link containing a Word 2007 document has the source changed on a computer with Word 2010 
installed, the image of the document is reduced in size to fit the entire paper area into the area of the 
existing link. It may also affect fonts used in the Word document.

1. Open the JPC#DES_GenlNote##.dgn located in ProjectWise or, for locally stored projects, C:\Proj-
ects\JPC#\Design\Drawings directory.

2. Select Edit > Links from the MicroStation Main Menu.
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3. In the Links dialog box, highlight one of the documents shown, then <D> Change Source.

4. In the Change Source dialog box, use the drop-down list next to the Look In field to select the desired 
directory.



LWDM- 4 Colorado Department of Transportation

 Linking Word Documents to MicroStation CDOT  Workflows

5. Highlight the JPC#DES_GenNote.doc file and <D> Open.

6. Repeat this process for the other link. 

7. <D> Cancel to dismiss the Change Source dialog box.

Note: both links use the same JPC#DES_GenNote.doc.

Editing the Notes

1. The General Note text document is located in the project directory under: 

C:\Projects\JPC#\Design\Drawings\Tabs\JPC#DES_GenNote.doc

2. This file is then linked twice to the JPC#DES_GenlNote##.dgn sheet files, once for each sheet border in 
the file. These links act independently of each other, however. Adding or deleting text from one link will 
not scroll text to the other link. 

3. Editing that will not change the number of lines in the Word document can be done through the existing 
link in the JPC#DES_GenlNote##.dgn file. For editing that will change the line count, open the 
JPC#DES_GenNote.doc and make the desired changes. After changes are made, delete the existing links 
in the JPC#DES_GenlNote##.dgn file and create new ones from the edited Word document.

Editing an Existing Link

1. Select the Element Selector tool from the MicroStation Main toolbar.
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2. Move the cursor on to the edge of the linked text (the edge will highlight) and double click (<D> <D>). 
This will open the JPC#DES_GenNote.doc file in a session of Word.

3. Make the desired changes in the text, Save, and Close the Word document. The changes will be 
automatically displayed in the JPC#DES_GenlNote##.dgn file.

4. Select Edit > Update Links so that the change will show in document.

Setting Up a Word Document for Linking

The following section contains guidelines for setting up a Word document for linking to MicroStation. Please 
be aware that MicroStation interprets Word 2007 documents and Word 2010 documents differently. Because of 
this, the setting for both Word 2007 and Word 2010 are given below. Other information, detailed below the 
page set-up section, pertains equally to both versions of Word.

Page Set-up for Word Documents

 Settings for Word 2007

The following settings are used when creating a new Word 2007 document for General Notes or SWMP Plans.

Page Size 11x17 (11” x 17”)

Orientation Landscape

Top Margin 1.00”

Bottom Margin 1.40”

Left Margin 1.00”

Right Margin 3.00”

Columns Two

Column 1 Width 6.25”

Column 2 Width 8.85”

Column Spacing 0.00”

Column 1 Left Indent 0.13”

Column 1 Right Indent 0.15”

Column 2 Left Indent 0.50” for General Notes 0.13” for SWMP Plans

Column 2 Right Indent 2.35” for General Notes 2.22” for SWMP Plans

Font Arial Monospaced for SAP

Font Size 10
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Settings for Word 2010

The following settings are used when creating a new Word 2010 document for General Notes or SWMP Plans.

Page Size 11x17 (11” x 17”)

Orientation Landscape

Top Margin 0.50”

Bottom Margin 0.50”

Left Margin 0.25”

Right Margin 0.25”

Columns Two

Column 1 Width 8.00”

Column 2 Width 8.00”

Column Spacing 0.50”

Column 1 Left Indent 0.00”

Column 1 Right Indent 0.00”

Column 2 Left Indent 0.00”

Column 2 Right Indent 0.00”\

Font Arial Monospaced for SAP

Font Size 10

General Information for Creating Word Documents

 The Auto-numbering function in Word will not function properly. Once the copied text is pasted into 
MicroStation, the first item of the copied text is renumbered starting at 1. This occurs even if the auto-
numbering is set to stat with a number other than 1.
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 If you wish to number the items, set the Indentation Special to Hanging with a By value of 0.25”, then 
physically type in the numbers. Also, clear any tabs set, as these may cause problems with the formatting.

Note: The image above shows the indents for a 2007 Word document. The Left and Right Indentation 
settings are 0.00 for a 2010 Word document.

 Use a “hard” return (by pressing the Enter key) at the end of each page. This will ensure that there is no 
text wrapping between pages.

 A Word 2007 document has a maximum viewable width of 13” when linked to MicroStation.

 A Word 2010 document has a maximum viewable width equal to the paper size when linked to 
MicroStation.

 When changing the source of a a linked Word document in MicroStation, the viewable area of the 
document will match the version of Word installed on the computer.

♦ If a link containing a Word 2010 document has the source changed on a computer with Word 2007 
installed, the reduction of the viewable area will result in approximately 3” of data on the right side of 
the document being hidden. It may also affect fonts used in the Word document.

♦ If a link containing a Word 2007 document has the source changed on a computer with Word 2010 
installed, the image of the document is reduced in size to fit the entire paper area into the area of the 
existing link. It may also affect fonts used in the Word document.

Creating a New Link

Use the following procedure when changes to the JPC#DES_GenNote.doc will increase or decrease the 
original number of lines in the document.

1. Select Delete from the MicroStation Main toolbar.

2. <D> on the linked text. <D> again to accept the command and delete the link.
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3. Open the edited JPC#DES_GenNote.doc and highlight the entire page of text that is to be linked.

4. Select Edit > Copy from the menu (or press CTRL + C) to copy the text to the clipboard.

5. Go to the MicroStation session with the JPC#DES_GenlNote##.dgn file open and select Edit > Paste 
Special.
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6. From the Paste Special window, select Linked Microsoft Office Word Document, then <D> Paste.

7. In the Paste OLE tool dialog box, set the Method to By Corners.

8. <T> to the left end of the guide line and <D>.

9. <T> to the right end of the guide line and <D> to complete the link.

An alternative method when attaching the linked document is to use the size option in the Paste OLE dialog 
box. 

1. Follow steps 1 through 6 described above.

2. In the Paste OLE tool dialog box, set the Method to By Size.
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3. Expand the dialog box and set the Scale to 13.00.

Note: Using the 13 scale factor will produce a text height of approximately.07”, which is the CDOT standard 
for a 1”=1’ annotation scale. This number can be adjusted if larger text is required.

4. Center the outline of the link in the sheet border and <D> to place it.

Once the linked document has been placed, it can be repositioned using the MicroStation Move command.
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Notes Placed From a PDF
A PDF file of the notes can be displayed within the MicroStation file to create General Notes and SWMP plan 
sheets. As with the other options, using a PDF file has advantages and disadvantages. Some of the advantages 
to using a PDF file are:

♦ The Word 2010 formatting can be used even on computers with Word 2007

♦ The autonumbering functions in Word can be used

♦ If the PDF is recreated, the new PDF in MicroStation is updated as well

Some of the disadvantages to using a PDF are:

♦ The Word file can be different from the PDF file. You will need to create a new PDF each time the 
document is edited

♦ A separate PDF is required for each page in the document

♦ A PDF that is attached in MicroStation cannot be overwritten while the DGN file is open. 

○ Close MicroStation.

○ Create a new pdf. Give it the same name to overwrite the existing one.

○ Open up MicroStation and PDF will be updated

To link a PDF to MicroStation, follow the steps below:

1. Open the Word document (the JPC#DES_GenNote_2010.doc is used in this example) and create a separate 
PDF print of each sheet to be linked.

Note: Be sure to name the PDF something meaningful for the print (in this example the PDF was named 
JPC#DES_GenNote_2010-pg1.pdf ).

2. ).Open MicroStation using the drawing that will contain the PDF (in this example 
JPC#DES_GenNote_2010.dgn is used). 
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3. Open the MicroStation Raster Manager.

4. In the Raster Manager dialog box, select File > Attach > Raster. This displays the Attach Raster 
Reference dialog box.

5. In the Attach Raster Reference dialog box, navigate to the desired location, highlight the desired file, and 
toggle on Place Interactively.

6. <D> the Open button.
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7. <T> to the left end of the bottom snap line within the sheet border then <D>.

8. <T> to the right end of the bottom snap line within the sheet border then <D>.



LWDM- 14 Colorado Department of Transportation

 Linking Word Documents to MicroStation CDOT  Workflows

This completes the attachment of the PDF file. Below is an example of a completed sheet.
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Notes Placed as MicroStation Elements

Included in the workspace are files called JPC#DES_GenlNoteMsta##.dgn and JPC#DES_SWMP‐Msta.dgn. 
These are MicroStation files that have the respective notes placed as MicroStation text elements instead of 
using links to Word. These files do not have an external data source and all editing occurs solely within the 
MicroStation environment using the Edit Text command.
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If used, these files should replace those containing the linked Word documents and should not be used in 
addition to them.
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Workflow OP 2 -  Linking Excel Documents to 
MicroStation 

This document guides you through linking Microsoft Office Documents within MicroStation. 

Workflow Outline

Creating a New Link - To create a link to an Excel file within MicroStation; copy the data from the Excel 
file, then Paste Special the data into MicroStation.

♦ Excel > Copy - Used to identify the text to be linked.

♦ MicroStation > Paste Special - Used to create the new link in MicroStation.

○ Method - Use the By Size option.

○ Scale - Use 10 so that the text will be the correct size.

Updating Links to the Excel - If a linked document gets moved or renamed, teh link to that file can be 
restored without re-creating the link.

♦ Commands Used: Edit > Links > Change Source - Used to change the directory path to the linked 
Word document.

Linking Excel Documents

1. Open your MicroStation File and your Microsoft Excel file.

2. Within the Excel file, select the information you would like in the MicroStation Sheet file and copy by 
right clicking and selecting Copy.
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3. Within the MicroStation file, select Edit > Paste Special … from the MicroStation menu. On the Paste 
Special dialog box, <D> Linked Microsoft Office Excel Worksheet and <D> Paste.

     

4. This brings up the Paste OLE dialog box. Select By Size as the Method: and enter a Scale of 10.

    

Note: The San Serif font should be used as the default Font in Microsoft Excel documents. The San Serif 
8 pt font in Excel, is equivalent to CDOT Standard Text (.07”), and the San Serif 12 pt font is 
equivalent to CDOT Title Text (.10”) for a 1”=1’ Drawing with a Scale of 10 noted above. The 
fonts are not exact duplicates but the San Serif will be the most similar Font to the CDOT 
Standard.
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5. The limits of the selected Excel data to be placed in the MicroStation Sheet will display in the 
MicroStation Window. Select the location for the Excel File and <D> to place the file.
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Note: The link will display with hatching which indicates that the Excel file containing the linked data is 
currently open. If you close out of your Excel file, the hatching will go away.
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6. You can single click on the Linked graphics and use MicroStation Commands to move the image. Do not 
resize the linked window with the handles, as the text size will also resize and will not plot as desired.

Note: You can hover over the linked image to display the location of the Excel file. Double clicking the 
link will open the Microsoft Excel document. You can edit the Excel file, close the file, and the 
updates will be displayed in the MicroStation file.

Updating Document Link Source and Properties

1. If the Excel document has been moved or renamed, you can simply update the link instead of redoing the 
above procedure. This is also the case for MicroStation files with links that were created with the Create 
Project Directory program. These files will be linked to Office files in a standard template and need to be 
updated to link to the Office files in the Project Directory Structure.
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2. From the MicroStation menu, select Edit > Links…

3. This will bring up the Links dialog box. You can select an available document link and <D> Change 
Source…
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4. This brings up the Change Source dialog box. Use this to navigate to and select the file with its new 
location. <D> Open. This dismisses the Change Source dialog box and re-displays the Links dialog box. 

5. You can select another available document link to update or <D> Close to exit the Update Links dialog 
box.

Note: You can select either to have the link update manually or automatically by selecting the method 
you prefer. You can do a manual update from the Links dialog box by selecting the link and <D> 
Update Now.
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Workflow OP 3 - Monumentation Sheets

This document describes the process used to assemble a Right of Way Monumentation Sheet. An InRoads 
XML report is used to display the required data from the geometry project. This data is copied and pasted into 
the JPC#ROW_TabMon.xls Excel file and then linked to the MicroStation JPC#ROW_Mon##.dgn file.

Workflow Outline

Creating the InRoads XML File - The data used to create the Right of Way Monumentation sheet is stored 
in an Geometry Project. The InRoads Clearance report is used to extract that data for use on the sheet.

♦ Commands Used: Tools > XML Reports > Clearance - Used to create the geometry report data 
used on the Monumentation sheet.

♦ InRoads Report Browser > Templates - Used to select the template that formats the report.

♦ Format Options - Used to set the number of decimal places shown in the report.

Copying the Report - After the report is formatted, it is copied and pasted into Excel.

♦ Commands Used: InRoads Report Browser > Copy - Used to copy the data from the report 
browser.

♦ Excel > Paste - Used to paste the report data into Excel.

♦ Protect Sheet - Used to give the user the ability to turn off the sheet gridlines.

♦ Options > View - Used to turn the gridlines off.

Creating a New Link - Once the report is in Excel and formatted, it can be linked to the MicroStation file..

○ Commands Used: MicroStation > Delete - Used to remove the old link.

○ Word > Copy - Used to identify the text to be linked.

○ MicroStation > Paste Special - Used to create the new link in MicroStation.

Creating the InRoads XML File

The data used to create the Right of Way Monumentation sheet is stored in an InRoads Geometry Project 
(*.alg).   Depending on the data required, one of two different reports are used to extract the data from the 
geometry project. Both reports display Point Number, Northing, Easting, and Elevation. If this is all the data 
that is required, a Geometry report is used. If Station and Offset information is also required, then the 
Clearance report is used.

Geometry Report

A geometry project containing the data is the only prerequisite for creating a Geometry Report.
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1. From the InRoads menu, select Tools > XML Reports > Clearance. The Clearance Report dialog box 
is displayed.

2. <D> the Cogo Points leaf.

3. In the Include field, key in the desired COGO point numbers then Tab to accept the keyed in information. 
COGO points can be specified as a range (XXX-XXX), a list of individual points (XXX,XXX,XXX) or a 
combination of both (XXX-XXX,XXX,XXX-XXX). If the required point numbers are unknown, all points can 
be listed by keying an asterisk ( * ) into the Include field. The asterisk can be used in conjunction with text 
to limit the list of points. For example, keying in ‘10*’ would find all points whose first two digits 
were’1’ and ‘0’. 

4. <D> Apply to start the report compilation process. The Bentley InRoads Report Browser dialog box 
displays.

The Bentley InRoads Report Browser

The Bentley InRoads Report Browser is a modified version of the Internet Explorer web browser used 
specifically for InRoads XML reports. It is launched automatically when an XML report is ran. It can also 
be launched by selecting Tools > View XML Reports from the InRoads main menu. The illustrations below 
use the List Coordinates report, however procedures are the same for the Clearance report.
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Selecting an XML Report Template

1. Report templates are program files that format the raw data contained within the XML file. When the 
Bentley InRoads Report Browser opens, it selects a default report template for the type of report that was 
created.

2. CDOT’s custom report templates are stored in the CDOT folder. <D> on the CDOT folder to display the 
available templates. Two custom templates are provided for creating Monumentation sheets; 
CDOT_Monumentation_ListCoordinates and CDOT_Monumentation_Clearance. <D> on the desired 
template name to activate that template. 

3. This updates the report layout automatically in the browser window.

Format Options

1. The default precision for reporting is set to two decimal places. If a different precision is required, it can be 
set using Format Options.

2. From the Bentley InRoads Report Browser, select Tools > Format Options. This displays the Format 
Options dialog box.
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3. Use the pull downs to set the desired precision for the different options. For the reports discussed in this 
document, the following fields are used: Northing/Easting, Elevation, Linear (for offsets), and Station.

4. Selecting a different precision will automatically update the column or columns in the report that uses that 
format option. <D> Close to dismiss the dialog box when finished.

Copying the Report to the Monumentation Spreadsheet

1. Now that the report has been generated and formatted properly, the contents of the report can be copied 
into the JPC#ROW_TabMon.xls Excel file. This file contains separate sheets for different types of 
monuments. These are; ROW Markers To Be Set, Control Points To Be Set, ROW Markers To Be Reset, 
Permanent Easement Markers, Aliquot Corners, and Temporary Easement Points. Because any number of 
these monument types may be stored in the geometry project, it may be necessary to copy different blocks 
of data from the report to paste into different sheets in the spreadsheet.

2. Open the JPC#ROW_TabMon.xls file with Excel then minimize it.

3. Go back to the Bentley InRoads Report Browser and highlight the desired data in the report.

4. Right Click on the highlighted data to display the menu. Select Copy from that menu.
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5. Minimize the Bentley InRoads Report Browser and maximize the Excel.

6. Using the tabs at the bottom, select the sheet for the copied data.

7. <D> in cell A3 of the selected sheet. This is where the copied data will be pasted. Right click in the same 
cell and select Paste from the menu that displays.



MS- 6 Colorado Department of Transportation

 Monumentation Sheets CDOT  Workflows

8. The illustration below shows the result of this operation.

9. Because the example is a List Coordinates report, the Station and Offset columns are empty. These two 
columns will be hidden in order to center the title over the data.

10. <D> and hold the mouse button on the ‘F’ column label and drag the cursor over the ‘G’ column label. 
Both columns highlight.

11. Right Click on the highlighted columns (in the body of the table) and select Hide from the menu.
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12. The Station and Offset columns vanish and the title is centered over the remaining columns. 

13. Before the sheet can be linked to the JPC#ROW_Mon##.dgn file, the grid lines need to be turned off. If 
they are left on, they will appear in a print of the dgn file.

14. Select Tools > Protection > Protect Sheet to maintain the new sheet formatting. This will display the 
Protect Sheet dialog box.

15. Toggle on Protect worksheet and contents of locked cells near the top of the dialog. In addition toggle 
on Select locked cells, and Select unlocked cells under Allow all users of this worksheet to:. <D> OK 
to accept the changes and dismiss the dialog box.
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16. Select Tools > Options from the Excel menu.

17. From the Options dialog box, select the View tab.

18. In the Windows Options area, toggle off Gridlines. <D> OK to accept the changes and dismiss the dialog 
box.

19. The left most column in the JPC#ROW_Mon##.dgn file can hold 50 rows of data (not counting the two 
title rows). Other columns can hold 41 rows of data. If there are more rows of data than a column can hold, 
the sheet can be copied and the duplicate data deleted from the sheets.
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20. To make a copy of a sheet, right click on the sheet tab (at the bottom of the window) and select Move or 
Copy from the menu.

21. In the Move or Copy dialog box, toggle on Create a copy. <D> OK to create the copy and dismiss the 
dialog box.

22. The Copy of the sheet is named with (2) appended to the sheet name. The sheets can be renamed by right 
clicking on the tab and selecting Rename from the menu. Key in the new name and press the Enter key to 
accept the change.

23. In the original sheet, delete all the data below row 52 for the long column, below row 43 for the short 
columns (the long column can hold 50 rows of data and there are two rows of headings).

24. In the copied sheet, delete the data from rows 3 through 52.

Linking the Spreadsheet to the MicroStation Sheet File

Once the data has been copied to the spreadsheet and the sheets formatted, they can be linked to the 
MicroStation sheet border.

1. Open JPC#ROW_Mon##.dgn in MicroStation then minimize it.

2. In the JPC#ROW_TabMon.xls file, highlight the data to be linked. Be sure to include only columns and 
rows with data (including the two title rows).
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3. From the Excel menu, select Edit > Copy (or right click in the highlighted area and select Copy from the 
menu).

4. Maximize the MicroStation window. From the MicroStation Menu select Edit > Paste Special.

5. The Paste Special dialog box is displayed. Select Linked MicroSoft Office Excel Worksheet from 
the list and <D> Paste.
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6. In the Paste OLE dialog box, set the Method to By Size. 

7. In the Scale field, key in 9.25.

8. An outline of the linked file is now attached to the cursor.

9. With AccuDraw active, <T> to the no-plot line in the middle of the sheet. Press the ‘O’ key to identify this 
point as the origin on the link placement.

10. Move the cursor along the line, away from the sheet border, then key in the desired value in the AccuDraw 
tool setting box. This should be 4” for a table with the Station and Offset columns and 4.5” for a table 
without. <D> to accept the location.
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Workflow OP 4 - Right of Way Property Tab 
Sheets

This document guides you through the use of the Excel spreadsheet JPC#ROW_TabProp.xls with the 
JPC#ROW_TabProp##.dgn to create a finished “Tabulation Of Properties” sheet file.

Using the ROW_TabProp.xls file:

1. The ROW_TabProp.xls file is set up to hold data for up to four complete tabulation sheets. This file is 
protected to maintain the column widths and number of rows. Data entry is allowed in the body of each 
table only. The illustration below highlights the body of table 1.

a. Data is entered beginning in cell 5A.
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2. After typing in the desired data, press the Tab key to move to the next available cell. This will move the 
cursor across each row, one cell at a time until the end of the row is reached. A tab at the end of the row 
will move the cursor to column A of the next row. A tab at the end of a table will move the cursor to the 
first row and column of the next table.

3. After the desired data is entered select File > Save. Do not close the document.

Updating the Link to the ROW_TabProp.xls file

1. Open the JPC#ROW_TabProp##.dgn in MicroStation.

2. Select Edit >Links from the menu. This will display the Links dialog box.
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3. In the Links dialog box, highlight the link to the spreadsheet and <D> Change Source.

4. From the Change Source dialog box, highlight the JPC#ROW_TabProp.xls file and <D> Open. 

5. Repeat steps 4 through 7 for other spreadsheets if needed.

Editing the ROW_TabProp.xls file

1. The Excel file (and thus the MicroStation tab sheet) can be edited from MicroStation by selecting the 
Element Selector then double clicking (<D> <D>) on the table. This opens Excel and the linked 
spreadsheet.
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2. Make the desired edits in Excel, Save then Close the file. The corrections will be updated automatically.

Note: If the link to the spreadsheet is lost or additional sheets are required, refer to the workflow 
document CDOT Linking MicroStation to Excel Documents for directions on reestablishing or 
creating new links.
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Workflow OP 5 - Numbering Plan Sets In Adobe

This document guides you through the use of the page numbering option within Adobe Acrobat Professional.

Prerequisites 

Before you begin, you will need a pdf file of the plan set that is not numbered in MicroStation. 

Basic Page Numbering

This section, explains how to set up header/footers to number sheets when the title block is located at the 
bottom of the sheet and at the top of the sheet.

1. Open the plan set PDF using Adobe Acrobat Professional.

2. Because Right-of-Way plans have the title block at the top of the sheet, the numbering at the bottom of the 
sheet must end prior to encountering the Right-of-Way sheets. Make a note of the page number of the last 
design plan sheet for use in the steps below.

3. From the menu bar, select Document > Header & Footer > Add. This displays the Add Header and 
Footer dialog box.

4. In the Font area of the Add Header and Footer dialog box, select Tahoma for the Name and 11 for the 
Size.

Next the margins and page numbers are set up for sheets with the title block at the bottom of the sheet.

Settings for Numbers in the Lower Right Corner

Use the following steps to set the right and bottom margins.
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1. In the Margins area of the Add Header and Footer dialog box, key in 0.71 for the Bottom margin and key 
in 0.75 for the Right margin.

2. <D> in the Right Footer Text field.

3. <D> the Insert Page Number button. This places the page numbering variable in the Right Footer Text 
field.

If the plan set contains Right-of-Way plans, then the page range for this header/footer will have to be set. This 
will prevent the Right-of-Way plans from being numbered in the wrong location. To set the page range:

4. <D> The Page Range Options link. This displays the Page Range Options dialog box.

5. In the Page Range Options dialog box, toggle on Pages From.

6. In the to field, key in the page number noted in the above section. This will stop this header/footer from 
being applied to the Right-of-Way sheets.
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7. <D> the OK button to accept the page range.

8. <D> The Save Settings button. This displays the Save Settings dialog box.

9. In the Save current settings as field, key in the desired name (e.g. Bottom Page Number) and <D> 
the OK button.

10. <D> the OK button on the Add Header and Footer dialog box. This applies the changes and dismisses the 
dialog box.

This completes the set up for page numbers at the bottom of the sheet. Below is an example of the sheet 
numbering.

Settings for Numbers in the Upper Right Corner

For sheets that are numbered in the upper right corner, the font size, right margin and top margin need to be set. 

1. In the Font area, set the Size to 8.
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2. In the Margins area of the Add Header and Footer dialog box, key in 1.42 for the Top margin and key in 
0.67 for the Right margin.

3. <D> in the Right Header Text field.

4. <D> the Insert Page Number button. This places the page numbering variable in the Right Header Text 
field.

Note: If the plan set contains Design plans, then the page range for this header will have to be set. To set 
the page range:

5. <D> The Page Range Options link. This displays the Page Range Options dialog box.

6. In the Page Range Options dialog box, key in the desired page range. 

7. <D> the OK button to accept the page range.

If this page numbering set up starts in the middle of the plan set, the starting number will have to be set to 
reflect its starting location within the plan set. 
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Important! If the Page Number and Date Format isn’t set, the Right-of-Way plans will be numbered 
starting with 1.

8. Select Page Number and Date Format from the dialog box.

9. In the Page Number and Date Format dialog box, key in or select the desired Start Page Number.

10. <D> OK to accept the page number.

11. <D> The Save Settings button. This displays the Save Settings dialog box.

12. In the Save current settings as field, key in the desired name (e.g. Top Page Number) and <D> the 
OK button.

13. <D> the OK button on the Add Header and Footer dialog box. This applies the changes and dismisses the 
dialog box.
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This completes the set up for page numbers at the top of the sheet. Below is an example of the sheet 
numbering.

Updating Headers/Footers When Pages Are Added

When a sheet is inserted into a PDF plan set, the inserted sheet does not automatically acquire the header/footer 
information. To update the page numbering:

1. From the menu bar, select Document > Header & Footer > Update. This displays the Add Header 
and Footer dialog box.

2. In the Add Header and Footer dialog box, select the Saved Settings that are affected by the added sheet.

3. <D> The Page Range Options link. 

4. In the Page Range Options dialog box, key in the desired page range. 

5. <D> the OK button to accept the page range.

6. <D> The Save Settings button. 

7. In the Save current settings as field, key in the same name as the setting you selected above.
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8. A dialog box asking if you want to replace the original settings is displayed. <D> OK.

9. <D> the OK button on the Add Header and Footer dialog box. This applies the changes and dismisses the 
dialog box.

10. Repeat the process for other headers/footers affected by page additions.

Adding Sub-Set Numbering

Sub-set numbering can also be added to the sheet border. Creating the header/footer for sub-set numbering is 
done in the same manner as described in the previous sections, with the following changes.

Note: Sub-set numbering is added to each individual pdf as needed. Sub-set numbering is not part of the 
Bates numbering described below, however, it can be used in addition to Bates numbering.

Settings for Sub-set at the Bottom of the Sheet

 Font - Tahoma

 Size - 8

 Top - 0.50

 Bottom - 0.65

 Left - 1.00

 Right - 2.10

Settings for Sub-set at the Top of the Sheet

 Font - Tahoma

 Size - 8

 Top - 1.51

 Bottom - 1.00

 Left - 1.00

 Right - 1.70

1. <D> in the appropriate text field (Right Header Text or Right Footer Text).

2. <D> the Insert Page Number button. 
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3. At the right end of the page number text, key in the following: of # where the # is the number of sheets in 
the sub-set.

4. <D> The Page Range Options link. 

5. In the Page Range Options dialog box, key in the desired page range. 

6. <D> the OK button to accept the page range.

7. <D> The Save Settings button. 

8. In the Save current settings as field, key in the desired name. This name should describe the sub-set the 
header/footer is used for.

9. <D> the OK button on the Add Header and Footer dialog box. This applies the changes and dismisses the 
dialog box.

Note: A different header/footer is required for each sub-set in the plans.

Below are examples of top and bottom page numbering with sub-set numbers included.

Note: Sub-set numbering will need to be updated when pages are inserted into the plan set. Use the steps 
from the Updating Headers/Footers When Pages Are Added section above to make changes to sub-
set numbering.
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Using Bates Page Numbering

Bates page numbering is used to number multiple pdf documents with a consistent series of numbers. This 
process replaces the Basic Page Numbering above when the plan sets are made up of multiple PDF files. Please 
note that the process for sub-set numbering remains the same as defined above.

Because Bates Numbering does not use page ranges across all of the files selected, this option requires sections 
that have the page number in a different location to be renumbered. In the example below, the second section 
(using the 12345_ROW-Plans.pdf file) has the page numbering in the upper right corner while the other three 
files have it in the lower right corner. The Bates Numbering will be added to all four files. then it will be 
removed from the 12345_ROW-Plans.pdf file and reapplied using the proper header/footer definition.

1. Launch Adobe Acrobat Pro, selecting the first PDF used in the plan set.
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2. From the Adobe Acrobat Pro Menu bar, select Advanced > Document Processing > Bates 
Numbering > Add. This displays the Bates Numbering dialog box.

3. In the Bates Numbering dialog box, Select Add Files > Add Files. This displays the Add Files dialog 
box.
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4. In the Add Files dialog box, navigate to the folder that contains the desired PDF files.

5. Select the desired files to be included in the plan set. <D> the Open button to add the files. In this 
example, 12345_Design‐Plans.pdf, 12345_HYDR‐Plans.pdf, 12345_ROW‐Plans.pdf, and 12345_TRAF‐
Plans.pdf are used.

Next, organize the files into the desired order. In this example the 12345_ROW‐Plans.pdf is moved up to the 
second position.

6. Highlight the file to be moved. In this example the 12345_ROW‐Plans.pdf will be moved.
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7. Use the Move Up and Move Down buttons to change the file’s location. In this example the Move UP 
button is used.

8. <D> OK. This accepts the files and opens the Add Header and Footer dialog box.

Use the following settings for Bates Numbering at the bottom of the sheet:

 Font - Tahoma

 Size - 11

 Top - 0.50

 Bottom - 0.71

 Left - 1.00

 Right - .75

9. <D> in the Right Footer Text field.
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10. <D> the Insert Bates Number button. This displays the Bates Numbering Options dialog box.

11. In the Bates Numbering Options dialog box, set the Number of Digits to 3.

12. Set the Start Number to 1.

13. <D> OK to accept the changes and dismiss the Bates Numbering Options dialog box.

This completes the set up for the Bates Numbering for the bottom right corner. Next, save these settings so that 
they can be used on other projects.
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Bates Numbering Options In Adobe Acrobat Pro 9

The Adobe Acrobat Pro 9 Bates Numbering Options dialog box does not allow less than 6 in the Number of 
Digits field. This can be corrected once the numbering code has been placed into the Add Header and Footer 
dialog box.

1. In the Add Header and Footer dialog box, highlight the “6” in the Bates numbering code located in the 
Right Footer Text field.

2. Key in 3. This resets the digits to 3.

Saving and Applying a Bates Numbering Definition

1. <D> the Save Settings button. This displays the Save Settings dialog box.

2. In he Save Settings dialog box, key in the desired settings name. In this example Bates Numbering 
Bottom is used.

3. <D> OK to accept the entry and dismiss the he Save Settings dialog box.
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4. In the Add Header and Footer dialog box, <D> OK. This adds the Bates Numbering to the selected files 
and dismisses the Add Header and Footer dialog box.

A Progress message box is displayed which shows the program adding the page numbering to the selected 
files. When the processing is complete, another message window is displayed indicating the successful 
completion of the numbering.

5. In the Adobe Acrobat message window, <D> OK to dismiss the window.

The Bates Numbering has been added to each of the selected files. Even though the numbering is placed in the 
wrong location on the 12345_ROW-Plans.pdf file, it was included here in order to get the correct numbers on 
the files that follow. Next, the Bates Numbering is removed from the 12345_ROW-Plans.pdf file and reapplied 
with the correct page numbers in the upper right corner of the sheets.

Replacing Bates Numbering on a File

1. In the Adobe Acrobat Pro dialog box, Select File > Close to close the open file.

2. Open the file that needs to have the numbering replaced. In this example, the 12345_ROW‐Plans.pdf file is 
used.
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3. Make a note of the page number currently on the page. This will be the starting Bates Number when the 
correct formatting is applied.
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4. From the Adobe Acrobat Pro Menu bar, select Advanced > Document Processing > Bates 
Numbering > Remove. This deletes the Bates Numbering from this file only.

5. Select Advanced > Document Processing > Bates Numbering > Add. This displays the Bates 
Numbering dialog box.
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6. In the Bates Numbering dialog box, Select Add Files > Add Open Files. This displays the Open PDF 
Files dialog box.

7. In the Open PDF Files dialog box, highlight the desired files and <D> Add Files. this adds the files to the 
list and dismisses the Open PDF Files dialog box.

8. In the Bates Numbering dialog box, <D> OK. This accepts the files and opens the Add Header and Footer 
dialog box.

Use the following settings for Bates Numbering at the top of the sheet:

 Font - Tahoma

 Size - 8
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 Top - 1.42

 Bottom - 0.50

 Left - 1.00

 Right - 0.67

9. <D> in the Right Header Text field.

10. <D> the Insert Bates Number button. This displays the Bates Numbering Options dialog box.

11. In the Bates Numbering Options dialog box, set the Number of Digits to 3.

12. Set the Start Number to that generated in the first run of the Bates Numbering. In this example 11.

13. <D> OK to accept the changes and dismiss the Bates Numbering Options dialog box.

This completes the set up for the Bates Numbering for the top right corner. Next, save these settings so that 
they can be used on other projects.

14. <D> the Save Settings button. This displays the Save Settings dialog box.

15. In he Save Settings dialog box, key in the desired settings name. In this example Bates Numbering 
Top is used.

16. <D> OK to accept the entry and dismiss the he Save Settings dialog box.
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17. In the Add Header and Footer dialog box, <D> OK. This adds the Bates Numbering to the selected files 
and dismisses the Add Header and Footer dialog box.

This completes the page numbering for the plan set.

Notes on Using Bates Numbering

 After the Bates Numbering is applied to a set of files, there is no further connection between the files. 
Therefore, if the page count changes for some reason, each file will have to be opened and the Bates 
Numbering removed before the files can be re numbered.

 Bates Numbering cannot be updated. If the page count changes for some reason, each file will have to be 
opened and the Bates Numbering removed before the files can be re numbered.

 A file cannot have more than one set of Bates page numbers.

 A Page Range setting in the Add Header and Footer dialog box will affect every PDF file selected for 
Bates page numbering.

 Each PDF file will have to be opened and printed then collated manually to assemble the plan set.
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Workflow OP 6 - Adding a Watermark to PDF 
Files

This document guides you through the process of adding a watermark to a PDF plan set. This method uses 
Adobe Acrobat Professional to add a watermark to an existing set of plans in PDF format.

1. Open the desired plan set in Adobe Acrobat Professional.

2. From the menu bar, select Document > Watermark > Add. This displays the Add Watermark dialog 
box.

3. In the Source area of the Add Watermark dialog box, toggle on Text.

4. In the Text key in field, type the desired text (FIR, FOR, etc.).
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5. Select the desired text color. Use Black for a watermark on line drawings. Use White for a watermark on 
sheets with aerial photos.

6. In the Appearance area, set the desired Rotation. In this example, the Rotation was set to Custom and 25 
degrees.

7. Set the desired Opacity; 25% is used for black text, 50% is used for white text.

8. Toggle on Scale relative to target page and set the desired scale. In this example 100% was used.

9. Toggle on Appear on top of page for Location.
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10. <D> OK to accept the changes. This adds the watermark to each sheet in the plan set and dismisses the 
Add Watermark dialog box.

11. To change the watermark settings, reopen the Add Watermark dialog box and make the desired changes.

Using Multiple Watermarks in a Plan Set

Plan sets may contain both line drawings and aerial photos combined into a single file. In these cases, multiple 
watermarks are required;  black watermarks are used on line drawings while white watermarks are used on 
aerial photos.

1. Follow steps 1 through 9 above to set up the first watermark.

2. <D> the Save Settings button.
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3. In the Save Settings dialog box, key in the desired setting name. The setting name should identify what the 
watermark is for. In the illustration below, the name indicates that the watermark is used for FIR line 
drawings.

4. <D> OK to save the settings.

5. Using the same process, create the other watermarks needed.

6. Select the desired watermark from the Saved Settings menu.

7. <D> the Page Range Options link (in the upper right corner).

8. In the Page Range Options dialog box, toggle on Pages From.

9. Key in or select the desired number in the  From and To fields.

10. <D> OK. This sets the specified watermark for the indicated pages.
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11. In the Add Watermark dialog box, <D> OK. This applies the specified watermark to the indicated pages.

12. From the menu bar, select Document > Watermark > Add. An Adobe Acrobat information dialog 
box is displayed. It explains that the document already has a watermark.

13. <D> the Add New button. This allows you to add an additional watermark.

14. Repeat steps 6 through 11 to add the additional watermark.

Any number of watermarks can be added in this manner. Also, the watermark settings are saved within Adobe 
Acrobat Professional (on your local computer) so they will be available for the next plan set to be printed. 



AWPF- 6 Colorado Department of Transportation

 Adding a Watermark to PDF Files CDOT  Workflows



InRoads Related Workflows



Page 2 Colorado Department of Transportation

 CDOT  Workflows



Colorado Department of Transportation   IPDM- 1

Workflow IR 1 - InRoads V8i Project Defaults 
Management

This document describes the set-up procedure InRoads Project Defaults in the V8i version of the software. 
InRoads project defaults perform two functions; firstly they load the appropriate CDOT standard resource files 
such as the standard XIN file, annotation resources, XML style sheets, etc. Additionally they define default 
paths to project specific directory folders that contain project data such as DTM’s, alignments, survey data, etc.  

Setting Up Project Defaults

To set up a Project Default:

1. Launch InRoads V8i.

2.   select File>Project Defaults from the InRoads menu bar.

.

3. Click on the New button.

4. In the New Configuration dialog box, key in the desired Project Code.

5. <D> OK to accept the key-in and dismiss the New Configuration dialog box.

This activates the Set Project Defaults dialog box so that it can be edited.

6. <D> in the Preferences (*.xin) field then <D> the Browse button.
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7. Browse to:
C:\Workspace\Workspace-CDOT_V81\Standards-Global\InRoads\Preferences

Note: If you are logged into ProjectWise, the ProjectWise browser will be displayed. <D> the Cancel 
button to dismiss it and display the (local) file Browser.

8. Select the file: CDOT_Civil.xin

9. <D> in the Drafting Notes (*dft) field then <D> the Browse button.

10. Browse to:
C:\Workspace\Workspace-CDOT_V81\Standards-Global\InRoads\Notes.

11. Cancel the ProjectWise browser if necessary.

12. Select the file: CDOT-Notes.dft.

This completes the Default Preferences part of the dialog box. Next the directory paths are filled in. If your 
project data resides on the ProjectWise server, fill in only the ProjectWise Directory field. 

13. <D> in the ProjectWise Directory field.

14. <D> the Browse button. This displays the ProjectWise Select Folder dialog box.

15. Navigate to the desired folder and highlight it.
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16. <D> the OK button to select the folder and dismiss the Select Folder dialog box.

If the project data is stored locally, then the fields below the ProjectWise Directory field should be used.

17. <D> in the Project Default Directory field.

18. <D> the Browse button. This displays the Open dialog box.

19. Navigate to the desired folder then <D> the Open button.

Note: Typically, the Projects (*.rwk), Surfaces (*.dtm), Geometry Projects (*.alg), Template Libraries 
(*.itl), and Roadway Design (*.ird) will use the same directory path as the Project Default 
Directory. Therefore, you do not have to fill in those fields unless they are different than the 
Project Default Directory.
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The path to the Style Sheet directory should be set for both ProjectWise and locally stored projects.

20. <D> in the Style Sheet (*.xsl) field.

21. <D> the Browse button. This displays the Open dialog box.

22. Navigate to the following directory:

C:\Workspace\Workspace-CDOT_V8i\Standards-Global\InRoads\XML Style Sheets

23. <D> the Open button.

24. Once the desired fields are filled in, <D> the Apply button to accept the changes.

THe Project Defaults are now active and will be used when opening and saving files.

Setting Project Defaults

1. Users can use the Configuration Name field to choose the appropriate Project Defaults for the project .
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Using Project Defaults Example

The following example demonstrates the benefits of using project defaults. Here, the project data is stored 
onProjectWise.

1.  Open InRoads.

2. Select File > Project Defaults.

3. In the Set Project Defaults dialog box, select any discipline from the Configuration Name drop-down list. 
Then Select the Apply & Close buttons.
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4. From the InRoads interface, select File>Open

Notice that the ProjectWise Open dialog box is already set to the default directory specified in the Project 
Defaults.
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5. Select the Preferences tab at the bottom of the InRoads Explorer. Notice that the default CDOT xin file 
is loaded.

6. Select Drafting > Place Plan Note from the InRoads main menu.

7. Notice that the CDOT‐Notes.dft file is loaded here.

8. Select Tools > View XML Reports from the InRoads Main menu.

9. In the Bentley InRoads Report Browser, notice that the Style Sheet folder is located within the CDOT 
workspace.
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Workflow IR 2 - InRoads Feature Filters

This document guides you through the use of InRoads feature filters. 

InRoads Feature Filters

Purpose of using Feature Selection Filters

InRoads utilizes feature based digital terrain models (DTM). Often users find the need to sort, or filter, 
through the contents of various InRoads dialog boxes that allow the users to display, annotate, or 
review the contents of a DTM. By creating Feature Selection Filters, the user will more efficiently be 
able to:

 Identify or view different categories of features found in a DTM

 Create a selection set of specific features

Example Feature Filters

A variety of feature filters have been developed for the CDOT configuration. A user may elect to use 
the developed feature filters or build and/or refine filters to suit individual needs.

Feature filters have been created based on major categories such as Design, Hydraulics, Topography 
and pay item number. Additional filters have been developed to allow the filtering of select subsets 
within the major categories.

For example, the filter:

 T_* ……. will display only features beginning with the T-under bar designation (all topography features)

 T_Gate* (ALL)……. will display all features that relate to Topo_Gate. (i.e. T_Gate Barbed Wire, T_Gate 
Combination, T_Gate Chain Linked etc.)

 Pay Items 403*…… pay items beginning with the primary number 403

Example 1 - No Feature Filter

In the Locks toolbar shown below, the Feature Filter Lock is off, or deactivated, so the selected filter _All Topo 
Features is not active. If the Surface > View Surface > Annotate Feature command is selected, the 
Annotate Feature dialog box would display all features located in that particular DTM in the Features list.
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Note: Features within a Feature Filter can be verified by executing the View Features, Edit Feature, or 
Annotate Feature commands.
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Example 2 - Applied Feature Filter

To display the results of the selected Feature Filter, in this case _All Topo Features, the Feature Filter Lock 
is simply toggled on, or activated, and the filter will then sort the assigned features. Notice in the Annotate 
Feature dialog box shown below, the features are displayed once the filter is activated, when compared to 
Example #1 when the filter was deactivated.

Creating a Selection Filter

1. From the Surface pull down menu Surface>Feature>Feature Selection Filter.
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2. In the Feature Selection Filter dialog box, create a name in the Filter Name field by <D> Save As…

3. In the Save Filter As dialog box, key in a name for the filter and <D> OK. The newly created filter name 
will appear in the Filter Name drop-down list in the Locks toolbar. 

Note: The Feature Filter drop-down list in the Locks toolbar has a limited amount of viewing display 
capability, so the filter name should be created accordingly.   

4. The first step in defining any filter is the Start With toggle. Toggle either All or None on. This selection 
allows the user to build the filter by adding or removing features with subsequent rules.

5. Complete the Build Selection section of the Feature Selection Filter dialog box by selecting an Attribute 
and keying in a Value, and selecting the appropriate Mode.
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Note: A wide variety of Attributes are available as criteria for building filters. These include display 
properties as defined by the feature style assigned to the features.

 

Note: The wild card symbol “*” is often used in filters created for CDOT. This particular symbol 
matches any number of characters at and following the location of the symbol.
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6. <D> Add Rule. The Current Results list box updates as rules are added, deleted, updated, or re-ordered.

 

7. Verify that the rule was added in the Rules list box.

8. Verify that the correct Feature(s) were added in the Current Results list box.
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9. <D> Save.

Note: The previous Feature Filter example was created by the use of only two rules: Exclude All Features 
and Include Style = T_A*. It should be noted that when creating rules, they can include any of the 
following attributes: style, name, description, parent, pay item, triangulation, etc. Multiple rules 
can be incorporated to further refine the filtering. The order in which the rules are listed in a filter 
is important. They are always read from top to bottom and build sequentially based on the Results 
that passed the previous rule. Also, be aware that when inputting value(s) as rules, the input is case 
sensative.
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Using a Feature Selection Filter

1. From the InRoads menu, select Surface>Feature>Feature Properties.

2. Verify that the Feature Filter Lock is toggled on. 

3. In the Locks Toolbar, use the Feature Filter drop-down list to select a Feature Filter.
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4. The selected Features will be displayed in the appropriate dialog boxes.

Note: Remember to disable the Feature Filter Lock when it is no longer needed.
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Workflow IR 3 - Update InRoads Features

This document is a guide for updating Digital Terrain Model (DTM) feature styles within InRoads.  These 
changes are necessary due to new feature styles being developed and modifications or deletions to previous 
feature style names in previous CDOT Configuration Releases.

Opening InRoads Files 

1. Open MicroStation and InRoads 

2. Load design DTM’s that have been created with a prior configuration. 

Note: Existing topographic DTMs will not require this update. The version of the CDOT configuration 
can be determined by pausing the cursor over the CDOT logo located on the Colorado DOT Task 
Tab.

Updating Digital Terrain Models Feature Styles

DTM Evaluation

Determine if the design DTM contains features that require re-association to any new or modified Feature 
Styles. This can be accomplished by Scrolling through the feature list in the Feature Properties dialog box, 
looking for entries colored red.

Note: The Feature Filter named CDOT v3.0 Update can be used to locate features in older DTMs that had 
style changes.

DTMs that require feature re-association

1. From the InRoads menu select Surface > Feature > Feature Properties.  The Feature Properties dia-
log will appear.
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2. Scroll through the Feature list until a red entry is found. 

3. Highlight the feature name that requires re-association.  In the example shown here, T_Bridge Curb is the 
selected feature.

4. In the Style section of the dialog box, select an appropriate Feature Style from the Primary and then <D> 
Apply.  

5. Continue updating other feature styles by repeating steps 5 and 6 until no features are displayed in red.

Note: To expedite the update process, sort the features by style and select several features that have 
common styles in a single selection.  Using this method, multiple features can have their Primary 
Feature Style updated in a single execution of the command.  Remember to hold down the 
<CTRL> or <SHIFT> keys while selecting features.

6. Once all feature styles have been updated, close the Feature Properties dialog box and toggle the Feature 
Filter lock off.

7. Save the DTM Surface.

Updating graphics

DTM features that are currently displayed in a MicroStation file will require redisplay to refresh the graphic 
display based on the new feature properties.
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1. From the InRoads menu select Surface > View Surface > Features.

2. Highlight all, or only the features that require redisplay, from the Feature list box and <D> Apply. Both 
the DTM and graphics display should now be up to date with the current CDOT configuration.
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Workflow IR 4 - Alignment Display in Cross 
Section

This document guides you through the process of displaying the location of alignments such as Right-of-Way 
locations in cross section or profile views.

Desired Result

The overall workflow is to export horizontal alignments to a surface as features with the appropriate 
feature styles assigned. A surface feature that is defined as having breakline properties can be displayed as 
a ‘crossing point’ in cross sections or profiles. A cell is used to indicate this ‘crossing point’. 
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Exporting the Alignment

1. Once the alignment has been created, as shown above, select File > Import > Surface from the InRoads 
menu. The Import Surface dialog will appear.

2. Select the From Geometry tab.

♦ Target Surface: Surface to be created or appended that will contain the alignment features

Proposed ROW - East

Existing ROW - East
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♦ Alignments: Alignments identified for importing

♦ Name: Set to Specify
♦ Seed Name: key-in the name of initial feature to be created. InRoads will automatically increment the 

seed name for multiple features.

♦ Style: Select RW_ROW-Existing or RW_ROW-Proposed
♦ Type: Breakline
♦ Point Density Interval: 0
♦ Duplicate Names: Rename is a good default setting

♦ Under Elevation: Set Source to Surface
♦ Under Elevation: Select the Surface for extraction of Elevation information for placement of the 

annotation.

Note: Existing and proposed alignments should be exported separately as they require different feature 
styles assignments.

3. <D> Apply to create or append the target surface

4. Repeat above steps to export additional alignments. Continue to Step 5 when all alignments have been 
exported.

5. Make sure that 12345ROWSurface01 is the Active Surface. From the InRoads pull down menu select 
Surface > Feature > Feature Properties the Feature Properties dialog box will appear.

6. Verify that the features were added to the surface.
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7. Select the features created and place a check in the Exclude from Triangulation check box

8. <D> Apply then <D> Close.

Note: Excluding the features from triangulation eliminates the possibility of the exported alignments 
becoming part of a surface (contoured) model. Features excluded from triangulation can be 
displayed in cross sections or profiles as crossing features, which is why these alignments were 
imported into the Surface as features.

9. Select Evaluation > Cross Section > Cross Sections 
(or Evaluation > Profile > Update Profile) to add, remove, or update the display for the new features.

10. <D> the Update Cross Section folder from the dialog box explorer.
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11. Highlight the Crossing Features leaf.

12. Select the desired Cross Section Set from the drop-down list.

13. Highlight the Display On radio button.

14. From within the Surface list box, highlight the surface containing the alignment features.
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15. In the Features list box, highlight the features to be displayed then <D> Apply. <D> Close to dismiss the 
window.
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Note: The InRoads global scale factor values should be set as they were when the cross sections were 
originally created. Additionally, the default vertical exaggeration for CDOT cross sections is a 
factor of 2:1. The feature styles used to place the cells depicting the ROW locations have been 
created at this ratio. See the following workflow to accommodate varying ratios.

Adjusting vertical distortion

Adjusting vertical scale of cells representing ROW limits can be accomplished in 2 ways. First is scaling the 
cells placed, second is temporarily modifying the named Symbologies used to place the cells.

Method One

1. Select the cells for scaling using the Element Selection, Power Selector, Select by Element, or by 
isolating the level(s) and using a Fence.

2. Select the MicroStation Scale command

3. Ensure that the scale lock is opened as shown in graphic under Step 5. Set X & Z scale factors to 1. 

4. Set the Y scale factor to the appropriate value (2:1 is the default in the configuration). This example used 
1:1 for the cross sections. Consequently, the cells are scaled (distorted) ½ the required amount.
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5. Place a check in the About Element Center check box (scales about the cell origin) .

6. <D> in the MicroStation view to execute the scale command.

Note: The cells should now be updated to the desired scale factor.

Method Two

The second method is to temporarily modify the named symbology used to place the annotation.

1. Select Tools > Style Manager to display the Style Manager dialog box. 

2. Toggle on Include Surface in the Show Styles with Properties area.
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3. Identify and highlight the appropriate feature style from the list and <D> Edit.

 

The named symbology that is associated with the feature style(s) used to create the features will be edited. 
In this example RW_ROW-Existing and RW_ROW_Proposed will be modified.

4. <D> the Surface Feature folder in the dialog box explorer.

5. Highlight the Symbology leaf.

6. <D> Edit in the Symbology section of the Edit Style dialog box. The Edit Named Symbology dialog box 
will appear.
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7. In the Edit Named Symbology dialog box, highlight the Cross Section Point and <D> Edit. The Point 
Symbology dialog box now appears.

Note: The Y Scale is set to 0.5 by default to compensate for the default vertical distortion of 2:1 as the 
cell is created proportionally correct as a 1:1 graphic. In other words, when creating a cross section 
at 2-Vertical:1-Horizontal, the cell would be stretched a factor of 2. The Named Symbology 
compensates for this by ‘offsetting’ the effect of vertical distortion.

8. Set the appropriate Y Scale For a cross section without a vertical exaggeration (1:1), input a value of 1 in 
the Y Scale field.

9. <D> OK in the Point Symbology dialog box. This closes the Point Symbology dialog box.

Note: Other useful values for scaling cells with MicroStation or symbology modification would be:

■ Vertical exaggeration    - Y Scale
1:1 –   1.0
2:1 –   0.5
5:1 –   0.2
10:1 – 0.1

10. <D> Apply then Close in the Edit Named Symbology dialog box. 
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11. Use the update commands for Cross Sections or Profiles to add, remove, or update the display for the 
required features.

12. Repeat the above steps for the Feature Style RW_ROW-Proposed.
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Workflow IR 5 - Annotating Horizontal and 
Vertical Alignments

This document demonstrates the procedure for displaying annotation for horizontal and vertical alignments. It 
further presents the workflow for annotating horizontal alignments that contain spiral components.

InRoads can display most alignment annotation as per the M&S standards. However some annotation will 
require editing and/or repositioning using standard MicroStation commands.

Annotating a Horizontal Alignment

Two InRoads commands are required to annotate a horizontal curve in the CDOT format. The first command 
(horizontal annotation) is used to display the linework and annotate the tangents. The second command 
(horizontal curve set annotation) is used to display the PI symbol, short tangents, and curve data. Once the 
InRoads annotation tools have been used the user needs to modify the text content and positioning to have it 
appear as per the M&S standards.

Display the alignment

This first example illustrates annotating a circular curve. This is followed by the workflow required for 
annotating circular curves with spiral transitions.

1. Display the horizontal alignment using Geometry > View Geometry > Horizontal Annotation. 
The View Horizontal Annotation dialog box is displayed.
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2. Select the correct alignment for display, <D> Apply then <D> Close.

3. Use the MicroStation Delete Element command to remove the curve annotation from the display, as this 
information will be re-displayed in the following steps.

Note: Prior to deleting the curve information, the MicroStation Graphic Group lock must be disabled 
(Settings > Locks). Otherwise the entire alignment will be deleted.

4. Display the curve annotation using Geometry > View Geometry > Curve Set Annotation. The 
Curve Set Annotation dialog box is displayed.

5. In the Main tab, select the correct Horizontal Alignment (SH 86 in this example) from the drop down 
list.
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6. <D> Preferences, as shown above, and choose the appropriate Spiral preference (Proposed Spiral was 
selected in this example). <D> Load and then <D> Close.

 

Note: The preferences established for spirals serve the dual purpose of annotating curves with either 
circular or spiral components. The central curve information required is common between the two 
types of geometry.

7. The InRoads Write Lock must be set to PEN mode prior to the next command. The curve requires 
annotation twice and PEN mode will retain previous annotation displays.

8. <D> Apply on the Curve Set Annotation dialog box. The central curve is annotated

9. <D> Preferences again and choose the appropriate Circular preference (Proposed Circular in this 
example). <D> Load then <D> Close.
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10. <D> Apply on the Curve Set Annotation dialog box. The remainder of the central curve information is 
annotated

Note: The M&S standards specify that curve information should include the Mean Design Speed (MDS) 
and Stopping Sight Distance (SSD) information. This information is not annotated by InRoads and 
will have to be added with MicroStation.

11. Select the MicroStation Edit Text command.

12. Select the desired text. The text editor will appear allowing the user to add the required information for 
MDS and SSD.
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13. Use MicroStation commands to reposition the text as desired.

14. If necessary, display the alignment stationing by selecting Geometry > View Geometry > 
Stationing.

Annotating a Horizontal Curve – Spiral Curve

The workflow is almost identical to the above steps 1-12. The exceptions are noted below.
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1. Display the horizontal alignment using Geometry > View Geometry > Horizontal Annotation.

2. Use the MicroStation Delete command to remove the central curve data leaving the spiral curve 
annotation intact.

Note: Prior to deleting the curve information, the MicroStation ‘Graphic Group’ lock must be disabled 
(Settings>Locks). Otherwise the entire alignment will be deleted.
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3. Follow steps 4-12 above to complete the annotation.

Annotating a Vertical Curve

Display the Alignment

1. The fist step is either have, or generate a profile view along the alignment using Evaluation > Profile > 
Create Profile.

2. Display the vertical alignment using Geometry > View Geometry > Vertical Annotation…

3. Select the appropriate Profile Set, Horizontal Alignment, and Vertical Alignment.
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4. <D> Preferences and highlight the preference for the appropriate symbology (Proposed in example 
below). <D> Load then <D> Close.

5. <D> Apply on the View Vertical Annotation dialog box to display the annotation.

6. Using the MicroStation Move command, relocate the tangent grade annotation to the short tangent lines.

Known Issues

1. The arrowheads in the vertical annotation are not user definable. They are hard-coded by the software as 
open arrow heads.
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Workflow IR 6 - Creating Combined Surfaces

This document explains the procedures for creating an exterior boundary, merging surfaces, and copying 
features from one surface to another. 

An exterior boundary eliminates inaccurate triangles that can occur in concave areas within the data.

The Merge Surfaces command can be used to create a single surface from two or more “existing” surfaces, 
update the “existing” surface with additional data, or to make an “as constructed” surface for the project by 
combining a proposed surface with an existing surface.

The Copy Portion of Surface command copies features (or portions of features) from one surface and places 
them in another surface. This can be used to create a new surface from elements of one or more other surfaces 
or to update a surface with data from another surface.

These tools can be used singularly or in conjunction with each other to achieve the desired results. The 
Creating an Exterior Boundary, Merging Surfaces, and Copy a Portion of a Surface sections will each have 
their own outline.

Creating an Exterior Boundary

An Exterior Boundary is a closed shape DTM feature that defines the area where triangulation can occur. 
InRoads will triangulate the surface (without an exterior boundary) across concave areas creating inaccurate 
triangles that could adversely affect proposed surface models. An exterior boundary will prevent the creation 
of false triangles outside of the actual data.

An exterior boundary should be created for a surface that does not currently have a boundary or for a surface 
that has been modified and now has usable data outside the current boundary.

Workflow Outline

The following outline describes the steps needed to create an exterior boundary for a surface along with a brief 
explanation of what each step does.

Creating an Exterior Boundary - To create an accurate exterior boundary, erroneous triangles are 
removed, the perimeter of the modified surface is displayed, and the perimeter graphic is imported as the 
exterior boundary.

Removing Inaccurate Triangles - A surface that does not contain an exterior boundary may contain 
triangles that do not represent actual data. Removing these triangles is essential to creating an accurate exterior 
boundary.

♦ Triangulate Surface - The Triangulate Surface dialog box has settings that allow the user to set the 
maximum length of a triangle leg. Because most erroneous triangles are long and narrow, setting a 
maximum length shorter than these triangles will remove many of them.

○ Command Used: View Triangles - Used to display the triangle data so that inaccurate triangles can 
be identified.

○ Measure Distance - Used to determine an appropriate maximum triangle length.

○ Triangulate Surface - Used to set a maximum triangle length, thus reducing the number of 
inaccurate triangles. 

♦ Delete Triangles - The Triangulate Surface command will get rid of many of the erroneous triangles, 
but not all of them. The Delete Triangle command is used to get rid of the rest.
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○ Commands Used: Delete Triangles - Used to remove erroneous triangles.

Creating an Exterior Boundary - Now that the surface triangles are cleaned up, the exterior boundary can 
be created.

♦ Displaying the Perimeter - The perimeter of the modified surface will be used as the exterior 
boundary.

○ Commands Used: 3D/Plan Surface Display - Used to display the surface perimeter.

○ View Perimeter - Used to display the surface perimeter. May be used instead of 3D/Plan Surface 
Display.

♦ Importing the Exterior Boundary - The final step is to import the z  perimeter as an exterior 
boundary feature. This will contain the triangles within the area of the data.

○ Import Surface - Used to create the exterior boundary feature.

○ Triangulate Surface - Use to incorporate the exterior boundary into the triangulated surface.

Creating an Exterior Boundary for a Surface Without One 

It may occur that a surface does not include an exterior boundary. If this is the case, an exterior boundary 
should be created and added to the surface. Adding the boundary will eliminate inaccurate triangles from 
the surface. Below is an example of a surface with no exterior boundary. The example is representative of 
what can happen when a boundary is omitted and a maximum triangle length is not defined. In the event of 
a missing exterior boundary, the software will calculate the inaccurate triangles shown in bold red below.

To create an exterior boundary for this surface three steps are required. One, the erroneous triangles are 
removed, two, the perimeter of the surface is displayed, and three, the MicroStation graphic representing 
that perimeter is then imported as an exterior boundary feature into the DTM.

Removing Inaccurate Triangles

Inaccurate triangles are usually long narrow triangles or those that span concave areas of a DTM. InRoads 
has two commands that can be used to reduce, then eliminate the number of inaccurate triangles, namely 
the Triangulate Surface and Delete Triangle commands. 

The Triangulate Surface command is used to set a limit on the length of a triangle edge, thereby 
reducing the number of inaccurate triangles. The Delete Triangle command is then used to eliminate the 
remainder of the inaccurate triangles. 

It should be noted that neither of these commands affect the data which was collected for the surface. The 
commands either modify the computation used to define triangles (in the case of Triangulate Surface) 
or delete specific triangles that have been defined (in the case of Delete Triangle).
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Triangulate Surface

There is no definitive rule for setting the Maximum Length when triangulating a surface. If the length is 
set too short, triangles will not be defined in areas they should be, forming holes where good data was not 
used. Below is an example of a surface whose Maximum Length is set too short.

When the length is set to long, an undesirable number of inaccurate triangles will remain. A general rule of 
thumb is to err on the long side. It is better to have the inaccurate triangles that can later be deleted than to 
lose data. 

To get an idea of what Maximum Length to use, display the surface’s features and triangles. Look for the 
longest triangles that lie within the data area (there is no need to be exact here, the object is to get an idea 
for the Maximum Length). Measure the long side of the triangle and use that as a starting point.

1. Select Surface > Update 3D/Plan Surface Display. The Update 3‐D/Plan Surface Display dialog 
box is displayed.

Note: If available, reference files showing the location of survey data can be used to view the DTM 
features without having to display them.

2. In the Update 3D/Plan Surface Display dialog box, set the Mode to Display On.

3. In the Surfaces drop down menu, select the desired surface.

4. Below the Surface drop down menu are a number of toggles. Toggle on Triangles.

5. Right click in the Features list at the bottom of the dialog box and choose Select All from the menu.
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6. The items selected are automatically displayed if they were not previously displayed.   If some of these 
items were previously displayed in the dgn file, <D> Refresh All to update those existing items.

7. Scan the triangles displayed and identify a large triangle within the data area. 

8. Select the MicroStation Measure Distance command. 

9. In the Measure Distance tool settings box, set the Distance to Between Points.

10. <D> at one triangle corner then the other. The distance measured will be displayed in the tool settings box.
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11. From InRoads select Surface > Triangulate Surface. This displays the Triangulate Surface dialog 
box.

12. In the Surface drop-down, select the surface.

13. In the Maximum Length field, key in the desired length. Because this length is just an estimate, it is 
advisable to increase the measured length as a buffer.

14. <D> Apply to launch the command. 

Note: In the example above, the measured distance of the triangle edge was 757.993’. Because this may 
not be the biggest triangle within the data, 800’ is used for the Maximum Length to insure all 
actual data is included.

15. Go back to the Update 3D/Plan Surface Display dialog box and <D> Refresh All to will re-display the 
triangles as computed using the Maximum Length set above.
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16. Examine the triangles to be sure no actual data was lost. Look for features not connected by triangles. If 
good triangles were lost, go back to the Triangulate Surface dialog box, increase the Maximum Length 
and Apply the new settings. Repeat this process as necessary until the desired results are obtained.

In the example above, most of the inaccurate triangles have been deleted by setting the Maximum Length 
and re-triangulating the surface. The remainder will be eliminated using the Delete Triangle command.

Delete Triangle

Now that the number of inaccurate triangles has been reduced to a manageable level, the rest can be 
removed easily with the Delete Triangle command.

1. Zoom in on the area where triangles are to be deleted.

2. From InRoads, select Surface > Edit Surface > Delete Triangle. This displays the Delete Triangle 
dialog box.
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3. In the Delete Triangle dialog box, use the Surface drop-down to select the desired surface.

4. <D> Apply.

5. The Delete Triangle dialog box will minimize. <D> inside the first triangle to be deleted, then move the 
cursor through other adjacent triangles that are to be deleted. Be sure not to pass through triangles you do 
not want to delete. The triangles will highlight as they are passed through.

6. After the last triangle in the group is selected, release the left mouse button to end triangle selection. The 
Accept/Reject prompt is displayed. <D> to confirm deletion of the triangles, <R> to reject the selection.

7. Using the same process, delete the remaining inaccurate triangles. After all of the desired triangles are 
deleted, <D> Close to dismiss the Delete Triangle dialog box.

Note: Do not re-triangulate the surface until the exterior boundary is added to the DTM. Otherwise all 
deleted triangles will regenerate.
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Creating the Exterior Boundary

After the triangles have been edited, the exterior boundary can be created. To create the boundary, the 
perimeter of the triangulated area will be displayed and that perimeter will be imported as the exterior 
boundary.

1. From the InRoads dialog box, select Surface > Update 3D/Plan Surface Display.

2. In the Surfaces list box, select the desired surface.

3. Toggle on Perimeter. All other toggles should be off and all features in the list deselected. This will turn 
off the display of the triangles and the features.

 <

4. To complete the exterior boundary process, the perimeter must now be imported as a feature into the 
surface. 

5. From InRoads, select File > Import > Surface. The Import Surface dialog box will be displayed. 

6. Select the From Graphics tab. Select the desired surface from the Surface drop-down.

7. Select Single Element from the Load From drop-down.

8. Verify that Elevations: is set to Use Element Elevations.

9. In the Features area of the dialog box, key in DTM_Exterior in the Seed Name field.
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10. From the Feature Style drop-down list, select DTM_Exterior.

11. From the Point Type drop-down list, select Exterior.

12. After the specified changes are made, <D> Apply.

13.  <D> on the boundary shape. The shape will highlight. <D> again in the blank area of the screen to accept 
the element and add it to the surface. Dismiss the Import Surface dialog.

14. To verify that the data was imported, select Surface > Feature > Feature Properties. This displays 
the Feature Properties dialog box.

15. Verify that the desired surface is selected in the Surface drop-down.

16. Verify that DTM_Exterior appears in the Feature list box. Also verify that the Feature Type is set to 
Exterior in the Triangulation area.

17. To complete the process, the surface must be re-triangulated.
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Merging Surfaces

The InRoads Merge Surfaces command is used to create a single surface from two surfaces. The surfaces being 
merged must be adjacent or overlapping. The merging of surfaces that are not adjacent or overlapping would 
result in inaccurate triangles between the areas of data.

In the examples below, the original surface is being extended by using information contained in an additional 
surface. The solid line represents the perimeter of the “Original” surface. The dashed line represents the 
perimeter of the additional surface to be merged, identified as the “Design” surface in the Merge Surfaces 
dialog box.

Workflow Outline

Merge Surfaces - Merging surfaces creates a single surface from two surfaces. If one surface is not fully 
contained within the limits of the other, an exterior boundary for the merged surface must be built also.

♦ Merge Surfaces - This combines two surfaces.

○ Commands Used: - Merge Surfaces - Used to create the combined surface.

○ Feature Properties - Used to identify residual exterior boundary features.

○ Delete Feature - Used to remove residual exterior boundary features.

♦ Creating an Exterior Boundary for the Merged Surface - Once the surfaces are combined a 
new exterior boundary is required to contain the data. This boundary will be created using the 
boundaries from the original surfaces.other boundary.

○ Commands Used: View Features - Used to display the exterior boundaries from the two original 
surfaces.

○ Place Fence - Used to define a fence around one of the exterior boundarys. This will be used to 
clip the other boundary.

○ Delete Fence Contents - Used to clip the exterior boundary not fenced.

○ Partial Delete - Used to clip the other boundary so that the two clipped lines can be used to 
create the new boundary.

○ Create Complex Shape - Used to combine the two clipped features into a single element that 
will be imported for the new boundary.

○ Import Surface - Used to create the exterior boundary feature.

○ Triangulate Surface - Use to incorporate the exterior boundary into the triangulated surface.
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Prerequisites

Before two surfaces can be merged, they must both be opened in InRoads. 

1. From InRoads main menu, select Surface > Edit Surface > Merge Surfaces. This will result in the 
display the Merge Surfaces dialog box.

This command operates with three surfaces; the original surface, the design surface, and the 
destination surface which will be created upon execution of the command.

♦ Original Surface- This is the surface whose features can be deleted or partially deleted in areas that 
overlap with the merging (Design) surface. Typically, this will be the Existing surface received from 
ROW/Survey, however it can be any surface. If the original and design surfaces overlap, the common 
area between the two will be occupied by data from the Design Surface and data from the Original 
Surface may be removed, depending on the toggle settings described below.

♦ Design Surface- This surface usually contains additional existing surface data or the Finished Grade 
surface generated from Roadway Modeler. Design Surface data can either replace or supplement the 
Original Surface data in areas where they overlap depending on the toggled setting Retain All 
Original Surface Points. In the illustration below, the shaded area shows the overlap between the 
original and design surfaces. The data from the Original Surface in this area will be deleted and only 
the Design Surface data will remain unless Retain All Original Surface Points is toggled on.
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Note: The Original Surface and the Design Surface remain intact. The Retain All Original Surface 
Points setting only affects the creation of the Destination Surface. 

♦ Destination Surface- This surface stores the results of the Merge command.

2. Use the pull downs in the Surfaces area of the dialog box to select the desired surface for Original, 
Design, and Destination. If a destination surface has not previously been created or loaded, it can be 
created “on the fly” by typing the desired name in the Destination field.

3. The next area of the Merge Surfaces dialog box contains four toggles: Retain All Original Surface 
Points, Retain Features Excluded from Triangulation, Merge Selected Areas from Original, 
and Add Design Surface Edge as Breakline.

♦ Retain All Original Surface Points- When checked on, all of the original surface’s features will be 
stored in the destination surface. When checked off, the original surface features that cross into the 
design surface’s perimeter will be clipped at the perimeter leaving only the design surface’s features in 
that area. By default the option is checked off. 

♦ Retain Features Excluded From Triangulation- When checked on, features excluded from 
triangulation from the original surface, like underground utilities, will be stored in the destination 
surface, regardless of their relationship to the design surface. When checked off, features excluded 
from triangulation will be treated as any other feature in the original surface. Un-triangulated features 
from the design surface by default are always included in the destination surface.

 A Destination surface name can be keyed 
in here to create the surface “on the fly”. 
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♦ Merge Selected Areas from Original - When toggled on, Merge Surfaces scans the active selection set 
for closed shapes (these are MicroStation elements selected with the Element Selector tool). Data from 
the original surface inside the shape is used to replace any data from the design surface in that area. If 
Add Design Surface Edge as Breakline is turned on, boundary features are added for each 
selected shape.

♦ Add Design Surface Edge as Breakline- When checked on, the perimeter of the design surface is added 
to the destination surface as a breakline. This will ensure that the design surface maintains its original 
triangle structure. When off, the perimeter is not added and the design surface’s triangle structure can 
be modified by the original surface data. This option should be turned on when creating an “as 
constructed” surface. It should be turned off when extending or modifying the existing surface.

4. Turn on or off the toggles as desired.

5. The Merge Surfaces dialog box contains an area for including and excluding design features from the 
destination surface. In the Included Design Surface Features area, highlighted features will be added to the 
destination surface and un-highlighted features will not. By default all features are highlighted. 

Note: Because this is an example of extending a surface, the Exterior Boundary of the design surface is 
not highlighted. When creating an “as constructed” surface leave all the features on.

6. Options for resolving feature naming conflicts are located at the bottom of the settings box under Duplicate 
Names. The options are:
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♦ Append- This adds the points from the new feature to those of the existing feature, making one feature 
out of the two. The combined feature will have a discontinuity (a gap) from the last point of the 
existing feature to the first point of the new feature.

♦ Replace- The existing feature will be deleted and replaced by the new feature with this option.

♦ Rename- The new feature will be renamed by appending a ‘1’ to the end of the name.

7. By default the Rename option is selected.

8. Once the desired settings are made, <D> Apply to execute the command. If the destination surface did not 
exist when the command was launched, it will be created now. After the command has been run, the 
destination surface will be added to the file list in the main InRoads interface. The Merge Surfaces dialog 
box can now be dismissed.

`



Colorado Department of Transportation   CCS- 15

CDOT  Workflows  Creating Combined Surfaces

9. If the design surface was at least partially outside the area of the original surface (as is the case in this 
example), a random feature will be created in the combined surface using the original surface’s exterior 
boundary name. This feature should be deleted prior to creating the new exterior boundary. To determine if 
the random exterior boundary feature was created, look at the Feature list in the Feature Properties dialog 
box (Surface > Feature > Feature Properties).

10. If the design surface is entirely within the area of the original surface, the original surface’s exterior 
boundary should be retained.

11. To delete the random feature that uses the original surface’s exterior boundary name, select the InRoads 
command Surface > Edit Surface > Delete Feature.

12. The Delete Feature dialog box will be displayed. Use the Surface drop-down to select the merged surface.

13. From the Features list, highlight the exterior boundary feature (this will usually be named DTM Exterior). 
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14. <D> Apply. A “Delete selected feature(s)?” warning message will display. <D> OK to complete the 
deletion. The Delete Feature dialog box can be dismissed. It is advisable not to re-triangulate the surface 
until a new exterior boundary is added.

15. The combined surface is now ready for a new exterior boundary. 

Creating an Exterior Boundary for the Merged Surface

To create the exterior boundary for the merged surface, the exterior boundaries of the source surfaces will 
be used. This will only be required if the design surface used in the Merge Surfaces operation lays at least 
partly outside the area of the Original surface. If the design surface is entirely within the area of the 
original surface, the original surface’s exterior boundary will be retained and this process can be omitted.

1. Select Surface >View Surface > Features from the InRoads dialog box.
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2. This will result in the display of the View Features dialog box. From the Surface drop-down, select the 
Design surface, 12345_Additional in this example, see Merging Surfaces Step 2.

3. By default, all of the features are highlighted. <D> on the exterior boundary feature (Exterior Boundary in 
this example) so that only the exterior boundary feature is highlighted. 

4. <D> Apply to display the exterior boundary feature. Do not dismiss the View Features dialog box yet, as 
it will be used again.

Place a fence using the exterior boundary of the design surface as the fence shape. By placing the fence, the 
exterior boundary of the original surface can be displayed clipping out the overlapping area so that less 
editing is required to finish the new exterior boundary.
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5. Select the Place Fence command from the MicroStation Main toolbar. Set the Fence Type to Element 
and Fence Mode to Inside.

6. Select the design surface’s exterior boundary displayed in Step 3 above. Left click again, anywhere in the 
view to accept the element. This places a fence on the element.

7. Go back to the View Features dialog box. Set the Surface to 12345_Existing (the Original surface from 
Merging Surfaces step 2).

8. Using the Fence Mode drop-down, select the Outside option. This will only display the part of the 
original exterior boundary that is outside of the design exterior boundary.

9. Highlight the DTM Exterior boundary feature only. <D> Apply to display this feature. The View 
Features dialog box can now be dismissed.
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10. Dismiss the fence by selecting the Place Fence command again. The results of this operation will look 
similar to the example below:

In order to get the element ends to match properly, use the following procedure, starting with selecting the 
Partial Delete command from the MicroStation Main Task toolbar:

11. Move the cursor near the end of the original exterior boundary (solid line) and <T> (left/right cord or 
middle mouse click, depending on the mouse settings). 

12. <D> to accept the snap. The original boundary will be highlighted.

13. Next, <R> (right mouse click). This will un-highlight the original boundary and highlight the design 
boundary (dashed line) where the two meet.

14. To identify the direction of the partial delete, move the cursor along the part of the element to be deleted 
and <D>.

15. <T> to the other end of the original exterior boundary.
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16. <D> to accept the snap and complete the partial delete.

The result will be two elements that represent the desired extent of the exterior boundary of the merged 
surfaces. 

17. Next, a closed shape must be made of the two elements. Select the Create Complex Shape command 
from the MicroStation Main toolbar. From the Method drop-down list select Manual.
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18. <D> on element one (solid line) then <D> on element two (dashed line). <D> once more in a blank area on 
the screen to finalize the command.

The shape is now ready to be incorporated into the combined surface as an exterior boundary. 

19. From InRoads, select File > Import > Surface. The Import Surface dialog box will be displayed. 

20. Select the From Graphics tab. Select the combined surface created with the Merged Surfaces command 
(Merge Surfaces step 2 above) from the Surface drop-down.

21. Select Single Element from the Load From drop-down.

22. Select Use Element Elevations from the Elevation drop-down.

23. In the Features area of the dialog box, key in DTM_Exterior in the Seed Name field. This will not 
appear in the drop down list because the original exterior boundary features were deleted from the surface.

24. In the Feature Style drop-down, select DTM_Exterior.

25. Using the Point Type drop-down, select Exterior. 
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26. After the above settings are made <D> Apply.

27. <D> on the complete boundary shape created earlier. The shape will highlight. <D> again in a blank area 
on the screen to accept the element and add it to the merged surface. Dismiss the Import Surface dialog 
box 

28. To verify that the data was imported, select Surface > Feature > Feature Properties. This displays the 
Feature Properties dialog box.

29. Verify that the merged surface is selected from the Surface drop-down list.
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30. Verify that DTM_Exterior appears in the Feature list box. Also verify that the Feature Type is set to 
Exterior in the Triangulation area.

31. To complete the process, the surface must be re-triangulated.

32. From InRoads select Surface > Triangulate Surface. The Triangulate Surface dialog box is displayed. 
One could also right click on the surface name in the InRoads Explorer and select Triangulate from the 
menu.

33. From the Surface drop-down list, select the merged surface.

34. In the Maximum Length field, key in the desired length. This option will automatically remove any 
triangles that have at least one edge longer than the specified distance. Zero indicates no restriction to 
length. Because the surface has an exterior boundary, ‘0’ should be used to ensure that all of the data is 
included in the triangulated surface.
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35. <D> Apply to execute the command.

36. When the command has finished processing, surface information will be displayed in the Results area of 
the Triangulate Surface dialog box. The exterior boundary is now part of the surface and the Triangulate 
Surface dialog box can be dismissed.

37. Now that the merged surface is complete, it should be saved.

38. From InRoads, select File > Save > Surface. If the surface has been saved previously, the updated data 
will be written to the DTM file. If the surface has not been saved before, then a new DTM file will be 
created. One could also right click on the surface name in the InRoads Explorer and select Save from the 
menu.

39. The Save As dialog box will display. Use the Save In drop-down to specify the desired folder for the DTM.

Next the file name must be specified. There are two ways to do this; one, by keying in a filename (not 
recommended), or two, by selecting the surface from the Active list at the bottom of the dialog box. 
Selecting the surface from the Active drop-down will ensure that the DTM has the same name in InRoads 
memory as it does on the hard drive.
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40. Select the down arrow on the Active drop-down then highlight the desired surface. This should be done 
even if the desired surface is already displayed in the Active drop-down. Selecting the surface in the Active 
drop-down will auto-populate the File Name field with the surface name. 

41. <D> Save to add the file to the ‘Save In’ directory. After the file has been saved the Save As dialog box 
can be dismissed (<D> Cancel).

Copy a Portion of a Surface

There may be occasions when only a portion of a surface is needed. For example, one might wish to extend 
their existing DTM with a few hundred feet from an adjacent project or perhaps specific features from one 
surface are required in another. Both copying an area of a surface, and copying whole features can be 
accomplished using the Copy Portion of Surface command.

Two examples will be used to illustrate the Copy Portion of Surface command. In the first, all of the features 
within a given area will be copied into a new surface. In the second example specific features will be copied 
into a new surface.

Workflow Outline-

Copy a Portion of a Surface - This command can be used to copy part of a surface, either an area or 
individual features, to a new DTM file.

♦ Commands Used: Copy a Portion of a Surface - Used to create a new surface from part of another 
surface. The new surface can come from a region of the original surface (defined by a fence or shape) 
and/or by selected features.

Example 1 – creating a subset of a DTM

In this example, all of the surface data in the box will be copied to create a new surface. 
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1. A MicroStation fence is used to identify the data to be copied. Select the Place Fence command from 
the MicroStation Main toolbar. Place the fence around the area to be copied. The blue box in the illustra-
tion below shows the location of the fence.

2. From InRoads, select Surface > Edit Surface > Copy Portion of Surface. The Copy Portion of 
Surface dialog box is displayed.

3. In the Copy Portion of Surface dialog box, from the Source Surface drop-down list select the surface to be 
copied from.
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4. From the Destination Surface drop-down list select the surface to be copied to. If the surface does not 
exist, the name for the new surface can be keyed in here.

5. Select Inside from the Fence Mode drop-down.

6. To select all the features from the Features list box, right click in the Features list box and choose <D> 
Select All.

7. For Duplicate Names, toggle on the Rename option.

8. <D> Apply to initiate the command. The Copy Portion of Surface dialog box will minimize then reappear 
when the process is completed. Dismiss the dialog box. 

9. From the InRoads dialog box, select File > Save > Surface and save the surface. The newly created 
surface is now ready for use once it’s been triangulated.

Example 2 -Copying a single element or multiple elements

In this example, the Edge of Gravel Road features will be copied into a new surface. The fence will not be 
used in this example because the whole feature is to be copied.

1. From InRoads, select Surface > Edit Surface > Copy Portion of Surface. The Copy Portion of 
Surface dialog box is displayed.
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2. In the Copy Portion of Surface dialog box, use the Source Surface drop-down to select the surface to be 
copied from.

3. Use the Destination Surface drop-down to select the surface to be copied to. If the surface does not exist, a 
name to be used for the new surface can be keyed in here.

Note: The Fence Mode drop-down is grayed out because no fence is present. If a fence is present, select 
the Ignore option to copy the whole element. If the fence is defining an area to be copied or not to 
be copied then set the Fence Mode as needed.

4. In the Features area, find the desired features in the list and highlight them individually. Hold the Ctrl key 
down to select a group of individual features or hold the Shift key to select a block of features.

5. For Duplicate Names, toggle on the Rename option.

6. <D> Apply to initiate the command. The Copy Portion of Surface dialog box will minimize then reappear 
when the process has completed. Dismiss the dialog box.
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7. To verify that the data was copied, select the InRoads command Surface > Features > Feature 
Properties. The copied features should appear in the Feature list box. 

Note: The destination surfaces in the above examples were empty, newly created surfaces. However, the 
same process will work to copy portions of a surface into another preexisting surface. This, along 
with Creating an Exterior Boundary can be used to merge two adjacent, non-overlapping, 
surfaces.)

Note: The Parent field in the Feature Properties dialog can be populated on a feature level in their 
respective DTMs prior to the merging or copying of features. Doing so allows the user to track 
where data originated. Any changes made require the surface to be saved for those changes to be 
retained for subsequent use.
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Workflow IR 7 - Displaying Features in Cross 
Section and Profile

This document is a guide for displaying features in both cross sections and profiles. Two types of cell 
placement will be considered in this workflow. One type is based on true scale meaning that the feature has a 
measurable size. For example a 24” pipe. The other type of cell is the pictorial location of a crossing feature for 
example overhead electric line. In order to compensate for the two types each needs to be scaled differently. 
Feature Filters have been developed to display them at their appropriate scale.

Cross Section

Workflow Outline-

Creating Cross Sections - Cross sections are used to evaluate a design surface. 

♦ Commands Used: Global Scale Factor - Used to set size for text and cells displayed by InRoads.

♦ Create Cross Section - Use to make the set of cross sections.

Displaying True Scale Cells - These are cells that represent actual design elements like drainage culverts 
and pipes. These items should be displayed at their actual size (allowing for vertical exaggeration).

♦ Commands Used: Global Scale Factor - Used to set size for text and cells displayed by InRoads. 
Use a cell factor of 1 when displaying True Scale Cells. 

♦ Feature Filter Lock - Use to show only True Scale features in the dialog box. This will help to 
prevent the user from selecting the wrong feature

♦ Update Cross Section > Crossing Features - This command is used to display the feature points 
in the cross sections.

Displaying Plot Cell Scale Cells - These are informational cells that identify the location of linear features 
like right-of-ways, existing pavement edges, and utility lines.

♦ Commands Used: Global Scale Factor - Used to set size for text and cells displayed by InRoads. 
Use the same scale factor that was used when the cross sections were created. 

♦ Feature Filter Lock - Use to show only Plot Scale features in the dialog box. This will help to 
prevent the user from selecting the wrong feature

♦ Update Cross Section > Crossing Features - This command is used to display the feature points 
in the cross sections.
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Displaying Features in Cross Sections

Note: Example Cross Section

The procedure for displaying features in cross sections follows.

1. Verify that the Global Scale Factor is set to the desired scale prior to creating the cross sections.

2. From the InRoads, menu select Evaluation > Cross Section > Cross Sections. The Create Cross 
Section dialog box will appear. <D> Preferences to load the appropriate saved preferences. In this 
example the CDOT preferences will be used.
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3. On the Include leaf in the Cross Sections dialog box, verify that Crossing Features and Projected 
Features are checked off.

4. <D> Apply. The dialog box will minimize allowing the selection of the origin for the cross section set 
with a <D> in a MicroStation View.

Display True Scale Cells

1. <D> the Update Cross Section folder in the dialog box explorer.

The first set of features to display will be the features that are defined to be true scale. These features have a 
defined size, such as pipes. In order to display these types of features, setting the scale factor and feature filter 
is required prior to displaying.
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2. Change the InRoads Scale Factor to 1.

Note: Scale Factor should be 1:1 for true scale cells so that cells come in at actual scale.

3. From the Locks toolbar Select the CELL_True-Scale filter from the drop-down list and toggle on the 
Feature Filter lock button.

4. Verify the correct Cross Section Set selected.

5. <D> the Crossing Features Leaf.

6. Toggle on the Display On radio button. 

7. From the Surface list box, select the surface name or names to display. The Feature list box will then 
populate with the list of features found in the highlighted surface(s). Use the Ctrl or Shift keys to select 
multiple names. Also, by right clicking in the Feature list displays a menu that can be used to select all of 
the features.

Note: The feature names in bold are Feature Styles that can be displayed in cross sections. Any names 
that are dithered are not configured to be displayed in a cross section view.
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Note: If no features are shown in the feature list box, there are no features that meet the criteria for the 
filter selected in step 5. It may be necessary to associate the correct feature styles to the desired 
features if this is the case. Feature styles can be re-associated by using the Surface > Feature > 
Feature Properties command. See CDOT Update InRoads Features.pdf for more information 
on the process involved.

8. <D> All (lower right corner of dialog box). The Features that can be displayed in cross section view will be 
highlighted.

9. <D> Apply. The dialog will minimize as the features are generated in the cross sections. When the 
process is finished, the dialog will reappear.

Displaying Plot Scale Cells

The second set of features to display is those that have location only defined with annotation. In order to 
display these types of features, the scale factor and the desired feature filter must be set prior to displaying.

1. Change the InRoads Scale Factor to 20.

Note: This is the desired plot scale for the set of Cross Sections we are working with. The scale should be 
changed accordingly to match the scale of the original cross sections.

2. From the Locks toolbar select the CELL_Plot-Scale filter from the pull down list. Verify that the feature 
filter is toggled on.

 

3. Verify that the correct Cross Section Set is selected.

4. <D> the Crossing Features Leaf.
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5. From the Surface list box, select the surface name or names to display. Once a surface or surfaces are 
selected, the Feature list box will populate with the list of features. Use the Ctrl and Shift keys to select 
multiple feature names. Also, by right clicking in the Feature list displays a menu that can be used to select 
all of the features.

Note: The names in bold are Feature Styles that can be displayed in cross sections. Any names that are 
dithered are not configured to be displayed in a cross section view.

6. <D> Apply. The Update Cross Section dialog box will minimize as the features are generated in the cross 
sections. When the process is finished, the dialog will reappear.
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Profile

Displaying Features in Profile

Note: Example Profile

The procedure for displaying features in profiles follows.

1. From the InRoads menu, select Evaluation > Profile > Create Profile. The Create Profile dialog box 
will appear. <D> Preferences to load the appropriate saved preferences. In this example the CDOT 
preferences will be used.

2. In the Create Profile dialog box, verify on the Include leaf that Crossing Features and Projected 
Features are checked off.
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3. <D> Apply. The Create Profile dialog box will minimize allowing the selection of the origin for the 
profile set. <D> in a MicroStation View to specify this location. After the profile is created <D> Close.

4. From the InRoads menu select Evaluation > Profile > Update Profile. The Update Profile dialog box 
will appear.

The first set of features to display will be the features that are defined to be true scale meaning the features 
have a defined size such as pipes. In order to display these types of features, set the scale factor and feature 
filter prior to displaying.

5. Change the InRoads Scale Factor to 1.

6. From the Locks toolbar select the CELL_True-Scale filter from the drop- down list and toggle on the 
Feature Filter lock.

7. Verify the correct Profile Set is selected in the Update Profile dialog box.

8. For the Mode, select the Display On radio button
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9. <D> the Crossing Features leaf.

10. From the Surfaces list box, select the surface name or names to display. Once surfaces have been selected, 
the Crossing Features list box will populate with the list of features. Use the Ctrl or Shift keys when you 
want to select multiple Surface names.

Note: The names that are black are Feature Styles that can be displayed in profile. Any names that are 
dithered are not configured to be displayed in a profile view.
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11. <R> in the Crossing Features list box and choose Select All from the menu.

12. <D> Apply. The dialog will minimize as the features are drawn in the profile. When the process is 
finished the dialog will reappear.

Displaying Plot Scale Cells

The second set of features to be displayed is those that have location only defined with annotation. In order to 
display these types of features, set the scale factor and the desired feature filter prior to displaying.

1. Change the InRoads Scale Factor to 20.

Note: This is the desired plot scale; change accordingly.
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2. From the Locks toolbar select the CELL_Plot-Scale filter from the pull down list and toggle on the 
Feature Filter lock.

 

3. Verify the correct Profile Set is selected in the Update Profile dialog box.

4. <D> the Crossing Features leaf.

5. For the Mode, select the Display On radio button.

6. From the Surfaces list box, select the surface name or names to display. Use the Ctrl or Shift keys when 
you want to select multiple Surface names.

7. <R> in the Crossing Features list box and choose Select All from the menu.

 

Note: The feature names that are black are Feature Styles that can be displayed in profile. Any names 
that are dithered are not configured to be displayed in a profile view.
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8. <D> Apply. The Update Profile dialog box will minimize as the features are generated in the profile. 
When the process has completed the dialog will reappear.
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Workflow IR 8 - Plan & Profile Generator

This document guides you through using the Plan and Profile Generator command in InRoads. The InRoads 
Plan and Profile Generator can be used for:

 Creating Roadway plan sheets depicting both plan and profile views on a single sheet.

 Full plan view sheets and double plan sheets (suitable for Roadway or Right-of-way plans).

 Full profile view sheets and double Profile Sheets.

Workflow Outline

Open Profile DGN File and Plan and Profile Generator - When the Plan and Profile Generator 
command is executed, it creates the profiles for the sheets first. Therefore, the dgn file that will contain the 
profiles must be opened at the time the command is launched.

♦ Command Used: MicroStation File > Open - Used to open a dgn file for editing. 

♦ Drafting > Plan and Profile Generator - This opens the dialog box use to generate plan sheets.

User Input for Plan and Profile Generator - This command requires a number of user inputs to obtain the 
desired results. These inputs are entered on various tabs within the Plan and Profile Generator dialog box. The 
inputs 

♦ Global Scale Factor - Used to set the InRoads text size. Set this before the command is executed.

○ Command Used: Tools > Global Scale Factor - Used to set the size factor for text and cells.

♦ Main Tab - This tab is used to set the Preference, alignment used, station extents, etc.

○ Preferences - Used to set the basic settings for most of the tabs. This should be selected before 
any other settings are made.

○ Horizontal Alignment - Used to define which alignment the plan and profile sheets will follow.

○ Station Limits - Used to define where along the horizontal alignment the sheets are made and how 
long each sheet will be.

♦ Plan Controls Tab - Used to specify the Reference Files used for the plan part of the sheet.

○ Model Files button - Used to select reference files for the plan section of the sheets.

♦ Profile Controls Tab - Used to set the profile preference, size, and data used.

○ Profile Preference - This determines some of the basic profile settings, like vertical 
exaggeration.

○ Vertical Alignment - Used to adjust the profile settings to accommodate the data.

○ Corridor - Used to specify which corridor will be used for superelevation data.

○ Surface - Used to specify which surfaces are displayed and which surface controls profile shifts.

○ Profile Elevation Shifts - Used to specify where profile shifts occur.

♦ Sheet Layout Tab - Used to specify the name for the plan sheets and identify the seed file used to 
create them.

○ Host File - Used to specify the name for the plan sheets.

○ Seed Host File - Used to specify the seed file used to create the plan sheets.

♦ Border and Title Tab - Used to specify the sheet border cell to be used for the plan sheets.

○ Cell > Name - Used to specify the sheet border cell to be used for the plan sheets.
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♦ Symbols and Details Tab - Used to specify two cells to be placed on each sheet.

○ North Arrow > Cell Name - Used to specify the north arrow cell to be used on the plan sheets.

○ Miscellaneous > Cell Name - Used to specify any other cell to be used on every plan sheet.

Editing Sheet Definitions - InRoads does not always create the sheets as the user desires. The following tabs 
are used to adjust the sheets.

♦ Main Tab - This tab is used to adjust sheet extents and add additional reference files to sheets.

○ Plan Views > Use Plan Views - This toggle tells InRoads to use the defined plan view settings 
instead of recreating these settings based on the station limits.

○ Plan View List - Used to select individual plan view definitions for editing.

♦ Sheet InDex Tab - Used to navigate between plan sheets and to adjust the location of reference files.

○ Sheet Index List - Used to select a plan sheet for display or editing.

○ Show Sheet Button - Used to open the selected sheet in MicroStation.

○ Regenerate Sheet Button - Used to recreate the selected sheet with data modified on the Main 
tab and the Sheet Index tab.

○ Delete Sheet Button - Used to remove a sheet from the plan list.

○ Sheet Views List - Use to select and edit the location of the Plan and Profile reference fiels.

Required Resources:

Before you begin, a number of resources are required for this command. 

Horizontal Alignment ‐ Plan view limits are defined relative to a horizontal alignment (length and right/left 
offsets). Therefore, a project specific Geometry Project must be loaded into memory.

Digital Terrain Models - Profile view limits are determined by the vertical relief of profiled DTM’s. At least 
one project specific DTM must be loaded into memory.

Cells - Cells are used to place the Drawings border and north arrows. The cell library 
General.cel must be attached for the Plan and Profile Generator to operate correctly.

Border Sheet - A Cell is used to generate the border sheet and is placed in each drawing created.

Source cell library: 

C:\Program Files\Workspace‐CDOT\Standards‐Global\MicroStation\cells\General.cel 

Cell Placed: SHEET_Design‐Sheet

Scale - Before the P&P command is run, the user needs to determine the final plot scale of the drawings being 
created. Current preferences exist for 20, 40, 50, 100, 200, and 500 scale plots. This is reflected on specific tabs 
within the command. See below for additional information.

Under Tools > Options > Factors the Global Scale Factor must be set to match the Plan & Profile Generator 
preference (horizontal scale) selected.

Note: If you are using ProjectWise, start InRoads and MicroStation from the Start Menu or desktop icon. 
This allows you to log in to the ProjectWise server through MicroStation establishing a link between 
the two programs so that file can be written directly to the ProjectWise server.
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Dialog Settings:

Project specific parameters need to be defined prior to command execution:

♦ Verification of Border Cell

♦ Location of MicroStation seed file

♦ Location for sheet output (project directory)

♦ Length along the alignment that will display in plan view

♦ Left and right offsets from a horizontal alignment for plan view display.

User Input:

1. Select Drafting > Plan and Profile Generator…

By default, the dialog will populate with the CDOT preference (100 horizontal scale by 1x vertical 
exaggeration Plan & Profile sheet).

2. <D> Preferences if a different scale or full plan sheet or double plan sheet or full profile sheet is desired:

Developed Preferences are:

♦ 100 Scale Double Plan – 100 scale (plot factor) double plan sheet

♦ 100 Scale Full Plan Sheet – 100 scale (plot factor) plan sheet

♦ 100 Scale Full Profile 10x – 100 scale (plot factor) full sheet profile with 10 times vertical exaggeration 
applied

♦ 100 Scale Double Profile 10x – 100 scale (plot factor) double profile sheet with 10 times vertical 
exaggeration applied

♦ 100 Scale Full Profile 1x - 100 scale (plot factor) full sheet profile with 1 times vertical exaggeration 
applied

♦ 100 Scale Full Profile 2x - 100 scale (plot factor) full sheet profile with 2 times vertical exaggeration 
applied

♦ 100 Scale P&P (1x Vert) - 100 scale (plot factor) plan & profile with 1 times vertical exaggeration 
applied

♦ 100 Scale P&P (2x Vert) - 100 scale (plot factor) plan & profile with 2 times vertical exaggeration 
applied
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♦ 100 Scale P&P (5x Vert) - 100 scale (plot factor) plan & profile with 5 times vertical exaggeration 
applied

♦ 100 Scale ROW Plan Sheet

♦ Replicas of the above for 20, 40, 50, 200, and 500 scale as appropriate

Note: There is a second copy of the preferences that are prefixed with a ‘PW’. These use a ProjectWise sheet 
border. Once the file is saved then reopened, ProjectWise will fill in the title block information 
automatically.

Main Tab

By default, the preference CDOT 100 Scale P&P (1xVert) will load & populate the dialog for generation of plan 
and profile sheets.

User input – Main Tab

Load the appropriate Preference (if necessary)

1. Select the Horizontal Alignment to be centered in the plan view

2. Define Start and Stop stations to define limits of sheet generation
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3. Length defines the length along the alignment that will fit in a plan view. 1400 feet is the default for a 100 
scale 11” x 17” plotted sheet. See graphic below.

Changing Scale

A 50 scale plot will display 700 feet along the alignment in plan view, a 200 scale plot will display 2800 feet.

If something other than 100 scale is desired, the different scaled preferences are created to proportionally 
change the following:

♦ Main tab – modifies Length along Alignment

♦ Plan Controls tab – modifies Width Left and Width Right of reference line (alignment)

♦ Profile Controls tab – modifies Profile Height

♦ View Layout tab – modifies Scale

♦ Symbols and Details tab – modifies Scale

♦ One item that is not set by the preferences and that needs to be set by the user is the overall InRoads 
scale which is set by selecting the command:
Tools> Options> Factors or Tools > Global Scale Factor – set Text, Cell, LineStyle to the 
desired plot scale
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Plan Controls Tab

1. <D> Model Files to pick the Drawing files (references) for display in plan view. These files can be 
located on ProjectWise or on the local hard drive.

Note: Nested Attachments can be checked, but you will only be able to manipulate levels (on or off) 
through Level Display and not in the Level Manager. Also, you can switch to live nesting in the 
actual P&P sheets by changing the reference file attachment settings.   
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2. The inputs Width Left and Width Right define plan view limits perpendicular from the reference line (left 
is negative).

3. The Boundary Chords setting will create a clipping limit that will fit the extents of the upper plan window 
area. This reference file clipping edge should be considered a “first pass limit” and may have to be edited 
on curved portions of the corridor path in locations where the cut / fill limits extend outside this 
“calculated” clipping limit. This plan limit editing, along with any shifting of the plan window position, is 
accomplished on the Sheet Index tab after the sheets have been created.

Model Files & Levels

The Model files selected (along with the profile generated) will be attached as reference files. The attached 
files will have the levels turned on that contain data. If additional data (levels) are added to the referenced files 
after the sheets are created, the user is required to turn on the appropriate levels through the use of the level 
display dialog box.

Additionally, the files referenced will have the design file ‘CDOT Default’ model attached. It is CDOT policy 
that only the model titled ‘CDOT Default’ should be used in any MicroStation file.

Profile Controls Tab

1. Profile Preference defines profile grid settings (ticks, annotation, grid/tick spacing etc.) as stored as a pref-
erence in Evaluation > Profile >Generate Profile.

2. Enter an appropriate profile Set Name. For better tracking and locating, this field will default to the name 
of the Horizontal Alignment from the Main tab.
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3. Select the Vertical Alignment from the drop-down list. (This tells InRoads to create a profile window with 
an elevation range compatible with the vertical design.) The alignment specified determines window 
clearance (top/bottom profile grid clearance) and vertical profile shifts if necessary.

4. Check on (X) any Surface that you wish to display in the profile window as it is created (you can always 
display additional data after the profiles have been constructed). 

5. Hold down the CTRL key and select any Surface that should be considered when establishing the elevation 
range position of the profile window. These selected surfaces can also affect the Profile Elevation Shifts 
locations.

6. Highlight the superelevation control lines that will be displayed in the profile from the Super Control Lines 
list box. The All and None buttons to the right of the Super Control Lines list box can be used to select or 
deselect all of the superelevation control lines.

Note: The Margin on the Top has additional space provided in case a superelevation diagram is shown in 
combination with the profile window.

From the InRoads help menu:

When a profile is shifted (vertically), the starting elevation will always be a multiple of the 
Spacing value for the ticks on the left axis in the Create Profile command. To set this parameter, go 
to the Axes tab on the Create Profile dialog box, set Axis to Left, set Annotation to Ticks, and key 
in the Spacing value in the Major Ticks group box. Therefore, if you get a message stating that the 
profile will not fit in the given profile height, you have two choices: (1) increase the profile height 
or (2) specify a smaller spacing value for the left axis.
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Sheet Layout Tab

1. <D> … next to the Host File field to identify the path and initial sheet name for the new drawing set. The 
Host File refers to the new MicroStation plan and profile drawings that will be created by this tool. The last 
number, “1”, will be automatically updated as each new sheet is created. This should be set to the project 
directory, i.e.: C:\Projects\12345\ Design\Drawings\12345DES_PnP01.dgn.

Note: This can also be a path to a ProjectWise location.

2. The Seed Host File is the ‘prototype’ file used to create the Host files. Verify the path is set 
to:C:\Workspace\Workspace-CDOT_V8i\Standards-Global\MicroStation\seed\3D-
Seed_CDOT.dgn

3. The Symbology for the Clipping Boundary will be blank since the Level specified will determine the 
clipping boundary symbology.
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View Layout Tab

1. This tab sets location (origin) for the profile and plan views relative to the border sheet. No user input is 
required in this dialog unless creating sheets at a scale other than 1”=100’

Note: The Location of the Profile Y position was determined by 1.50” of outside title block border plus 
0.25” of clear space for the station text at that bottom of the profile window. (1.50+0.25 = 1.75)

Note: The Location of the Plan Y position was determined by 1.50” of outside title block border plus 
0.25” clear space for the station text below the profile window plus 4.5” of space required for 45’ 
of profile elevation plus 0.25” of clear space above the profile window plus ½ of the remaining 4” 
width of the plan window. (1.50+0.25+4.50+0.25+2.00 = 8.50)

Border and Title Tab

The only user input on this tab is to ensure the correct cell is specified for the border sheet and turn off the User 
Text if it is not used. 
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1. Cell Placed: 

♦ SHEET_PW_Design-Plan-Sheet
♦ SHEET_Design-Sheet

Note: Use the SHEET_PW_Design-Plan-Sheet with projects located on ProjectWise. Use 
SHEET_Design-Sheet with projects stored on a local computer.

Symbols and Details Tab

The North Arrow cell is preset on this tab. The ProjectWise Title Block area is not used because the 
ProjectWise tags are imbedded in the sheet border cell. The Miscellaneous area can be used to place another 
cell in the sheet. To use the Miscellaneous area:

1. Toggle on Attach.

2. Select the desired Cell Name.

3. Toggle on Retain Cell Levels for Each Sheet.

4. Key in the desired Scale.
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5. Key in the X and Y values for the Location in Paper Units.

Note: The North Arrow position is specified by the Location in Paper Units input and is set to the upper 
right corner of the sheet. This is a rough placement and will likely have to be moved for clarity and 
conflicts on many sheets. Once the sheets are constructed each sheet should be checked for 
optimum cell position. 

Note: The North Arrow and matchline information are not being placed on the correct level. A 
workflow document has been created to assist you in moving the North Arrow and matchline 
information to the correct level through a batch process. If these elements are not moved to the 
correct level, they will not plot. InRoads places these elements on a no plot level. See the CDOT 
Batch Processing workflow document for more information on this process. 
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Match Lines Tab

1. No user input is required in this dialog.

Executing the Command

The workflow process for this command follows the sequence:

1. New profiles are generated for referencing to individual sheets.

2. Plan view reference limits are established.

3. New drawing files are created based on the host file name.

4. Each new drawing file has 3 items generated (Sheet Border, North Arrow, and one user specified cell).

5. Plan views or Plan and Profile views.

6. Profile views.

7. Border sheet placed as a cell in each generated drawing.

8. North arrows are placed in all sheets.

9. The Plan and Profile dialog (sheet index tab) will populate with sheets created and sheet limits.



PPG- 14 Colorado Department of Transportation

 Plan & Profile Generator CDOT  Workflows

Note: Because new profiles will be generated, you should execute the command in a drawing specific for 
this use. For example:  
C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Prof.dgn 

Sheet Index Tab

1. Nothing is required by the user on this tab prior to Plan & Profile sheet creation.

2. After the Plan and Profile Generator has been run, each sheet should be reviewed for:

♦ North Arrow position and Miscellaneous Cell. (Manually move the Cell if necessary).

♦ Plan view Clipping limits (Using MicroStation Modify, edit the clipping shape). This level is set to be 
on a no plot level.

♦ Plan View Position (Select the sheet on the Sheet Index tab, modify the anchors as necessary, and 
Regenerate Sheet to reconstruct).

3. Save a project specific View Definition File (VDF) so that sheet definitions can be recalled and modified if 
necessary. This file should be saved to your InRoads project folder location, not within the CDOT 
Workspace. 
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4. By highlighting a specific sheet and <D> Show Sheet, MicroStation will open the selected drawing.

Main Tab

1. Once the command has been run the Geometry Projects in this VDF, Plan View and Profile View list boxes 
are updated.
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2. <D> <D> on a Plan or Profile View in the list to open an Edit dialog box. Sheet limits can be modified and 
reference files can be added or removed from this location. 

Note: If you are using ProjectWise and you are going to regenerate the P and P sheets, you must first delete 
the sheets off of the ProjectWise server. InRoads cannot overwrite files on the ProjectWise server as it 
does with locally stored files.



Colorado Department of Transportation   IPNC- 1

Workflow IR 9 - InRoads Place Note Command

This document guides you through using the InRoads Place Plan Note command, which places annotation 
based on a combination of manual input and information extracted from InRoads geometry, surfaces, profiles, 
or cross sections. A major benefit of using this command is generation of annotation based on the engineering 
model and the ability to automate updating the annotation if the engineering information changes.

Plan Notes

Setting Defaults

1. Launch both MicroStation and InRoads with the CAD file that requires annotation. This document follows 
C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn.

2. From the InRoads menu, select File>Projects Defaults. Select the appropriate configuration name for 
the active project. If not already defined, the Drafting Notes field should be directed to: C:\Program 
Files\Workspace-CDOT\Standards-Global\InRoads\Notes\CDOT-Notes.dft. 

3. <D> Apply and Close.

Note: Project specific DFT (drafting notes) files can be created and stored in the project directory 
structure. Creating this file will be discussed later in this document.
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4. Open project related data files such as geometry projects and surfaces. If developed, choose the projects 
RWK file to open project related data. (File > Open). Select the appropriate project file and <D> OK. 
<D> Cancel to dismiss the Open dialog box.

Placing Notes

1. Select Drafting>Place Plan Notes.

2. Expand the file tree structure (+) for Plan > Existing. Select Feature – Station Offset & Elevation 
and <D> Apply.
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3. <D> on any element, <D> to accept, move mouse to desired location, and <D> again to insert note into 
drawing.

Note: In order for InRoads to generate annotation extracted from a surface feature, that feature 
must be displayed in the CAD file using the Surface > View Surface > Feature 
command. If text fields appear empty (non quantitative) it is more than likely due to the 
feature’s properties. Either a description is not provided or the element is not displayed as 
a feature in the design file.

Creating a Plan Note

1. From the Place Plan Note dialog box, <R> in desired folder to insert note. Select New > Note.

2. Enter a name for the note (Spot Elevation for this example) and hit Enter to complete.

3. Expand dialog box using the downward arrow in the lower right of the dialog box. Use the keyboard to 
insert any prefix text (Spot Elevation: in this example) into the Note: field. 
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4. <D> <D> the desired computed values (ELEVATION_ACTIVE_SURFACE in this example) from the 
Inserts: list box

5. <D> Settings.
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6. In the Settings dialog box, make the desired settings then <D> OK.

Note: To keep note settings for future use, save the DFT file in a project specific folder 
(Projects\#####\Project_Configuration) by selecting File>Save As from the Place Plan 
Note dialog box. Saving to the CDOT workspace will not retain this information.

7. <D> Apply in the Place Plan Note dialog box. <D> at any location in the MicroStation view, <D> to 
accept, move mouse to desired location, and <D> again to insert note into drawing.
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Updating Plan Notes

If design information such as stationing, surface elevations or feature information changes, annotation placed 
with the Place Note command does not have to be deleted and regenerated. However, it does need to be 
updated. The following example shows the procedure assuming the stationing of an alignment has been 
modified.

1. Select Drafting > Update Plan Note. To update a single note, toggle Single From Graphic on. If 
multiple changes are desired, the Update modes All or Fence can be used. <D> Apply.

2. <D> on note to update, <D> again to accept. The note will automatically be updated with new stationing 
information.

Moving Notes

1. Select Drafting > Move Note.

2. <D> on note to be moved; <D> to accept selection; <D> to choose new location.

Note: When using the Drafting > Move Notes command, the leader will stay associated with the 
original insertion point. Using the MicroStation Move command would reposition both the note 
and leader.
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Editing Notes

1. From the MicroStation Drawing Task Tab, select Edit Text.

2. <D> on any note to edit the text in the Text Editor. <D> anywhere in MicroStation view to accept changes 
made to text.

Note: Editing text will disassociate values, disabling the automatic updates to text feature.
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Workflow IR 10 - Calculate Volume

This document guides you through three methods to calculate volume: Grid, Triangle, and End Area.

Calculating Grid Volumes

Calculate the volume between the existing surface and the proposed surface using the grid volume method.

1. Select Tools > Customize > [Toolbars] and check on Volume. <D> Close to dismiss the Customize 
dialog.

2. Select the Grid Volume command.

♦ Select the desired Original Surface.
♦ Select the desired Design Surface.

♦ Enter the Grid Interval. Ideally, this should be equal to or a factor of the template drop interval or 
the interval at which data was collected.

♦ Set the desired the Cut Factor and Fill Factor.

3. <D> Apply.

4. Record the results. 

If you would like an electronic copy of the Grid Volume:
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5. <D> the Results button. This displays the Results dialog box with the volume data.

6. In the Results dialog box, <D> the Save As button.

7. Navigate to the desired folder, enter a File name, then <D> Save to create the report file.

8. <D> Close to dismiss the Results dialog box.

9. <D> Close to dismiss the Grid Volume command.

Calculating Triangle Volumes

Calculate the volume between the existing surface and the proposed surface using the triangle volume method.
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1. From the Volumes toolbar select the Triangle Volume.

♦ Set the Mode to Entire Surface.
♦ Select the desired Original Surface.

♦ Select the desired Design Surface.

♦ Set the Cut Factor and Fill Factor as required for the project.

2. <D> the ADD button.

3. <D> Apply.

This method will take longer to process than the grid method.

4. The results are displayed in the Bentley Civil Report Browser dialog box.

5. Use the Triangle Volume.xls template to review the report.

If you would like an electronic copy of the Triangle Volume:

6. Select File > Save from the menu bar.

7. Navigate to the desired folder, enter a File name, then <D> Save to create the report file.

8. <D> Close to dismiss the Triangle Volume command.

Calculating End-Area Volumes

Calculate the volume between the existing surface and the proposed surface using the end-area volume method 
(CDOT standard method). With the first run, you will not take the subgrade into account.

In order to use this command, you must be in the design file where your final cross sections were cut.

1. Open the desired cross section design file.
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2. From the Cross Sections dialog box, select the End‐Area Volumes from the dialog box explorer.

3. Select the desired Cross Section Set using the drop down menu.

Note: End area volumes are calculated based on the cross section graphics. If the selected set does not 
contain sections for the full length of the project, or the design toes fall outside the cross section 
grid, then the volumes will not be correct for the project.
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4. Identify the surfaces to be compared from the Surfaces list. There must be one Existing type surface and 
one Design type surface.

5. Set Imperial Units to Cubic Yards.

6. Toggle on Create XML Report.

7. <D> Apply.
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8. The Bentley Civil Report Browser appears. There are several report templates that are useful. Some 
recommended templates to look at are:

♦ EndAreaVolume.xsl

♦ EndAreaVolumePage Totals.xsl

♦ Volumes.xls

The first two are standard end area volume reports. the Volume.xls also has the same volume data, but is 
formatted differently. It also contains volume information on the closed shape template components 
contained in the design surface.

If you would like an electronic copy of the End Area Volume:

9. Select File > Save from the menu bar.

1. Navigate to the desired folder, enter a File name, then <D> Save to create the report file.

2. Close the Bentley Civil Report Browser.
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Workflow IR 11 - Calculating Quantities With 
InRoads and Quantity Manager

This document guides you through the use of InRoads and Quantity Manager to calculate and extract quantities 
from InRoads data. The processes included in this document cover: 

♦ Editing the Pay Item database to calculate quantities for materials that use the same pay item code but 
use different variables or formulas to compute the quantity

♦ Importing MicroStation graphic elements into a surface (DTM) so that they can be quantified

♦ Using the Shapes Tool to create surface features from closed areas

♦ Using the Compute Quantities tool to calculate quantities and store the output to a database

♦ Working with Quantity Manager to input quantities that were not calculated and create various reports 
on the quantity data

CDOT Customizing the Pay Items Database

When figuring quantities, it is possible that two or more features will use the same pay item code but require 
different values for some formula variables. For example, the same paving material may be used for both the 
roadway and driveways but the thickness of that material can vary. Pay Item Manager will be used to copy a 
pay item and edit that copy for use with different variables or formulas.

Copying The CDOT Pay-Items.mdb:

Because the changes made to the pay items database will be unique to the project, a copy of the CDOT Pay-
Items.mdb should be placed in the project directory.

Making The Copy

1. Open an Explore window to the C:\Program Files\Workspace-CDOT\Standards-Global\InRoads 
directory and Copy the entire CDOT Pay Items folder.
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2. Change the directory to C:\Projects\JPC#\Design\InRoads and Paste. 

Copying A Pay Item

Now that a copy of the master database has been made, customizing the copy for the particular project can be 
accomplished.

1. Start InRoads (and MicroStation), opening the; C:\Projects\JPC#\Design\Working\XXXJPC#Quantity-
Model##.dgn file. 

2. From the InRoads menu, select Quantities > Pay Item Manager.   This displays the Pay Item Manager 
dialog box.

3. From the Pay Item Manager dialog box, select File > Open.
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4. In the Open dialog box, Set the directory path to: C:\Projects\JPC#\Design\InRoads\CDOT Pay Items\.

5. Select CDOT Pay-Items.mdb and Open.

Locate The Pay Item To Be Copied

1. Select Edit > Find from the Pay Item Manager dialog box. This displays the Find dialog box.

2. In the Find What field of the Find dialog box, key in the desired Pay Item Code. And select Find Next. 
The desired pay item will be displayed, highlighted in the right pane of the Pay Item Manager dialog box.

3. Select Close from the Find dialog box. 



CQIQ- 4 Colorado Department of Transportation

 Calculating Quantities With InRoads and Quantity Manager CDOT  Workflows

Making The Copy

1. In the right pane of the Pay Item Manager window, <R> on the desired Pay Item Name. Note: be sure that 
the cursor is in the Name column. Select Copy from the menu that is displayed.

2. Move the cursor to the Description column, <R> and select Paste. A copy of the pay item with (2) 
appended to the name is placed under the original.

Editing The Pay Item:

1. In the right pane of the Pay Item Manager window, <D> on the copied Pay Item Name. 

Note: be sure that the cursor is in the Name column. This will highlight the copied Pay Item.

2. <R> on the Pay Item Name and select Edit. This displays the Edit Pay Item dialog box.

3. <D> just to the left of the ‘(2)’ in the Pay Item Name field. Key in a brief, descriptive addition to the 
name. Delete the ‘(2)’.
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4. For Example, if pay item 403-32621 is to be laid down 6” thick, the name could read, 403‐32621 – 6 Thick.

5. Do not change the Pay Item Code, Description, or Unit Name. Doing so will result in errors in the pay 
quantity calculations.

6. A different formula may be selected from the Formula pull-down in the Quantity Calculation area.

7. For example, there are two formulas for computing tons; ‘Ton’ and ‘Ton – L’. ‘Ton’ uses the area of a 
feature and the variables Thickness and WeightCFT. ‘Ton – L’ uses the length of the feature and the 
variables Width, Thickness, and WeightCFT.

Editing Formula Variables

1. <D> on the desired variable from the Variables list in the Quantity Calculation area.
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2. Highlight the data in the Value field directly below the Variables list and key in the desired value. Press the 
Tab key to accept the value.

Deduction From Pay Items

This option is used when two features occupy the same location (are coincident) and one of those features can 
reduce the quantity of the other. For example, suppose a curb feature is stored as a continuous Breakline and 
inlet features are stored as random points on the curb Breakline. For each occurrence of an inlet on the curb, the 
quantity of the curb can be reduced by a defined value.

1. To add a pay item for deduction <D> on the Pay Item Browser button. This displays the Pay Item browser 
dialog box.

2. <D> on the desired pay item and select Add. The Pay Item is add to the Deduct From Pay Items list. <D> 
on the Close button to dismiss the Pay Item browser dialog box.

3. <D> on the desired pay item from the list in the Deduct From Pay Items area.
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4. Highlight the data in the Value field directly below the Pay Items list and key in the desired value. Press 
the Tab key to accept the value.

The Measurement Area

The options in this area are used to determine how areas and lines are measured. It is also used to specify 
quantity factors and rounding.

1. There are two mode of measurement; Planarized and Slope. Planarized projects the shape to a flat (2D) 
plane for measurement. Slope measures the actual (3D) shape.

2. <D> on the desired radio button to select the measurement Mode.

3. A Quantity Factor is a multiplier applied to the calculated quantity.

4. If a Quantity Factor is to be used, <D> the check box to the left of Apply Quantity Factor.
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5. Highlight the data in the field to the right of Apply Quantity Factor and key in the desired value. Press 
the Tab key to exit the field.

6. A Rounding Factor is used to modify the computed value to the nearest specified increment. There is also 
the option to round up or down.

7. If a Rounding Factor is to be used, <D> the check box to the left of Apply Rounding Factor.

8. Highlight the data in the field to the right of Apply Rounding Factor and key in the desired value. Press 
the Tab key to exit the field.

9. Select the desired rounding option from the two radio buttons below Apply Rounding Factor.

10. <D> the Apply button to accept all of the changes made to the pay item.

11. <D> the Close button to dismiss the Edit Pay Item dialog box.
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12. This completes the edit.

Importing Graphics To surface

This command takes the X, Y, and Z coordinate information from a MicroStation element and stores it in a 
DTM file. This command will be primarily used for creating pay quantity data. Because of the high level of 
data control required, the Load From Fence option is inappropriate and will not be described.

Creating Or Opening The Surface

Data imported from graphics can be either loaded into a new or existing surface.

Creating A Surface

1. In the InRoads menu, <D> on the bottom Surfaces tab. <R> on the word ‘Surfaces’ at the top of the left 
pane then select New from the menu.

2. Set the Type to Ignore.

3. In the Name field of the New window, key in the desired name.

4. In the Description field, key in the desired description.
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5. <D> the Apply button then <D> Close.

Opening An Existing Surface

1. In the InRoads menu, <D> on the bottom Surfaces tab. <R> on the word ‘Surfaces’ at the top of the left 
pane then select Open from the menu.

2. In the Open dialog box, use the Look In pull down menu to select the desired directory path.

3. <D> on the desired file name.
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4. <D> on the Open button, then <D> on the Cancel button to dismiss the Open dialog box.

Importing Graphic Data

1. In the InRoads menu, select File > Import > Surface. The Import Surface dialog box will be displayed.

2. Using the Surface pull down menu, select the desired surface.

3. With the Load From pull down menu, select the desired method.

Note: If all of the elements on a particular level are to be imported, select Level.

4. If some elements on a level are to be imported and others are not, then select Single Element.

5. If Load From is set to Level, then with the Level pull down menu select the desired level. If Load From 
is set to Single Element this field is inactive.

6. In the Seed Name field, key in the desired name. This will be used to name the features imported from the 
graphic elements.

Note: this field may be populated if an existing surface is being used.

7. Use the Feature Style pull down menu to select the desired feature style.

8. Select the desired Point Type from the pull down menu. Note: when importing graphics for pay quantities, 
Random should be used for items paid for as each. Breakline is used for items whose quantity is figured 
from a linear measurement.

9. <D> the Apply button.
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a. If the Load From is set to Level, all elements on the selected level are imported.

b. If Load From is set to Single Element, then <D> on the desired element. <D> a second time to 
Accept the selection.

10. After all Levels and Elements are imported, <D> the Close button.

Saving The Surface

1. In the InRoads menu, <R> on the surface name in the left pane then select Save from the menu. If the file 
existed prior to importing data then the data is saved to that file and no further action is required.
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2. If the file was new then the Save As dialog box will appear. Select the directory path using the Save In pull 
down menu.

3. In the File Name field, key in the desired name.

4. <D> on the Save button, then <D> on the Cancel button.

Using The Shapes Tool

The Shapes Tool is used to create dtm features that define an area. The advantage of this tool is that it does not 
affect the graphic elements used to create the features. So, some of the same elements used to define an area 
feature can also be used to define linear features as well. 

Creating A Working DGN file:

Because the Shapes Tool may require additional graphic elements to be added to the model file, or existing 
elements to be modified, a copy of this file should be used.

Creating A Copy of the DGN File

1. Start InRoads (and MicroStation). Set the directory path and highlight the desired file. Select OK.
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2. Select File > Save As from the MicroStation Menu.

3. In the Save As dialog box, set the directory to the Working directory.

4. Key in the new name for the copied file and select OK. The copied file is now open in MicroStation.

Preparations For Using The Shapes Tool:

Creating A surface For Quantity Data

The design DTM will contain a large number of features that will not be used for quantity calculation. Using 
this surface could produce unwanted or erroneous quantity data. To avoid this problem a surface will be created 
to contain only pay quantity data.
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1. In the InRoads menu, <D> on the bottom Surfaces tab. <R> on the word ‘Surfaces’ at the top of the left 
pane then select New from the menu.

2. In the Name field of the New window, key in the desired name.

3. In the Description field, key in the desired description.

4. <D> the Apply button then <D> Close.

Setting The Level Display

1. The Shapes Tool works with all of the visible graphic elements. Therefore, it is necessary to turn off those 
levels that do not contain elements that will be used define the area feature. 

2. Select the Level Display.
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Note: if the down arrow next to the Level Display button is selected, the Level Display menu will be 
automatically dismissed when the cursor is moved off the menu.

3. <R> on the desired level and select Set Active from the menu.

4. <R> on the Level Display and select All Off from the menu. This will leave only the desired elements 
displayed.
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5. Use the Match Element Attributes command. Turn on all of the check boxes. <D> on the desired 
element to match its attributes.

6. Select the Place Smartline (or Place Line) command. <T> to the end of one of the elements that will form 
the area then <D>.

7. <T> to the end of the next element that will form the area then <D>.
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8. Repeat this process until all of the gaps in the area are filled. Below is an example of a closed area.

Creating The Area Feature

1. From the InRoads menu, select Quantities > Shapes Tool. The Shapes Tool dialog box will be displayed.

2. On the Shapes Tool dialog box, select Fill for the Shape entry.

3. Using the Surface pull down menu, select the surface created above.

4. In the Feature Name field, key in the desired feature name.

5. In the Description field, key in the desired text.

6. Using the Feature Style pull down menu, select the desired feature style.

7. Select Rename for the Duplicate Names setting.
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8. Toggle on Use Dynamics and Exclude From Triangulation.

9. In the Limits area, toggle Station on if desired. If used, key in the Start and Stop stations in their respective 
fields.

Note: If station limits are used, temporary lines extending perpendicular to the active alignment 1,000 
feet in either direction will be placed at the Start and Stop stations. These will be used to define 
areas both inside and outside the station limits.

10. Select the Apply button.

11. Move the cursor inside the desired area. Closed areas will highlight as the cursor is moved through them.
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12. <D> inside the area to create the feature. <D> a second time to accept. If additional features are to be 
created using the same settings, these can be selected at this time. The first additional feature will have a 
‘1’ appended to its name. This will be incremented by 1 for each additional feature thereafter.

After the desired areas have been selected, <R> to re-display the Shapes Tool dialog box and then select 
Close.

Saving The Surface

1. In the InRoads menu, <R> on the surface name in the left pane then select Save from the menu. If the file 
existed prior to importing data then the data is saved to that file and no further action is required.

2. If the file was new then the Save As dialog box will appear. Select the directory path using the Save In pull 
down menu.

3. In the File Name field, key in the desired name.
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4. <D> on the Save button, then <D> on the Cancel button.

InRoads Compute Quantities

The compute Quantities command collects pay quantity data from a DTM and stores it in a database to be used 
with Quantity Manager. This command requires a surface with pay items assigned to the features and a 
geometry project with a horizontal alignment.

1. From the InRoads menu, select Quantities > Compute Quantities. This will display the Compute Quan‐
tities dialog box.

2. Select the desired alignment using the Alignment pull down menu. Quantities will only be calculated for 
features within the station range of the specified alignment.
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3. Using the Mode pull down menu, select either All or Fence. The All mode uses all features within the 
alignment, the Fence mode uses only those features that are within a defined fence.

4. In the Include area, <D> either the All or Selected radio button for Pay Items, Features, and Graphic 
Elements.
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Note: If the Selected radio button is chosen, then the items to be processed must be identified on their 
respective tab. If the All radio button is selected all data of that type is processed and its tab is not 
used.

5. In the Output area, <D> on the browser button next to the Database field. This will display the Browse 
window.

6. Select the desired directory path from the Save In pull down menu.

7. In the File Name field, key in the desired filename or select an available one from those listed.

8. <D> on the Save button. This will dismiss the Browse window and fill in the Database field.
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9. Select a Mode. Choose Create to make new file or to overwrite an existing file. Choose Append if adding 
additional data to an existing file. 

10. Select a Phase from the combo box to the right. A new Phase can be created by keying in a name in the 
combo box. Phases are used to group quantities. 

11. The Run field is another method of grouping quantities. If desired, key in a Run name in the field to the 
right.

12. <D> in the Deduction Tolerance check box to turn it on or off. The field to the right is used to define the 
distance at which features are considered coincident. Key in the desired value. For more information on 
pay item deductions see the “Customizing The Pay Items Database” workflow.

13. <D> in the Sheet Number check box to turn it on or off. When on, the field to the right is made active and 
a Sheet Number can be keyed in. This field is for informational purposes when quantities are tabulated on 
a per sheet basis.
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14. <D> in the Purge check box to turn it on or off. When on, this option deletes pay quantities from the 
database if the feature used to calculate the quantity has been deleted from the DTM.

15. The Symbology area is used to set the parameters for highlighting elements that quantities were computed 
for. <D> on the check box in the Display column to turn the highlight on or off.

The Pay Items Tab

This tab is used if Pay Items in the Include area is set to Selected.

1. <D> on the Pay Items tab to bring it to the front.
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2. Select the Pay Items to be computed by clicking in the check box to its left.

Note: All of the pay items in the list can be selected by selecting the ‘Root’ directory at the top of the list. 
If a Category is selected (‘300 Bases’ in the example above) then all of the items in that category 
and its sub-categories are selected. If a Sub-Category is selected (‘603 Culverts and Sewers 
‘above) then all of the items in that sub-category are selected. Finally, individual pay items can be 
selected (‘606-00350 Guardrail Type 3 above).

The Features Tab

1. This tab is used if Features in the Include area is set to Selected.

2. <D> on the Features tab to bring it to the front.

3. In the Surface area, <D> on the desired surface. Multiple surfaces can be selected by holding the Shift or 
Ctrl key and then clicking on the desired surfaces.

4. In the Features area, <D> on the desired Feature. A consecutive range of features can be selected by 
holding the Shift key then clicking on the first and last feature in the range. A number of individual 
features can be selected by holding the Ctrl key then clicking on the desired features.
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5. The Locator button can be used to identify features from the graphic elements displayed. The Ctrl key can 
be used with this option, however, the Shift key can not. To use it, <D> on the Locator button then <D> 
on the desired graphic element.

6. <D> the Apply button to calculate the quantities.
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7. When processing is completed, a message stating that the *.mdb file has been created will appear in the 
lower left corner of the InRoads interface.

8. <D> the Close button to dismiss the Compute Quantities dialog box.

Working With Quantity Manager

Quantity Manager is a “Stand Alone” interface with the pay quantity database created by the InRoads 
Compute Quantities command. It is used to update the database with quantities not computed by InRoads 
and to create reports on the quantity data. 

Opening Quantity Manager

1. Quantity Manager can be started from the InRoads menu by selecting Quantities > Quantity Manager. It 
can also be started from the Start menu by selecting Start > All Programs > Bentley > InRoads Group 
V8i (SELECTseries 2) > Quantity Manager. MicroStation and InRoads do not have to be running for 
Quantity Manager to work.
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2. Select Project > Open.   This option is used to load the database created by the InRoads Compute 
Quantities command. The Connect to Database window will appear. 

3. Set the Database pull down to: MS Access 2000. This is the format used by the Compute Quantities 
command (SQL Server 2000 and Oracle formats can also be used by Quantity Manager).

4. In the File box, type in the directory path and file name of the desired file. The Browse button to the right 
of the field can be used to locate and select the desired file. 

5. <D> the Connect button. (unless otherwise noted, the User Name and Password fields are left blank.) 
The database is now loaded into Quantity Manager and editing can begin.

Properties And Preferences 

Information about the project that is used by Trns*port is stored in the Project Properties. A data file that 
facilitates the manual entry of quantities is attached to through the Project Preferences. This information 
should be filled in after the project is opened the first time.
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Properties Data

1. Select Project > Properties from the menu bar.

2. In the Project Properties dialog box, fill in the desired information for: Project Number (JPC Code), 
Description (optional), Unit System, and Spec. Year. This information is used when creating a data file to 
be used with Trns*port. After the data is entered, <D> the OK button.

Preference Data

1. Select Project > Preferences from the menu bar.
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2. From the Project Preferences dialog box, <D> the Browse icon for the Payitem field. Navigate to the 
C:\Projects\JPC#\Design\InRoads\CDOT Pay Items\ directory and select the 
CDOOT_Payitem_Reference_v33.xml file. <D> the Open button.

Note: This file contains a searchable pay item code list that will allow users to select pay item data from 
the file instead of manually keying in the information.

3. <D> the OK button from the Project Preferences dialog box. This will dismiss the Project Preferences 
dialog box.



CQIQ- 32 Colorado Department of Transportation

 Calculating Quantities With InRoads and Quantity Manager CDOT  Workflows

4. The data stored in the pay quantity database is now displayed in the Quantity Manager window. The 
window is divided into three parts; the Pay Items Table, the Quantities Table, and the Elements Table. 
The Pay Items table is used to add, edit, and delete Pay Items and Categories within the database. It is 
also used to add additional quantities. The Quantities Table is used to add, edit, and delete specific 
quantities within the database. The Elements Table is for informational purposes only. 

The Pay Item Table

The majority of the work done in Quantity Manager will be accomplished through the Pay Item Table. It is 
used to add or delete categories and pay items and can also be used to add quantity data to new or existing pay 
items within the pay quantity database.

The Pay Item Table is broken down into two basic types of data; Categories and Pay Items. Categories (and 
Sub-Categories) are used to divide the pay item data up into manageable pieces. They work much like the 
folders in the project directory structure, with the pay items organized by the first three digits of the pay item 
code. Sub-Categories are used to further divide pay items.

The pay item contains data on each element that had a quantity calculated for it using its pay item code. It also 
contains quantity data that was added manually to the database.
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The illustration below identifies Categories, Sub-Categories, and Pay Items within the Pay Item Table’s tree 
view.

Information can be displayed within the Pay Item Table in two ways; the Payitem Tree and the Payitem 
Table. The Payitem Tree (illustrated above) shows only the Category and Pay Item names. The Payitem 
Table displays data specific to each pay item code used in the database. Below is an illustration of a sample 
Payitem Table:

Because the Payitem Tree is generally easier to work with, it will be used throughout this workflow.

Displaying Pay Item Information

1. Expand the Pay Item Tree to show the desired pay item. <D> on the desired pay item. The data for that 
pay item is displayed in the quantity table.
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2. To show all of the items within a category or sub-category, <D> on the category in the pay item tree. All 
items within the category are displayed. In the example below, by selecting category 600, the pay items in 
subcategories 603,606,607,and 627 are displayed.

3. Items from multiple categories can be displayed by holding the Shift or Ctrl key and selecting the desired 
categories or items.

 

Adding Data To The Database

1. Quantities for earthwork and many lump sum items will not be included in the dtm and, therefore, not 
incorporated into the database by the Compute Quantities command. To include these additional Cate-
gories, Sub-Categories, and Pay Items may need to be added to the database.

2. To add a new category <D> on the category next in sequence to the one to be added.

3. Right Click and select Insert Category Above… or Insert Category Below… This displays the New 
Category Properties dialog box.
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4. In the New Category Properties dialog box, key in the desired category name. Select OK to create the 
new category.

 

5. Note: A new category can not be placed above or below the Root category they must be placed as sub-
categories.

6. To add a new sub-category <D> on the category that will contain the new sub-category.

7. Right Click and select Insert Subcategory… This displays the New Category Properties dialog box.
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8. In the New Category Properties dialog box, key in the desired category name. Select OK to create the 
new category.

 

9. To add a new pay item <D> on the pay item next in sequence to the one to be added (or <D> on the 
category the pay item is to be added to).

10. Right Click and select Insert Payitem Above… or Insert Payitem Below… (or Insert Payitem… if a 
category was selected above). The New Payitem Properties dialog box appears. 

11. Select the Search icon next to the  Payitem Name field. This displays the Select Payitem dialog box.

12. Key in the desired value in the Payitem Filter. This will greatly reduce the number of items that will have 
to be scrolled through.

13. <D> on the pay item to be used, then select the Import icon.
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14. The Select Payitem dialog box is dismissed and the New Payitems Properties dialog is populated with the 
selected data. Select the OK icon and the pay item is added to the Pay Item Tree.

 

15. To add a Quantity to a pay item <D> on the pay item then Right Click.

16. From the Right Click menu select Insert Quantity… The New Quantity Properties dialog box is 
displayed.

Only the Measurement Basis, Computed Quantity, and Phase are required fields. The others may be filled in 
as desired so that the data included with the manually entered quantity will match those of the ones imported 
from InRoads. 

17. Select the desired Measurement Basis. This is how the feature would have been measured if there was 
one. There are three options; Area, Linear, and Each. Items measured by volume (Tons, Gallons, Cubic 
Yards, etc.) or area (Square Feet or Square Yards) should be set to Area. Those measured in Linear Feet or 
Linear Yards should be set to Linear. Items listed as Each or Lump Sum should use Each. Use the pull 
down menu to select the desired entry.

18. Select the desired Measurement Value. This equates to the area of a shape feature, the length of a line 
feature, and the number of points in a random feature. For a Lump Sum payitem this should be 1. This 
number is not used for any calculation. It is here to make this payitem record consistent with those 
imported from the DTM. Key in the desired value.
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19. Key in the desired Computed Quantity. If a formula was utilized, this field is the result of the 
computation. Using a pavement quantity example, a formula computing tons from square feet could be 
utilized. In this case, the tonnage is the Computed Quantity. Entering data into this field auto-fills the 
Rounded Quantity with the same value. Key in the desired value.

20. Key in the desired Rounded Quantity. Some payitems use a Rounding Factor which is applied to the 
Computed Quantity. If the quantity being entered uses a rounding factor, change the number in this field 
to the rounded computed quantity. For example, concrete pipe is rounded to 2 foot increments. An 83 foot 
long pipe would be rounded to 84 feet. Key in the desired value.

21. Select the desired Deduction Quantity. The quantity of some payitems may be reduced by the presence 
of another payitem. While the payitem causing the reduction is not listed here, the amount of the reduction 
is. Key in the desired value.

22. Key in the desired Sheet Number. This is the name of the sheet upon which the quantities are located. 
This can be useful when computations are tabulated for individual sheets.

23. Key in the desired Run Name. This is a user-defined name. The run name is a grouping mechanism to 
permit segregation of quantities under the same payitem. It could be used to represent quantities of 
different stages or different alternatives.

24. Select the desired Phase. To assign the quantity to a particular phase. 

Note: If this data is to be exported to Trns*port the Phase must be set to Design.

25. Key in the desired Remarks. Key-in field for remarks is limited to 256 characters.

26. Key in the desired Description. Key-in field for the Description is limited to 256 characters.

27. Key in the desired Extended Description. Key-in field for the Extended Descriptionis limited to 256 
characters.

Note: It is not required to enter location data. However, this information may be used when generating 
some reports.
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28. Select the Location tab. This tab is used to identify the location of the quantity in relation to an alignment. 

29. Select the desired Baseline Chain from the pull down menu. This is the alignment to be measured from. 

Note: Minimum and Maximum Stations are used to set a boundary around the quantity. The station 
numbers do not represent the beginning or end of a feature, but the lowest and highest station at 
which the quantity would occur. The same can be said about the offsets, they represent denote the 
furthest distance to the left and right of the alignment that the quantity occurs. 

30. Key in the desired Minimum Station number. 

Note: Station numbers should be computed as if there is no station equation.

31. Key in the desired Minimum Offset. Left of the alignment is negative, right of the alignment is positive.

32. Select the desired Region. This is used if the alignment has a station equation. This option is usually 
selected automatically when the station number is entered.

33. Key in the desired Maximum Station number. 

34. Key in the desired Maximum Offset. 

35. Select the Create icon to complete the quantity.

Editing Quantities

Note: The quantity value of pay items imported from InRoads can not be changed in Quantity Manager 
only those entered manually can.
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1. To edit a quantity, <D> on the quantity in the Quantities Table, then Right Click and select Edit from the 
menu.

2. This displays the Edit Quantity Properties dialog box. This dialog box is the same as the New Quantity 
Properties dialog box. The illustration on the left shows the fields that can be edited for a quantity 
imported from InRoads. The illustration on the right shows fields that can be edited for a quantity that is 
manually entered.

Creating A Report

Reports are used to display the quantity data in a meaningful way.

1. Display the quantities to be reported on in the Quantities Table. This can be done by selecting pay items 
from the Pay Item Table (hold the Shift or Ctrl to select multiple pay items) or Select Edit > Select All. 

2. Highlight the desired quantities in the Quantities Table.

3. Select Tools > Reports > Create to open the Create Report window.

4. Select the desired Report Style from the pull down menu. The Style name describes the type of 
information to be contained in the report.
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5. Key in the directory path and filename for the Report File Name. The ‘search’ button can be used to select 
the directory path and filename if desired.

Some report styles use the Starting Page Number to automatically number the pages of the report. If this field 
is active, the desired page number can be keyed in.

6. The three buttons at the bottom of the window determine how the information will be stored. Select 
Append to add the data to an existing file. 

Note: This button is not available if the report type is PDF. 

7. Select Create to create a new file or overwrite an existing file. Cancel closes the Create Report window 
without processing any data. No report is created.
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This document guides you through saving survey fieldbook information to separate MicroStation files for ease 
of referencing and level control. 

Exporting a Fieldbook File

Creating a new file

1. From the MicroStation pull-down menu select File > New.  The New dialog will appear.

2. Navigate to the project directory folder ROW_Survey\Drawings\Reference_Files.

3. At the bottom of the dialog box verify that the seed file is set to 3D-Seed_CDOT.dgn.

Note: If 3D-Seed_CDOT.dgn is not the seed file specifieid, <D> Select button and chose navigate to 
C:\Program Files\Workspace-CDOT\Standards-Global\MicroStation\seed and select 3D-
Seed_CDOT.dgn from the Select a Seed File dialog box.

4. Key in the name of the file to be created in the Files filed: 12345SURV_Topo100Scale01.dgn

5. <D> OK in the New dialog.  The New dialog will close and the file 12345SURV_Topo100scale01.dgn 
will open.

6. Disable the view display of dynamic survey graphics shown on the screen.  Toggle off the View 

Planimetrics icon   or any other symbols, names, codes, etc. that may be enabled, using the toggles in 
the View Survey Data toolbar.
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7. Verify the correct fieldbook is active.  The active fieldbook is indicated by a red box around the fieldbook 
icon in the InRoads workspace pane.

8. To modify the scale as it relates to cells, text, and linestyles select Tools > Survey Options. The Survey 
Options dialog will appear.

9. On the General tab verify the Scales for Cell, Text, and Line are set as shown below.

10. Verify the check box labeled Segregate Text by Feature Level is checked on.

 

Note: Segregate Text by Feature Level, if checked on, will save the symbols, point names, codes, notes, 
errors, and elevations to the same level as the survey feature.

11. <D> OK.  The Survey Options dialog will close.
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12. Once the settings have been verified or changed, write the survey data to graphics.  From the InRoads 
menu select Survey > View Survey Data > Write Survey Data to Graphic.  The Write Survey Data to 
Graphics dialog will open.

Note: If dynamic graphics were toggled on, those same components would be toggled on in the Write 
Survey Data to Graphics dialog.

13. Check the Select All check box.

14. Set Curve Stroking Mode to Horizontal Only.

15. <D> Apply. The graphics will be created in the design file.

16. <D> Close. The Survey fieldbook data has been written to the design file.
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17. Verify all dynamic View Survey Data icons are toggled off.

18. Fit the view of the contents of the design file within MicroStation.

19. Review the results to verify the data has been written to the design file and are level stratified.

20. From the CDOT Menu pull-down select Add On’s > Stratify Survey.  The Stratify Survey dialog will 
appear.

Note:  

♦ Under Existing Files, the Append option will add or merge the new data into an existing file. A new 
file will be created if the file does not already exist.

♦ Under Existing Files, the Overwrite All option will create a new file, deleting any previously existing 
file.

♦ Under Existing Files, the Overwrite None option will disable the processing option for a file if the file 
already exists.
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♦ The Process option Adjust Planimetrics will resize the planimetrics text (if necessary) and convert the 
grouped text strings to view independent cells in order to allow for viewing this text in any 3D view.

21. Verify the JPC, Scale, and Sheet Number entries are correct.  Altering any of those values will 
automatically alter the output file names.  If the Attach check box in the Contours section is grayed out, 
the contour file does not exist.  You may edit the name specified in the File Name field to enter the name of 
an existing contour file.

22. <D> OK button to start the process.

23. As the data is being moved to the appropriate reference file a Processing Status dialog provides an update 
on the progress.  You may <D> Cancel at any time to stop the processing, if necessary.

24. When completed, a Processing Completed message is displayed.  <D> OK to exit the program.
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25. The fieldbook data has now been stratified into separate reference files. The planimetrics will be in the 
master design file with all of the symbols, names, codes, etc., attached as reference files. To view these 
attachments select File > Reference from the MicroStation pull-down menu.

Roadway Design referencing Survey Topo files

1. By using nested references, the designers can attach one Survey Topo file and have all the additional refer-
ences attach as well.

2. From the MicroStation pull-down menu select File > Reference.  The References dialog will appear.
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3. From the References pull down menu select Tools > Attach.  The Attach Reference dialog will appear.

4. Set the directory to C:\Projects\12345\ROW_Survey\Drawings\Reference_Files

5. Select the file 12345SURV_Topo100Scale01.dgn and <D> OK.  The Reference Attachment Settings 
dialog will appear.

6. From the Nested Attachments drop down list, select Live Nesting and set the Depth to 1.
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7. <D> OK.  The Survey Topo file will attach along with the fieldbook nested attachments.
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Workflow IR 13 - Editing Feature Styles for 
Display in Cross Sections

This document guides you through the process of setting a feature style to display in cross sections. Displaying 
a feature in cross sections allows the designer to see the relative position of the features and to annotate 
individual features.

Note: The changes made using this workflow occur in the XIN file. If you wish to save these changes past 
the current login session, the XIN file must be saved to a different location. Use the Save As option 
and store the file in the project directory.

In this example, we wish to display the T_Edge of Parking Lot features in the cross sections to see if our toe of 
slope encroaches into the parking lot.

Workflow Outline

Opening Style Manager - Style Manager is the interface used to edit the xin file, where the feature style 
definitions are stored.

♦ Commands Used: Tools > Style Manager - Used to display the Style Manager dialog box.

♦ Edit Style - And alternate method for displaying the Style Manager dialog box. This button is found 
on the Update Cross Section > Crossing Features leaf of the Cross Section dialog box.

Selecting a Style to Edit - Within the Style Manager dialog box, there are some items that can make 
locating the desired Style easier to find. This step is skipped when the Edit Style button is selected from the 
Cross Section dialog box.

♦ Commands Used: Show Styles with Properties > Include Surface - This option is used to 
remove any non-surface feature styles from the Features list.

♦ Edit (button) - Used to display the Edit Style dialog box. This is where feature style data is modified.

♦ Surface Features - This is the leaf of the Edit Style dialog box where the first changes are made.

Editing the Style - Changing the Style’s display settings allows the feature to be displayed in the cross 
section set. Editing the Named Symbology allows the user to determine how that feature is displayed.

♦ Make Style Settings Changes - Use the toggles to turn on the Cross Section Display. This sets the 
style so that the feature can be displayed. 

♦ Make Symbology Settings Changes - These determine how the feature will look when 
displayed in the cross section set. These changes are made to the Named Symbology attached to the 
Feature Style.

○ Commands Used: Surface Feature > Symbology - This is the leaf of the Edit Style dialog box 
that provides access to the Named Symbology editor.

○ Edit the Symbology - Select the Symbology type to edit (either Default Point or Cross Section 
Point). Make changes in the Point Symbology dialog box. 

Opening the Style Manager and Selecting a Style to Edit

The display settings for features is accessed through the Style Manager. There are various ways to open Style 
Manager, depending on which dialog boxes are open. Here, opening the Style Manager from the InRoads main 
dialog box and from the Cross Sections dialog box is described.
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Opening the Style Manager from the Main InRoads Dialog Box

1. From the InRoads main menu, select Tools > Style Manager. This displays the Style Manager dialog 
box.

2. In the Style Manager dialog box Show Styles with Properties area, toggle on Include Surface. This 
filters out all styles that are not surface styles, reducing the number of items in the style list to search 
through.

3. In the styles list at the bottom of the dialog box, highlight the desired style (in this example T_Edge of Oil 
Parking Lot) 

4. <D> the Edit button to display the Edit Style dialog box. You can also <D> <D> on the style in the list to 
open the dialog box.
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5. In the Edit Style dialog box, expand the Surface Feature folder.

This takes us to the point where the style will be edited.

Opening Style Manager from the Cross Sections Dialog Box

Usually, you will discover that a particular feature is not set up for display in cross sections or profiles when 
you are using the Update Cross Sections or the Update Profile commands. Because of this, InRoads has 
provided access to the Style Manager directly from the Cross Sections and Update Profile dialog boxes.

In this example, the Cross Sections dialog box is used.

1. In the Cross Sections dialog box, expand the Update Cross Section folder and select Crossing Fea-
tures.

2. In the Surfaces area, highlight the surface that has the features to be displayed (in this example 12345 
Existing Ground is used).

3. In the Feature area, highlight the desired feature (in this example T_Edge of Parking Lot is used).

4. Notice that the feature is grayed out. This indicates that the feature cannot be displayed in cross section.
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5. <D> the Edit Style button. This displays the Edit Style dialog box.

This method takes you directly to the Surface Feature folder of the Edit Style dialog box.

Editing the Style

Two settings are required for the feature to be displayed; the display option must be toggled on and the Named 
Symbology must be set up.

1. In the Edit Style dialog box, toggle on the desired display option (in this example Crossing Points from 
the Cross Section Display area is used).

2. <D> the Apply button. This saves the setting to the XIN file.

This allows the feature to be displayed in the cross section but does not setup the symbology for its display. 
The steps below describe how to set up the symbology.



Colorado Department of Transportation   EFCS - 5

CDOT  Workflows  Editing Feature Styles for Display in Cross Sections

3. Highlight the Symbology in the Edit Style explorer.

4. <D> the Edit button in the Symbology area of the dialog box. This displays the Edit Named Symbology 
dialog box.

5. In the Edit Named Symbology dialog box, highlight Cross Section Point from the Symbology list and 
<D> Edit. This displays the Point Symbology dialog box.

6. In the Point Symbology dialog box, toggle on the desired Display option (in this example Symbol 
Display is used).

7. Select the desired Symbol or Cell used for the feature display (in this example the Plus Sign is used).

8. Select the desired Level for the feature (in this example TOPO_ROADWAY-Edge-Of-Parking-Lot 
was used)

9. Set the Color and Weight to By Level.

10. Set the desired Height and Width for the symbol.
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11. <D> the OK button to accept the changes. This dismisses the Point Symbology dialog box.

12. In the Edit Named Symbology dialog box, <D> Apply then <D> Close.

13. In the Edit Style dialog box, <D> Apply then <D> Close.
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This completes the changes required in the XIN file. The features can now be added to the cross sections using 
the Update Cross Section command.

Note: This change will be available only until the next login on your computer. If you wish to save the 
change for future use, Save As the CDOT_Civil.xin file to your project directory.
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Workflow IR 14 - Using InRoads Sight Visibility 
Tools

This document guides you through the use of the InRoads Sight Visibility Tools. There are two sight visibility 
tools available, Roadway Visibility and Surface Visibility. The Roadway Visibility tool analyzes sight 
distances along a roadway. The Surface Visibility tool evaluates the visibility from a given point on a surface.

The Roadway Visibility Tool

This tool is used to check sight distances along an alignment. The Roadway Visibility tool draws a line the 
length of the specified sight distance between two points of the alignment, at the specified elevation above the 
selected surface. It then checks the line against the surface to determine if it passes through the surface to reach 
its destination point.

Before using this tool, you will need an alignment and a surface created by merging the design surface to the 
existing surface. For help creating the merged surface, refer to CDOT Workflow Creating Combined Surfaces. 
The steps below describe Roadway Visibility tool’s set-up and function.

Adding the Sight Visibility Tools to the Menu

By default, the sight visibility tools are not available on the InRoads menu bar. To add them to the menu, 
follow the steps below.

1. Select Tools > Application Add-Ins from the InRoads main menu. This displays the Application Add‐
Ins dialog box.

2. From the Application Add‐Ins dialog box Available list, toggle on the Sight Visibility Add-In.
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3. <D> OK to accept the change and dismiss the Application Add‐Ins dialog box.

The Sight Visibility tools are added to the Evaluation menu.

Using the Roadway Visibility Tool

1. From the InRoads main menu, select Evaluation > Sight Visibility > Roadway Visibility. This 
displays the Roadway Visibility dialog box.
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2. In the Roadway Visibility dialog box, select the General leaf.

3. In the Surfaces list, select the merged surface.

Note: If two or more surfaces are selected, InRoads will use the highest surface to base eye height and 
object height from. This could result in inaccurate readings in areas of cut.

4. Using the Horizontal Alignment drop down menu, select the desired alignment.

5. Key in the desired Start Station and Stop Station in their respective fields.

6. If the alignment runs in the opposite direction as the flow of traffic, <D> the Reverse button. This will 
make the command check the sight distance in the same direction as the flow of traffic.

7. In the Interval field, key in the desired value.

8. In the Sight Distance field, key in the desired value. See Chapter 3 - Elements of Design of the CDOT 
Roadway Design Guide 2005 for information on computing sight distances and sight distance look up 
tables.

9. In the Relaxed Distance field, key in the desired value. This is the minimum allowable distance. It can be 
the same value as used in the Sight Distance field.

10. Toggle on Create XML Report to create a textual copy of the sight distance data.

11. Select the Position leaf.

12. Set the Offset value in the Eye Position area so that it will be in the center of the driving lane to the inside 
of the curve.

13. Set the Offset value for the Object Position area so that it will be in the center of the driving lane to the 
inside of the curve.

Note: On 4 lane roads the eye and object position offset will have to change depending on the direction 
of the curve. This may require a different run of the command for each curve.
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14. <D> the Apply button to execute the command.

A sample of the results are shown below:

 A green line meets or exceeds the Sight Distance.

 A yellow line meets or exceeds the Relaxed Distance.

 A red line does not meet either the Sight Distance or the Relaxed Distance.
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Below is an example of the report created by the Roadway Visibility command:

The entries in the report correspond to a line drawn in MicroStation.

Using the Surface Visibility Tool

The Surface Visibility tool determines the visibility from a given point. There are three modes for this tool; 
Surface Points, Surface Regions, and Line of Sight. The Surface Points mode indicates what triangle vertices 
can be seen from the observation point. The Surface Regions mode draws lines radially from the observation 
point showing where sight is clear or blocked. The Line of Sight mode shows whether sight is clear or blocked 
between two points.

The steps below describe how to use the Surface Visibility tool.
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1. From the InRoads main menu, select Evaluation > Sight Visibility > Surface Visibility. This displays 
the Surface Visibility dialog box.

2. In the Surface Visibility dialog box General leaf, select the desired Surface to be evaluated.

3. Select the desired Mode using the drop down menu.

4. Toggle on or off Drape Surface as desired. If Drape Surface is on, the base Elevation for the Eye 
Position is set to that of the Surface at the specified location.

5. Set the Northing and Easting (and Elevation if Drape Surface is not used) for the Eye Position. This can 
be done by key in or by using the locator button.

6. Key in the desired value for the Eye Height. This is the distance above the Elevation for the actual eye 
position.

Surface Points Settings

These settings are only used when the Mode is set to Surface Points on the General Leaf.

1. <D> the Surface Points leaf from the dialog box explorer pane.

2. Toggle on or off the Object Height as desired. If toggled on, key in the desired value. This is an 
elevation adjustment above the surface at the target location and represents the height of an object sitting 
on the surface at that location.
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3. Toggle on or off the Sight Radius as desired. If toggled on, key in the desired value. This is the distance 
from the Eye Position that data is collected. If toggled off, the entire surface is evaluated.

4. <D> the Apply button to execute the command. The data is displayed in the MicroStation view. An 
example of the data is displayed below.

The green dots represent locations that can be seen from the Eye Position. Red dots represent locations that 
cannot be seen from the Eye Position. The locations evaluated are the triangle vertices of the selected surface 
that are within the Sight Radius.

Surface Region Settings

These settings are only used when the Mode is set to Surface Regions on the General Leaf.

1. <D> the Surface Regions leaf from the dialog box explorer pane.

2. In the Method area, select either Radial Angle Interval or Number of Radials. The Radial Angle 
Interval option places data lines radiating from the Eye Position in a circle at the specified angle interval. 
the Number of Radials option places data lines radiating from the Eye Position in a circle at angle intervals 
equal to 360/Number of Radials value. In each case, the first radial is

3. Toggle on or off the Object Height as desired. If toggled on, key in the desired value. This is an 
elevation adjustment above the surface at the target location and represents the height of an object sitting 
on the surface at that location. In each case, the first radial is placed at the MicroStation 0 angle 
(horizontally to the right from the Eye Position in a Top view).
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4. Toggle on or off the Sight Radius as desired. If toggled on, key in the desired value. This is the distance 
from the Eye Position that data is collected. If toggled off, the entire surface is evaluated.

5. <D> the Apply button to execute the command. The data is displayed in the MicroStation view. An 
example of the data is displayed below.

The green lines represent locations that can be seen from the Eye Position. Red lines represent locations that 
cannot be seen from the Eye Position. The locations evaluated are within the Sight Radius.

Line of Sight Settings

These settings are only used when the Mode is set to Line of Sight on the General Leaf.

1. <D> the Line of Sight leaf from the dialog box explorer pane.
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2. Toggle on or off Drape Surface as desired. If Drape Surface is on, the base Elevation for the Object 
Position is set to that of the Surface (on the General leaf) at the specified location.

3. Set the Northing and Easting (and Elevation if Drape Surface is not used) for the Object Position. This 
can be done by key in or by using the locator button.

4. 4. Key in the desired value for the Object Height. This is the distance above the Elevation for the actual 
object position.

5. <D> the Apply button to execute the command. The data is displayed in the MicroStation view. An 
example of the data is displayed below.

The green lines represent locations that are above the surface. Red lines represent locations that are below the 
surface.
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Appendix

Enter all workflow document history information in a document control sheet as part of the appendix 
which would include what version the workflow was updated to and the date of the update
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